導航:首頁 > 源碼編譯 > 通達信好用的選股公式源碼

通達信好用的選股公式源碼

發布時間:2022-06-23 16:27:33

⑴ 通達信選股公式源碼

你好,通達信選股公式源碼如下。
次日漲停
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=交叉(C,REF(W3,1));
W4和計數(W4,5)=1;
黃轉紫選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
紫柱:MACD<0和MACD>REF(MACD,1)和REF(MACD,1)低位金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
低位金叉:交叉(差異,DEA)和差異<-0.1;
二次金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=計數(交叉(差異,數據包絡分析),BARSLAST(數據包絡分析>=0));
二次金叉:交叉(差異,DEA)和DEA<0,計數(JCCOUNT=2,21)=1;
絕地反彈
(1)
VAR1:=參考值(低,1);
VAR2:=SMA(ABS(低VAR1),13,1)/SMA(最大值(低VAR1,0),13,1)*100;
VAR3:=EMA(如果(關閉*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(低,34);
VAR5:=HHV(VAR3,34);
VAR6:=如果(LLV(低,55),1,0);
VAR7:=EMA(如果(低)<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(低,2)*0.96;
XL2:=MA(低,26)*0.85;
XL3:=REF(XL1,1)啟動:=如果(XL3,0,VAR7*3),則為紅色;
XG:啟動>25;
(2)
倒退((參考(關閉,1)<參考(打開,1)和
關閉>打開和ABS(關閉參考(關閉,1))/關閉<0.002),2);
A2:=過濾器(A1<=V3,10);
ND資本<300000000
REF(V,1)=LLV(V,4)和V>=REF(V,1)
HHV(V,3)=參考(V,1)和HHV(V,5)=參考(V,1)和HHV(V,21)=參考(V,1)
和V>=REF(V,1)
01>0,T02>0;
1.三線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1,A2和A3,C>O和V>REF(V,1),資本<=300000000;
2.三條線粘合
N1:=5;N2:=10;N3:=20;M:=1;
MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
最大值(MA1,最大值(MA2,MA3))/MIN(MA1,最小值(MA2,MA3))<1+0.01*M
C>O和V>REF(V,1)和財務(7)<=300000000
A3及資本<=300000000;
3.均線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.01*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1以及A2和A3;
3.金叉選股指標
快線:=均線(均線)(均線(收盤,2,2,2),;
慢線:=EMA(參考(快線,1),2);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
交叉(快線,慢線) 和C>O和
五> =MA(V,21)和V>REF(V,1),資本<=300000000;

⑵ 通達信最好尾盤選股公式

1、尾盤14:50——14:55選股,結合自己的交易系統找出一隻最有可能上漲標的股,於14:57——15:00競價買入。
2、第二天開盤後,如果高開高走,逢高止贏。如低開或平開反彈不過止贏位趁紅盤時或盤中沖高時止損出局。
3、對於高開高走的開股,如果盤中沒有及時止贏,沒漲停的建議收盤前止贏賣出,漲停的持有待漲。盡量減少持股時間,避免下個交易日再次低開導致利潤丟失而坐電梯。

⑶ 通達信選股指標公式

通達信選股公式1、多方炮TJ1:=COANDC=HAND(C-REF(C,1))REF(C,1)100=5;TJ2:=VOLTJ4:=EVERY(MAX(C,O)MA(C,7),3)ANDCAPITAL10000007;TJ3:=COANDC=H;XG:TJ1ANDREF(TJ2,1)ANDREF(TJ3,2)ANDTJ4;

通達信選股公式2、向上跳空缺口三天不回補選股公式:XSTK:=LOWREF(HIGH,1);TT1:=BARSLAST(XSTK)+1;HH:=REF(HIGH,TT1);不回補:=TT1=3ANDCOUNT(XSTK,TT1)=1ANDLOWHHANDLOW=HH1.01ANDNOT(EXIST(CROSS(HH,LOW),TT1));COUNT(LOWREF(HIGH,1),3)0AND不回補;

通達信選股公式3、向上跳空缺口當天不回補選股公式:XSTK:=LOWREF(HIGH,1);TT1:=BARSLAST(XSTK)+1;HH:=REF(HIGH,TT1);不回補:=TT1=1ANDCOUNT(XSTK,TT1)=1ANDLOWHHANDLOW=HH1.001ANDNOT(EXIST(CROSS(HH,LOW),TT1));缺口:=LOW=HH1.001;去ST:=IF(NAMELIKE('ST'),0,1)ANDIF(NAMELIKE('S'),0,1)ANDIF(DYNAINFO(9)=0,0,1){停牌};未補:COUNT(LOWREF(C,1),3)0AND不回補AND去ST;

通達信選股公式4、錘子線選股公式B:=IF(CO,O,C);B1:=IF(CO,C,O);錘子線選股:if((B-L)ABS(C-O)=2and(H-B1)ABS(C-O)1andco,1,0);

通達信選股公式5、啟明星+選股預警公式{啟明星}VARF1:=TROUGHBARS(3,15,1)4;DRAWTEXT(FILTER(VARF1=1,3),48.8,'啟明星'),COLORRED;空:=EMA((CLOSE-MA((2CLOSE+HIGH+LOW)4,30))MA((2CLOSE+HIGH+LOW)4,30)100,3),COLORWHITE;STICKLINE(FILTER(VARF1=1,5)AND多空-10,60,0,3,0),COLORF00FF0;STICKLINE(FILTER(VARF1=1,5),60,0,1,0),COLORYELLOW。

通達信選股公式6、選股預警公式:VARF1:=TROUGHBARS(3,15,1)4;啟明星:FILTER(VARF1=1,3);

通達信選股公式7、平頭底部形態的選股公式K1:=ABS(LOW-REF(LOW,1))0.02;K2:=ABS(LOW-REF(LOW,2))0.02;K3:=ABS(LOW-REF(LOW,3))0.02;K4:=ABS(LOW-REF(LOW,4))0.02;K5:=ABS(LOW-LLV(LOW,5))0.02;K1ORK2ORK3ORK4ANDK5;20均線之上出現的平底(強勢股)K1:=ABS(LOW-REF(LOW,1))0.02;K2:=ABS(LOW-REF(LOW,2))0.02;K3:=ABS(LOW-REF(LOW,3))0.02;K4:=ABS(LOW-REF(LOW,4))0.02;K5:=LOWMA(C,20)ANDABS(LOW-LLV(LOW,5))0.02;K1ORK2ORK3ORK4ANDK5;用這個通達信選股公式選出來的股票,最好是回撤到前頭部止跌的,是絕對強勢,成功率極高。

拓展資料
通達信選股公式1.公式類型說明:調出公式管理器:功能à專家系統à公式管理器公式類型分為四大類:技術指標公式、條件選股公式、交易系統公式、五彩K線公式。

通達信選股公式1.1技術指標公式:我們在技術分析界面中見到的指標為技術指標公式,比如KDJ,MACD等;通過公式管理器編寫技術指標公式,在公式管理器界面選擇技術指標公式,點擊右邊的「新建」就可進入技術指標公式編輯區。通達信選股公式編寫?在指標公式編輯區,可以通過「引入指標公式」,在已有指標的基礎上修改指標公式,也可以通過插入函數來實現指標公式的編寫。

通達信選股公式1.2條件選股公式:利用條件選股公式可以把符合一定技術形態的個股選出來,首先在公式管理器中建立條件選股公式,再通過「條件選股」調用條件選股公式。

⑷ 求通達信的選股公式,條件是MACD大於零。

DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MACD>0;
另附通達信幾種常用的選股公式:
一、均線上拐選股法

自編公式操作步驟:

①均線上拐

公式:ma(c,60)>ref(ma(c,60),1)andref(ma(c,60),1)

「設置」「公式管理」「自編」「條件選股」「新建」「公式名稱——「60天均線上拐」在圖片下方位置,把公式「ma(c,60)>ref(ma(c,60),1)andref(ma(c,60),1)

②時間統計

公式:last(ref(ma(c,60),1)

步驟如下:

「設置」「公式管理」「自編」「技術指標」「新建」「公式名稱—60天時間統計」在圖片下方位置,把公式「last(ref(ma(c,60),1)

選股步驟:均線上拐——時間統計——安全系數。

①使用條件選股——條件選股(新版)——60天均線上拐——執行選股:

執行結果如下:

②添加技術指標——時間統計——排序


二、預測漲停選股

用法:每天9:25後,用條件選股,篩選出優質股票,自己再再結合市場情況判斷,選出的股票裡面會有驚喜!

源碼:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=(SMA(RSV,3,1));

D:=(SMA(K,3,1));

KK:=INTPART(SMA(RSV,3,1));

DD:=INTPART(SMA(K,3,1));

N:=KK+DD,COLORFF00FF,LINETHICK2;

預測:=IF(CROSS(N,50),90,50),COLOR00FF00;

漲停:=IF(CROSS(N,99.5),100,50),COLORYELLOW;

漲停>預測;

三、股價位於均線上方選股公式

{股價位於均線上方選股公式}

TA:=BARSSINCE(CLOSE);

MA5:=IF(TA>=5,MA(C,5),0);

MA10:=IF(TA>=10,MA(C,10),0);

MA20:=IF(TA>=20,MA(C,20),0);

MA60:=IF(TA>=60,MA(C,60),0);

A1:=MA5>MA10ANDMA10>MA20ANDMA20>MA60;

LMAX:=MAX(MAX(MA5,MA10),MAX(MA20,MA60));

CROSS(CLOSE,MA5)ANDV>=REF(V,1)ANDA1;


四、老鴨頭

「老鴨頭」的操作要領:

1、找到鴨脖子,見圖中的A處。由5日、10日和20日平均線組成的鴨脖子,從60日、120日平均線下往上伸出來。

2、鴨頭頂在B處,這里發生5日平均線和10日平均線的死叉,意味著回檔開始了。老鴨頭形態的關鍵是回檔時:跌越淺越好,量越小越好。

3、鴨鼻孔在C點處,是5日平均線死叉後轉成金叉所形成的小「孔」。這個鴨鼻孔要越小越好,太大的鴨鼻孔會影響後市的上升高度。

4、鴨嘴在D處,由60日平均線和120日平均線組成了鴨嘴,要求兩線之間的距離要大。兩線之間的距離大,說明鴨嘴大,叫起來才響亮。

5、嘎嘎叫在E點處,這時K線沖過鴨頭頂,發生陣陣鴨叫聲。這時,整個老鴨頭形態完成了。

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA60:=MA(CLOSE,60);

PDAY1:=BARSLAST(CROSS(MA5,MA60));{5日均線上穿60日均線}

PDAY2:=BARSLAST(CROSS(MA10,MA60));{10日均線上穿60日均線,至此形成鴨頸部}

PDAY3:=BARSLAST(HIGH=HHV(HIGH,PDAY2));{形成頭部,要下跌}

PDAY4:=BARSLAST(CROSS(MA10,MA5));{下跌後,5日均線和10日均線死叉}

PDAY5:=BARSLAST(CROSS(MA5,MA10));{回落不久,5日均線和10日均線形成金叉,形成嘴部}

A1:=PDAY1>PDAY2ANDPDAY2>PDAY3ANDPDAY3>PDAY4ANDPDAY4>PDAY5ANDPDAY5<5;

A2:=COUNT(CROSS(MA10,MA5),PDAY2)=1;

A1ANDA2;

⑸ 通達信選股公式

通達信選股公式:

條件選股公式源碼:
年認同價:=MA(C,240);
價格中樞:=(SUM(年認同價,0)/(BARSSINCE(年認同價>0)+239));
箱頂:=價格中樞*1.2;
箱底:=價格中樞*0.8;
毛利潤率:=FINANCE(21)/FINANCE(20);
成長價值:=年認同價*(1+毛利潤率);
收益價值:=年認同價+FINANCE(33);
回調認同:=EMA(EXPMA(C,20),13);
多頭:=(回調認同>REF(回調認同,1))AND(成長價值>REF(成長價值,1))AND(收益價值>REF(收益價值,1))AND(DYNAINFO(7)>0);
回調條件:=COUNT(C<回調認同,5)>=3;
回調突破:=(REF(C,1)<=REF(回調認同,1))AND(C>回調認同)AND(回調條件)AND多頭;
成長條件:=COUNT(C<成長價值,5)>=3;
成長突破:=(REF(C,1)<=REF(成長價值,1))AND(C>成長價值)AND(成長條件)AND多頭;
收益條件:=COUNT(C<收益價值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益價值,1))AND(C>收益價值)AND(收益條件)AND多頭;
箱底條件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底條件)AND多頭;
價格條件:=COUNT(C<價格中樞,5)>=3;
價格突破:=(REF(C,1)<=REF(價格中樞,1))AND(C>價格中樞)AND(價格條件)AND多頭;
箱頂條件:=COUNT(C<箱頂,5)>=3;
箱頂突破:=(REF(C,1)<=REF(箱頂,1))AND(C>箱頂)AND(箱頂條件)AND多頭;
突破買點:(回調突破+成長突破+收益突破+箱底突破+價格突破+箱頂突破);

專買老鼠倉
{老鼠倉}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠倉'),COLOR4080FF;
老鼠倉是個很不錯的指標,信號發出一般都在一個波段的底部起漲之時。
根據本人的實踐,使用指標時候要注意幾點:
1 該指標可以添加到任何一個主圖裡面去,比如MA均線什麼的。
2 出現信號當天買進股票,第二天收陽繼續持股,直到出陰為止。
3 第二天出陰考慮賣出,非常適合短線操作!

老鼠倉(選股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠倉:BB1AND CC1 AND DD1 AND EE1;

理想選股(選股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) ANDREF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) ANDCROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR12OR VAR13) AND VAR10;
買2:=(VAR12OR VAR13) AND VAR3;
買3:=(VAR12OR VAR13) AND VAR2;
買4:=(VAR2AND VAR10) OR (VAR3 AND VAR10);
買5:=(金叉AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
輸出:=(買1OR 買2OR 買3OR 買4OR 買5OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空線:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,多空線) and CROSS(C,AB) and 輸出 ;

點石成金(選股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市絕底(選股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) *100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市絕底:VAR2< 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 ANDBARSCOUNT(CLOSE) > 47;

飛彈一號(選股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

跟庄建倉源碼
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH -LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(Var3,3)-10;
STICKLINE(趨勢>80,趨勢,80,5,0);
DRAWICON(CROSS(趨勢,0),0,1);
STICKLINE((A09 > 0 AND (趨勢<20 OR 趨勢>REF(趨勢,1)AND趨勢<50)),0,A09,6,0),colorFFff00;
機構建倉區:0,LINETHICK0,colorFFFF00;
Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(趨勢<=13,15),30,'准備現金'),colorcc9900;
STICKLINE(趨勢<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((趨勢<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'買入'),color0099ff;
STICKLINE(趨勢>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((趨勢>=90 AND Var4),10);
DRAWTEXT(Var6,40,'清倉'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'險'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7AND 趨勢<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線:趨勢,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(趨勢線,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趨勢線,Var2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'追漲'),COLORff00ff;
風險區:IF(趨勢>80,趨勢,80),colorff00ff;

雙信號"全倉"選股(選股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1)AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{收盤價=4日內收盤價的最高值AND 昨收>=2日前的收盤價}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{收盤價=4日內收盤價的最高值AND 昨收=4日內收盤價的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{收盤價=4日內收盤價的最低值AND (昨收<2日前的收盤價}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{昨收=4日內收盤價的最低值AND 收盤價>=2日前的收盤價}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{昨收=4日內收盤價的最高值AND 收盤價<2日前的收盤價}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{今日V5向上形成拐點}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR14OR VAR15) AND VAR11;
買2:=(VAR14OR VAR15) AND VAR04;
買3:=(VAR14OR VAR15) AND VAR02;
買4:=(VAR02AND VAR11) OR (VAR04 AND VAR11);
買5:=(金叉AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=買1OR 買2OR 買3OR 買4OR 買5AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{以下波浪理論浪底重疊"買底"選股原碼}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{以下二者結合共同選股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

⑹ 求通達信可用的基本面選股公式

通達信可用的基本面選股公式:1均線上拐選股法自編公式操作步驟:①均線上拐公式:ma(c,60)>ref(ma(c,60),1)andref(ma(c,60),1)「設置」「公式管理」「自編」「條件選股」「新建」「公式名稱——「60天均線上拐」在圖片下方位置,把公式「ma(c,60)>ref(ma(c,60),1)andref(ma(c,60),1)
②時間統計
公式:last(ref(ma(c,60),1)
步驟如下:
「設置」「公式管理」「自編」「技術指標」「新建」「公式名稱—60天時間統計」在圖片下方位置,把公式「last(ref(ma(c,60),1)
選股步驟:均線上拐——時間統計——安全系數。
二、預測漲停選股用法:每天9:25後,用條件選股,篩選出優質股票,自己再再結合市場情況判斷,選出的股票裡面會有驚喜!源碼:RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=(SMA(RSV,3,1));D:=(SMA(K,3,1));KK:=INTPART(SMA(RSV,3,1));DD:=INTPART(SMA(K,3,1));N:=KK+DD,COLORFF00FF,LINETHICK2;預測:=IF(CROSS(N,50),90,50),COLOR00FF00;漲停:=IF(CROSS(N,99.5),100,50),COLORYELLOW;漲停>預測;三、股價位於均線上方選股公式{股價位於均線上方選股公式}TA:=BARSSINCE(CLOSE);MA5:=IF(TA>=5,MA(C,5),0);MA10:=IF(TA>=10,MA(C,10),0);MA20:=IF(TA>=20,MA(C,20),0);MA60:=IF(TA>=60,MA(C,60),0);A1:=MA5>MA10ANDMA10>MA20ANDMA20>MA60;LMAX:=MAX(MAX(MA5,MA10),MAX(MA20,MA60));CROSS(CLOSE,MA5)ANDV>=REF(V,1)ANDA1;

⑺ 通達信經典實用的選股公式都有哪些

一則“通達信經典實用的選股公式都有哪些?”的問題,是受到了高度的關注,我來說下我的了解。通達信裡面使用的選股公式是非常多,我們是在裡面有很多地方都可以看到他這個公式,對應的勝率基本上都是比較高的。選了好的股票,我們還是要知道怎麼樣去賣,只有正確的賣點,那才會讓你有更多的盈利。如果走勢不如預期,我們也要及時的進行止損,不能夠無腦的補倉。的下面說說詳細情況。

一.實用的選股公式非常多

通達信裡面會有非常多實用的選股公式,還有一些網站裡面也是有很多實用的公式,這些公式都會幫你選擇出來一批股票,它們的走勢都會相對較好一些。


大家看完,記得點贊+加關注+收藏哦。

⑻ 通達信條件選股公式集

公式如下:
①均線上拐公式:ma(c,60)>ref(ma(c,60),1) and ref(ma(c,60),1)
②時間統計公式:last(ref(ma(c,60),1)
拓展資料:
一、 預測漲停選股用法:每天9:25後,用條件選股,篩選出優質股票,自己再再結合市場情況判斷,選出的股票裡面會有驚喜!
1、源碼:RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=(SMA(RSV,3,1));D:=(SMA(K,3,1));KK:=INTPART(SMA(RSV,3,1));DD:=INTPART(SMA(K,3,1));N:=KK+DD,COLORFF00FF,LINETHICK2;
2、預測:=IF(CROSS(N,50),90,50),COLOR00FF00;
3、漲停:=IF(CROSS(N,99.5),100,50),COLORYELLOW;
4、漲停>預測。
二、股價位於均線上方選股公式
1、TA:=BARSSINCE(CLOSE);MA5:=IF(TA>=5,MA(C,5),0);MA10:=IF(TA>=10,MA(C,10),0);MA20:=IF(TA>=20,MA(C,20),0);MA60:=IF(TA>=60,MA(C,60),0);A1:=MA5>MA10 AND MA10>MA20 AND MA20>MA60。
2、LMAX:=MAX(MAX(MA5,MA10),MAX(MA20,MA60));CROSS (CLOSE,MA5) AND V>=REF(V,1)AND A1。
三、老鴨頭
1、操作要領:
(1)找到鴨脖子,見圖中的A處。由5日、10日和20日平均線組成的鴨脖子,從60日、120日平均線下往上伸出來。
(2)鴨頭頂在B處,這里發生5日平均線和10日平均線的死叉,意味著回檔開始了。老鴨頭形態的關鍵是回檔時:跌越淺越好,量越小越好。
(3)鴨鼻孔在C點處,是5日平均線死叉後轉成金叉所形成的小「孔」。這個鴨鼻孔要越小越好,太大的鴨鼻孔會影響後市的上升高度。
(4)鴨嘴在D處,由60日平均線和120日平均線組成了鴨嘴,要求兩線之間的距離要大。兩線之間的距離大,說明鴨嘴大,叫起來才響亮。
(5)嘎嘎叫在E點處,這時K線沖過鴨頭頂,發生陣陣鴨叫聲。這時,整個老鴨頭形態完成了。
2、老鴨選股公式
MA5 := MA(CLOSE,5);MA10 := MA(CLOSE,10);MA60 := MA(CLOSE,60);PDAY1 := BARSLAST(CROSS(MA5,MA60));{5日均線上穿60日均線}PDAY2 := BARSLAST(CROSS(MA10,MA60));{10日均線上穿60日均線,至此形成鴨頸部}PDAY3 := BARSLAST(HIGH=HHV(HIGH,PDAY2));{形成頭部,要下跌}PDAY4 := BARSLAST(CROSS(MA10,MA5));{下跌後,5日均線和10日均線死叉}PDAY5 := BARSLAST(CROSS(MA5,MA10));{回落不久,5日均線和10日均線形成金叉,形成嘴部}A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;A1 AND A2。
四、MACD二次翻紅
1、公式:

閱讀全文

與通達信好用的選股公式源碼相關的資料

熱點內容
安卓為什麼裝不了軟體 瀏覽:78
app有什麼作用 瀏覽:822
爬蟲伺服器如何獲取高效的家用ip 瀏覽:996
網站備案可以不用雲伺服器嘛 瀏覽:256
程序員開周會嗎 瀏覽:857
安卓光遇怎麼豎屏了 瀏覽:233
程序員上進圖片 瀏覽:289
跟外國人視頻的app是什麼 瀏覽:806
電腦如何訪問區域網伺服器地址 瀏覽:283
評論熱度排序演算法工程實現方案 瀏覽:578
安卓怎麼刷加密nfc 瀏覽:838
京東雲伺服器如何下載 瀏覽:889
客戶文件夾r 瀏覽:345
伺服器感染怎麼辦 瀏覽:934
iphone怎樣關閉隱私應用加密 瀏覽:908
怎麼看一個軟體的伺服器地址填什麼 瀏覽:682
三星超頻內核編譯 瀏覽:799
編譯器無法建立之占存文件 瀏覽:578
正式版python發布的時間 瀏覽:661
web前端開發和php 瀏覽:671