導航:首頁 > 源碼編譯 > 異動指標源碼無未來

異動指標源碼無未來

發布時間:2022-08-19 12:31:25

A. 求超級短線指標源代碼(農產品現貨的) 無未來 有買賣點提示的 還得能用的 我做的是河南新鄉金銀花的盤

用未來函數的指標都是不可靠的

沒有能預測未來的科技,這點你要明白

B. 哪位高手可以把通達信指標公式改成選股公式 源碼如下:V6:=CLOSE/REF(CLOSE,3)>=1.1; V7:=BACKSET(V6,3);

其實你不用發別人的什麼源碼,你只將你的想法說出來,就會有人幫你
-----------------------------------------------------------------------------------
看你發了上面兩句代碼,估計你沒有看懂源碼是什麼意思,看不懂的東西,最好是別去看他,不如自己想自己的,根據自己的想法做的東西(自己不會做,可以請人幫忙的),才知道是怎麼回事

C. 求通達信頂底趨勢指標源碼

頂底趨勢指標(通達信)
此指標是我精心收藏的指標,無未來函數,真正的好指標。圖片演示在下面網址里.

趨勢:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1) ,COLORGREEN;
STICKLINE(趨勢>50,趨勢,50,4,0),COLOR32329B;
STICKLINE(50>趨勢,趨勢,50,4,0),COLOR326400;
IF(趨勢>50, 趨勢,DRAWNULL), COLORRED;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
轉點:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(轉點=1,50,50,6,0),COLORYELLOW;
STICKLINE(轉點=0,50,50,6,0),COLORCYAN;
頂部:90,COLORYELLOW;
底部:10,COLORCYAN;
判斷:SMA(趨勢,3,1),COLORFF00FF, LINETHICK2;
IF( 趨勢>判斷,判斷,DRAWNULL), COLORYELLOW, LINETHICK2;
IF( 趨勢<判斷,判斷,DRAWNULL) ,COLORFFF000,LINETHICK2;
DRAWICON(CROSS(趨勢,判斷),判斷,1);
DRAWICON(CROSS(趨勢,頂部),頂部,2);
LC:= REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
短線1: IF(VAR6>45,VAR6-45,0),COLORA6B8C1;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
VR2:=REF(LOW,1);
VR3:=SMA(ABS(LOW-VR2),3,1)/SMA(MAX(LOW-VR2,0),3,1)*100;
VR4:=EMA(IF(CLOSE*1.3,VR3*10,VR3/10),3);
VR5:=LLV(LOW,30);
VR6:=HHV(VR4,30);
VR7:=IF(MA(CLOSE,58),1,0);
VR8:=EMA(IF(LOW<=VR5,(VR4+VR6*2)/2,0),3)/618*VR7;
VR9:=IF(VR8>100,100,VR8);
主力進場:STICKLINE(VR9>-150,0,VR9,3,0), , COLORFF00FF;
洗盤:IF(VR9<REF(VR9,1),VR9,0),COLORGREEN,NODRAW;
STICKLINE(VR9<REF(VR9,1),0,VR9,3,0),COLORGREEN;
短線獲利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,25,2,0),COLORYELLOW;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);

逃頂:=CROSS(82,RSI);
STICKLINE( 逃頂,逃頂,20,5,0),COLORFF5500;
STICKLINE( 逃頂,逃頂,30,3,0),COLORFF8800;
STICKLINE( 逃頂,逃頂,30,2,0),COLORFFAA00;
STICKLINE( 逃頂,逃頂,30,1,0),COLORFFCC00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
風險區:80,COLORFF85FF;
安全區:20,COLORYELLOW,POINTDOT;
天線:100,COLORFFFF00;
強弱線:50,COLORGREEN,POINTDOT;
DRAWICON(BBUY,(LOW *1),1);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,15);
DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;
MAV:=(2*C+H+L)/4;
VAR9:=LLV(LOW,34);
VAR7:=HHV(HIGH,34);
SK:= EMA((MAV-VAR9)/(VAR7-VAR9)*100,13);
SD: EMA(0.667*REF(SK,1)+0.333*SK,2);
高拋:80, POINTDOT;
低吸:20, POINTDOT;
強弱分界:50, POINTDOT;
DRAWTEXT(CROSS(SD,16),低吸,'●主力'),COLORF0FF00,LINETHICK3;

D. 通達信主圖指標源碼,求老師看有沒有未來,並幫改成選股和預警公式,謝謝

(1)無未來函數
(2)選股公式如下(買入):
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
CROSS(VAR2,MA(VAR3,6));

E. 股票軟體的公式、指標的未來函數是什麼意思

未來函數指的是,如果在指標公式的源碼,使用了未來函數,那麼可能信號會漂移,比如今天開盤是漲的,顯示漲的信號,結果第二天發現上一天跌了,就變成跌的信號了,信號就會一直調整,讓人覺得這個指標百分比准確。

但是不是說有未來函數的指標一無是處,用好了也是一個利器。

如果你不知道你的指標是不是包含未來函數可以去檢測一下:

在這里給您提供一下未來函數的列表:

ZIG - 之字轉向

PEAK - 前M個ZIG轉向波峰值

PEAKBARS - 前M個ZIG轉向波峰到當前距離

TROUGH - 前M個ZIG轉向波谷值

TROUGHBARS - 前M個ZIG轉向波谷到當前距離

FLATZIG - 歸一化之字轉向

FLATZIGA - 歸一化之字轉向

PEAKA - 前M個ZIG轉向波峰值

PEAKBARSA - 前M個ZIG轉向波峰到當前距離

TROUGHA - 前M個ZIG轉向波谷值

ZIGA - 之字轉向

FFT - 傅立葉變換函數

BACKSET - 將當前位置到若干周期前的數據設為1

WINNER - 獲利盤比例

LWINNER - 近期獲利盤比例

PWINNER - 遠期獲利盤比例

COST - 成本分布情況

CAPITAL - 當前流通股本

DYNAINFO - 即時行情數據

FINANCE - 財務函數

XMA - 返回偏移移動平均

#MONTH - 跨周期引用

#WEEK - 跨周期引用

#YEAR - 跨周期引用

DHIGH - 返回該不定周期最高價

DOPEN - 返回該不定周期開盤價

DLOW - 返回該不定周期最低價

DCLOSE - 返回該不定周期收盤價

DVOL - 返回該不定周期成交量價

BARSNEXT - 下一次條件成立到當前的周期數

REFX - 引用若干周期後的數據(平滑處理)

REFXV - 引用若干周期後的數據(未作平滑處理)

PEAK - 前M個ZIG轉向波峰值

PEAKBARS - 前M個ZIG轉向波峰到當前距離

DRAWLINE - 繪制直線段用到日後數據

F. 尋庄出擊(無未來)股票指標-股票公式源碼如下:

股神就是以AA為通道下軌 BB為上軌 這個通道叫DD ,是當前股價在這個通道中的相對位置;
股海:用DD再做一個通道,當前的DD在這個通道中的位置;

G. 漲停板抄底副圖源碼 通達信 貼圖 無未來通達信指標公式源碼

參考鏈接:網頁鏈接

漲停板抄底副圖源碼通達信 貼圖 無未來通達信指標公式源碼

H. 什麼是大智慧的「絕無未來」啊

「絕無未來」這句話說指標公式的,很多人在設計指標的時候居心不良和一味追求100%准確,造出的指標都是「馬後炮」指標,這樣的指標源碼里一般都是ZIG等比較常用的未來函數,有了這些函數,指標的用處將大打折扣。而你說的「絕無未來」,是說這個指標是真實的,所發出的信號是永久存在的

閱讀全文

與異動指標源碼無未來相關的資料

熱點內容
螢石雲伺服器怎麼添加到桌面 瀏覽:389
湖南命令行 瀏覽:35
qq自動壓縮文件 瀏覽:751
c語言inline預編譯 瀏覽:47
小米解壓文件時出問題 瀏覽:803
cad設置快捷命令 瀏覽:191
西安阿里某程序員總結 瀏覽:176
飛凌單片機官網 瀏覽:168
ipadjava編程 瀏覽:229
陝西伺服器租賃有限公司雲主機 瀏覽:23
phpci資料庫操作 瀏覽:631
哪個免費app可以投屏 瀏覽:860
公益捐款類app叫什麼名字 瀏覽:681
我的世界迷你玩家為什麼要炸掉伺服器 瀏覽:161
androidget中文亂碼問題 瀏覽:329
張明楷刑法學pdf 瀏覽:564
曙光集pdf 瀏覽:845
雲播影視app在哪裡下載 瀏覽:724
安卓手機電池不耐用怎麼辦呢 瀏覽:149
何老師講單片機 瀏覽:296