導航:首頁 > 源碼編譯 > 大v模型選股源碼

大v模型選股源碼

發布時間:2022-09-26 15:25:32

1. 大智慧底部構成源碼及選股公式

要說出底部的技術含義才能寫啊

2. 通達信捕捉牛股利器 條件選股公式

通達信選股公式:

條件選股公式源碼:
年認同價:=MA(C,240);
價格中樞:=(SUM(年認同價,0)/(BARSSINCE(年認同價>0)+239));
箱頂:=價格中樞*1.2;
箱底:=價格中樞*0.8;
毛利潤率:=FINANCE(21)/FINANCE(20);
成長價值:=年認同價*(1+毛利潤率);
收益價值:=年認同價+FINANCE(33);
回調認同:=EMA(EXPMA(C,20),13);
多頭:=(回調認同>REF(回調認同,1))AND(成長價值>REF(成長價值,1))AND(收益價值>REF(收益價值,1))AND(DYNAINFO(7)>0);
回調條件:=COUNT(C<回調認同,5)>=3;
回調突破:=(REF(C,1)<=REF(回調認同,1))AND(C>回調認同)AND(回調條件)AND多頭;
成長條件:=COUNT(C<成長價值,5)>=3;
成長突破:=(REF(C,1)<=REF(成長價值,1))AND(C>成長價值)AND(成長條件)AND多頭;
收益條件:=COUNT(C<收益價值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益價值,1))AND(C>收益價值)AND(收益條件)AND多頭;
箱底條件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底條件)AND多頭;
價格條件:=COUNT(C<價格中樞,5)>=3;
價格突破:=(REF(C,1)<=REF(價格中樞,1))AND(C>價格中樞)AND(價格條件)AND多頭;
箱頂條件:=COUNT(C<箱頂,5)>=3;
箱頂突破:=(REF(C,1)<=REF(箱頂,1))AND(C>箱頂)AND(箱頂條件)AND多頭;
突破買點:(回調突破+成長突破+收益突破+箱底突破+價格突破+箱頂突破);

專買老鼠倉
{老鼠倉}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠倉'),COLOR4080FF;
老鼠倉是個很不錯的指標,信號發出一般都在一個波段的底部起漲之時。
根據本人的實踐,使用指標時候要注意幾點:
1 該指標可以添加到任何一個主圖裡面去,比如MA均線什麼的。
2 出現信號當天買進股票,第二天收陽繼續持股,直到出陰為止。
3 第二天出陰考慮賣出,非常適合短線操作!

老鼠倉(選股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠倉:BB1AND CC1 AND DD1 AND EE1;

理想選股(選股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) ANDREF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) ANDCROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR12OR VAR13) AND VAR10;
買2:=(VAR12OR VAR13) AND VAR3;
買3:=(VAR12OR VAR13) AND VAR2;
買4:=(VAR2AND VAR10) OR (VAR3 AND VAR10);
買5:=(金叉AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
輸出:=(買1OR 買2OR 買3OR 買4OR 買5OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空線:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,多空線) and CROSS(C,AB) and 輸出 ;

點石成金(選股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市絕底(選股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) *100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市絕底:VAR2< 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 ANDBARSCOUNT(CLOSE) > 47;

飛彈一號(選股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

跟庄建倉源碼
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH -LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(Var3,3)-10;
STICKLINE(趨勢>80,趨勢,80,5,0);
DRAWICON(CROSS(趨勢,0),0,1);
STICKLINE((A09 > 0 AND (趨勢<20 OR 趨勢>REF(趨勢,1)AND趨勢<50)),0,A09,6,0),colorFFff00;
機構建倉區:0,LINETHICK0,colorFFFF00;
Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(趨勢<=13,15),30,'准備現金'),colorcc9900;
STICKLINE(趨勢<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((趨勢<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'買入'),color0099ff;
STICKLINE(趨勢>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((趨勢>=90 AND Var4),10);
DRAWTEXT(Var6,40,'清倉'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'險'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7AND 趨勢<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線:趨勢,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(趨勢線,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趨勢線,Var2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'追漲'),COLORff00ff;
風險區:IF(趨勢>80,趨勢,80),colorff00ff;

雙信號"全倉"選股(選股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1)AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{收盤價=4日內收盤價的最高值AND 昨收>=2日前的收盤價}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{收盤價=4日內收盤價的最高值AND 昨收=4日內收盤價的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{收盤價=4日內收盤價的最低值AND (昨收<2日前的收盤價}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{昨收=4日內收盤價的最低值AND 收盤價>=2日前的收盤價}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{昨收=4日內收盤價的最高值AND 收盤價<2日前的收盤價}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{今日V5向上形成拐點}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR14OR VAR15) AND VAR11;
買2:=(VAR14OR VAR15) AND VAR04;
買3:=(VAR14OR VAR15) AND VAR02;
買4:=(VAR02AND VAR11) OR (VAR04 AND VAR11);
買5:=(金叉AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=買1OR 買2OR 買3OR 買4OR 買5AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{以下波浪理論浪底重疊"買底"選股原碼}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{以下二者結合共同選股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

3. 通達信選股公式

通達信選股公式:

條件選股公式源碼:
年認同價:=MA(C,240);
價格中樞:=(SUM(年認同價,0)/(BARSSINCE(年認同價>0)+239));
箱頂:=價格中樞*1.2;
箱底:=價格中樞*0.8;
毛利潤率:=FINANCE(21)/FINANCE(20);
成長價值:=年認同價*(1+毛利潤率);
收益價值:=年認同價+FINANCE(33);
回調認同:=EMA(EXPMA(C,20),13);
多頭:=(回調認同>REF(回調認同,1))AND(成長價值>REF(成長價值,1))AND(收益價值>REF(收益價值,1))AND(DYNAINFO(7)>0);
回調條件:=COUNT(C<回調認同,5)>=3;
回調突破:=(REF(C,1)<=REF(回調認同,1))AND(C>回調認同)AND(回調條件)AND多頭;
成長條件:=COUNT(C<成長價值,5)>=3;
成長突破:=(REF(C,1)<=REF(成長價值,1))AND(C>成長價值)AND(成長條件)AND多頭;
收益條件:=COUNT(C<收益價值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益價值,1))AND(C>收益價值)AND(收益條件)AND多頭;
箱底條件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底條件)AND多頭;
價格條件:=COUNT(C<價格中樞,5)>=3;
價格突破:=(REF(C,1)<=REF(價格中樞,1))AND(C>價格中樞)AND(價格條件)AND多頭;
箱頂條件:=COUNT(C<箱頂,5)>=3;
箱頂突破:=(REF(C,1)<=REF(箱頂,1))AND(C>箱頂)AND(箱頂條件)AND多頭;
突破買點:(回調突破+成長突破+收益突破+箱底突破+價格突破+箱頂突破);

專買老鼠倉
{老鼠倉}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠倉'),COLOR4080FF;
老鼠倉是個很不錯的指標,信號發出一般都在一個波段的底部起漲之時。
根據本人的實踐,使用指標時候要注意幾點:
1 該指標可以添加到任何一個主圖裡面去,比如MA均線什麼的。
2 出現信號當天買進股票,第二天收陽繼續持股,直到出陰為止。
3 第二天出陰考慮賣出,非常適合短線操作!

老鼠倉(選股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠倉:BB1AND CC1 AND DD1 AND EE1;

理想選股(選股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) ANDREF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) ANDCROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR12OR VAR13) AND VAR10;
買2:=(VAR12OR VAR13) AND VAR3;
買3:=(VAR12OR VAR13) AND VAR2;
買4:=(VAR2AND VAR10) OR (VAR3 AND VAR10);
買5:=(金叉AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
輸出:=(買1OR 買2OR 買3OR 買4OR 買5OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空線:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,多空線) and CROSS(C,AB) and 輸出 ;

點石成金(選股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市絕底(選股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) *100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市絕底:VAR2< 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 ANDBARSCOUNT(CLOSE) > 47;

飛彈一號(選股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

跟庄建倉源碼
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH -LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(Var3,3)-10;
STICKLINE(趨勢>80,趨勢,80,5,0);
DRAWICON(CROSS(趨勢,0),0,1);
STICKLINE((A09 > 0 AND (趨勢<20 OR 趨勢>REF(趨勢,1)AND趨勢<50)),0,A09,6,0),colorFFff00;
機構建倉區:0,LINETHICK0,colorFFFF00;
Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(趨勢<=13,15),30,'准備現金'),colorcc9900;
STICKLINE(趨勢<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((趨勢<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'買入'),color0099ff;
STICKLINE(趨勢>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((趨勢>=90 AND Var4),10);
DRAWTEXT(Var6,40,'清倉'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'險'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7AND 趨勢<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線:趨勢,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(趨勢線,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趨勢線,Var2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'追漲'),COLORff00ff;
風險區:IF(趨勢>80,趨勢,80),colorff00ff;

雙信號"全倉"選股(選股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1)AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{收盤價=4日內收盤價的最高值AND 昨收>=2日前的收盤價}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{收盤價=4日內收盤價的最高值AND 昨收=4日內收盤價的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{收盤價=4日內收盤價的最低值AND (昨收<2日前的收盤價}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{昨收=4日內收盤價的最低值AND 收盤價>=2日前的收盤價}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{昨收=4日內收盤價的最高值AND 收盤價<2日前的收盤價}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{今日V5向上形成拐點}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR14OR VAR15) AND VAR11;
買2:=(VAR14OR VAR15) AND VAR04;
買3:=(VAR14OR VAR15) AND VAR02;
買4:=(VAR02AND VAR11) OR (VAR04 AND VAR11);
買5:=(金叉AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=買1OR 買2OR 買3OR 買4OR 買5AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{以下波浪理論浪底重疊"買底"選股原碼}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{以下二者結合共同選股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

4. 請高手用下面源碼編個選股公式 條件 地量出現後一天為倍量 最少是地量的一倍以上

REF(VOL<MA(VOL,5)/2 AND V<MA(V,12)/2,1) AND V>REF(V,1)*2;{量大於昨天的2倍}

5. 通達信pbx指標源碼

通達信PBX 指標源碼如下

PBX1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;

PBX2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;

PBX3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;

PBX4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;

PBX5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;

PBX6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;

6. 通達信量比公式 今日比昨日大於1怎樣編寫選股公式 量比指標源碼:量比:V/REF(MA(V,5),1);

V/REF(MA(V,5),1)-REF(V/REF(MA(V,5),1),1)>1;
回答過題主的問題之後,下面帶大家深入探討一下量比的問題!
有人說炒股猶如賭博一樣。其實不是這樣的,賭博是一種投機行為,而炒股其實還是有不少技術講究。量比,就是分析股票漲跌趨勢的其中一項重要技術指標,接下來就仔細分析一下。
假如這只股票的情況你搞不清楚該怎麼分析,點擊進入下面這個鏈接,把你想買的股票代碼輸進去,即可看自己到底是不是適合買這個股票,其中還能看到最新的行情消息,可以讓你不會失去每一個時機。【免費】測一測你的股票當前估值位置?
一、量比是什麼意思
量比就指的是量比中間的比率,是如今均值每分的交易量與以往五個股票交易時間均值每分的交易量之比。也可以用於衡量比較成交量。有了這個指標就可以知道成交活躍程度與過去5個交易日的平均活躍程度的對比情況。
計算公式為:量比=(現成交總手數 / 現累計開市時間(分) )/ 過去5日平均每分鍾成交量
舉個例子:例如過去的前5天裡面平均每一分鍾的成交量為100手,今天僅開盤5分鍾,就有1000手的成交量,用這個數據計算量比的話,就是:(1000÷5)÷ 100=2。開盤後10分鍾時間里,就總共成交了1800手,那麼此時的量比則為:(1800÷10)÷100=1.8
剛剛開盤時,在市場上會有一些優勢,市場的活躍會讓量比保持一個較高的數值,但接下來就會逐漸降低。
不少朋友苦惱於熱點資訊接收不及時,那麼這個股市播報神器絕對很適合你,得到了它,就不會再有錯過的情況,點擊下方鏈接就能免費獲取~【股市晴雨表】金融市場一手資訊播報
量比的高低能夠給我們帶來什麼樣的啟發呢?接下來就和大家講一講~
二、量比怎麼看?高好還是低好?多少為好?
先給大家分析一下不同區間的量比的差異到底在哪裡:
關於量比和股價之間的聯系,下面的總結大家可以看看:
量比小於1,股價上漲:這個時候也許出現的會是和前一天比起來市場處於放量的狀態。
量比上升,股價下跌:這一點一定要小心!這可能是由於主力高位出貨,從而很有可能會導致未來股價的下降。
量比下降,股價上升:在此時也要多加留意!通常是買盤無力導致,股價隨時可能下跌。
總的來說,並不是量比多就會好,因為股票下跌時量比同時也會被放大。正常來說,從1.5到2.3這個范圍的量比,可以認為很多人在買。要是碰到量比在3以上的股,推薦大家多多關注。
三、怎麼利用量比指標來選股?
從量比指標看股和選股的方法會分享給大家。

1、當量比為1.5~2.5倍,處於溫和放量狀態,且股價也處於溫和緩慢上升的態勢。{那麼這意味著該股的升勢還是比較正向的,如果你已經有了這個股票,那麼就接著持股。如果這個股價開始下跌,那麼這個股票的跌勢可能在短期內很難結束,如果大家還沒有買入的話,建議還是要仔細考慮。如果說一些小夥伴已經持有該股,可以依據持有量,考慮一下停損退出。
2、當量比為2.5~5倍,處於明顯放量狀態,並且股價即將突破主力位置或重要支撐。那麼這只股在有效突破的概率上還是很大的,大家能選取相應行動。
3、當量比為5~10倍,處於劇烈放量狀態,加之該股股價長期處於地位,這就意味著該股還有不小的上升空間,恐怕「錢」途無量。
雖然說量比對於我們分析市場走勢起到了很大的作用,是一個重要的指標,但是不能一味的只看這一種指標去選股。
建議剛入門的新手,第一次進行價值投資,優先選擇長期持有龍頭股,避免短線投資被人割了韭菜:吐血整理!各大行業龍頭股票一覽表,建議收藏!

應答時間:2021-09-23,最新業務變化以文中鏈接內展示的數據為准,請點擊查看

7. 簡單高效的選股公式有哪些

財經信紙

在A股市場中本來就是一個莊家和散戶博弈的戰場,那麼為什麼虧的都是散戶呢?原因無非在於三點,選股、買點、賣點,每個股民心中都有一個夢,就是炒股的時候能多抓一些漲停板,那麼究竟如何才能成功穩抓漲停板呢?今天給大家講解幾種選股公式,希望大家仔細學習與領悟。

1、牛股等待啟動選股公式

本人是根據股價與均線的一種比例關系,而編寫的一個選股公式,經長久的試用,效果挺好,很多牛股啟動前大部分都是這個走法,還有高控盤的股票,特拿來分享!

公式源碼:

S2:=IF(NAMELIKE('S'),0,1);

S3:=IF(NAMELIKE('*'),0,1);

S4:=DYNAINFO(17)>0;

ST:FROMOPEN>165 AND MA(C,5)/MA(C,60)>0.95 AND MA(C,5)/MA(C,60)<1.28and MA(C,10)/MA(C,60)>0.95 AND MA(C,10)/MA(C,60)<1.28 AND MA(C,30)/MA(C,60)>0.95AND MA(C,30)/MA(C,60)<1.28 AND CROSS(C,MA(C,5)) AND S2 AND S3 AND S4 AND C<50;

2、抄底高手

{M 153530

N 123227

D 185042}

VAR1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+M<0;var2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+N<0;

VAR3:=VAR1 AND VAR2;

VAR4:=VAR1 AND VAR2 AND COUNT(VAR3,2)=1 AND DATE> AND (CLOSE>OPEN OR CLOSE

-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)

(REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)REF(CLOSE,3) OR REF

(OPEN,3)REF(CLOSE,4) OR REF(OPEN,4)

(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)

VAR5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

VAR6:=(CLOSE-VAR5)/VAR5*100;

VAR7:=REF(VAR6,1)+D<0 AND VAR6>REF(VAR6,1) AND REF(VAR6,1)1.8 AND (HIGH>LOW) AND (REF(HIGH,1)>REF(LOW,1)) AND (REF(HIGH,2)>REF(LOW,2)) AND (REF(HIGH,3)>REF(LOW,3)) AND (REF(HIGH,4)>REF(LOW,4)) AND (REF(HIGH,5)>REF(LOW,5));

VAR4 OR VAR7;

實戰技巧

(1)梅開二度

13日均線向上穿越55日均線以後,股價滯漲回落,13日均線弱勢下叉34日均線,隨著股價的止跌企穩,13日均線開始勾頭向上二次穿越34日均線,我們把在主均線上的13日均線金叉穿越34日均線,稱之為「梅開二度」。

8. 請懂的人幫忙寫一個選股公式!要求:1.當天開盤價的漲幅在-0.5%以上。2.當天量比大於或等於5.

AA:=REF(C,1);
AB:=O>AA*0.995;
AC:=V/REF(MA(V,5),1);
選股:AB AND AC>=5 AND DYNAINFO(7)>0;

{呵呵 事關重大 選股公式源碼如上 量比大於5實在不如大於2 或3 您可以把最後一行的5改為2或3試試 不過 不修改就是您要的了 如果不適用於選股 而是用於盤中分時預警 用樓上的公式也可以的 }

9. 通達信量化選股公式

通達信的選股公式為xg:v>ref(v,1)*2 and c>ref(c,1)。公式的定義為今天的量大於等於昨天量的2倍,股價上漲。此公式的使用說明有以下幾點:1、五行量化指標(淺灰色實心空心方格):實心代表趨勢走好,空心代表趨勢走壞;2、操盤動力線指標(黃金線):短線靈敏指標,低位拐頭向上可跟進,高位拐頭向下要警惕,附有高低位買賣提示;3、海洋狀態指標(綵帶):綵帶顏色代表短中期多空趨勢,低位轉紅可跟進,高位變色宜減倉、清倉。

量化選股的方法
1、多因素模型(Multiple-factor regression)
多因素模型將那些引起證券價格聯動的因素直接加入到收益率公式之中,然後開發基於這些因素的模型,簡化投資組合分析所要求的關於證券之間相關系數的輸入。模型效果的好壞主要取決於因素的選取,即那些被選定的因素是否足以證明,證券收益率之間聯動效應的根源在於那些因素對各證券的共同影響。
2、動量反轉選股
有效市場假說分三個層次,分別為弱有效市場、 半強有效市場、 強有效市場分別代表價格反映了歷史信息、公開信息和全部信息。
動量效應(Momentum Effect)指的是投資策略或組合的持有期業績方向和形成期業績方向一致的股價波動現象;
而反轉效應(ContrarianEffect)則指的是投資策略或組合的持有期業績方向和形成期業績方向相反的股價波動現象。
3、分類和回歸樹(Classification and regression tree)
分類和回歸樹是數據挖掘技術的一種,以遞歸分割技術為基礎(常用於制葯學的研究),包括分類樹和回歸樹:分類樹產生定性輸出,回歸樹處理定量輸出。
4、神經網路(Neural networks)
因為股市的建模與預測所處理的信息量往往十分龐大,因此對演算法有很嚴格要求,它的非線性動力學特性也非常復雜,所以一般傳統的方法對於股市的預測往往難如人意。人工神經網路不僅具有大規模並行模擬處理、網路全局作用和非線性動力學等特點,而且有很強的自適應、自學習以及容錯能力,具備傳統的建模方法所不具有的許多優點,其可以不必事先知道有關被建模對象的參數、結構以及動態特性等方面的知識, 對被建模對象經驗知識要求不高。 而只需給出對象的輸入和輸出數,通過網路本身的學習功能即可實現輸入和輸出之間的映射。

10. 通達信選股公式源碼

你好,通達信選股公式源碼如下。
次日漲停
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=交叉(C,REF(W3,1));
W4和計數(W4,5)=1;
黃轉紫選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
紫柱:MACD<0和MACD>REF(MACD,1)和REF(MACD,1)低位金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
低位金叉:交叉(差異,DEA)和差異<-0.1;
二次金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=計數(交叉(差異,數據包絡分析),BARSLAST(數據包絡分析>=0));
二次金叉:交叉(差異,DEA)和DEA<0,計數(JCCOUNT=2,21)=1;
絕地反彈
(1)
VAR1:=參考值(低,1);
VAR2:=SMA(ABS(低VAR1),13,1)/SMA(最大值(低VAR1,0),13,1)*100;
VAR3:=EMA(如果(關閉*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(低,34);
VAR5:=HHV(VAR3,34);
VAR6:=如果(LLV(低,55),1,0);
VAR7:=EMA(如果(低)<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(低,2)*0.96;
XL2:=MA(低,26)*0.85;
XL3:=REF(XL1,1)啟動:=如果(XL3,0,VAR7*3),則為紅色;
XG:啟動>25;
(2)
倒退((參考(關閉,1)<參考(打開,1)和
關閉>打開和ABS(關閉參考(關閉,1))/關閉<0.002),2);
A2:=過濾器(A1<=V3,10);
ND資本<300000000
REF(V,1)=LLV(V,4)和V>=REF(V,1)
HHV(V,3)=參考(V,1)和HHV(V,5)=參考(V,1)和HHV(V,21)=參考(V,1)
和V>=REF(V,1)
01>0,T02>0;
1.三線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1,A2和A3,C>O和V>REF(V,1),資本<=300000000;
2.三條線粘合
N1:=5;N2:=10;N3:=20;M:=1;
MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
最大值(MA1,最大值(MA2,MA3))/MIN(MA1,最小值(MA2,MA3))<1+0.01*M
C>O和V>REF(V,1)和財務(7)<=300000000
A3及資本<=300000000;
3.均線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.01*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1以及A2和A3;
3.金叉選股指標
快線:=均線(均線)(均線(收盤,2,2,2),;
慢線:=EMA(參考(快線,1),2);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
交叉(快線,慢線) 和C>O和
五> =MA(V,21)和V>REF(V,1),資本<=300000000;

閱讀全文

與大v模型選股源碼相關的資料

熱點內容
程序員用得到數字區嗎 瀏覽:170
python求商 瀏覽:473
ipad能用c語言編譯器嗎 瀏覽:557
軟泥解壓球最新版 瀏覽:994
4萬程序員辭職創業 瀏覽:755
thinkingphp 瀏覽:593
安卓相冊移動文件夾 瀏覽:2
耳朵清潔解壓聲控99的人都睡得著 瀏覽:201
叉車出租網站源碼 瀏覽:870
共享單車的app是什麼 瀏覽:404
不帶gui的伺服器什麼意思 瀏覽:369
金剛經及PDF 瀏覽:98
php中冒號 瀏覽:354
php5432 瀏覽:348
命令在哪使用 瀏覽:168
php獲取網頁元素 瀏覽:704
為什麼需要硬體驅動編譯 瀏覽:881
pm編程怎樣看導柱孔對不對稱 瀏覽:134
農業大學選課找不到伺服器怎麼辦 瀏覽:645
路由配置網關命令 瀏覽:931