導航:首頁 > 源碼編譯 > 絕佳成交量指標公式源碼

絕佳成交量指標公式源碼

發布時間:2022-10-05 23:18:18

❶ 求高手編寫一個通達信:「成交額%」的指標源碼

通達信無法把編寫的公式加到附加欄目和行情界面下。

❷ 求通達信成交量指標公式以及選股公式

你設計的條件中,在日線下當日盤後這個條件只能當日用,並且條件是取的本地計算機時間.

你上面3個條件設計的都是技術指標條件,第四個條件是選股,選股條件是什麼,是上面條件的任意其中一個嗎,還是什麼選股條件

下面公式的選股是選上面條件中的任意一個成立符合選股條件.

技術指標公式

VOLUME:VOL,VOLSTICK;

MAVOL1:MA(VOLUME,5);

MAVOL2:MA(VOLUME,10);

STICKLINE((V>REF(V,1)*1.9) OR (MACHINETIME>113100 AND V>=REF(V,1)),V,0,2,0),COLORFF0080;

STICKLINE((V<REF(V,1)*0.45),V,0,2,0),COLORBLUE;

STICKLINE(COUNT(C>REF(C,1),3)=3 AND COUNT(V<REF(V,1),3)=3,V,0,2,0),COLOR400080;

選股公式

XG:((V>REF(V,1)*1.9) OR (MACHINETIME>113100 AND V>=REF(V,1))) OR (V<REF(V,1)*0.45) OR (COUNT(C>REF(C,1),3)=3 AND COUNT(V<REF(V,1),3)=3);

❸ 周線圖中成交量的指標源碼如何編寫,請高手指教!!!比如,vol為當天量,ref(vol,1)為昨天量,這些都是在

vol為當天量,ref(vol,1)為昨天量
----------------------------------------
說法改一下

vol為當前量,ref(vol,1)為上一周期量
--------------------------------------
你在周線圖中以及30分鍾圖中試試,看你看到了什麼?

❹ 成交量公式

成交量指標公式

核心提示:什麼是成交量均線公式?下面是我搜集的資料為您總結的。

N:=27;N2:=9;N3:=3;N4:=16;
Var1:=IF(DATE>=1030131,1,1);
Var2:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
獲利盤:WINNER(CLOSE)*100*Var1;
Var3:=SMA(Var2,3,1)*Var1;
Var4:=SMA(Var3,N2,1)*Var1;
Var5:=3*Var3-2*Var4*Var1;
Var6:=VOL*Var1;
角度:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100*Var1;
換手: VOL/CAPITAL*100*Var1;
Var7:=SUM(換手,30)*Var1;
Var8:=LLV(INDEXL,5)*Var1;
Var9:=HHV(INDEXH,5)*Var1;
VarA:=EMA((INDEXC-Var8)/(Var9-Var8)*100,4);
VarB:=MA(EMA(0.667*REF(VarA,1)+0.333*VarA,2),9);
VarC:=MA(VarB,30);
VarD:=EMA(獲利盤,4)*Var1;
本盤億股: CAPITAL/1000000;
V5: MA(VOL,5)*2*Var1;
V13: MA(VOL,13)*2*Var1;
CROSS(VarB,VarC) AND VarC<29*Var1;
STICKLINE(VOL AND Var5>Var4,0,VOL,9,0),color000055;
STICKLINE(VOL AND Var5>Var4,0,VOL,8,0),color000066;
STICKLINE(VOL AND Var5>Var4,0,VOL,7,0),color000077;
STICKLINE(VOL AND Var5>Var4,0,VOL,6,0),color000088;
STICKLINE(VOL AND Var5>Var4,0,VOL,5,0),color000099;
STICKLINE(VOL AND Var5>Var4,0,VOL,4,0),color0000aa;
STICKLINE(VOL AND Var5>Var4,0,VOL,3,0),color0000bb;
STICKLINE(VOL AND Var5>Var4,0,VOL,2,0),color0000cc;
STICKLINE(VOL AND Var5>Var4,0,VOL,1,0),color0000dd;
STICKLINE(VOL AND Var5<Var4,0,VOL,9,0),colorFF1100;
STICKLINE(VOL AND Var5<Var4,0,VOL,8,0),colorFF2200;
STICKLINE(VOL AND Var5<Var4,0,VOL,7,0),colorFF3300;
STICKLINE(VOL AND Var5<Var4,0,VOL,6,0),colorFF4400;
STICKLINE(VOL AND Var5<Var4,0,VOL,5,0),colorFF5500;
STICKLINE(VOL AND Var5<Var4,0,VOL,4,0),colorFF6600;
STICKLINE(VOL AND Var5<Var4,0,VOL,3,0),colorFF7700;
STICKLINE(VOL AND Var5<Var4,0,VOL,2,0),colorFF8800;
STICKLINE(VOL AND Var5<Var4,0,VOL,1,0),colorFF9900;
STICKLINE(VOL AND Var4<N4,0,VOL,9,0),color333333;
STICKLINE(VOL AND Var4<N4,0,VOL,8,0),color444444;
STICKLINE(VOL AND Var4<N4,0,VOL,7,0),color555555;
STICKLINE(VOL AND Var4<N4,0,VOL,6,0),color666666;
STICKLINE(VOL AND Var4<N4,0,VOL,7,0),color777777;
STICKLINE(VOL AND Var4<N4,0,VOL,6,0),color888888;
STICKLINE(VOL AND Var4<N4,0,VOL,5,0),color999999;
STICKLINE(VOL AND Var4<N4,0,VOL,4,0),coloraaaaaa;
STICKLINE(VOL AND Var4<N4,0,VOL,3,0),colorbbbbbb;
STICKLINE(VOL AND Var4<N4,0,VOL,2,0),colorcccccc;
STICKLINE(VOL AND Var4<N4,0,VOL,1,0),colordddddd;
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
拋壓:STICKLINE(CROSS(84,RSI),0 ,VOL,9,0),COLORFF0033;
STICKLINE(CROSS(84,RSI),0 ,VOL,8,0),COLORFF0044;
STICKLINE(CROSS(84,RSI),0 ,VOL,7,0),COLORff0055;
STICKLINE(CROSS(84,RSI),0 ,VOL,6,0),COLORff0066;
STICKLINE(CROSS(84,RSI),0 ,VOL,5,0),COLORff0077;
STICKLINE(CROSS(84,RSI),0 ,VOL,4,0),COLORFF0088;
STICKLINE(CROSS(84,RSI),0 ,VOL,3,0),COLORff0099;
STICKLINE(CROSS(84,RSI),0 ,VOL,2,0),COLORff00aa;
STICKLINE(CROSS(84,RSI),0 ,VOL,1,0),COLORff00bb;

VAR13:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR14:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR15:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR16:=(VAR13+VAR14+VAR15)/3;
VAR18:=IF(VAR16<=-20,10,0);
VAR19:=HHV(VAR18,10);
VAR20:=IF(VAR19 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
底部:STICKLINE(VAR20=20,0 ,VOL,9,0),COLOR005555;
STICKLINE(VAR20=20,0 ,VOL,8,0),COLOR006666;
STICKLINE(VAR20=20,0 ,VOL,7,0),COLOR007777;
STICKLINE(VAR20=20,0 ,VOL,6,0),COLOR008888;
STICKLINE(VAR20=20,0 ,VOL,5,0),COLOR009999;
STICKLINE(VAR20=20,0 ,VOL,4,0),COLOR00aaaa;
STICKLINE(VAR20=20,0 ,VOL,3,0),COLOR00bbbb;
STICKLINE(VAR20=20,0 ,VOL,2,0),COLOR00CCCC;
STICKLINE(VAR20=20,0 ,VOL,2,0),COLOR00dddd;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VAR100:=100-3*SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1);
VAR111:=VARF<REF(VAR100,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
大資金活動:STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,9,0),COLOR006600;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,8,0),COLOR007700;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,7,0),COLOR008800;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,6,0),COLOR009900;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,5,0),COLOR00aa00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,4,0),COLOR00BB00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,3,0),COLOR00CC00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,2,0),COLOR00DD00;
STICKLINE(VAR111 AND COUNT(VAR111,30)=1,0 ,VOL,1,0),COLOR00EE00;

❺ 如何安裝雙向成交量指標公式源碼

如果你用的是通達信,在公式管理新建指標公式將下面源碼復制並保存付圖即可。

成交量萬手:VOL/10000,LINETHICK0;

BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主動買:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

主買萬手:主動買/10000,COLORRED;

主動賣:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));

主賣萬手:-主動賣/10000,COLORGREEN;

資金流入億元:主買萬手*CLOSE/100;

資金流出億元:主賣萬手*CLOSE/100;

STICKLINE(VOL>0,VOL,0,2,1),COLORWHITE;

STICKLINE(主動買>0,0,主動買,2,0),COLORRED;

STICKLINE(主動賣<0,0,主動賣,2,0),COLORGREEN;

成交額(億元):AMOUNT/100000000,COLORRED;

換手率:VOL/CAPITAL*100,COLORYELLOW;

❻ 成交量(均量 千手)指標公式

公式 VO=MA(V,m)-MA(V,n)
資金決定成交量,成交量決定趨勢,趨勢決定漲跌,趨勢決定投資者的命運。成交量對應的是成交金額,即「錢」,俗語稱:「錢不是萬能的,沒有錢是萬萬不能的」……資金是逐利的,一個品種的漲與跌,都是資金對於價格的把握而形成,有人鳴槍發號,有人吶喊助威,每一個過程都會有資金的身影在其中,最直觀的體現就在成交量上。
成交量的意義
是指個股或大盤的成交總手,市場成交量的變化反映了資金進出市場的情況,成交量是判斷市場走勢的重要指標。在形態上用一根立式的柱子來表示(如圖)

❼ 求高手編寫一個通達信用:個股每日「成交額」的指標源碼

總購買量:dynainfo (23) * C;
總銷售額:dynainfo (22) * C;
Stickline(總購買金額 < > 0,0,總購買金額,5,0),顏色為紅色;
Stickline(總銷售額 < > 0,總購買量,總銷售額,5,0),顏色綠色;
Stickline(總購買量,0,0,總購買量,5,0),紅色
詳細信息:操作數沒有對應的運算符匹配!
錯誤起始位置:48; 長度:1
拓展資料
1.股票技術指標屬於統計范疇。它們是一些用來衡量一切的數據指標,用數據來展示股票走勢、交易等。通過指數代碼,股票軟體可以用公式自動計算出股票技術指數。估計只能手動操作了。
2.首先選擇通大信報價,按7,選擇深滬A股,列出股票,點擊上方的增加一兩次。一次按股價漲幅排列股票後,在屏幕上右擊選擇「批量操作」,在新對話框中選擇「全選」,然後「添加到板塊」和「新板塊」,然後重復上一步,依次將90隻股票加入新版塊,返回通大信報價主界面,中下邊自定義。單擊後,將出現列表。選擇剛才新建的板塊,90隻股票都在裡面。在菜單欄中選擇第二個「功能」,選擇「報價分析」。左上角有一個尖銳的向下的小三角形。單擊並選擇「平均值」以等待計算。
3.除非您使用超級計算機,否則對垂直統計的需求會導致您的計算機速度急劇下降。一般計算機不推薦使用縱向統計。 i7沒測試過,8核電腦測試過,涉及縱向統計。電腦只是卡住了。可以按指標排序,對交易金額進行排序,並附上上述指標。符合條件的另存為另一盤這比那快得多
4.股票是股份公司發行的所有權憑證,是股份公司為籌集資金而發行給各個股東作為持股憑證並藉以取得股息和紅利的一種有價證券。每股股票都代表股東對企業擁有一個基本單位的所有權。每支股票背後都有一家上市公司。換言之,每家上市公司都會發行股票。同一類別的每一份股票所代表的公司所有權是相等的。每個股東所擁有的公司所有權份額的大小,取決於其持有的股票數量占公司總股本的比重。股票是股份公司資本的構成部分,可以轉讓、買賣或作價抵押,是資本市場的主要長期信用工具,但不能要求公司返還其出資。
5.股票投資是一種沒有期限的長期投資。股票一經買入,只要在股票發行公司存在,任何股票持有者都不能退股,即不能向股票發行公司要求抽回本金。同樣,股票持有者的股東身份和股東權益就不能改變,但他可以通過股票交易市場將股票賣出,使股份轉讓給其他投資者,以收回自己原來的投資。

❽ 成交量VOL公式編碼

以下是通達信成交量公式源碼:
成交量:=VOL/100,VOLSTICK;
VAR1:=成交量/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主買:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+ (CLOSE-LOW)),成交量/2)),NODRAW;
主賣:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- VAR1*(HIGH-LOW),0-成交量/2)),NODRAW;
STICKLINE(成交量>0,成交量,0,2.5,0),COLORCYAN;
STICKLINE(主買>0,0,主買,2.5,0),COLORRED;
主持倉:EMA(100*(CLOSE- LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF;
主集中度:WINNER(C)*100,COLORRED;
散集中度: (WINNER(C*1.1)-WINNER(C*0.9))*100,COLORGREEN;
地量:=成交量<LLV(成交量,14)*1.001;
買賣差:(主買+主賣),NODRAW,COLORYELLOW;
買賣比:(主買/主賣),NODRAW,COLORYELLOW;
換手率:=VOL/CAPITAL*100;
換手55:SUM(換手率,55),NODRAW,COLORLICYAN;
買賣差55:SUM(買賣差,55),NODRAW,COLORGRAY;
量能飽和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))>1,1,(AMOUNT/C) /(HHV(AMOUNT,20)/HHV(C,20)))*100,COLORYELLOW,NODRAW;
中點:=REFDATE(HHV(EMA(買賣差,9),120),DATE)*2;
STICKLINE(CURRBARSCOUNT=19,中點*1.9,中點*1.5,120,1),COLOR00DDDD;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=19,中點*1.88,中點*1.52,量能飽和度*1.2,0),COLOR0033FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=19,中點*1.82,中點*1.58,量能飽和度*1.2,0),COLOR0077FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=19,中點*1.76,中點*1.64,量能飽和度*1.2,0),COLOR0099FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=19,中點*1.7,中點*1.7,量能飽和度*1.2,0),COLOR00DDFF;
STICKLINE(CONST(C<O)=1 AND CURRBARSCOUNT=19,中點*1.88,中點*1.52,量能飽和度*1.2,0),COLORFF7700;
STICKLINE(CONST(C<O)=1 AND CURRBARSCOUNT=19,中點*1.82,中點*1.58,量能飽和度*1.2,0),COLORFF9900;
STICKLINE(CONST(C<O)=1 AND CURRBARSCOUNT=19,中點*1.76,中點*1.64,量能飽和度*1.2,0),COLORFFBB00;
STICKLINE(CONST(C<O)=1 AND CURRBARSCOUNT=19,中點*1.71,中點*1.69,量能飽和度*1.2,0),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=22,中點*2.3,'量能飽和度'),COLORYELLOW;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),NODRAW,COLOR000099;
V2:=IF(CURRBARSCOUNT=1,成交量*240/FROMOPEN/REF(成交量,1)-1,成交量/REF(成交量,1)-1);
STICKLINE(成交量>0,成交量,0,2,1),COLORWHITE;
STICKLINE(主買>成交量/2,0,成交量,2,0),COLORYELLOW;
STICKLINE(主買<=成交量/2,0,成交量,2,0),COLORWHITE;
STICKLINE(主買>0,0,主買,2,0),COLORRED;
STICKLINE(主賣<0,0,主賣,2,0),COLOR00FF00;
STICKLINE(地量>0,0,成交量,1,0),COLORMAGENTA;
STICKLINE(V2>=1,成交量,0,1,0),COLORYELLOW;

❾ 幫忙弄個最準的成交量特色選股公式謝謝。

成交量:=VOL;
立柱量:=成交量>=2*REF(成交量,1);
立柱量;

閱讀全文

與絕佳成交量指標公式源碼相關的資料

熱點內容
編譯時間和更新時間 瀏覽:222
華為文件夾訪問限制 瀏覽:240
程序員項目管理檢討書 瀏覽:209
繞過壓縮包密碼 瀏覽:705
如何登錄別人的雲伺服器 瀏覽:216
蜘蛛俠解壓所以從高空摔下來視頻 瀏覽:758
c語言設計編譯器 瀏覽:863
eclipsejava混淆 瀏覽:692
咖啡程序員 瀏覽:631
編程寶典pdf 瀏覽:443
伺服器uc1是什麼 瀏覽:810
文件夾有個字錯了怎麼統一替換 瀏覽:609
手機搶號伺服器很卡怎麼辦 瀏覽:392
andpython 瀏覽:963
高濟互聯網醫院app怎麼購買 瀏覽:881
網能從手機上設置加密嗎 瀏覽:832
普通app怎麼製作 瀏覽:285
浪潮伺服器raid怎麼測試 瀏覽:25
壓縮彈簧總圈數 瀏覽:201
手機內屏壞了怎麼操作app 瀏覽:652