導航:首頁 > 源碼編譯 > 最有潛力的選股源碼

最有潛力的選股源碼

發布時間:2022-10-06 18:36:30

⑴ 請老師將下列源碼做個選股公式,要求選出"有牛"的股票

{顯示儀表盤=1} ;
范圍高A:=REFDATE(HHV(H,120),DATE)*1.05;
范圍低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA24:=MA(C,24);
MA72:=MA(C,72);
MA200:=IF((MA(C,200)<=范圍高A AND MA(C,200)>=范圍低A) OR C>=MA(C,200),MA(C,200),DRAWNULL);
有牛:MA24<MA72 AND C>=MA72 AND MA72<MA200 AND C>=MA200;

⑵ 選股源碼編輯

摘要 你好!以下公式僅供學習研究之用:

⑶ 九品神龍九品神龍選股指標的源碼

摘要 神龍在天指標是tdx自帶副圖指標,其編制原則建立在收盤價和階段最高價基礎上。

⑷ 250分!!!求好的選股公式,必有重謝!!!

每個人想法不同,針對你手裡資金量也有不同的方案,全且當你也是個小散吧。選股分長線短線,但是實際上都差不多。第一找業績極為突出的,比如三季報八毛多,股價才三十上下的。其次看行業,要穩定的行業,才能做大做長,第三看政策面,政府是否支持。最後看相對價位,同類相比,和自己的前期高點比,是否處於相對低價。
益盟操盤手經典指標源碼及使用方法(全部)

ABJB
按部就班
N(1,100,5)
現價:C;
頂部: cost(95) ,colorffff33;
賣出: cost(75) ,colorgreen;
買入: cost(30) ,colorred;
底部: cost(5) ,colorteal;

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

LTSH
龍騰四海
N(1,100,8)
坐標線:0;20;50;80;100;
100-100*(HHV(HIGH,5*N)-CLOSE)/(HHV(HIGH,5*N)-LLV(LOW,5*N));
海面:20,COLORGREEN;
海天分界線:50,COLORYELLOW;
天際:80,COLORRED;
————————————————————————
QSDD
趨勢頂底
80,COLOR996699;
20,COLORGREEN;
10,COLORCC6633,LINETHICK2;
90,COLOR9966FF,LINETHICK2;
{
50,COLORRED;
FILLRGN(1,20,80),color222222;
FILLRGN(1,90,100),color000068;
FILLRGN(1,79,90),color663366;
FILLRGN(1,10,20),color666600;
FILLRGN(1, 0,10),color663300;
}
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
d:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),linethick2;
長期線:A+100,color9900FF;
短期線:B+100,color888888;
中期線:d+100,coloryellow,linethick2;
{見頂:(長期線>85 or ref(長期線,1)>85 ) and (cross(中期線,短期線) or cross(ref(中期線,1),ref(短期線,1)) )and cross(長期線,短期線);
}
見頂:(ref(中期線,1)>85 and ref(短期線,1)>85 and ref(長期線,1)>65) and cross(長期線,短期線) ;
頂部區域:(中期線<ref(中期線,1) and ref(中期線,1)>80) and (ref(短期線,1)>95 or ref(短期線,2)>95 ) and 長期線>60 and 短期線<83.5
and 短期線<中期線 and 短期線<長期線+4;
頂部:=filter(頂部區域,4);
{DRAWICON( 見頂, 108, 2 );}
底部區域:(長期線<12 and 中期線<8 and (短期線<7.2 or ref(短期線,1)<5) and (中期線>ref(中期線,1) or 短期線>ref(短期線,1)))
or (長期線<8 and 中期線<7 and 短期線<15 and 短期線>ref(短期線,1)) or (長期線<10 and 中期線<7 and 短期線<1) ;
stickline( {見頂 or} 頂部,99,103,20,1 ),colorred,linethick2;
stickline( 底部區域,-4,0,22,0 ),colorgreen;
低位金叉:長期線<15 and ref(長期線,1)<15 and 中期線<18 and 短期線>ref(短期線,1) and cross(短期線,長期線) and 短期線>中期線
and (ref(短期線,1)<5 or ref(短期線,2)<5 ) and (中期線>=長期線 or ref( 短期線,1)<1 );
stickline( 低位金叉,0,5,11,0 ),colorred;
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
BDWQ
波段無敵
P1:=0;
P2:= IF (CLOSE>MA(CLOSE,5),P1+10,P1-10);
P3:= IF (CLOSE>MA(CLOSE,10),P2+10,P2-10);
P4:= IF (CLOSE>MA(CLOSE,10),P3+10,P3-10);
P5:= IF (MA(CLOSE,5)>MA(CLOSE,10),P4+10,P4-10);
P6:= IF (MA(CLOSE,10)>MA(CLOSE,20),P5+10,P5-10);
BD:P6;
STICKLINE(BD>=-50,-50,BD,3,0),COLORGREEN;
STICKLINE(BD>=-30,-30,BD,3,0),COLORFFFF00;
STICKLINE(BD>=0,0,BD,3,0),COLORYELLOW;
STICKLINE(BD<=50 AND BD>=30,30,BD,3,0),COLORRED;
{STICKLINE(BD<=50 OR BD>=30,30,BD,3,0),COLORRED;}

………………………………………………………………………………
BHLCT
冰火兩重天
P1(1,100,16)
能量:=SQRT(VOL)*(((C-(H+L)/2))/((H+L)/2));
平滑能量:=EMA(能量,P1);
能量慣性:EMA(平滑能量,P1) ;
STICKLINE(能量慣性>=0,(能量慣性-能量慣性*0.05),(能量慣性-能量慣性*0.15),3,0), COLOR0000CC;
STICKLINE(能量慣性>=0,(能量慣性-能量慣性*0.2),(能量慣性-能量慣性*0.35),3,0), COLOR0066FF;
STICKLINE(能量慣性>=0,(能量慣性-能量慣性*0.4),(能量慣性-能量慣性*0.55),3,0),COLOR0099FF;
STICKLINE(能量慣性>=0,(能量慣性-能量慣性*0.6),(能量慣性-能量慣性*0.75),3,0), COLOR00CCFF;
STICKLINE(能量慣性>=0,(能量慣性-能量慣性*0.8),(能量慣性-能量慣性*0.95),3,0), COLOR00FFFF;
STICKLINE(能量慣性<0,(能量慣性-能量慣性*0.05),(能量慣性-能量慣性*0.15),3,0), COLORFF3300;
STICKLINE(能量慣性<0,(能量慣性-能量慣性*0.2),(能量慣性-能量慣性*0.35),3,0), COLORFF6600;
STICKLINE(能量慣性<0,(能量慣性-能量慣性*0.4),(能量慣性-能量慣性*0.55),3,0), COLORFF9900;
STICKLINE(能量慣性<0,(能量慣性-能量慣性*0.6),(能量慣性-能量慣性*0.75),3,0), COLORFFCC00;
STICKLINE(能量慣性<0,(能量慣性-能量慣性*0.8),(能量慣性-能量慣性*0.95),3,0), COLORFFFF00;
------------------------------------
cmfx
籌碼分析
HSL:=EMA(VOL/CAPITAL,3);
ZDL:HHV(HSL,240);
ZXL:LLV(HSL,240);
XS:=MA(C,33);
鎖定籌碼:EMA((HSL-ZXL)/ZXL*XS,13);
浮動籌碼:EMA((ZDL-HSL)/HSL*XS,13);
力量對比:鎖定籌碼-浮動籌碼 ,COLORSTICK;
------------
dkby
多空博弈
VAR1:=(HHV(HIGH,21)-C)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
VAR2:=(C-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=SMA(VAR2,13,8);
高位:90;
低位:0;
多方: SMA(VAR3,13,8),COLORRED;
空方: SMA(VAR1,21,8),COLORGREEN;
中軸:45;
-----------------
mmpp
買賣頻譜
買線:EMA(C,3);
賣線:EMA(SLOPE(C,21)*20+C,55);
買賣差:=買線-賣線;
STICKLINE(買賣差>=0,(買線-買賣差*0.05),(買線-買賣差*0.15),5,0) ,COLOR00FFFF;
STICKLINE(買賣差>=0,(買線-買賣差*0.2),(買線-買賣差*0.35),5,0) ,COLOR00CCFF;
STICKLINE(買賣差>=0,(買線-買賣差*0.4),(買線-買賣差*0.55),5,0) ,COLOR0099FF;
STICKLINE(買賣差>=0,(買線-買賣差*0.6),(買線-買賣差*0.75),5,0) ,COLOR0066FF;
STICKLINE(買賣差>=0,(買線-買賣差*0.8),(買線-買賣差*0.95),5,0) ,COLOR0000CC;
STICKLINE(買賣差<0,(賣線+買賣差*0.05),(賣線+買賣差*0.15),5,0) ,COLOR006600;
STICKLINE(買賣差<0,(賣線+買賣差*0.2),(賣線+買賣差*0.35),5,0) ,COLOR009900;
STICKLINE(買賣差<0,(賣線+買賣差*0.4),(賣線+買賣差*0.55),5,0) ,COLOR00CC00;
STICKLINE(買賣差<0,(賣線+買賣差*0.6),(賣線+買賣差*0.75),5,0) ,COLOR00FF00;
STICKLINE(買賣差<0,(賣線+買賣差*0.8),(賣線+買賣差*0.95),5,0) ,COLOR66FF00;
------------
zljc
主力進出
MAV:=(C*2+H+L)/4;
SK:= EMA(MAV,13) - EMA(MAV,34);
SD := EMA(SK,5);
中軸:0;
空方主力 : (-2*(SK-SD))*3.8,COLORGREEN;
多方主力 : (2*(SK-SD))*3.8,COLORRED;
--------------------------------------

按部就班:
1。白線為當日收盤價,黃線為底部價格,紅線為買入價格,綠線為賣出價格,藍線為頂部價格。
2。白線上穿黃線說明股票底部形態已初步形成,可能目前股價已經處於最低價,但不建議建倉,可以關注。
3。白線上穿紅線說明股票底部已經確立,股價已經進入可以建倉階段,突破點就是買入點,開始建倉。
4。白線上穿綠線說明股價已經開始拉升,此時已經不宜繼續加倉,而應該持股待漲,隨時准備賣出。
5。白線上穿藍線說明股價已經進入頂部區域,此時風險較大,隨時准備離場。
6。白線向下擊穿藍線說明頂部已經基本形成,開始逐步減磅,獲利豐厚者可以考慮清倉。
7。白線向下擊穿綠線,說明股價頂部已經確認,此時進一步賣出手中剩餘倉位,清倉離場。
8。白線向下擊穿紅線或者黃線均說明股價仍然處於弱勢,繼續觀望,等待時機。
9。各線條數值亦可作為阻力位,支撐位,目標位來看待。

龍騰四海
1.取值范圍0-100。
2.海面以下為空頭控盤區域,不得介入。
3.天際以上為多頭快速拉抬區,經常為主升浪階段。
4.海面到天際之間多頭控盤區,正常的股價拉升及調整區域。
5.當「龍騰四海」由上穿海面時為買入信號,回穿海面再次上穿為加倉信號,配合操盤線買點使用更加佳。
6.當「龍騰四海」由下穿天際為賣出信號,如「龍騰四海」為100,則通常第二天必然出現近期最高價,考慮第二天出貨。
8.該指標不適用於領漲股及主力完全控盤無量上漲的股票,因為這類股票經常會在80左右反復震盪,但股價卻不斷走高,它比較適用於二線股,跟漲的股票。

趨勢頂底
長、中、短期趨勢顯示,便於用戶明確股價當前走勢的狀況。頂部的紅色區域和底部的藍綠色區域用於用戶識別股價走勢的高低和超買超賣情況。最底部的綠色方塊顯示階段性底部,出現的紅點意味短線抄底信號;而頂部的紅色方框表示階段性頭部區域提示用戶要謹慎。用戶使用時以黃色的中期趨勢線為主要的判斷依據,結合灰色短期線和紅色長期線把握買賣點,當長期趨勢線向上時盡量選擇短期線回調時進場,反之要注意高拋止贏止損。可作為操盤線的有效輔助判斷工具。
具體的使用方法並不復雜,作為一個輔助指標應與操盤線結合使用。用法的要點如下:
1) 3條曲線的多空頭排列,類似均線系統,可以確認BS點買賣信號。
2) 3條曲線的方向分別表明了當前股價的短中長期運動趨勢。
3) 3條曲線的位置,超買超賣現象類似擺動指標(20以下為超賣,80以上超買)。某些情況下有底部、抄底買點和風險區域信號提示,方便用戶了解當前股價狀態。
4) 中長期曲線的頂底部背離特徵,用法類似傳統指標。

波段無敵
1、取值范圍:-50~+50。
2、0軸以下為空方優勢區域,0軸以上為多頭優勢區。
3、若BD值等於-50且橫盤,堅決持幣觀望。
4、若BD值等於+50且橫盤,堅決持股待漲,且往往會漲勢加速。
5、股價回調不破+30,繼續持股待漲,屬於正常調整。

冰火兩重天
1、暖色系圖譜為多頭控制區域,冷色系為空頭控制區域。
2、若股價創新高而該指標不同步創新高,則產生頂背離,表明股價上漲乏力,隨時准備賣出,此時最好結合60分鍾操盤線賣出,以獲得最大利潤。
3、若股價創新低而該指標不同步創新低,則產生底背離,表明股價下跌開始缺乏動力,隨時准備介入,此時若日線操盤線發出買入信號,則介入的安全系數會比較大。

籌碼分析:
分析市場籌碼流動情況,掌握多空對戰實力。
1。白線代表市場鎖定籌碼,多為主力控盤籌碼,數值越大說明主力控盤鎖定籌碼越多,上漲概率越大。
2。黃線代表市場浮動籌碼,多為散戶流動籌碼,數值越大說明散戶持有浮動籌碼越多,下跌概率越大。
3。柱差反映市場籌碼控盤能力,反映主力控盤力度,預示後市上揚概率及幅度,紅柱越大,說明主力控盤度越高,上漲概率越高,反之則下跌概率越高。

多空博弈
1。當「多方」線向上與「空方」線「金叉」時為買點。
2。當「多方」線向下與「空方」線「死叉」時為賣點。

買賣頻譜:
1。白線為買線,黃線為賣線。
2。當白線向上穿越黃線為買入信號,此時柱差顯示為紅色系頻譜。
3。當白線向下擊穿黃線為賣出信號,此時柱差顯示威綠色系頻譜。
4。紅色系頻譜展開越充分,上升力度越強。
5。綠色系頻譜展開越充分,下跌力度越強。

主力進出:
1。若多方主力向上穿越空方主力,則為買入信號。
2。若多方主力向下擊破空方主力,則為賣出信號。

自己試試看那個好用用那個吧,技術指標我有很多。買賣判斷還是要靠自己。如果技術指標就可以賺錢,就沒人虧錢了。
發現強勢股的主要方法:

從實戰操作角度講,大資金的運做遠比小資金的操作技術性要求高,其操作的痕跡必然要顯露出現,這樣就給中小資金帶來了一定的伏擊機 會給職業機構發現強勢股的主要手段有以下幾種:

1、技術性態來發現強勢股

在大盤強勢的時候,每當大盤進行技術調整時,目標股基本上呈現較強的走勢,比如說橫盤或者小幅上漲,特別是那些在大盤強勢後出現較大的下跌時,放大量逆市上漲的個股,最典型的如1996年12月中旬大盤連續出現三個跌停板的背景下,東大阿派逆市放量上漲,後來,該股成為1997年漲幅最大的股票。在一個例子是1998年8月長江發大水滬市連續數周大跌,但西寧特鋼逆市放量打上漲,在其後大盤表現一般的情況下,該股成為漲幅最大的明星股之一。在大盤弱勢時,股價能夠無量沿均線連續走出上升通道的股票,或者在大盤出現一個稍微大的跌幅,目標股股價受到影響,但隨後在大盤止跌後立即有反應的。在大盤處於正常的波動時,目標股的總體賣天的成交量不大,再股價掛單檔位上,經常有連續的較大買單或者賣單出現,此時再有其它的較大買賣單與掛單成對手成交,股價盤面上會立即有反應的個股,在經歷一定時間後可能會成為強勢股,深圳方大在其上市後的第一次大幅上漲前就有該種現象。

2、從歷史及時成交量能來發現強勢股

在股價觀察參考時間前的一段時間,股價在一個箱體內(橫盤或者緩斜上)震盪,經常出現量價異動的個股,在其出現一次破位後,股價立即強勢上漲,該股有望成為強勢股,如大元股份的市場表現。在某主流熱點股票群體上揚後,其中的一些股票市場表現明顯強於其它多數股票,在技術調整後又再次放量上漲的個股容易成為強勢股,比如2000年春節後的上海梅林。在大盤高點或者低點,逆市連續單邊表現的個股容易成為強勢股,比如2000年初的上菱電器。

3、從市場題材來發現強勢股

某個個股明顯具有可操作題材容易成為強勢股,比如說在轉債發行新股前轉債題材(如南化轉債),在基金分紅前的填權題材(安信基金),螺旋槳線股的報表題材(2001年的松遼汽車),出利空後立即放量上攻的朦朧題材(2001年4月的信聯股份),具有第一次概念的獨特題材(煙台萬華)。

4、從歷史信息記錄來發現強勢股

最常見的該類強勢股有,第一是市場形象突出的個股一旦出現異動容易成為強勢股,這里的市場形象主要有,基本面突出有龍頭潛力,股本結構突出(三無概念或者小盤股),股價表現特別沉悶的個股;第二是有明顯操作風格的主力重倉持有的個股,比如說華安基金管理公司重倉的個股,在每輪行情中都回冒出幾匹;第三是有特殊事件發生,股價量價配合默契的個股,比如說羅牛山、青山紙業、通化金馬內部職工股上市時的市場表現(現在更流行戰略投資者);第四是大盤強勢時,成交量連續成為市場中最大的一類個股,在大盤弱勢中,成交量連續成為最小的一類個股。第五是市場都看好又不敢買,但還在漲的個股容易成為強勢。

手把手之選股的N個關鍵點法:

由於工作和學習牽扯了大量的精力和時間,因此筆者選擇了長線投資的策略。雖然持續4年的大熊市使股票投資者整體虧損嚴重,但筆者在始終保持重倉的情況下,通過運作為數不多的個股,在熊市中仍保持了接近15%的年收益率。我總結了一些選股方法。

中小投資者由於資金量小,因此集中投資不超過6隻股票才是明智的選擇,長線投資更適合。那麼如何才能從千餘只股票中找出值得長線投資的個股呢?我總結了以下方法:

首先是十不選。凡上市公司有以下十種情況中任何一種,就一票否決。通過這種方法可以排除95%以上的公司。

一、有信用污點的公司不選。包括:大股東掏空上市公司,虛假陳述,隱瞞應當披露的信息,內幕交易,提供虛假會計信息等等。

二、整體不景氣行業的公司不選。行業整體不景氣,上市公司的經營就會受影響。

三、母公司經營不善的公司不選。上市公司的母公司常被稱為集團公司,如果集團公司經營不善,那麼上市公司的經營能力往往也好不到哪裡去,而且掏空上市公司的危險性也會上升。

四、主業不突出,搞多元化經營的公司不選。

五、企業規模過小的公司不選。規模過小的上市公司沒有形成規模效應,經營成本高、抗風險能力弱。

六、績差績平公司不選。

七、5年內業績大幅波動的公司不選。這一條同時排除了許多上市時間短的公司。公司業績大幅波動說明公司經營不穩定,風險較高。要考察公司的穩定性,5年時間是必須的。

八、無穩定現金分配的公司不選。穩定的現金分配證明了公司經營的穩定性和業績的真實性。造假的公司只能造出帳面利潤而不能造出現金,只能通過送轉股分配而不能通過現金分配。

九、被媒體質疑的公司不選。

十、庄股、累計漲幅巨大的公司不選。

在排除了上述上市公司後,可選擇的公司已經不多。如果投資者覺得所有股票都被排除了,那索性就不要買股票。如果還有股票沒被排除,那麼就挑選符合下列四種條件的股票。

一、選有壟斷性的公司。壟斷包括地理位置壟斷、資源壟斷、行政許可壟斷、技術壟斷等。排位靠前的壟斷方式可靠性較高,壟斷是超額利潤的來源。

二、選在國際競爭中具有比較優勢的產業的公司。

三、選行業龍頭公司。

四、選中高價公司。這與多數人的想法不符。但事實是:越是低價的股票其價值越容易被高估,因為其絕對價格看起來比較便宜;越是高價的股票其價值越容易被低估,因為很多人買不起。我在多年投資中,為我帶來較好收益的幾乎全部是中高價股票,低價股投資整體是虧損的。

當然,通過上述方法選擇股票後,還要掌握好介入時機。

投資高手選股絕招:

威廉. 鷗內爾在1958年開始股票生涯,是華爾街最頂尖的資深投資人士。他白手起家,三十歲時就買下紐約證券交易所席位,並於洛杉磯創辦執專業投資機構之牛耳的奧尼爾公司,目前是全球六百位基金經理人的投資顧問 。在1983年創辦《投資者財經日報》,該報成長迅速,是《華爾街日報》的主要競爭對手。同時他是一位樂觀主義者,也是一位美國式經濟制度的熱誠追隨者和支持者,他說:「在美國每年都有好機會,你要隨時做好准備,抓住時機,你會欣喜地發現一顆小小的的橡果會長成巨大的橡樹林,只要勤奮和持之以恆,凡事都可有成,你本人希望成功的決心才是最重要的的因素。」

威廉.鷗內爾1988年以其四十年來研究股市的心得和經營共同基金的實證經驗,著有《股海淘金》一書,他將他的選股藝術淬煉出CANSLIM的選股模式,這個選股模式可以成為你最簡單的分析手段。很多人認為投資股票和減重一樣困難,Can(可)Slim(瘦)意味著減肥的成功。

「C」=股票每季每股收益
檢閱過去的大黑馬的特徵,就是盈餘均有大幅度的增長,尤其是最近一季,因此,適合買進股票應該是:與去年同季相較的當季每純益(最近公告的一季)有高成長。但也要注意,若是去年同季獲利水平很低,例如每股收益僅1分,今年5分,就不能包括在內。

當季收益高速增長,應當排除非經常性的收益,比和有些公司靠出售一些資產,取得了巨額的收益,這些收益以後將不會再出現,因此,不會理會這些公司。最好的情況,就是每股收益能夠加速增長,這類公司是股市的明星。

當季收性益成長率至少應在20%-50%或更高;最好的純益成長率更可能高達100%至500%之間。而每股純正益成長率8%或10%是不夠的,你若想挑出黑馬股,這些是最基本的要求。

「A」=年度每股線性益成長率
一隻好股票過去5年的每年每股純收益應較上年度每股純收益顯著成長。值得你買的好股票,應在過去的四到五年間,每股純收益年度復合成率達25%至50%,甚至100%以上。據統計,所有飆升股票在初動時的每股純收益年度復合成長率平均為24%,中間值則21%。

一隻表現優異的股票,需要在最近幾年有出色的盈餘成長紀錄,更不能欠缺的是最近數季大幅成長的盈餘成果,這兩者缺一不可。許多人把本益比高低作為選股的標准,但是,無法判斷到底應該買進或賣出股票,在多數情況下,一隻股不會因本益比很低,就大幅漲升,相反,大飆升股的本益比往往是市場平均值的2倍,甚至更高,事實上,每股純收益成比率與股價上漲之間的關系,要較本益比股價漲跌之間的關系,遠遠來得密切。所以,投資者將分析重點放在,找出過去5年每股純益成長明確增長的潛力股。不要聽信任何藉口,一隻好股票必須是年度純收益成長與最近幾季每股純收益成長同步向榮。

"N"=新東西、新管理層、股價新高
公司展現新氣象,是股價大漲的前兆。它可能是一項促成營業收入增加及盈餘加速成長的重要新商品或服務;或是過去數年裡,公司最高管理階層換上新血液。新官上任三把火,不管事何,新領導人至少會替公司帶來新的理念及注入新的活動 。或者,發生一些和公司本身產業有關的事件,如:產品供不應求、售價激升或新科技引進,均可能使同一產業里所公司受益。

大多數人都不敢買創出新高的股票,反而逢低搶進越跌越多的股票。據研究,在以前數次股市的行情循環里,創新高的股票易於再創出高價。買進股票的最佳時機是在漲勢正逐漸止穩,進而向上邁向新高時,正是考慮的最佳時刻----最好在股票突破盤整期之時就先買進。但千萬不要等到股價已經漲逾突破買價5%或10%後,才跚然進場。股價走勢若能在盤整區中轉強,向上接近或穿越整理上限,則更值得投資。

在研究過去1953年至1993年年間能夠大漲的股票之後,我們發現,超過95%的飆股不是推出重要的新商品或服務、更換經營層,就是在該產業里出現有利的環境變化。買入一隻多數投資者起先都覺得有些貴的股票,然後等待股票漲到讓那些投資人都想買這只股票的時候,再賣出股票。

"S"=流通股本要小
通常股本較少的股票較具股價表現潛力,一般而言,股本小的股票流動性較差,股價波動情況會比較激烈,傾向於暴漲暴跌,但是,最具潛力的股票通常在這些中小型成長股上,過去40年,對於所有飆升股的研究顯示,95%公司的盈餘成長及股價表現,最高峰均出現在實收股份少於2500萬股,流通股本越少越好,易於被人操縱,顯然易於漲升。

"L"=領漲股
在大多數情況下,人們傾向於買自己一向喜歡、覺得安心、熟悉的那幾檔股票。但是,你的愛股通常未必是當時市場最活躍的領漲股,若只因你的習慣而投資這些股票,恐怕只好看他們慢牛拖步。要成為股市的羸家的法則是:不買落後股,不買同情股,全心全力抓住領漲股。在你採用這項原則之前,要先確認股票是在一個橫向底部型態,而且股價尚未向上突破後上升了5%或10%,這樣,可以避免追進一隻漲得過高的股票。

領漲股的相對強弱度指數RSI一般不少於70,在1953年至1993年間,每年股價表現最好的500檔美國上市股票,在真正大漲之時的平均相對強弱度指數RSI為87。股市中強者恆強,弱者恆弱是永恆的規律,一旦大盤跌勢結束,最先反彈回升創新高的股票,幾乎肯定是領漲股。所以,不買則已,要買就買領漲股。

"I"=大機構的關照

股票需求必須擴大到相當程度,才能剌激股票供給需求。而最大的股票需求好來自大投資機構,一隻股票之所以會漲,不全然是因為很多家投資機構搶著買進投資,但至少部分原因是因為投資機構投資這只股票,擁有幾家投資機構認同是最基本而合理的。

大投資機構的認同可以來自其同基金,企業退休基金、保險公司、大型投資顧問、銀行信託部門等,但是,一隻股票若是贏得太多的投資機構的關照,將會出現大投資機構爭相搶進、買過頭的現象(搶庄),一旦公司或大盤出了情況,屆時競相賣出的壓力是十分可怕的。

知道有多少大投資機構買進某一隻股票並不那麼重要。最重要的是去了解操作水準較佳的大投資機構的持股內容;而知道擁有多少家大投資機構認同的唯一用途,就是可藉此判斷最近一季的股市趨勢。綜括而論,適於投資者買進的股票,應是最近操作業績良好的數家大投資機構所認同的股票。

"M"=大市走向

你可以找出一群符合前6項選股模式的股票。但是一旦看錯大盤走勢,在你持有的股票中,約有七八成股票恐將隨勢沉落,慘賠出場。所以,你必須學習一套簡易而有效的方法,來判斷大盤是否處於多頭行情或是空頭行情。研判大盤走向最好的方法就是了解並跟蹤每日大盤指數的波動與走向。市場頭部形態出現一般有幾種形式:

1)一般是市場上漲到一個新高度,但成交量較低,說明在這個價格高度股票的需求量不大,這一上漲容易收挫,

2)成交量猛沖幾天,但每次收盤後發覺股票指數幾乎沒有或很少上漲
3)原來發動牛市的領漲股票開始突破下跌,

4)ADL指標(每天上漲股票家數和下跌股票家數的差值)如股票指數平均線背馳,
5)銀行加息。

市場上能夠符合上述原則的股票僅在少數,而這些股票之中也只有2%的股票成為飆升股,有的升幅超過一倍,足可以彌補由於選股不當造成的損失。投資者所要做到的是,買進所有的股票,訂下損失時你准備止損的價位,專注心力觀察股價是否已經到達這些設定價位,一旦達到及時止損,一般而言,在購進成本以下7%至8%的價位絕對是止損的底線。

⑸ 二板定龍頭選股公式源碼

ZD:=(C-REF(C,1))/REF(C,1)*100;
ZDTP:EVERY(ZD>9.9,2);{二連板}。
拓展資料
選股有條件的:
條件一、不同的大勢有不同的選擇。升勢的時候選擇板塊類的個股;盤整的時候突破的個股比較好;跌勢的時候我是不會做板塊的,即使做了,那些除了龍頭股以外的個股也不會跟著被帶上來。
條件二、選擇龍頭股。假如在領頭的股票身上賺不到錢又怎能在別的股票身上賺錢呢?即使我要做整個板塊,也是有一隻的籌碼比較集中的作為領頭羊。同樣的,即使是超跌反彈等行情也都是有籌碼最集中的。
條件三、盡量在尾盤買。這樣一天的圖形做完了,可以簡單的看出我們的意圖而不會被迷惑。
條件四、不要被大陽線嚇倒。漲幅居前的股票總有幾只在明、後天還會好的。
條件五、參考大盤。大盤的分析比個股簡單的多,牛市陽多陰長,熊市陰多陽長。
條件六、不要相信越跌越買的言論。經過風險的量化可以發現,越跌越買比越漲越買的風險大得多。如果跌到止損位,果斷賣出。
每天最實用的辦法就是復盤漲停,漲停的股票都是當天排名較強的股票,然後給他們歸類,分析一下為什麼漲停?看看同板塊的有多少個漲停?一般來說,同板塊漲停個股多的往往第二天走勢都會比較好。
股票數據貓幾乎每天都利用量化數據+人工智慧技術選出一個股票池,這些股票有的適合長線,有的適合潛伏,有的適合短線。也都有說明。
這樣的股票池,本身就是基於概率的原則,機會較大。
風格激進的追漲停板的人,首先要當日漲幅超過9.8%,這樣就把漲停的基本上一網打盡了,然後可以設置資金流向,選資金流入的把流出的踢掉,這樣范圍就縮小了。這種風格的股票,肯定是市值越小越方便拉升,那麼就設置一個,看自己理解把市值框定一個范圍,低於200億或者低於100億什麼的,具體數字多少都可以。
而價值投資長線風格的,就要看每年的業績增長、穩定性、市盈率等等,這些也是可以直接設置范圍,注意市盈率設置的時候要大於零小於自己要求的一個數,因為還有很多虧損股那市盈率是負數。

⑹ 集合競價選股公式源碼

1.集合競價選股公式源碼為:
N:=95;
開幅%:(O-REF(C,1))/REF(C,1)*100,NODRAW;
去ST股:=IF(NAMELIKE('S'),0,1);
去ST股1:=IF(NAMELIKE('*'),0,1);
去停牌:=DYNAINFO(17)>0;
流通值:=FINANCE(40)/100000000;
一字板:=C/REF(C,1)>1.0975 AND H=L;
TJA:=REF(WINNER(C)*100,1)>=N AND WINNER(O)*100>=N AND BETWEEN(開幅%,3,9) AND 去ST股 AND 去ST股1 AND 流通值<100000 {AND NOT( 一字板)};
2.股票集合競價是指每個交易日上午的9:15到9:25,由投資者按照自己的目標價格,買賣申請不受任何限制。之所以要進行股票集合競價,目的就是確定開盤價,就是在9:30股市開市時間到達時的首個價格。
3.對於下面的3條競價規則,一般這個價格都需要遵守:
1)在這個價格的成交量是最大的;
2)買這個或者賣這個的,任何一方所出的價格跟這個一樣的話,有一邊必須要全部成交;
3)比這個價高的買入申請以及比這個價低的賣出申請在最後的階段都要保證完成交易。
拓展資料:
1.集合競價時間不止一段,而是有兩段,在不同的時間段里可以進行不同的操作:
2.第一個時間段9:15-9:20:申報和撤銷都可以進行,匹配成交量在這個時間段是虛假的信息,那是因為在這個時間段里完成的成交是可以撤單的。在開始的前幾分鍾,股票的價格會隨著大單的買入而升高,但是時間在9:20左右,大單就又撤單了,這個時候我們再想撤單就來不及了。正是這個原因,大家要提高注意力,擦亮自己的眼睛,別中了主力的圈套。

⑺ 通達信選股公式源碼

你好,通達信選股公式源碼如下。
次日漲停
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=交叉(C,REF(W3,1));
W4和計數(W4,5)=1;
黃轉紫選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
紫柱:MACD<0和MACD>REF(MACD,1)和REF(MACD,1)低位金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
低位金叉:交叉(差異,DEA)和差異<-0.1;
二次金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=計數(交叉(差異,數據包絡分析),BARSLAST(數據包絡分析>=0));
二次金叉:交叉(差異,DEA)和DEA<0,計數(JCCOUNT=2,21)=1;
絕地反彈
(1)
VAR1:=參考值(低,1);
VAR2:=SMA(ABS(低VAR1),13,1)/SMA(最大值(低VAR1,0),13,1)*100;
VAR3:=EMA(如果(關閉*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(低,34);
VAR5:=HHV(VAR3,34);
VAR6:=如果(LLV(低,55),1,0);
VAR7:=EMA(如果(低)<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(低,2)*0.96;
XL2:=MA(低,26)*0.85;
XL3:=REF(XL1,1)啟動:=如果(XL3,0,VAR7*3),則為紅色;
XG:啟動>25;
(2)
倒退((參考(關閉,1)<參考(打開,1)和
關閉>打開和ABS(關閉參考(關閉,1))/關閉<0.002),2);
A2:=過濾器(A1<=V3,10);
ND資本<300000000
REF(V,1)=LLV(V,4)和V>=REF(V,1)
HHV(V,3)=參考(V,1)和HHV(V,5)=參考(V,1)和HHV(V,21)=參考(V,1)
和V>=REF(V,1)
01>0,T02>0;
1.三線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1,A2和A3,C>O和V>REF(V,1),資本<=300000000;
2.三條線粘合
N1:=5;N2:=10;N3:=20;M:=1;
MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
最大值(MA1,最大值(MA2,MA3))/MIN(MA1,最小值(MA2,MA3))<1+0.01*M
C>O和V>REF(V,1)和財務(7)<=300000000
A3及資本<=300000000;
3.均線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.01*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1以及A2和A3;
3.金叉選股指標
快線:=均線(均線)(均線(收盤,2,2,2),;
慢線:=EMA(參考(快線,1),2);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
交叉(快線,慢線) 和C>O和
五> =MA(V,21)和V>REF(V,1),資本<=300000000;

⑻ 請高手朋友幫我做個選股公式,就是出現量能新高的地方為選股源碼如下:

N3:=10;
M:=100;
買:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
賣:=AMOUNT-買;
VA0:=IF(CLOSE>=REF(C,1),買,-賣*M/100);
ZF0:=(C-REF(C,1))/REF(C,1);
ZL:=SUM(IF(CLOSE=REF(CLOSE,1),0,ABS(ZF0)*VA0),0)/1000000;
市場能量:=MA(ZL,N3);
新高0:=ZL>REF(HHV(ZL,100),1);
新高:=IF(新高0=1 AND REF(新高0,1)=0 ,ZL,DRAWNULL);
XG:新高=ZL AND COUNT(新高=ZL,20)=1;

(已測試。需要設置N3,N3暫時給你設為10。可自己修改)

閱讀全文

與最有潛力的選股源碼相關的資料

熱點內容
程序員用得到數字區嗎 瀏覽:170
python求商 瀏覽:473
ipad能用c語言編譯器嗎 瀏覽:557
軟泥解壓球最新版 瀏覽:994
4萬程序員辭職創業 瀏覽:755
thinkingphp 瀏覽:593
安卓相冊移動文件夾 瀏覽:2
耳朵清潔解壓聲控99的人都睡得著 瀏覽:201
叉車出租網站源碼 瀏覽:870
共享單車的app是什麼 瀏覽:404
不帶gui的伺服器什麼意思 瀏覽:369
金剛經及PDF 瀏覽:98
php中冒號 瀏覽:354
php5432 瀏覽:348
命令在哪使用 瀏覽:168
php獲取網頁元素 瀏覽:704
為什麼需要硬體驅動編譯 瀏覽:881
pm編程怎樣看導柱孔對不對稱 瀏覽:134
農業大學選課找不到伺服器怎麼辦 瀏覽:645
路由配置網關命令 瀏覽:931