導航:首頁 > 源碼編譯 > 顯示所屬概念指標源碼

顯示所屬概念指標源碼

發布時間:2022-10-07 02:00:58

A. 你好,我想問一下如何同花順在k線界面用公式調出股票概念等信息

通過編寫指標公式就可以顯示股票概念信息。

一、什麼公式可以顯示股票概念信息?
具體公式如下:
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,BLOCK(0,0)+BLOCK(1,0)+BLOCK(2,0)+BLOCK(3,0))

二、如何用公式顯示股票板塊?
具體公式如下:
Hh:=HHV(H,120);
gg:=CROSS(ISNULL(REFX(&CLOSE,40)),0.9);
板塊:=IF(INBLOCK('工程建築'),'工程建築',
IF(INBLOCK('電力'),'電力',
IF(INBLOCK('計算機硬體'),'計算機硬體',
IF(INBLOCK('電子信息'),'電子信息',
IF(INBLOCK('房地產'),'房地產',
IF(INBLOCK('紡織服裝'),'紡織服裝',
IF(INBLOCK('鋼鐵'),'鋼鐵',
IF(INBLOCK('供水供氣'),'供水供氣',
IF(INBLOCK('化工化纖'),'化工化纖',
IF(INBLOCK('電器'),'電器',
IF(INBLOCK('交通設施'),'交通設施',
IF(INBLOCK('銀行類'),'銀行類',
IF(INBLOCK('旅遊酒店'),'旅遊酒店',
IF(INBLOCK('煤炭石油'),'煤炭石油',
IF(INBLOCK('釀酒食品'),'釀酒食品',
IF(INBLOCK('農林牧漁'),'農林牧漁',
IF(INBLOCK('商業連鎖'),'商業連鎖',
IF(INBLOCK('建材'),'建材',
IF(INBLOCK('其他行業'),'其他行業',
IF(INBLOCK('汽車類'),'汽車類',
IF(INBLOCK('機械'),'機械',
IF(INBLOCK('醫葯'),'醫葯',
IF(INBLOCK('外貿'),'外貿',
IF(INBLOCK('教育傳媒'),'教育傳媒',
IF(INBLOCK('儀電儀表'),'儀電儀表',
IF(INBLOCK('有色金屬'),'有色金屬',
IF(INBLOCK('造紙印刷'),'造紙印刷',
IF(INBLOCK('券商'),'券商',
IF(INBLOCK('電力設備'),'電力設備',
IF(INBLOCK('通信'),'通信',
IF(INBLOCK('運輸物流'),'運輸物流',
IF(INBLOCK('保險'),'保險','')
)))))))))))))))))))))))))))))));
DRAWTEXT(gg,Hh,'所屬: '+板塊),coloryellow;

三、同花順如何進行公式管理?
「同花順」系統預置了近兩百個經典指標,並且為了滿足那些對於那些對指標有著比較深入認識的股民和希望能編寫結合了自己經驗的選股條件和指標的股民,還提供隨意編寫、修改各種公式、指標、選股條件及預警條件的功能。在軟體里,可以新建、修改、刪除、查找、導入、導出各類公式。

指標圖示有:系統公式圖標、數據圖標、技術指標圖標、資訊數據圖標、交易系統圖標、五彩K線圖標、自定公式圖標。

打開公式管理快捷鍵是「Ctrl+F」。
「新建」:可以直接創建各種指標曲線。
「修改、刪除」:對選中的曲線做修改,或者將其刪除。
「查找」:可以通過名稱或者描述來查詢。當一次查詢不到想要的結果時可以按「F3」來繼續查詢。
「設為常用」:對於「曲線」有「設為常用」選項。選擇後則在頁面上適合該曲線顯示的區域(即周期與坐標類型合適)點右鍵時,在右鍵菜單里「常用指標」里出現此曲線,以方便調用。
「導入」、「導出」:可以導入、導出各類公式。

B. 有木有同花順主圖顯示板塊概念的源碼

可以有同花順主圖顯示概念板塊的源碼,只顯示概念板塊,效果如下圖.

C. 求高手來編一個通達信的指標要求在主題最左上角顯示這支股票的板塊 地區 概念

DRAWTEXT_FIX(1,0.00,0,0,'所屬行業:')COLOR0080FF;
DRAWTEXT_FIX(1,0.05,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.1,0,0,'所屬地區:')COLORWHITE;
DRAWTEXT_FIX(1,0.15,0,0,DYBLOCK)COLORWHITE;
DRAWTEXT_FIX(1,0.2,0,0,'所屬概念:')COLORRED;
DRAWTEXT_FIX(1,0.25,0,0,GNBLOCK)COLORRED;

D. 請高手編一個:能顯示所屬板塊指標的通達信主圖公式,謝謝!

{說明:通達信最新版可用}

MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,60);

HH:=CONST(HHV(H,160));

LL:=CONST(LLV(L,160));{160可改成你習慣鎖定的日K線數}

HL1:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.76,0.04));

HL2:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.80,0.08));

HL3:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.84,0.12));

HL4:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.88,0.16));

HL5:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.92,0.20));

HL6:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.96,0.24));

DRAWTEXT_FIX(1,0.00,0,0,'所屬行業:')COLOR0080FF;

DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;

DRAWTEXT_FIX(1,0.14,0,0,'所屬地區:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.04,0,'主題投資:')COLOR0000FF;

DRAWTEXT_FIX(1,0.07,0.04,0,EXTERNSTR(0,1))COLOR0000FF;

DRAWTEXT_FIX(1,0.00,0.08,0,'主營業務:')COLORFF00FF;

DRAWTEXT_FIX(1,0.07,0.08,0,EXTERNSTR(0,2))COLORFF00FF;

DRAWTEXT_FIX(1,0.00,0.12,0,'出千概念:')COLORFF88FF;

DRAWTEXT_FIX(1,0.07,0.12,0,EXTERNSTR(0,3))COLORFF88FF;

DRAWTEXT_FIX(1,0.80,HL1,0,'股本:');

DRAWNUMBER_FIX(1,0.84,HL1,0,CONST(FINANCE(1)/100000000));

DRAWTEXT_FIX(1,0.80,HL2,0,'流通:');

DRAWNUMBER_FIX(1,0.84,HL2,0,CONST(FINANCE(7)/100000000));

DRAWTEXT_FIX(1,0.80,HL3,0,'動PE:');

DRAWNUMBER_FIX(1,0.84,HL3,0,CONST(DYNAINFO(39)));

DRAWTEXT_FIX(1,0.80,HL4,0,'換手:');

DRAWNUMBER_FIX(1,0.84,HL4,0,CONST(DYNAINFO(37)*100));

DRAWTEXT_FIX(1,0.80,HL5,0,'量比:');

DRAWNUMBER_FIX(1,0.84,HL5,0,CONST(DYNAINFO(17)));

DRAWTEXT_FIX(1,0.80,HL6,0,'漲幅:');

DRAWNUMBER_FIX(1,0.84,HL6,0,CONST(DYNAINFO(14)*100)),COLORFF00FF;

DRAWNUMBER_FIX(1,0.84,HL6,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL))COLOR00FF00;

E. 求編寫公式——主圖上顯示個股所屬的地區、行業、概念

所屬板塊:=STRCAT('所屬板塊: ',STRCAT(STRCAT(STRCAT('[行業]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所屬板塊),COLORYELLOW;
試試這個。

F. 我想在通達信里建立一個指標 就顯示f10里的行業和主營內容 怎麼寫這個指標

「所屬行業」可以在公式內以文本方式引用HYBLOCK,在系統設置下的「設置4」下有選項可以直接在分時圖上提示行業信息。「主營內容」沒找到方法顯示,財務數據中有「主營業務利潤率」(FINANCE(23)/FINANCE(20)*100)的引用可供參考。 通達信行業資料F10資料公式源碼。把這段話放在任何一個主圖里看盤都會覺得方便,源碼DRAWTEXT_FIX(1,0.07,0,0,"所屬行業:")COLOR0080FF;DRAWTEXT_FIX(1,0.14,0,0,HYBLOCK)COLOR0080FF;DRAWTEXT_FIX(1,0.21,0,0,"所屬地區:")COLOR00FFFF;DRAWTEXT_FIX(1,0.28,0,0,DYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.35,0,0,"概念板塊:")COLOR00FFFF;DRAWTEXT_FIX(1,0.43,0,0,GNBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.07,0.06,0,"重要參考:")COLOR0000FF;DRAWTEXT_FIX(1,0.13,0.06,0,"每股凈資產:"),COLOR0000FF;
DRAWNUMBER_FIX(1,0.20,0.06,0,FINANCE(34));DRAWTEXT_FIX(1,0.25,0.06,0,"每股未分配利潤:"),COLOR0000FF;DRAWNUMBER_FIX(1,0.34,0.06,0,FINANCE(32));DRAWTEXT_FIX(1,0.39,0.06,0,"每股公積金:"),COLOR0000FF;DRAWNUMBER_FIX(1,0.46,0.06,0,FINANCE(18));DRAWTEXT_FIX(1,0.50,0.06,0,"利潤同比(43):"),COLOR0000FF;DRAWNUMBER_FIX(1,0.57,0.06,0,FINANCE(43)DRAWTEXT_FIX(1,0.63,0.06,0,"流通股億(7):"),COLOR0000FF;DRAWNUMBER_FIX(1,0.69,0.06,0,FINANCE(7)/100000000);DRAWTEXT_FIX(1,0.78,0.06,0,"流現量(9):"),COLOR0000FF;DRAWNUMBER_FIX(1,0.83,0.06,0,FINANCE(9));DRAWTEXT_FIX(1,0.88,0.06,0,"振幅:"),COLOR0000FF;DRAWNUMBER_FIX(1,0.91,0.06,0,DYNAINFO(13)*100);

G. 誰有通達信個股概念主圖顯示的代碼,是個股的概念,不是所屬行業,誰有給我個,謝謝

鍵盤輸入15快捷鍵,調出行情報價,然後選擇「概念板塊」。左邊是概念板塊,右邊是相關概念的個股,如下圖:

2.至於進入個股主圖後,看相關概念。進入K線主圖,左下角有「擴展」,點開就能看到相關概念。

H. 有通達信關於題材和概念的公式嗎像同花順題材概念的公式

同花順題材概念指標公式
IF CODELIKE(�')= 0 AND CODELIKE("399")=0 THEN DRAWTEXT_FIX(ISLASTBAR ,0.4,0.05,0,'題材概念有'+" "+BLOCK(3,8)),coloryellow;
IF CODELIKE(�')= 0 AND CODELIKE("399")=0 THEN DRAWTEXT_FIX(ISLASTBAR ,0.05,0.05,0,"二級行業是"+ " "+BLOCK(0,8)),coloryellow;
IF CODELIKE(�')= 0 AND CODELIKE("399")=0 THEN DRAWTEXT_FIX(ISLASTBAR ,0.2,0.05,0,"三級行業是"+ " "+BLOCK(1,8)),coloryellow;

拓展資料

一、通達信的發展史:

通達信是2002年以後網上交易領域市場份額上升最快的廠商:通達信自2002年進入網上交易領域以來,成功完成了多家券商總部級的網上交易系統承建,維護工作。

從南方證券超強版開始,通達信一直是網上交易系統業務創新和技術性能指標領先的軟體供應商。

截至2010年12月份,通達信覆蓋行情伺服器超過3000台,資訊主站超過2500個,交易中心伺服器超過1500台,為全國近80%以上的證券公司提供軟體定製化服務,穩定的為近800萬同時在線並發,總使用人數超過5000萬的投資者提供國內證券市場的實時行情服務。

二、
通達信 88 是指由上海和深圳證券市場中 選取 88 只 A 股作為樣本編制而成的成份股指 數。

具體概念選股原則: 剔除 ST 股,總市值達到 20 億,取最新年報的每股收益>0 的股票,得到 56 個通達信二級行業中各行業中每股收益排 名前 5 的股票,根據各行業的重要性對成分股進行篩選(如 金融地產可能成分股比其他行業要多)。

一般情況下在該行業前5的成分股中選取股本最大的作為通達信88的成分 股(如股本相差不大,根據活躍度進行判斷)概念板塊指數名稱: 通達信 88 代碼:880515。

從它的選原則就可以知道是一個優質板塊, 一般不會碰上黑天鵝事件。這就為我們散戶就解決了選股的幸勞,我們只要長期操作這88隻股票就可以了,接下來我們集中力量關注選時問題。

三、
股票指數的作用就是反映股票市場行情變化,由於編制機構、指數歷史等方面存在不同,股票指數在影響力上有非常大的差距。以下是一些影響力很大的著名股票指數:
(1)道·瓊斯股票指數。道·瓊斯股票指數是歷史最為悠久的股票指數,也是目前世界上影響最大、最有權威性的一種股票價格指數。
(2)標准·普爾股票價格指數。標准·普爾股票價格指數在美國的影響力也很大,它由美國最大的證券研究機構,標准·普爾公司進行編制。
(3)日經道·瓊斯股價指數。日經道·瓊斯股價指數也被成為日經平均股價,是由日本經濟新聞社編制並公布的股票價格平均數,主要反映日本股票市場的價格

I. 如何在通達信公式顯示所屬行業和板塊

板塊基本有:地域,行業,概念,風格。

要線有顯示文字函數,這樣才可以有板塊名稱。

以下是行業板塊的顯示:DRAWTEXT_FIX(1,0.67,0,0,HYBLOCK),COLORYELLOW;顯示位置你自己調整就可以了。

(9)顯示所屬概念指標源碼擴展閱讀:

初次變革:

如果說網上交易是經紀業務的第一次變革,集成化外圍系統就可以說是經紀業務的第二次變革,在第二次變革中,通達信抓住機遇,成為領導產商。從某種意義上說,營業網點的標准化簡單化集約化管理和由此而產生的營業網點建設和業務理念。

可以說是網上交易的第三次變革,而通達信是行業內最早提出這個思路,並率先成功商業化實現的產商。

作為國內證券行業有長遠歷史的行業解決方案提供者,通達信潛心於總部級證券電子商務平台的研發和建設,與國內一些有影響力的客戶的緊密合作為通達信提供了寶貴的經驗,使得通達信一直擁有業內最先進的產品系列,和提供最好的技術服務的能力。

閱讀全文

與顯示所屬概念指標源碼相關的資料

熱點內容
程序員用得到數字區嗎 瀏覽:174
python求商 瀏覽:477
ipad能用c語言編譯器嗎 瀏覽:561
軟泥解壓球最新版 瀏覽:998
4萬程序員辭職創業 瀏覽:759
thinkingphp 瀏覽:597
安卓相冊移動文件夾 瀏覽:6
耳朵清潔解壓聲控99的人都睡得著 瀏覽:205
叉車出租網站源碼 瀏覽:874
共享單車的app是什麼 瀏覽:408
不帶gui的伺服器什麼意思 瀏覽:373
金剛經及PDF 瀏覽:102
php中冒號 瀏覽:358
php5432 瀏覽:352
命令在哪使用 瀏覽:172
php獲取網頁元素 瀏覽:708
為什麼需要硬體驅動編譯 瀏覽:885
pm編程怎樣看導柱孔對不對稱 瀏覽:138
農業大學選課找不到伺服器怎麼辦 瀏覽:660
路由配置網關命令 瀏覽:935