導航:首頁 > 源碼編譯 > 回調突破主圖選股公式源碼

回調突破主圖選股公式源碼

發布時間:2022-11-30 08:21:10

❶ 漲停回調第二波精確買入公式是什麼

如果把macd指標演變後加進主圖(也可以單獨使用用來選股),源碼為; {MACD指標的演變後的買點}DIFF:=EMA(CLOSE,3)EMA(CLOSE,8);DEA:=EMA(DIFF,5); MACD := 2*(DIFF-DEA); X1:=EMA(DIFF,5)*5; X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5; A1:= CROSS(X2,X1) AND X1>=0; DRAWICON(A1,L*0.96,13);
拓展資料:
1. 漲停回調股:
a、要求是小時的量陽量多於或者大於陰量,如果附加macd指標的話,要求小時的macd要在0軸之上,出現2次金叉,因為macd是慢速指標,有時候會出現遲鈍,就是所說的指標鈍化,在這里我們用一個輔助付圖指標代替,這個是我變通的macd指標,源碼如下:DIFF:EMA(CLOSE,3)-EMA(CLOSE,8); DEA:EMA(DIFF,5); MACD : 2*(DIFF-DEA); X1:=EMA(DIFF,5)*5; X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5; DRAWICON((CROSS(X2,X1) AND X1>=0),0,1);
b、用它的優點是可以把原macd的鈍化讓他反應相對快速一些。就是我們所說的買在相對低點。剛才所說的兩個條件不是獨立的,而是必須同時滿足。這裡面的奧妙之處用文字也無法很好的描述。自己體會一下,多找規律,再結合一下其他知識,技術分析只是基本面的k線圖表象,就是我們平時所說的倒推基本面,圖像可以映射基本面,就像是一種語言,只是我們忽略了他而已,k線圖就是一種語言。
2.2點半之前漲停的選股公式:
公式沒有,方法倒是有一個,不過時間會相對更為靠前:你可以在中午休盤(11:30-13:00)的時間,篩選一下漲停的股票,很簡單,就看漲幅排排行榜就可以了,你要是想將信息導出的話,可以試試智能選股裡面的條件選股,將你的條件輸入裡面就行了。
3.漲停次日縮量調整買入法:大家在實際操作中經常會發現一種現象,就是當天漲停的股票,次日出現沖高回落或者直接低開低走,根本不給你出局的機會,遇到這種情況,我們要仔細分析一下這根漲停K線後面的文章,是主力出貨還是主力洗盤,這點判斷正確,那麼你依據我的方法買進才可以穩穩地獲利。舉例:600528在5月21日開盤以跳空方式快速封死漲停,雖說盤中打開過漲停,但最終漲停還是牢牢封住了,次日該股最高價都沒有超過漲停價,漲停價買進的人全部被套住了,那麼主力花了這么大力氣就是為了把自己套進去的嗎?結合次日這根K線成交量,大家就會發現,調整時成交量沒有超過漲停這天的成交量,呈現縮量調整的走勢,那麼這根縮量調整K線就是我們的回踩買點。

❷ 通達信選股公式

通達信選股公式:

條件選股公式源碼:
年認同價:=MA(C,240);
價格中樞:=(SUM(年認同價,0)/(BARSSINCE(年認同價>0)+239));
箱頂:=價格中樞*1.2;
箱底:=價格中樞*0.8;
毛利潤率:=FINANCE(21)/FINANCE(20);
成長價值:=年認同價*(1+毛利潤率);
收益價值:=年認同價+FINANCE(33);
回調認同:=EMA(EXPMA(C,20),13);
多頭:=(回調認同>REF(回調認同,1))AND(成長價值>REF(成長價值,1))AND(收益價值>REF(收益價值,1))AND(DYNAINFO(7)>0);
回調條件:=COUNT(C<回調認同,5)>=3;
回調突破:=(REF(C,1)<=REF(回調認同,1))AND(C>回調認同)AND(回調條件)AND多頭;
成長條件:=COUNT(C<成長價值,5)>=3;
成長突破:=(REF(C,1)<=REF(成長價值,1))AND(C>成長價值)AND(成長條件)AND多頭;
收益條件:=COUNT(C<收益價值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益價值,1))AND(C>收益價值)AND(收益條件)AND多頭;
箱底條件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底條件)AND多頭;
價格條件:=COUNT(C<價格中樞,5)>=3;
價格突破:=(REF(C,1)<=REF(價格中樞,1))AND(C>價格中樞)AND(價格條件)AND多頭;
箱頂條件:=COUNT(C<箱頂,5)>=3;
箱頂突破:=(REF(C,1)<=REF(箱頂,1))AND(C>箱頂)AND(箱頂條件)AND多頭;
突破買點:(回調突破+成長突破+收益突破+箱底突破+價格突破+箱頂突破);

專買老鼠倉
{老鼠倉}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠倉'),COLOR4080FF;
老鼠倉是個很不錯的指標,信號發出一般都在一個波段的底部起漲之時。
根據本人的實踐,使用指標時候要注意幾點:
1 該指標可以添加到任何一個主圖裡面去,比如MA均線什麼的。
2 出現信號當天買進股票,第二天收陽繼續持股,直到出陰為止。
3 第二天出陰考慮賣出,非常適合短線操作!

老鼠倉(選股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠倉:BB1AND CC1 AND DD1 AND EE1;

理想選股(選股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) ANDREF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) ANDCROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR12OR VAR13) AND VAR10;
買2:=(VAR12OR VAR13) AND VAR3;
買3:=(VAR12OR VAR13) AND VAR2;
買4:=(VAR2AND VAR10) OR (VAR3 AND VAR10);
買5:=(金叉AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
輸出:=(買1OR 買2OR 買3OR 買4OR 買5OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空線:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,多空線) and CROSS(C,AB) and 輸出 ;

點石成金(選股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市絕底(選股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) *100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市絕底:VAR2< 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 ANDBARSCOUNT(CLOSE) > 47;

飛彈一號(選股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

跟庄建倉源碼
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH -LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(Var3,3)-10;
STICKLINE(趨勢>80,趨勢,80,5,0);
DRAWICON(CROSS(趨勢,0),0,1);
STICKLINE((A09 > 0 AND (趨勢<20 OR 趨勢>REF(趨勢,1)AND趨勢<50)),0,A09,6,0),colorFFff00;
機構建倉區:0,LINETHICK0,colorFFFF00;
Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(趨勢<=13,15),30,'准備現金'),colorcc9900;
STICKLINE(趨勢<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((趨勢<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'買入'),color0099ff;
STICKLINE(趨勢>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((趨勢>=90 AND Var4),10);
DRAWTEXT(Var6,40,'清倉'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'險'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7AND 趨勢<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線:趨勢,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(趨勢線,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趨勢線,Var2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'追漲'),COLORff00ff;
風險區:IF(趨勢>80,趨勢,80),colorff00ff;

雙信號"全倉"選股(選股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1)AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{收盤價=4日內收盤價的最高值AND 昨收>=2日前的收盤價}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{收盤價=4日內收盤價的最高值AND 昨收=4日內收盤價的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{收盤價=4日內收盤價的最低值AND (昨收<2日前的收盤價}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{昨收=4日內收盤價的最低值AND 收盤價>=2日前的收盤價}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{昨收=4日內收盤價的最高值AND 收盤價<2日前的收盤價}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{今日V5向上形成拐點}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR14OR VAR15) AND VAR11;
買2:=(VAR14OR VAR15) AND VAR04;
買3:=(VAR14OR VAR15) AND VAR02;
買4:=(VAR02AND VAR11) OR (VAR04 AND VAR11);
買5:=(金叉AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=買1OR 買2OR 買3OR 買4OR 買5AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{以下波浪理論浪底重疊"買底"選股原碼}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{以下二者結合共同選股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

❸ 求高手編寫,股票突破了長期整理的平台後,進行回踩確認的選股公式。具體的選股形態,請看圖

可以編寫平台突破後回踩的選股公式,例如下圖的指標就是一個可以自定義平台整理的時間幅度,然後選擇回踩位置的.效果如圖

❹ 請高手幫忙編個漲停後回調的選股公式.謝謝!

主圖公式:


ZT1:=ABS(C-REF(C,1))/REF(C,1)>=0.09;

D1:=BARSLAST(ZT1);

JX4:=CROSS(MACD.DIF,MACD.DEA);

D2:=BARSLAST(JX4);

L1:=REF(ZT1,4)=1;

L2:=REF(H,3)>REF(C,3)ANDREF(C,3)<REF(C,4)ANDREF(H,3)>REF(H,4);

L3:=REF(H,1)<MAX(REF(C,3),REF(O,3))ANDREF(H,1)<MAX(REF(C,3),REF(O,3));

L4:=COUNT(MACD.DIF>REF(MACD.DIF,D2),4)=4;

XG:L1ANDL2ANDL3ANDL4,NODRAW;

DRAWTEXT(L1,H*1.002,'回調'),COLORYELLOW;



選股公式:

ZT1:=ABS(C-REF(C,1))/REF(C,1)>=0.09;

D1:=BARSLAST(ZT1);

JX4:=CROSS(MACD.DIF,MACD.DEA);

D2:=BARSLAST(JX4);

L1:=REF(ZT1,4)=1;

L2:=REF(H,3)>REF(C,3)ANDREF(C,3)<REF(C,4)ANDREF(H,3)>REF(H,4);

L3:=REF(H,1)<MAX(REF(C,3),REF(O,3))ANDREF(H,1)<MAX(REF(C,3),REF(O,3));

L4:=COUNT(MACD.DIF>REF(MACD.DIF,D2),4)=4;

XG: L1ANDL2ANDL3ANDL4;


選出的股票例子之一:600093.

❺ 通達信捕捉牛股利器 條件選股公式

通達信選股公式:

條件選股公式源碼:
年認同價:=MA(C,240);
價格中樞:=(SUM(年認同價,0)/(BARSSINCE(年認同價>0)+239));
箱頂:=價格中樞*1.2;
箱底:=價格中樞*0.8;
毛利潤率:=FINANCE(21)/FINANCE(20);
成長價值:=年認同價*(1+毛利潤率);
收益價值:=年認同價+FINANCE(33);
回調認同:=EMA(EXPMA(C,20),13);
多頭:=(回調認同>REF(回調認同,1))AND(成長價值>REF(成長價值,1))AND(收益價值>REF(收益價值,1))AND(DYNAINFO(7)>0);
回調條件:=COUNT(C<回調認同,5)>=3;
回調突破:=(REF(C,1)<=REF(回調認同,1))AND(C>回調認同)AND(回調條件)AND多頭;
成長條件:=COUNT(C<成長價值,5)>=3;
成長突破:=(REF(C,1)<=REF(成長價值,1))AND(C>成長價值)AND(成長條件)AND多頭;
收益條件:=COUNT(C<收益價值,5)>=3;
收益突破:=(REF(C,1)<=REF(收益價值,1))AND(C>收益價值)AND(收益條件)AND多頭;
箱底條件:=COUNT(C<箱底,5)>=3;
箱底突破:=(REF(C,1)<=REF(箱底,1))AND(C>箱底)AND(箱底條件)AND多頭;
價格條件:=COUNT(C<價格中樞,5)>=3;
價格突破:=(REF(C,1)<=REF(價格中樞,1))AND(C>價格中樞)AND(價格條件)AND多頭;
箱頂條件:=COUNT(C<箱頂,5)>=3;
箱頂突破:=(REF(C,1)<=REF(箱頂,1))AND(C>箱頂)AND(箱頂條件)AND多頭;
突破買點:(回調突破+成長突破+收益突破+箱底突破+價格突破+箱頂突破);

專買老鼠倉
{老鼠倉}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠倉'),COLOR4080FF;
老鼠倉是個很不錯的指標,信號發出一般都在一個波段的底部起漲之時。
根據本人的實踐,使用指標時候要注意幾點:
1 該指標可以添加到任何一個主圖裡面去,比如MA均線什麼的。
2 出現信號當天買進股票,第二天收陽繼續持股,直到出陰為止。
3 第二天出陰考慮賣出,非常適合短線操作!

老鼠倉(選股公式)
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠倉:BB1AND CC1 AND DD1 AND EE1;

理想選股(選股公式)
VAR1:=MA((LOW+HIGH+CLOSE)/3,5);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) ANDREF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR4:=VAR1>REF(VAR1,1) AND REF(VAR1,1)<REF(VAR1,2);
VAR5:=LOW<HHV(VAR1,13) AND HIGH>HHV(VAR1,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR6:=VAR5 AND COUNT(VAR4,2);
VAR7:=VAR6 AND NOT(REF(VAR6,1));
VAR8:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR9:=EMA(MA(C,13),13);
VAR10:=FILTER((LLV(VAR8,2)=LLV(VAR8,7) AND COUNT(VAR8<0,2) ANDCROSS(VAR8,MA(VAR8,2)))=1,5);
VAR11:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR12:=FILTER(((CROSS(VAR11,0) OR CROSS(C,VAR9)) AND VAR10)=1,3);
VAR13:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR12OR VAR13) AND VAR10;
買2:=(VAR12OR VAR13) AND VAR3;
買3:=(VAR12OR VAR13) AND VAR2;
買4:=(VAR2AND VAR10) OR (VAR3 AND VAR10);
買5:=(金叉AND VAR3) OR (金叉 AND VAR2) OR (金叉 AND VAR10);
ST:=EXIST(C/REF(C,1)>1.06,50);
輸出:=(買1OR 買2OR 買3OR 買4OR 買5OR VAR7) AND ST;
MA5:=MA(C,5),COLORWHITE;
X:=(3*C+L+O+H)/6;
多空線:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
AB:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW;
CROSS(MA5,多空線) and CROSS(C,AB) and 輸出 ;

點石成金(選股公式)
KS13:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
FASTK:=SMA(RSV,3,1);K:=SMA(FASTK,3,1);D:=SMA(K,5,1);
Var1:=CLOSE/MA(CLOSE,40)*100<76;
Var2:=CLOSE/MA(CLOSE,60)*100<74;
Var3:=HIGH>LOW*1.051;
Var4:=Var3 AND COUNT(Var3,5)>1;
Var4 AND (Var1 OR Var2) AND REF(KS13,1)>=10 AND REF(KS13,1)/KS13>=1.13AND
CLOSE/REF(CLOSE,1)>=1.02;

牛市絕底(選股公式)
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),7,1) / SMA(ABS((CLOSE - VAR1)),7,1)) * 100);
VAR3:=((SMA(MAX((CLOSE - VAR1),0),13,1) / SMA(ABS((CLOSE - VAR1)),13,1)) *100);
VAR4:=((100 * (HHV(HIGH,48) - LOW)) / HHV(HIGH,48));
VAR5:=((100 * (HIGH - LLV(LOW,48))) / LLV(LOW,48));
牛市絕底:VAR2< 15 AND VAR3 < 20 AND (VAR2 + VAR3) > 20 AND VAR4 > 40 ANDBARSCOUNT(CLOSE) > 47;

飛彈一號(選股公式)
var1:=c/ma(c,40)*100<78;
var2:=c/ma(c,60)*100<74;
var3:=h>=l*1.051;
var4:=var3 and count(var3,5)>=2;
xg:var4 and (var1 or var2) and count(h=l and c=o and c<ref(c,1),3)=0
and hhv(v/capital,30)<0.8;

跟庄建倉源碼
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH -LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var2:=EMA(Var1,8);
Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢:=EMA(Var3,3)-10;
STICKLINE(趨勢>80,趨勢,80,5,0);
DRAWICON(CROSS(趨勢,0),0,1);
STICKLINE((A09 > 0 AND (趨勢<20 OR 趨勢>REF(趨勢,1)AND趨勢<50)),0,A09,6,0),colorFFff00;
機構建倉區:0,LINETHICK0,colorFFFF00;
Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;
STICKLINE(趨勢<=13,0,20,3,0),colorcc9900;
DRAWTEXT(FILTER(趨勢<=13,15),30,'准備現金'),colorcc9900;
STICKLINE(趨勢<=13 AND Var4>13,0,50,2,0),color0099ff;
Var5:=FILTER((趨勢<=13 AND Var4>13),10);
DRAWTEXT(Var5,60,'買入'),color0099ff;
STICKLINE(趨勢>=90 AND Var4,0,30,3,0),colorgray;
Var6:=FILTER((趨勢>=90 AND Var4),10);
DRAWTEXT(Var6,40,'清倉'),colorgray;
Var7:=LLV(LOW,30);
Var8:=HHV(HIGH,30);
Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;
STICKLINE(Var9>90,100,105,3,2),COLORRED;
Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;
DRAWTEXT(IF(CROSS(Var9,Var10) AND Var9>87,95,0),88,'險'),Color00FF00;
DRAWICON(CROSS(90,Var9),95,9);
Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
Var12:=HHV(Var11,30)*8;
火焰山:EMA(IF(LOW<=Var7AND 趨勢<40,(Var11+Var12),0),3)/618,COLORRED,linethick2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,4,0 ),COLORRED;
Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趨勢線:趨勢,colorff0000;
Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;
Var17:=EMA(Var16,5);
波浪峰:Var17,stick,colorff00ff;
STICKLINE(Var17<REF(Var17,1),0,Var17,1,0),color00ff00;
Var18:=MA(趨勢線,8);
if(CROSS(Var2,Var18) AND Var2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趨勢線,Var2)AND 趨勢線>REF(趨勢線,1)AND 趨勢線<50,50,'追漲'),COLORff00ff;
風險區:IF(趨勢>80,趨勢,80),colorff00ff;

雙信號"全倉"選股(選股公式)
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
TTJ:=CROSS(FF,MA15);
上:=EMA(C,3),COLORBLUE,LINETHICK1;
中:=EMA(C,5),COLORWHITE,LINETHICK1;
下:=EMA(中,5),COLOR00FF00,LINETHICK1;
QQ:= C<中;
MM:=上>REF(上,1)AND REF(上,1)<REF(上,2) ;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
MA1:=MEMA(CLOSE,5);
MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
MA3:=IF(MA2>0,MA2,MA2);
MA5:=MA(CLOSE,5),COLOR888899;
MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
VAR01:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND
REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND
C>=REF(C,1) AND C>=REF(C,2);
{收盤價=4日內收盤價的最高值AND 昨收>=2日前的收盤價}
VAR02:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
{收盤價=4日內收盤價的最高值AND 昨收=4日內收盤價的最低值}
VAR03:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR
REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND
C<REF(C,1) AND C<REF(C,2);
{收盤價=4日內收盤價的最低值AND (昨收<2日前的收盤價}
VAR04:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND
REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
{昨收=4日內收盤價的最低值AND 收盤價>=2日前的收盤價}
VAR05:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND
REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND
REF(C,2)>=REF(C,4) AND C<REF(C,1);
{昨收=4日內收盤價的最高值AND 收盤價<2日前的收盤價}
VAR06:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);
{今日V5向上形成拐點}
VAR07:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) ANDCLOSE>OPEN;
VAR08:=VAR07 AND COUNT(VAR06,2);
VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7) AND COUNT(VAR09<0,2) AND
CROSS(VAR09,MA(VAR09,2)))=1,5);
VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7) AND COUNT(VAR09>50,2) AND
CROSS(MA(VAR09,2),VAR09))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
VAR16:=VAR08 AND NOT(REF(VAR08,1));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
買1:=(VAR14OR VAR15) AND VAR11;
買2:=(VAR14OR VAR15) AND VAR04;
買3:=(VAR14OR VAR15) AND VAR02;
買4:=(VAR02AND VAR11) OR (VAR04 AND VAR11);
買5:=(金叉AND VAR04) OR (金叉 AND VAR02) OR (金叉 AND VAR11);
TTJ0:=VAR16;
TTJ1:=買1OR 買2OR 買3OR 買4OR 買5AND MM;
XG0:=TTJ AND TTJ0;
XG1:=TTJ AND TTJ1;
XG11:=XG0 OR XG1;
{以下波浪理論浪底重疊"買底"選股原碼}
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2)AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2)AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;
{以下二者結合共同選股}
XG:=XG11 OR XG22;
W18:EXIST(XG,1);

閱讀全文

與回調突破主圖選股公式源碼相關的資料

熱點內容
美東伺服器叫什麼 瀏覽:532
四年級平均值怎麼算簡單演算法 瀏覽:183
冷撲大師演算法 瀏覽:373
重復數據比對演算法 瀏覽:740
golang調用python 瀏覽:171
hsc伺服器做raid0怎麼做 瀏覽:231
android50源代碼 瀏覽:127
程序員需要本科學位證書嗎 瀏覽:775
手機版wps許多文檔如何放到文件夾 瀏覽:687
安卓手機怎麼退出帳戶 瀏覽:767
夜神安卓模擬器怎麼刪 瀏覽:561
運行命令無法打開共享 瀏覽:524
安卓怎麼與單片機交互 瀏覽:736
linux下tcpdump 瀏覽:919
華為榮耀手機隱藏文件夾方法 瀏覽:535
python怎麼做簡單線性回歸模型 瀏覽:252
安卓系統電視是什麼 瀏覽:343
全款買了房開發商遲遲不解壓 瀏覽:812
linux退出oracle 瀏覽:652
不能截圖的app怎麼截長圖 瀏覽:307