導航:首頁 > 源碼編譯 > 絕底副圖指標公式源碼

絕底副圖指標公式源碼

發布時間:2023-03-28 09:36:58

1. 求高手將通達信副圖改為條件選股公式,請用OR,滿足副圖其中一個指標即選出,"絕對底部"公式如下,謝謝!

你所提的條件一共有4個,其中只有一個可以選出信號,那就是「底部」條件可以。其他條件幾乎選不出來票,所以我感覺沒有多大意義。
VAR1:=INDEXC;
VAR2:=MA(VAR1,6);
VAR3:=MA(VAR1,24);
VAR4:=MA(VAR1,32);
VAR5:=MA(VAR1,62);
VAR6:=MA(VAR1,105);
VAR7:=VAR5<REF(VAR5,1) AND VAR6<REF(VAR6,1) AND VAR5<VAR6*0.98;
VAR8:=VAR4>VAR2*1.11 AND VAR3>VAR2*1.095;
VAR9:=VAR2>VAR1*0.95;
百發百中:=VAR7 AND VAR8 AND VAR9 AND CLOSE/COST(8)<=0.8 AND
(CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR
REF(CLOSE,1)<REF(OPEN,1)),COLORYELLOW;
VAR1N:=MA(CLOSE,5);
VAR2N:=MA(CLOSE,10);
VAR3N:=(VAR1N-CLOSE)/CLOSE>3/100;
VAR4N:=(VAR2N-VAR1N)/VAR1N>0.03;
VAR5N:=LLV(CLOSE,30)=LLV(CLOSE,120);
底部:=VAR3N AND VAR4N AND VAR5N,COLORGREEN;
絕對底部2:=COUNT(百發百中=1,5)=1 AND 底部,COLORRED;
絕對底部:=STICKLINE( FILTER(絕對底部2=1,5),0 ,1.5,5 , 0.8),COLORRED;
絕對底部出擊:=百發百中=1 AND 底部=1 ,COLORRED;
XG:底部 OR 絕對底部2 OR 絕對底部出擊 OR 百發百中;

2. 經傳神龍籌碼副圖指標公式

公式如下:
籌碼副圖指標代碼
五十成本集中:=(COST(75)-COST(25))/(COST(75)+COST(25))*100;
成本價1:=COST(五十成本集中),COLORGREEN;
五十成本集中1:=100-五十成本集中;
成本價2:=COST(五十成本集中1),COLORBLUE;
單峰密集價:成本價2/成本價1-1,STICK;
紅:=REF(單峰密集價,1)<單峰密集價AND成本價2>REF(成本價2,1);
綠:=REF(單峰密集價,1)>單峰密集價;
主力籌碼:=單峰密集價<=0.25;
底部:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
底部成本價:=COST(底部),COLORYELLOW;
頂部:=100-底部;
頂部成本價:=COST(頂部),COLORGREEN;
均值:=(底部+頂部)/2;
均值成本:=COST(均值),COLORLICYAN,DOTLINE;
STICKLINE(紅,單峰密集價,0,2.8,0),COLOR000055;
STICKLINE(紅,單峰密集價,0,2,0),COLOR000088;
STICKLINE(紅,單峰密集價,0,1.5,0),COLOR0000AA;
STICKLINE(紅,單峰密集價,0,1,0),COLOR0000CC;
STICKLINE(紅,單峰密集價,0,0.5,0),COLOR0000EE

3. 有朋友能幫忙副圖指標修改成選股公式通達信,萬分感謝!

多方趨勢:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1) -3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1) -SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1) ,3,1),2,1); 用這一條線吧,你下面的源碼我看了一下,都是kdj的變種,不過是把參數換了一下,我給你的這一條線,好好研究一下,一般在大漲之前,這條線會率先啟動,懂不懂就看你的造化了,這個事上海的一個機構左手的干法

4. 編寫一個通達信選股公式,MACD周線金叉

DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
周DIF:="MACD.DIF#WEEK"(12,26,9),COLORGRAY;
周DEA:="MACD.DEA#WEEK"(12,26,9),COLORRED;
AA:=CROSS(周DIF,周DEA);
XG:=CROSS(AA,0.5);
拓展資料:
一、通達信MACD金叉副圖指標源碼公式
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
二、以下公式適合通達信股票軟體。選出股票後能否買入依然還要綜合參考大趨勢和其它指標。
金叉並非萬能,有時剛剛進入金叉或准金叉狀態,也可能是上一波反彈的結束,下一波下跌的開始。
只有當金叉周期的前後周期均為上漲趨勢,金叉的威力才最大。
業績的持續增長才是技術指標的前提和保證。
1、0軸上方第一次金叉選股公式:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
xg:cross(diff,dea) and dea>-1.0 and dea<0.5 and CLOSE>ref(CLOSE,1) and CLOSE>=ma(c,60);
2、0軸上方二次金叉的選股公式:
JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),
SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),
0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);
{選股設JC=10即可}
3.0軸下方一次金叉的選股公式:
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;
4、0軸下方二次金叉且第二次金叉高於第一次金叉:
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AA:=BARSLAST(REF(CROSS(DIF,DEA),1));
二次金叉:CROSS(DIF,DEA) AND DIF>REF(DIF,AA+1) AND AA<20 AND DIF<0;
5、0軸下方二次金叉選股公式:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {選股設JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
JC:IF(SSS-SSB=2 AND SSS>REF(SSS,1),10,0);
6、縮量橫盤突破選股:
WH01:=(HHV(C,10)-LLV(C,10))/LLV(C,10)*100<=10;
WH02:=SUM(VOL,10)/CAPITAL*100<45;
WH03:=REF(WH01,1);
WH04:=HHVBARS(HIGH,55)>20 OR C=HHV(H,55);
WH05:=WH02 AND WH03 AND WH04 AND C>REF(HHV(H,10),1);
WH05 AND REF(NOT(WH05),1);
7、均線、KDJ、MACD金叉的預警選股公式
完全符合以下條件:
(1) 5日線上穿10日線
(2) MACD金叉
(3) KDJ金叉

5. 絕對底追風買的指標源碼

scr指標用於研究籌碼分布的集中程度,如果scr值越低,則籌碼分布越集中,反之,則籌碼分布很分散。源碼如下:

P1:=1,100,90;

A:=P1+(100-P1)/2;

B:=(100-P1)/2;

CC:=COST(A);

DD:=COST(B);

SCR:(CC-DD)/(CC+DD)*100/2;

其代碼的含義如下:

P1參數取值范信碼悔圍為1到100,默認值90

A賦值:P1+(100-P1)/2

B賦值:(100-P1)/2

CC賦值:獲利盤為A%的滑正成本分布

DD賦值:獲利盤為B%的模配成本分布

輸出籌碼集中度:(CC-DD)/(CC+DD)*100/2

6. 請高手把大智慧副圖指標改成通達信的副圖指標

{通達信已通過,與大智慧一模一樣}
CV:=CLOSE;
BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:=BBIBOLL+6*STD(BBIBOLL,11);
DWN:=BBIBOLL-6*STD(BBIBOLL,11);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻擊:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻擊,3);0,POINTDOT,COLORWHITE;
B1:SUM(LLJX,1),COLORCYAN;
B2:SUM(LLJX,2),COLORCYAN;
B3:SUM(LLJX,3),COLORCYAN;
B4:SUM(LLJX,4),COLORCYAN;
B5:SUM(LLJX,5),COLORCYAN;
B6:SUM(LLJX,6),COLORCYAN;
B7:SUM(LLJX,7),COLORCYAN;
B8:SUM(LLJX,8),COLORCYAN;
B9:SUM(LLJX,9),COLORCYAN;
B10:SUM(LLJX,10),COLORCYAN;
IF(B1>REF(B1,1),B1,DRAWNULL),COLORRED,LINETHICK2;
IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED,LINETHICK2;
IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED,LINETHICK2;
IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED,LINETHICK2;
IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED,LINETHICK2;
IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED,LINETHICK2;
IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED,LINETHICK2;
IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED,LINETHICK2;
IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED,LINETHICK2;
IF(B10>REF(B10,1),B10,DRAWNULL),COLORRED,LINETHICK2;

7. 各位老師,通達信 副圖 源碼如下;編寫選股公式要求要求:出現完整的紅三角 選入,不知是否難以實現

{未來函數,信號會漂移,慎用!}
VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);
絕底:((VARB28 < (0)) AND ZXNH) AND ((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)<10;

閱讀全文

與絕底副圖指標公式源碼相關的資料

熱點內容
方舟端游伺服器怎麼搜索房間 瀏覽:71
單片機學51好還是stm8好 瀏覽:798
手中的app如何隱藏 瀏覽:1001
安卓什麼壁紙軟體號 瀏覽:436
java設置內存大小 瀏覽:434
php循環匹配 瀏覽:325
技巧pdf 瀏覽:481
單片機斷程序怎麼解決 瀏覽:160
如何製作APP的圖片 瀏覽:506
php大小排序 瀏覽:550
linuxkerberos 瀏覽:126
暗黑破壞神3如何下載亞洲伺服器 瀏覽:953
linux中ftp伺服器地址怎麼看 瀏覽:438
ansys命令流do 瀏覽:122
單片機6502 瀏覽:765
自助洗車有什麼app 瀏覽:937
程序員離職率多少 瀏覽:322
程序員那麼可愛電視劇今天沒更新 瀏覽:337
我的世界地形演算法 瀏覽:344
台灣dns的伺服器地址雲空間 瀏覽:288