導航:首頁 > 源碼編譯 > 通達信市凈率指標公式源碼

通達信市凈率指標公式源碼

發布時間:2023-09-22 12:33:25

A. 通達信選股公式源碼

你好,通達信選股公式源碼如下。
次日漲停
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=交叉(C,REF(W3,1));
W4和計數(W4,5)=1;
黃轉紫選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
紫柱:MACD<0和MACD>REF(MACD,1)和REF(MACD,1)低位金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
低位金叉:交叉(差異,DEA)和差異<-0.1;
二次金叉選股
差異:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(差異,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=計數(交叉(差異,數據包絡分析),BARSLAST(數據包絡分析>=0));
二次金叉:交叉(差異,DEA)和DEA<0,計數(JCCOUNT=2,21)=1;
絕地反彈
(1)
VAR1:=參考值(低,1);
VAR2:=SMA(ABS(低VAR1),13,1)/SMA(最大值(低VAR1,0),13,1)*100;
VAR3:=EMA(如果(關閉*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(低,34);
VAR5:=HHV(VAR3,34);
VAR6:=如果(LLV(低,55),1,0);
VAR7:=EMA(如果(低)<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(低,2)*0.96;
XL2:=MA(低,26)*0.85;
XL3:=REF(XL1,1)啟動:=如果(XL3,0,VAR7*3),則為紅色;
XG:啟動>25;
(2)
倒退((參考(關閉,1)<參考(打開,1)和
關閉>打開和ABS(關閉參考(關閉,1))/關閉<0.002),2);
A2:=過濾器(A1<=V3,10);
ND資本<300000000
REF(V,1)=LLV(V,4)和V>=REF(V,1)
HHV(V,3)=參考(V,1)和HHV(V,5)=參考(V,1)和HHV(V,21)=參考(V,1)
和V>=REF(V,1)
01>0,T02>0;
1.三線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1,A2和A3,C>O和V>REF(V,1),資本<=300000000;
2.三條線粘合
N1:=5;N2:=10;N3:=20;M:=1;
MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
最大值(MA1,最大值(MA2,MA3))/MIN(MA1,最小值(MA2,MA3))<1+0.01*M
C>O和V>REF(V,1)和財務(7)<=300000000
A3及資本<=300000000;
3.均線粘合
M:=1;
M5:=MA(閉合,5);
M10:=MA(閉合,10);
M20:=MA(閉合,20);
K1:=最大值(最大值(M5,M10),最大值(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=最大(M5,最大(M10,M20))/MIN(M5,最小(M10,M20))<1+0.01*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5和V>MA(V,5);
XG:A和A1以及A2和A3;
3.金叉選股指標
快線:=均線(均線)(均線(收盤,2,2,2),;
慢線:=EMA(參考(快線,1),2);
A3:=V>REF(V,1)*1.5和V>MA(V,5);
交叉(快線,慢線) 和C>O和
五> =MA(V,21)和V>REF(V,1),資本<=300000000;

B. 跪求:通達信版L2大單凈量指標源碼,請友友割愛喲。

主力買力度:LARGEINTRDVOL*100/VOL,COLORRED;

主力賣力度:LARGEOUTTRDVOL*100/VOL,COLORGREEN;
超B:=L2_VOL(0,0)*VOL/CAPITAL;
大B:=L2_VOL(1,0)*VOL/CAPITAL;
中B:=L2_VOL(2,0)*VOL/CAPITAL;
小B:=L2_VOL(3,0)*VOL/CAPITAL;
超S:=-L2_VOL(0,1)*VOL/CAPITAL;
大S:=-L2_VOL(1,1)*VOL/CAPITAL;
中S:=-L2_VOL(2,1)*VOL/CAPITAL;
小S:=-L2_VOL(3,1)*VOL/CAPITAL;
凈流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);
大宗凈流入:=(超B+大B)+(超S+大S);
超凈:=超B+超S;
大凈:=大B+大S;
中凈:=中B+中S;
散凈:=小B+小S;
AA:=CONST(MAX(ABS(凈流入),MAX(ABS(大宗凈流入),MAX(ABS(超凈),MAX(ABS(大凈),MAX(ABS(中凈),ABS(散凈)))))))*3,NODRAW;
DRAWRECTREL(10,CONST(830-(ABS(大宗凈流入)*500/AA)),50,945,IF(CONST(大宗凈流入)>0,RGB(250,0,0),RGB(0,50,0)));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.01,0.88,0,INTPART(大宗凈流入)),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.014,1,0,' 大宗'),COLORYELLOW;
DRAWRECTREL(55,CONST(830-(ABS(超凈)*500/AA)),95,945,IF(CONST(超凈)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(100,CONST(830-(ABS(大凈)*500/AA)),140,945,IF(CONST(大凈)<0,RGB(0,50,0),RGB(255,0,0)));
DRAWRECTREL(145,CONST(830-(ABS(中凈)*500/AA)),185,945,IF(CONST(中凈)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(190,CONST(830-(ABS(散凈)*500/AA)),230,945,IF(CONST(散凈)<0,RGB(0,50,0),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.061,1,0,' 超凈 大凈 中凈 散凈'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.055,0.88,0,INTPART(超凈)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.103,0.88,0,INTPART(大凈)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.144,0.88,0,INTPART(中凈)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.190,0.88,0,INTPART(散凈)),COLORYELLOW;
AAD:=CONST(MAX(ABS(主力買力度),ABS(主力賣力度)))*4,NODRAW;
DRAWRECTREL(0,515,CONST(ABS(主力買力度)*500/AAD),568,IF(CONST(主力買力度)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(0,570,CONST(ABS(主力賣力度)*500/AAD),623,IF(CONST(主力賣力度)>0,RGB(0,50,0),RGB(255,0,0)));
DRAWTEXT_FIX(1,0,0.512,0,STRCAT('主力買力度:',CON2STR(主力買力度,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.57,0,STRCAT('主力賣力度:',CON2STR(主力賣力度,0))),COLORYELLOW;

C. [通達信公式] 求圖中所含公式指標源碼,請高手幫忙,萬分感謝 !

{通達信已通過測試,會出現紅色箭頭時,報警}
DIFIF1:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEAEA1:= EMA(DIFIF1,9);
CROSS(DIFIF1,DEAEA1);

D. 通達信 SAR指標源碼

sar指標,也叫拋物線指標,基本的分析指標源碼:
VAR1:=SAR(10,2,20);
S:IF(VAR1>C,VAR1,DRAWNULL),COLORRED,CIRCLEDOT;
X:IF(VAR1B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1)ANDREF(C,1)>=REF(C,2),1,IF(CREF(C,2)ANDREF(C,2)>REF(C,1),2,IF(CSM:=IF(REF(SS,1)>0ORREF(SS,1)<0,REF(SS,1),IF(REF(SS,2)>0ORREF(SS,2)<0,REF(SS,2),IF(REF(SS,3)>0ORREF(SS,3)<0,REF(SS,3),IF(REF(SS,4)>0ORREF(SS,4)<0,REF(SS,4),IF(REF(SS,5)>0ORREF(SS,5)<0,REF(SS,5),IF(REF(SS,6)>0ORREF(SS,6)<0,REF(SS,6),IF(REF(SS,7)>0ORREF(SS,7)<0,REF(SS,7),0)))))));
MC:IF(REF(SS,1)>0ORREF(SS,1)<0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2))),COLORFF00FF;
STICKLINE(SS=1ORSM>=1ANDSS=0,B1,C,0.8,1),COLORRED;
STICKLINE(SS=-1ORSM<=-1ANDSS=0,B1,C,0.8,0),COLORFF9000;
STICKLINE(SS=2,B2,C,0.8,1),COLORRED;
STICKLINE(SS=-2,B2,C,0.8,0),COLORFF9000;
STICKLINE((SS=-1ORSS=-2)ANDSM>0,B2,B1,0.8,1),COLORRED;
STICKLINE((SS=1ORSS=2)ANDSM<0,B2,B1,0.8,0),COLORFF9000;

E. 通達信pbx指標源碼

通達信PBX 指標源碼如下

PBX1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;

PBX2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;

PBX3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;

PBX4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;

PBX5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;

PBX6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;

F. 知道通達信指標源碼,怎樣編出這個的選股公式如能把主圖公式指標也給改一下讓它顯示的更直觀更好。

選股公式:
JJ1:=MA(C,30);
JJ2:=MA(C,60);
入1:=IF(JJ1>REF(JJ1,1),JJ1,DRAWNULL),COLORRED,LINETHICK2;
入2:=IF(JJ1<REF(JJ1,1),JJ1,DRAWNULL),COLOR00FF00,LINETHICK2;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
TT:=(V2*1.01-REF(V2,1));
TT2:=(REF(V2*1.01,1)-REF(V2,2));
YY:=TT>3*ABS(TT2);
TT1:=EMA(V2,15);
A:TT>0 AND CROSS(TT,TT1) AND YY;

主圖公式修改如下:
DRAWKLINE(H,O,L,C);
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
TT:=(V2*1.01-REF(V2,1));
TT2:=(REF(V2*1.01,1)-REF(V2,2));
YY:=TT>3*ABS(TT2);
TT1:=EMA(V2,15);
DRAWTEXT(TT>0 AND CROSS(TT,TT1) AND YY,LOW,'━買入'),COLORYELLOW;
A111:=COST(85);
A222:=COST(15);
A333:=A111-A222;
A444:=(A111+A222)/2;
單峰密集:=A333/A444*100<30,LINETHICK0;
BU1:=HHV(HIGH,250);
BU2:=LLV(LOW,250);
BU3:=BU1-BU2;
BU4:=(A444-BU2);
低位:=A444<(BU3*04+BU2),LINETHICK0;
低位單峰密集:=單峰密集 AND 低位;
BU5:=C/REF(C,1)>1.04; {AND V/REF(V,1)>2;{ AND H=C;}
主力持倉%:=EMA(100*(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30)),3);
主力持倉:=主力持倉%>=75 {AND 主力持倉%<=91} AND C>0 AND CLOSE>OPEN;
強突:=主力持倉 AND 低位單峰密集 AND BU4 AND WINNER(C)>=0.90 AND BU5;
集買:=低位單峰密集 AND TT>0 AND CROSS(TT,TT1) AND YY AND WINNER(C)>=0.90;
DRAWICON(集買,HIGH,6);

G. 通達信 wvad指標源碼

N:=24;

M:=6;

WVAD:SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,N)/10000;

MAWVAD:MA(WVAD,M);

wvad指標代碼如上,

顯示效果圖如下

H. 知道通達信這個指標源碼,怎樣編出這個指標的選股公式

你寫不下, 你以為別人就能寫的下嗎?這是一個組合疊加的指標(說白了是個雜種)
裡面設置了很多買入條件,不知你要哪個?有w底,買點,滿倉等都是買入信號啊!!!
就暫且設置w底選股吧,
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
W底選股:IF(SSS-SSB=2 AND SSS>REF(SSS,1),1,0);
這是一個底部選股比較可靠的指標之一。

閱讀全文

與通達信市凈率指標公式源碼相關的資料

熱點內容
優酷app的廣告怎麼那麼多 瀏覽:292
免費在線觀看小電影 瀏覽:919
不用付費免費看的動漫 瀏覽:549
泰國電影大全免費觀看 瀏覽:454
雲伺服器快照是什麼 瀏覽:885
廣數980數控車床編程 瀏覽:12
ulinix維語電影 瀏覽:339
python爬蟲京東價格 瀏覽:660
python接收表單數據 瀏覽:990
小說電影圖片 瀏覽:559
150部忘年戀電影 瀏覽:409
姜恩惠拍過的電影 瀏覽:710
linuxtomcat訪問不了 瀏覽:402
蘋果可以看的網站有什麼 瀏覽:196
電影下映後多久全網公映 瀏覽:251
pdf轉換大小 瀏覽:596
歐美片BL站好看的電影院 瀏覽:131
免費在線觀看電視劇的網站 瀏覽:896
十大封禁愛情電影在哪裡看 瀏覽:129
市民雲伺服器不可用是怎麼回事 瀏覽:459