導航:首頁 > 源碼編譯 > 通達信pvi指標源碼

通達信pvi指標源碼

發布時間:2024-02-22 18:22:09

A. 誰有航海家通達信指標公式源碼

{航海家通達信指標全套公式}
{1.海洋狀態}
XY_S1101:=(2*CLOSE+HIGH+LOW)/4;
XY_S1102:=LLV(LOW,34);
XY_S1103:=HHV(HIGH,34);
XY_SZQQS1:EMA((XY_S1101-XY_S1102)/(XY_S1103-XY_S1102)*100,13),COLOR00FF00;
XY_SZQQS2:EMA(0.667*REF(XY_SZQQS1,1)+0.333*XY_SZQQS1,2),COLORFF0000;
AA:20,COLORFF0000;
BB:50,COLOR808080;
CC:80,COLOR00FF00;
XY_SSY1300:=REF(CLOSE,1);
XY_SSY1302:=SMA(MAX(CLOSE-XY_SSY1300,0),6,1);
XY_SSY1303:=SMA(ABS(CLOSE-XY_SSY1300),6,1);
XY_SDFX:=(CLOSE-LLV(CLOSE,250))/LLV(CLOSE,250)*100;
XY_SKFX:=(HHV(CLOSE,250)-CLOSE)/CLOSE*100;
XY_SSY1301:=XY_SSY1302/XY_SSY1303*100;
XY_SMC1:IF(REF(XY_SSY1301,1)>80 AND XY_SSY1301<80 AND XY_SKFX>XY_SDFX,50,0),COLORFFFFFF;
STICKLINE(XY_SDFX>XY_SKFX,0,5,3,0),COLOR0000FF;
STICKLINE(XY_SDFX<XY_SKFX,0,5,3,0),COLORFF0000;
-------------------------------

{2.主力控盤}
VUR1:=VOL/CAPITAL;
VUR2:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
VUR3:=2.5*MAX(VUR1,VUR2);
VUR4:=DMA(CLOSE,VUR3);
VUR5:=20*(VUR4/REF(VUR4,1)-1)*38;
VUR6:=EMA(VUR5,2);
VUR7:=EMA(VUR5,2);
VUR8:=EMA(VUR7,3);
VURS:=EMA(VUR7,8);
VUR9:=1.1*(MAX(INDEXH,REF(INDEXC,1))/MIN(INDEXL,REF(INDEXC,1))-1);
VURA:=2.5*MAX(VUR1,VUR9);
VURB:=DMA(INDEXC,VURA);
VURC:=EMA(20*(VURB/REF(VURB,1)-1),1)*38;
VURD:=EMA(VURC,2);
VURE:=EMA(VURC,2);
D強:STICKLINE(VURD>0,0,VURD,6.5,1),COLORB210E4;
D弱:STICKLINE(VURD<0,0,VURD,6.5,1),COLORFFA6A6;
極強:STICKLINE(VUR5>0,0,VUR5,6.5,0),COLOR00FFFF;
強勢:STICKLINE(VUR6>0,0,VUR6,6.5,0),COLOR0000FF;
極弱:STICKLINE(VUR5<0,0,VUR5,6.5,0),COLOR10D010;
弱勢:STICKLINE(VUR6<0,0,VUR6,6.5,0),COLORE4E410;
DX:VURE,LINETHICK2,COLOR1088FF;
界:VURS,LINETHICK2,COLOR6CBC10;
控:VUR8,COLORFF10FF;
指:VUR7,COLOR10E4E4;
--------------------------------

{3.分時買賣}
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,30);
MA4:MA(CLOSE,60);
WYA001:=(2*CLOSE+HIGH+LOW)/4;
WYA002:=EMA(WYA001,4);
WYA003:=EMA(WYA002,4);
WYA004:=EMA(WYA003,4);
WYA柱:=(WYA004-REF(WYA004,1))/REF(WYA004,1)*100;
WYA線1:=MA(WYA柱,2);
WYA線2:=MA(WYA柱,1);
WY分時1線:=MA(CLOSE,1);
WY分時21線:=MA(CLOSE,21);
DRAWICON(WYA線1>0.25 AND WYA線2>0.25 AND CROSS(WYA線1,WYA線2),HIGH*1.0128,9);
DRAWICON(WYA線1<0 AND WYA線2<0 AND CROSS(WYA線1,WYA線2),HIGH*1.0128,9);
DRAWICON( CROSS(WY分時21線,WY分時1線),HIGH*1.0128,9) ;
DRAWICON(WYA線1<-0.25 AND WYA線2<-0.25 AND CROSS(WYA線2,WYA線1),LOW,8);
DRAWICON(WYA線1>0 AND WYA線2>0 AND CROSS(WYA線2,WYA線1),LOW,8),COLORYELLOW;
DRAWICON(CROSS(WY分時1線,WY分時21線),LOW,8),COLORYELLOW;
----------------------------------------
{4.主力監控}
A:=VOL*100/CAPITAL;
MA(A,120),POINTDOT,COLOR996633;
MA(A,2),POINTDOT,COLORFFFF00;
游資:MA(A,4),POINTDOT,COLOR3399FF;
主力:MA(A,9),POINTDOT,COLOR00FF00;
大戶:MA(A,17),POINTDOT,COLOR0000FF;
散戶:MA(A,34),POINTDOT,COLORF2E9E7;
警戒線:MA(A,180),COLORFF0000;
STICKLINE(MA(A,120)>0,0,MA(A,120),1,0),COLOR996633;
STICKLINE(MA(A,2)>0,0,MA(A,2),1,0),COLORFFFF00;
STICKLINE(游資>0,0,游資,1,0),COLOR3399FF;
STICKLINE(主力>0,0,主力,1,0),COLORFF0000;
STICKLINE(大戶>0,0,大戶,1,0),COLOR0000FF;
STICKLINE(散戶>0,0,散戶,1,0),COLORF2E9E7;

B. 通達信可用的 資金博弈指標的 源代碼

散戶:(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,LINETHICK1,COLORYELLOW;
中戶:(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,LINETHICK1,COLORGREEN;
大戶:(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,LINETHICK1;
機構:(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,LINETHICK2,COLORRED;
一、通達信炒股軟體是一款定位於提供多功能服務的證券信息平台,由深圳財富趨勢科技股份有限公司設計的一款移動證券軟體。通達信允許用戶自由劃分屏幕,並規定每一塊對應哪個內容。
二、股票是股份公司所有權的一部分,也是發行的所有權憑證,是股份公司為籌集資金而發行給各個股東作為持股憑證並藉以取得股息和紅利的一種有價證券。股票是資本市場的長期信用工具,可以轉讓,買賣,股東憑借它可以分享公司的利潤,但也要承擔公司運作錯誤所帶來的風險。每股股票都代表股東對企業擁有一個基本單位的所有權。每家上市公司都會發行股票。
三、同一類別的每一份股票所代表的公司所有權是相等的。每個股東所擁有的公司所有權份額的大小,取決於其持有的股票數量占公司總股本的比重。股票是一種有價證券,是股份公司在籌集資本時向出資人發行的股份憑證,代表著其持有者(即股東)對股份公司的所有權,購買股票也是購買企業生意的一部分,即可和企業共同成長發展。這種所有權為一種綜合權利,如參加股東大會、投票表決、參與公司的重大決策、收取股息或分享紅利差價等,但也要共同承擔公司運作錯誤所帶來的風險。獲取經常性收入是投資者購買股票的重要原因之一、分紅派息是股票投資者經常性收入的主要來源。
四、股票買進和賣出都要收傭金(手續費),買進和賣出的傭金由各證券商自定(最高為成交金額的千分之三、最低沒有限制,越低越好),一般為:成交金額的0.05%,傭金不足5元按5元收。賣出股票時收印花稅:成交金額的千分之一(以前為3‰,2008年印花稅下調,單邊收取千分之一)。股票收益即股票投資收益,是指企業或個人以購買股票的形式對外投資取得的股利,轉讓、出售股票取得款項高於股票賬面實際成本的差額,股權投資在被投資單位增加的凈資產中所擁有的數額等。股票收益包括股息收入、資本利得和公積金轉增收益。

C. 求分時均價線,通達信指標的源碼,

均價:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK2;
IF(均價<=REF(均價,1),均價,DRAWNULL),COLORGREEN,LINETHICK3;
IF(均價>=REF(均價,1),均價,DRAWNULL),COLORYELLOW,LINETHICK3;
DRAWTEXT(CURRBARSCOUNT=4,均價,'均'),COLORYELLOW,LINETHICK3;
DRAWNUMBER(CURRBARSCOUNT=2,均價,均價),COLORYELLOW,LINETHICK3;
簡單一點就是
均價:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK2;

D. 誰有通達信pvi和NVI源碼

正負成交量指標
系統源碼的仔斗我沒有我有自己編的和系統數埋簡值不同但現實效果一樣彎戚褲
{NVI負成交量}
A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
PVIX:=IF(V>REF(V,1),A,0);
NVIX:=IF(V<REF(V,1),A,0);
ZNL:=SUM(PVIX,72);
FNLL:SUM(NVIX,0);
MA(FNLL,72);

{PVI正成交量}
A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
PVIX:=IF(V>REF(V,1),A,0);
B:SUM(PVIX,0);
CC:MA(B,72);

閱讀全文

與通達信pvi指標源碼相關的資料

熱點內容
將女人收服成神奇寶貝的小說 瀏覽:303
縱情似海4 瀏覽:920
雪花霜電影完整版 瀏覽:681
虛無未判鴻蒙未開 瀏覽:513
高尺度bl電影 瀏覽:504
葉凡司空嫣然小說名叫什麼 瀏覽:1002
主角連女兒都上的小說 瀏覽:44
主角有投資系統的小說 瀏覽:835
原著小智為主角的小說 瀏覽:165
女主叫簡寧男主姓席 瀏覽:729
女主重生男主姓陸軍婚 瀏覽:854
看片小網站 瀏覽:195
穿越之一女n蛇王 瀏覽:677
曹查理吃千年人參是什麼電影 瀏覽:396
《色變天下》女尊 瀏覽:416
碧藍航線同人小說 瀏覽:761
sci謎案集小說全集+番外TXT下載 瀏覽:98
最經典的啄木鳥電影 瀏覽:295
男主是爐鼎被女修采補小說 瀏覽:424
李彩譚有特點的電影 瀏覽:262