導航:首頁 > 源碼編譯 > 背馳買賣指標源碼

背馳買賣指標源碼

發布時間:2024-02-23 08:30:01

『壹』 通達信可用的 資金博弈指標的 源代碼

散戶:(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,LINETHICK1,COLORYELLOW;
中戶:(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,LINETHICK1,COLORGREEN;
大戶:(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,LINETHICK1;
機構:(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,LINETHICK2,COLORRED;
一、通達信炒股軟體是一款定位於提供多功能服務的證券信息平台,由深圳財富趨勢科技股份有限公司設計的一款移動證券軟體。通達信允許用戶自由劃分屏幕,並規定每一塊對應哪個內容。
二、股票是股份公司所有權的一部分,也是發行的所有權憑證,是股份公司為籌集資金而發行給各個股東作為持股憑證並藉以取得股息和紅利的一種有價證券。股票是資本市場的長期信用工具,可以轉讓,買賣,股東憑借它可以分享公司的利潤,但也要承擔公司運作錯誤所帶來的風險。每股股票都代表股東對企業擁有一個基本單位的所有權。每家上市公司都會發行股票。
三、同一類別的每一份股票所代表的公司所有權是相等的。每個股東所擁有的公司所有權份額的大小,取決於其持有的股票數量占公司總股本的比重。股票是一種有價證券,是股份公司在籌集資本時向出資人發行的股份憑證,代表著其持有者(即股東)對股份公司的所有權,購買股票也是購買企業生意的一部分,即可和企業共同成長發展。這種所有權為一種綜合權利,如參加股東大會、投票表決、參與公司的重大決策、收取股息或分享紅利差價等,但也要共同承擔公司運作錯誤所帶來的風險。獲取經常性收入是投資者購買股票的重要原因之一、分紅派息是股票投資者經常性收入的主要來源。
四、股票買進和賣出都要收傭金(手續費),買進和賣出的傭金由各證券商自定(最高為成交金額的千分之三、最低沒有限制,越低越好),一般為:成交金額的0.05%,傭金不足5元按5元收。賣出股票時收印花稅:成交金額的千分之一(以前為3‰,2008年印花稅下調,單邊收取千分之一)。股票收益即股票投資收益,是指企業或個人以購買股票的形式對外投資取得的股利,轉讓、出售股票取得款項高於股票賬面實際成本的差額,股權投資在被投資單位增加的凈資產中所擁有的數額等。股票收益包括股息收入、資本利得和公積金轉增收益。

『貳』 股市當中有哪些好用的指標,帶源碼

指標不是萬能的,不是萬能鑰匙,靈丹妙葯,指標五花八門,林林總總,不計其數。每一類指標只能反映股票運行規律的一個側面。

我自以為是的適合自己的好用的主圖指標如下:

DRAWKLINE(H,O,L,C);

漲停1:=(C/REF(C,1))>=1.095 AND (C/REF(C,1))<=1.105;

STICKLINE(漲停1,O,C,4,0),COLORYELLOW;

漲停2:=(C/REF(C,1))>1.105 AND (C/REF(C,1))<=1.195;

STICKLINE(漲停2,O,C,4,0),COLORLIRED;

漲停3:=(C/REF(C,1))>1.195 ;

STICKLINE(漲停3,O,C,4,0),COLORMAGENTA;

EXPMA17:EXPMEMA(C,17)COLORMAGENTA LINETHICK2;

MA55:MA(C,55) COLORWHITE;

MA89:MA(C,89)COLORYELLOW ;

MA144:MA(C,144) COLORRED LINETHICK2;

CCL:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DDL:=DMA(CLOSE,CCL);

上:=(1+7/100)*DDL,DOTLINE,COLORGREEN;

下:=(1-7/100)*DDL,DOTLINE,COLORGREEN;

中:=(上+下)/2,DOTLINE,COLORGREEN;

上上:=EMA(上,181),DOTLINE,COLORRED;

下下:=EMA(下,181),DOTLINE,COLORRED;

中中:=EMA(中,181),DOTLINE,COLORRED;

DRAWICON(上>=上上,上上,17);

主十增倉:10*WINNER(CLOSE*0.9)*8,NODRAW COLORYELLOW;

十換手:SUM(VOL/CAPITAL*100,10),NODRAW COLORWHITE;

ER:=V/FINANCE(7)*100;

MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));

T1T:=BARSLAST(C>MAXCYC*POW(1.1,0.9));

T2T:=BARSLAST(C<maxcyc*pow(1.1,-0.9)); p=""> </maxcyc*pow(1.1,-0.9));>

T3T:=CROSS(T1T,T2T) OR CROSS(T2T,T1T) OR BARSSINCE(T1T+1)=0 OR BARSSINCE(T2T+1)=0 OR BARSCOUNT(C)=0;

T4T:=REF(MAXCYC,BARSLAST(T3T));

主力盈利:LN(C/T4T)/LN(1.1)*10,NODRAW;

{盈利天:BARSLASTCOUNT(主力盈利>0) COLORMAGENTA,NODRAW;}

獲利比例:WINNER(CLOSE)*100,NODRAW;

DRAWICON(獲利比例>0 AND 獲利比例<=2,L*0.98,9);

DRAWICON(獲利比例>2 AND 獲利比例<=5,L*0.98,23);

P1:=90;

AO:=P1+(100-P1)/2;

BO:=(100-P1)/2;

CCO:=COST(AO);

DDO:=COST(BO);

籌碼集中度:(CCO-DDO)/(CCO+DDO)*100/2,COLORRED,NODRAW;

DRAWICON(獲利比例>80 AND 籌碼集中度<10,L*0.98,25);

翻倍:=REFDATE(REF(LLV(LOW,90),3),DATE)=LOW AND (CLOSE-LOW>0-CLOSE OR OPEN-LOW>CLOSE-OPEN);

STICKLINE(翻倍,H,H*1.2,2,0),COLORLIRED;

DRAWTEXT(翻倍,H*1.2,'機會來了'),COLORYELLOW;

DRAWTEXT(翻倍,H*1.15,'堅決持有'),COLORCYAN;

DRAWTEXT(翻倍,H*1.1,'後市暴漲'),COLORMAGENTA;

N:=1.5;

M:=3;

DIFF:=EMA((EMA(CLOSE,N*12)-EMA(CLOSE,N*26))/EMA(CLOSE,N*26)*1000,M);

DEAF:=EMA(DIFF,N*9),COLOR000088;

加倉:IF(DIFF>=REF(DIFF,1) AND DEAF<ref(deaf,1),diff,drawnull),colorlired,nodraw; p=""> </ref(deaf,1),diff,drawnull),colorlired,nodraw;>

短線出局:=IF(DIFF REF(DEAF,1),DIFF,DRAWNULL),NODRAW;

STICKLINE(加倉 ,C,C*1.0015,8,0),COLORYELLOW;

在告訴你答案之前,先簡短的講講我的經歷吧!十多年前,我是世界500強企業的一名職員。通過自學,考試後現在轉行為證券公司的一名投顧。在我轉行之前也是到處找資料學習。相關的書籍啊,指標啊等等,但掌握了一些基礎知識後發現即使學會了這些東西還是遠遠不能在這個市場上生存的。通過認真思考我發現,如果做投資沒有自己的交易體系,那是很危險的一件事。在自己的交易體系建立之前,我做過外匯,做過權證,做過商品期貨,做過期權,當然也有股票。現在從業了,所以也就只是做做股票的模擬盤。所以對於指標類的東西還是有所發言權的。言歸正傳,下面來回答一下你的問題吧!

1.如果你真的想在這個投資市場上暢意的行走,你首先應該建立自己的交易體系。

2.在你建立交易體系之後,我現在正式回答你的問題。正常情況下,你只需要認真研究系統默認的幾個指標就可以了,K線,均線,量,KDJ,MACD就這幾個,其它雜亂的指標都是通過這幾個基礎指標編輯演變而成的,因為是手機截圖,所以這里截了兩個圖,如果需要操盤,建議最好是用電腦。

3.K線,K線就是紅綠柱,他代表最高價,最低價,開盤價和收盤價。在這里我就不詳細贅述了。

4.均線,均線分日,月,周,季,年均線等。那要看你是什麼周期,比如日均線m5就是五天內的平均價,也就是五日均線。M10就是十天均線等等。

5.量,量就比較復雜一點,常常需要配合其他指標使用,它代表成交量或成交額。周期也是和均線一樣。

6.MACD和KDJ,同樣需要結合周期來使用,最常見的就是金叉和死叉,但是也需要結合市場環境來看。


給大家一個去掉不適合自己參與的過濾選股器吧,懂代碼的可以自己修改,不懂得那就直接用,有幾個參數最好自己做一下修改,比如,股價,交易密度,等等。

它的功能是選出適合自己的帶有漲停板的活躍股,他不是操作的依據,只是幫你過濾掉那些不適合參與的股票,每天盤後下載數據,復盤選股,他不適合最預警,只適合復盤高效選股。

僅供參考(通達信使用者)

公式名稱:去掉無效選股

參數:N=2:2000:60(周期數)

N1=1:200:3(漲停板個數)

SS=2:2000:50(股價)

NN=2:30:15(交易密度)


ENTERLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,20));{這是一個均線自動交易代碼暫時先保存著以備後用}

EXITLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,3));{這是一個均線自動交易代碼暫時先保存著以備後用}

ZTTJ1:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));

ZTTJ:=(CLOSE>=ZTPRICE(REF(CLOSE,1),IF(FINANCE(3)=3,0.2,0.1)));

ZTTM:=COUNT(ZTTJ,N)>=N1;

AR2:=EVERY(ZTTJ,2);

AR3:=COUNT(AR2,60)>=1;

RZ1:=INBLOCK('殼資源')=0; RZ2:=INBLOCK('商譽減值')=0; RZ4:=INBLOCK('風險品種')=0;

RZ6:=INBLOCK('細分龍頭')=1; RZ7:=INBLOCK('已高送轉')=0;

{通達信去掉創業板*ST} S1:=IF(CODELIKE(馄'),1,0);

{通達信去掉退市股}{去掉不需要的板塊}{通達信去掉*、S、ST}

S2:=IF(NAMELIKE('S'),0,1); S3:=IF(NAMELIKE('*'),0,1);

{通達信去掉停牌}

S4:=DYNAINFO(17)>0;

S5:= BETWEEN(FINANCE(7)/10000000,1,400) AND FINANCE(7)*C/100000000<360 AND C<ss p="" ;

{去掉融券融資 AND S6}

S6:=FINANCE(52)=0;

S7:=IF(CODELIKE(鬈'),0,1);{通達信去掉科創板}

S10:=FINANCE(30)>=-5;

S12:=DYNAINFO(39)<500;

S13:=SUM(DYNAINFO(37),20)>0.2;

S14:=FINANCE(30)/FINANCE(20)*100>-50;

ST:S2 AND S3 AND S4 AND S7 AND RZ4 AND S13 AND ZTTM AND C<ss;{and p="" s1}

AA1:=C/REF(C,1)>1.03 AND C<ss p="" s7;{強勢選股}

AB1:=FROMOPEN*NN;

AB2:=DYNAINFO(50)>AB1;

S11:=IF(AB2,AA1,DRAWNULL);

大家好,給大家分享一個監測莊家動向的指標——獵庄擒牛。指標通過對莊家資金的監測,可以捕捉到莊家何時進場拉升,何時出貨離場。洞察到莊家的這些動向之後,散戶獵庄擒牛並不只是說說而已。

「獵庄擒牛」指標要點:

一、指標提示「莊家出現」信號時,表明監測到此處有莊家大資金進場,行情即將開啟拉升,可跟進建倉。

二、指標提示「莊家出貨」信號時,表明監測到此處莊家在進行籌碼派發,應果斷止盈離場,落袋為安。

效果圖:

「獵庄擒牛」主要作用就是對莊家大資金動向的監測,從而給出預警信號。當然指標還有其它關於籌碼和趨勢的信號判斷,這里就不做過多講解,大家拿到後可以去慢慢摸索。

大道至簡,簡單有效不要復雜。股市中最有效的技術指標就是那些最貼近市場本質的數據跟蹤指標,我最常用的就是K線,均線,MACD和量能及均量線,夠用了。

在一個多變復雜的市場中,越簡單反而才是越有效,過於復雜的技術工具適應能力太差。

通達信精準指標——趨勢布林線主圖+神針起爆副圖+源碼 給大家分享一個趨勢布林線主圖,搭配神針起爆副圖,適用於短線和中長線,是基於系統布林線而研發的,比系統自帶的更加精準。 主圖當出現紅色箭頭為建倉信號,當出現綠色箭頭為減倉或者平倉信號。 副圖紅色趨勢為上升趨勢,綠色趨勢為下跌趨勢,紅色趨勢變為綠色交叉點為減倉信號。 綠色趨勢變為紅色為建倉信號,出現神針起爆紅柱可作為啟動點和建倉點。

主副圖點位一一對應,產生共振。 源碼

這套指標主要利用主副圖共振點來進行操作,精準率很高,喜歡的朋友可以關注我的首頁,留言指標二字,我會免費分享給大家。

好用的公式有很多,但是適合自己才行!今天我分享幾個我自己經常用的公式分享給大家!

擒牛大中短


這個公式主要就是抓買賣點的指標,不含未來函數,可以放心操作!

主力波段吸籌

該公式是精準判斷操作位置,依然沒有未來函數!

其次,如果大家想炒股,先學習一些基本的炒股知識,並且少量投入,切不可一梭哈。不要迷信技術指標,所謂的指標都是事後才出來的,有精力的可以去看看指標編程,無非都出自於成交量、成交額、均線等等,所以都是滯後的。簡單的K線、成交量、2條均線,輔助參考判斷即可。技術指標越復雜,越難以付諸實施。

所以,還請大家不要迷戀技術指標,我曾經花了1年多的時間研究、編寫各種技術指標,到現在,我已經放棄了,只留了交易軟體裡面最原始的指標,做輔助判斷而已,記住只是輔助判斷。還請大家不要走彎路,一入股市深似海,到處都是坑,切記!!!

這個我認為因人而異,畢竟適合自己的指標才是好指標。這里我們來分享下我常用的指標

第一,均線,均線是時候非常實用的指標,無論是短線,中線,長線都非常實用。

(1)如果是短線,5日均線就夠了。5日均線比較神奇。

①當K線從5日均線下方上穿5日均線,而且均線開始拐頭,結合量能,底部放量,那麼短線就可以把我了,而且是超短機會。基本都有不錯的收益。

②當市場均線多頭排列,只要K線在5日均線上方,沿著5日均線上行,那麼也是一個持倉的機會。

(2)中線,中線一般就是看20日均線,這個均線比較實用,也稱為萬能均線,只要K線站穩在20日均線上方,而且拐頭向上,結合籌碼,籌碼低位單峰,中線就可以把握。

(3)長線,長線就是60日均線上穿120日均線,而且趨勢上行。

第二,MACD,領略到精髓,賺錢非常簡單。

1、 MACD在0軸上方——每發生一次金叉,股價將創新高,但是二次金叉不要追。2、 MACD在0軸下方——每發生一次死叉,股價將創新低新低後可以適當的補倉。3, MACD在0軸上方——金叉死叉次數越多越好、牛股,4,, MACD在0軸下方——金叉死叉次數越多越差、熊股。5,MACD水下兩次金叉,第二次金叉就是買入機會。6.MACD的黃白兩線不能和柱狀形成背離,背離則會產生行情反轉。

好了我就分享了我常用的這兩個希望對大家有幫助。


如果想聽實話,我就告訴你。最好用的指標是:K線、成交量(手)、均線和MACD。其它指標都可以忽略。

你進入叢林,容易繞花眼睛,七選八選-選個漏眼。其實最顯眼的就是最好的。

『叄』 k線顯示買賣資金指標公式

簡單的bbd指標公式如下:
a=(ZDMR[-1]+BDMR[-1]);b=(ZDMC[-1]+BDMC[-1]);A1=SUM(a,1);b1=-SUM(b,1);STICKLINE(A1+b1>0,0,A1+b1,9,0),color0000ff;STICKLINE(A1+b1<0,0,A1+b1,9,0),color00ff00;顯示的是一根根的紅綠柱子,在上方的是紅色柱子,下方的是綠色柱子,這個時候投資者可以根據柱子的方向,判斷主力資金買賣的操作方向,從中研究股價的發展趨勢。但是有的時候,僅僅是通過柱子的判斷還不是很嚴謹,那麼就可以通過日線個股中的BBD指標進行分析,分布有5日、10日等指標線與紅綠量柱結合分析股價的運行方向。此外,投資者需要注意的是,BBD指標不僅僅是可以通過日K線的走勢反映主力資金的方向變化,還可以通過分時圖中的走勢進行展示。

『肆』 比較好的買賣點提示的股票指標公式

通達信軟體裡面有上千個指標公式,提供一個本人在用的買賣點把握以及解決持股問題的簡潔公式。
操盤手指標公式源碼:
A:=AMOUNT/V/100;
VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
操盤線:=EMA(((VARA/10)+EMA(A,10)),3);
行情線:=EMA(A,3);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
趨勢線:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK2;
紅升:IF(重心>=趨勢線,趨勢線,DRAWNULL),COLORRED,LINETHICK2;
藍降:IF(重心<趨勢線,趨勢線,DRAWNULL),COLORBLUE,LINETHICK2;
STICKLINE(行情線<操盤線,H,L,0,1),COLORGREEN;
STICKLINE(行情線<操盤線,C,O,2,1),COLORGREEN;
STICKLINE(行情線>=操盤線,H,L,0,1),COLORRED;
STICKLINE(行情線>=操盤線,C,O,2,1),COLORRED;
{頂底信號}
買線:=EMA(C,5);
賣線:=EMA(C,13);
BU:=CROSS(買線,賣線);
SEL:=CROSS(賣線,買線);
DRAWICON(BU,LOW*0.971,7);
DRAWICON(SEL,HIGH*1.011,8);
{漲跌停顯示}
漲停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(漲停,O,C,2,0),COLORRED;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(跌停,O,C,2,1),COLORGREEN;
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,L*0.99,'B1'),COLORRED;
加分可以再給你幾個,哈哈!~
友情提示:指標不在多,而在精,看你能不能把它用好。

『伍』 買賣點不漂移好用指標公式

STICKLINE(C>0.1,0,100,4.8,0),COLOR668800;

STICKLINE(C>0.1,-5,0,4.8,0),COLORFFB06C;

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

火:=BARSLAST(EMA(CLOSE,5)
山:=COUNT(EMA(CLOSE,5)>REF(EMA(CLOSE,5),1),5),NODRAW;

KL:=IF(山>0,2*火,0);

趨勢:=KL/2,COLOREE687B,NODRAW;

VARL1:=(EMA(C,12)-EMA(C,26))*100+50;

VARL2:=EMA(VARL1,9);

VARL3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;

VARL4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

VARL5:=SMA(VARL4,13,8);

VARL6:=SMA(VARL3,21,8);

低位線:=IF((趨勢-VARL6<(-70)),0,-5);

DRAWBAND(低位線,RGB(00,300,150),-5,RGB(00,300,150));

QS:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

高位線:=IF((QS-VARL6>85),0,-5);

DRAWBAND(高位線,RGB(255,20,147),-5,RGB(255,20,147));

K1:EMA(VAR2,5),COLORLIBLUE,NODRAW;

K2:SMA(VAR2,5,1),COLORYELLOW,NODRAW;

K:EMA((K1-K2),2),COLORWHITE,NODRAW;

『陸』 短線高手主力版「買賣趨勢」指標公式源碼

非常準的趨勢買賣(圖片演示在下面網址里)

VAR1:=(C+H+O+L)/4;
賣出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
買入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(賣出-買入)/買入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(賣出>LOW AND 賣出<HIGH,賣出,MAX(賣出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(賣出>MIN(C,O) AND 賣出<MAX(C,O),賣出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(賣出>LOW AND 賣出<HIGH,賣出,HIGH,0,0),COLORGREEN;
STICKLINE(賣出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(賣出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(買入>LOW AND 買入<HIGH,買入,MIN(MIN(OPEN,CLOSE),買入),3,0),COLORMAGENTA;
STICKLINE(買入>MIN(C,O) AND 買入<MAX(C,O),買入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(買入>LOW AND 買入<HIGH,買入,LOW,0,0),COLORMAGENTA;
STICKLINE(買入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(買入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,買入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(賣出,HIGH),HIGH*1.02,'S'),COLORGREEN;

綠上賣,紅下買。

閱讀全文

與背馳買賣指標源碼相關的資料

熱點內容
主角有投資系統的小說 瀏覽:835
原著小智為主角的小說 瀏覽:165
女主叫簡寧男主姓席 瀏覽:729
女主重生男主姓陸軍婚 瀏覽:854
看片小網站 瀏覽:195
穿越之一女n蛇王 瀏覽:677
曹查理吃千年人參是什麼電影 瀏覽:396
《色變天下》女尊 瀏覽:416
碧藍航線同人小說 瀏覽:761
sci謎案集小說全集+番外TXT下載 瀏覽:98
最經典的啄木鳥電影 瀏覽:295
男主是爐鼎被女修采補小說 瀏覽:424
李彩譚有特點的電影 瀏覽:262
李承憲電影 瀏覽:741
台灣小敏 瀏覽:109
水沫緣淺的所有小說txt 瀏覽:244
喪屍之神主角張楊 瀏覽:343
91電影 瀏覽:945
書包網txt 瀏覽:286
台灣懷舊限級電影 瀏覽:394