導航:首頁 > 源碼編譯 > 選股入門公式源碼小寫怎麼編寫

選股入門公式源碼小寫怎麼編寫

發布時間:2024-05-23 08:32:35

Ⅰ 簡單高效的選股公式有哪些

財經信紙

在A股市場中本來就是一個莊家和散戶博弈的戰場,那麼為什麼虧的都是散戶呢?原因無非在於三點,選股、買點、賣點,每個股民心中都有一個夢,就是炒股的時候能多抓一些漲停板,那麼究竟如何才能成功穩抓漲停板呢?今天給大家講解幾種選股公式,希望大家仔細學習與領悟。

1、牛股等待啟動選股公式

本人是根據股價與均線的一種比例關系,而編寫的一個選股公式,經長久的試用,效果挺好,很多牛股啟動前大部分都是這個走法,還有高控盤的股票,特拿來分享!

公式源碼

S2:=IF(NAMELIKE('S'),0,1);

S3:=IF(NAMELIKE('*'),0,1);

S4:=DYNAINFO(17)>0;

ST:FROMOPEN>165 AND MA(C,5)/MA(C,60)>0.95 AND MA(C,5)/MA(C,60)<1.28and MA(C,10)/MA(C,60)>0.95 AND MA(C,10)/MA(C,60)<1.28 AND MA(C,30)/MA(C,60)>0.95AND MA(C,30)/MA(C,60)<1.28 AND CROSS(C,MA(C,5)) AND S2 AND S3 AND S4 AND C<50;

2、抄底高手

{M 153530

N 123227

D 185042}

VAR1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+M<0;var2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+N<0;

VAR3:=VAR1 AND VAR2;

VAR4:=VAR1 AND VAR2 AND COUNT(VAR3,2)=1 AND DATE> AND (CLOSE>OPEN OR CLOSE

-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)

(REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)REF(CLOSE,3) OR REF

(OPEN,3)REF(CLOSE,4) OR REF(OPEN,4)

(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)

VAR5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

VAR6:=(CLOSE-VAR5)/VAR5*100;

VAR7:=REF(VAR6,1)+D<0 AND VAR6>REF(VAR6,1) AND REF(VAR6,1)1.8 AND (HIGH>LOW) AND (REF(HIGH,1)>REF(LOW,1)) AND (REF(HIGH,2)>REF(LOW,2)) AND (REF(HIGH,3)>REF(LOW,3)) AND (REF(HIGH,4)>REF(LOW,4)) AND (REF(HIGH,5)>REF(LOW,5));

VAR4 OR VAR7;

實戰技巧

(1)梅開二度

13日均線向上穿越55日均線以後,股價滯漲回落,13日均線弱勢下叉34日均線,隨著股價的止跌企穩,13日均線開始勾頭向上二次穿越34日均線,我們把在主均線上的13日均線金叉穿越34日均線,稱之為「梅開二度」。

Ⅱ 如何編寫股票公式

1、先了解股票公式的函數,這里不需要強記,有個大概的印象即可,以後用到的時候,用一個查一個即可。

打開軟體,然後點擊新建公式,裡面有個插入函數,點擊進入,就可以看到全部的公式函數了。

一開始看不懂裡面的字元也沒關系,可以利用網路,一個個來學。


3、多實踐,多看一些指標的形態,嘗試自己去編寫出相同形態的指標,熟能生巧。

Ⅲ 幫忙編寫一個通達信選股公式

以下十種選股公式如下:
1、macd-kdj金叉共振選股公式:
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DEA:=EMA(DIF,9);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
B4:CROSS(DIF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
2、金蜘蛛選股公式:
{n1 1 .00 300.00 5.00
n2 1.00 300.00 10.00
n3 1.00 300.00 20.00}
MA1:=MA(CLOSE,N1);
MA2:=MA(CLOSE,N2);
MA3:=MA(CLOSE,N3);
A1:=COUNT(CROSS(MA2,MA3),2)=1;
A2:=COUNT(CROSS(MA1,MA3),2)=1;
A1 AND A2;
3、穿雲箭多方炮選股公式:
M5:=HHV(MA(C,5),15);
MM5:=IF(M5=REF(M5,1),M5,DRAWNULL);
AA:=MM5=REF(M5,1) AND REF(M5,1)=REF(M5,2) AND REF(M5,2)=REF(M5,3);
XG:REF(L,1)REF(C,1) AND C>M5 AND AA AND L>REF(C,1)
AND FINANCE(34)>1 AND FINANCE(33)>0.1 ;
4、五榜合一選股公式:
ZF:=DYNAINFO(14)*100;{漲幅}
LB:=DYNAINFO(17);{量比}
HS:=DYNAINFO(37)*100;{換手}
ZJ:=AMOUNT/10000;{資金}
TM:=V-MA(V,10);{量填滿}
ZF>=2 AND ZF<=5 AND LB>=2 AND ZJ>=500 AND HS>1 AND TM>0;
盤中預警:
JR:=DYNAINFO(7)>DYNAINFO(11);{現價大於均價}
CL:=DYNAINFO(11)>DYNAINFO(3);{均價大於前收盤價}
GK:=DYNAINFO(4)>DYNAINFO(3);{今天開盤價大於前收盤價}
ZF:=DYNAINFO(14)>0.015;{漲幅}
HS:=DYNAINFO(37)>1;{換手}
LB:=DYNAINFO(17)>1;{量比}
YX:=(REF(CLOSE,1)-REF(CLOSE, 2))/REF(CLOSE,2)<=0.01;{(昨天收盤價-2日前的收盤價)/2日前的收盤價小於等於0.01}
WZ:=DYNAINFO(7)>=MA(CLOSE,5);{現價大於等於收盤價的5日簡單移動均線}
JR AND CL AND GK AND ZF AND HS AND LB AND YX AND WZ;
5、五線順上選股公式:
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1)
AND MA60>REF(MA60,1) AND MA120>REF(MA120,1);
6、三金叉選股公式:
MA5:=EMA(C,5);
MA10:=EMA(C,10);
MV5:=EMA(V,5);
MV10:=EMA(V,10);
K:="KDJ.K"(9,3,3);
D:="KDJ.D"(9,3,3);
V1:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND C>REF(C,1) AND C/O>1.01;
VV1:=MV5>REF(MV5,1) AND MV10>=REF(MV10,1) AND V>REF(V,1)*1.2 ;
KD1:=K>REF(K,1) AND D>=REF(D,1);
VA:=COUNT(CROSS(K,D),4)>=1 AND COUNT(CROSS(MA5,MA10),4)>=1 AND
COUNT(CROSS(MV5,MV10),4)>=1;
XG1:IF(V1 AND VV1 AND KD1 AND VA,1,0);
7、早晨之星選股公式:
STAR:REF(CLOSE,2)/REF(OPEN,2)<0.95&&
REF(OPEN,1)
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03&&
CLOSE/OPEN>1.05&&CLOSE>REF(CLOSE,2);
{輸出STAR:2日前的收盤價/2日前的開盤價<0.95並且昨日開盤價<2日前的收盤價並且昨日開盤價-昨收的絕對值/昨收<0.03並且收盤價/開盤價>1.05並且收盤價>2日前的收盤價}
8、sp低點搜尋選股公式:
{n1 1.00 100.00 5.00}
W:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,N);
CROSS(-5,W);
{W賦值:(45日內最低價的最低值-收盤價)/(45日內最高價的最高值-45日內最低價的最低值)*100的N日簡單移動平均
-5上穿W}
9、旭日初升選股公式:
BUY1:=LAST(CLOSE
BUY:CLOSE>MA(CLOSE,N)&&VOL>MA(VOL,5)*2&&BUY1;
{BUY1賦值:從前0日到前5日持續收盤價<收盤價的N日簡單移動平均
輸出BUY:收盤價>收盤價的N日簡單移動平均並且成交量(手)>成交量(手)的5日簡單移動平均*2並且BUY1
}
近日創歷史新低:
{n 1.00 60.00 3.00}
LLV(LOW,N)=LLV(LOW,0);
{N日內最低價的最低值=0日內最低價的最低值}

(3)選股入門公式源碼小寫怎麼編寫擴展閱讀:
選股方法
1、選擇龍頭股。龍頭股在同行業板塊中有一定的影響力和號召力的,並且龍頭股會起到引導和示範的作用。
2、選擇大市值股。大市值的股票風險小,股票穩定,波動小。
3、選擇政策支持的股票。有政策支持的股票是受國家保護的,發展會比較穩定。
4、避免問題股票。避免st股、*st股,這種股票存在退市的風險。

Ⅳ 如何編寫選股公式

在股市中我們經常看的大盤就是一個龐大的資料庫,它保存著從有股市以來所有股票的有用數據,如收盤價、最高價、最低價、開盤價等。股民要選股可以自己根據K線走勢去選,也可以根據自己的要求通過函數設計出公式來找到自己所要選的股,這個公式我們就叫選股公式。假如您要找股價小於5.00元的股票,那麼您只要設一個公式: c<5.00;這個就是簡單的選股公式.
一、簡單條件選股公式編寫編寫一選股公式,要求選出「股價小於每股凈資產」的個股。進入公式管理器,新建一條件選股公式依次點擊菜單「功能à專家系統à公式管理器」,進入公式管理器界面。
二、選擇左邊樹型列表中條件選股公式下面的其它類型,點擊「新建」。
三、輸入公式名稱,公式描述。
四、點「插入函數」,選擇「收盤價」,點擊「確定」,對應的函數就到了編輯區。
五、點擊 「測試公式」,若顯示測試通過,點擊「確定」按鈕保存公式。
溫馨提示:以上內容僅供參考,不做任何建議。入市有風險,投資需謹慎。
應答時間:2021-04-26,最新業務變化請以平安銀行官網公布為准。
[平安銀行我知道]想要知道更多?快來看「平安銀行我知道」吧~
https://b.pingan.com.cn/paim/iknow/index.html

Ⅳ 編寫一個通達信選股公式,MACD周線金叉

DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
周DIF:="MACD.DIF#WEEK"(12,26,9),COLORGRAY;
周DEA:="MACD.DEA#WEEK"(12,26,9),COLORRED;
AA:=CROSS(周DIF,周DEA);
XG:=CROSS(AA,0.5);
拓展資料:
一、通達信MACD金叉副圖指標源碼公式
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
二、以下公式適合通達信股票軟體。選出股票後能否買入依然還要綜合參考大趨勢和其它指標。
金叉並非萬能,有時剛剛進入金叉或准金叉狀態,也可能是上一波反彈的結束,下一波下跌的開始。
只有當金叉周期的前後周期均為上漲趨勢,金叉的威力才最大。
業績的持續增長才是技術指標的前提和保證。
1、0軸上方第一次金叉選股公式:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
xg:cross(diff,dea) and dea>-1.0 and dea<0.5 and CLOSE>ref(CLOSE,1) and CLOSE>=ma(c,60);
2、0軸上方二次金叉的選股公式:
JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),
SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),
0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);
{選股設JC=10即可}
3.0軸下方一次金叉的選股公式:
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;
4、0軸下方二次金叉且第二次金叉高於第一次金叉:
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AA:=BARSLAST(REF(CROSS(DIF,DEA),1));
二次金叉:CROSS(DIF,DEA) AND DIF>REF(DIF,AA+1) AND AA<20 AND DIF<0;
5、0軸下方二次金叉選股公式:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {選股設JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
JC:IF(SSS-SSB=2 AND SSS>REF(SSS,1),10,0);
6、縮量橫盤突破選股:
WH01:=(HHV(C,10)-LLV(C,10))/LLV(C,10)*100<=10;
WH02:=SUM(VOL,10)/CAPITAL*100<45;
WH03:=REF(WH01,1);
WH04:=HHVBARS(HIGH,55)>20 OR C=HHV(H,55);
WH05:=WH02 AND WH03 AND WH04 AND C>REF(HHV(H,10),1);
WH05 AND REF(NOT(WH05),1);
7、均線、KDJ、MACD金叉的預警選股公式
完全符合以下條件:
(1) 5日線上穿10日線
(2) MACD金叉
(3) KDJ金叉

閱讀全文

與選股入門公式源碼小寫怎麼編寫相關的資料

熱點內容
高清電影免費觀看 瀏覽:397
韓國經典愛情電影推薦 瀏覽:205
pgptray私鑰加密 瀏覽:928
在線大片網站 瀏覽:568
手機怎麼開通中國銀行app 瀏覽:85
5g影視為什麼不能觀看了 瀏覽:662
韓國張美仁愛三部曲 瀏覽:540
安卓版手機怎麼拍照 瀏覽:950
如何解鎖文件夾鎖 瀏覽:720
免費在線觀看的網路電視劇 瀏覽:591
svn命令查看地址 瀏覽:896
丁度巴拉度所有作品 瀏覽:103
手機在線免費觀看推理片 瀏覽:150
黑科技app免費看視頻 瀏覽:265
數控里編譯程序公式 瀏覽:635
安卓系統趣步糖果怎麼賣 瀏覽:850
捷徑怎麼打開app內部 瀏覽:363
轉pdf出錯 瀏覽:81
vip影院電視劇免費觀看 瀏覽:840
伺服器如何更改只讀文件 瀏覽:870