導航:首頁 > 程序命令 > 常用交換機配置命令及作用

常用交換機配置命令及作用

發布時間:2024-03-02 18:59:52

① 華為交換機基本配置命令明細盤點

華為交換機基本配置命令明細盤點

傳統 華為交換機從網橋發展而來,屬於OSI第二層即數據鏈路層設備。它根據MAC地址定址,通過站表選擇路由,站表的建立和維護由 CISCO思科交換機自動進行。下面是我整理的關於華為交換機基本配置命令明細,希望大家認真閱讀!

1:配置登錄用戶,口令等

//用戶直行模式提示符,用戶視圖

system-view //進入配置視圖

[Quidway] //配置視圖(配置密碼後必須輸入密碼才可進入配置視圖)

[Quidway] sysname xxx //設置主機名成為xxx這里使用

[Quidway] aaa //進入aaa認證模式定義用戶賬戶

[Quidway-aaa] local-user wds password cipher wds

[Quidway-aaa] local-user wds level 15

[Quidway-aaa] local-user wds service-type telnet terminal ssh //有時候這個命令是最先可以運

//行的,上邊兩個命令像password,level都是定義完vty 的

// authentication-mode aaa後才出現

[Quidway-aaa] quit

[Quidway] user-interface vty 0 4 //當時很奇怪這個命令就是找不到,最後嘗試了幾次才能運行

[Quidway-ui-vty0-4] authentication-mode aaa

[Quidway-ui-vty0-4] quit

2:華為S9303 VLan設置

創建vlan:

//用戶直行模式提示符,用戶視圖

system-view //進入配置視圖

[Quidway] vlan 10 //創建vlan 10,並進入vlan10配置視圖,如果vlan10存在就直接進入vlan10配置視

[Quidway-vlan10] quit //回到配置視圖

[Quidway] vlan 100 //創建vlan 100,並進入vlan100配置視圖,如果vlan10存在就直接進入vlan100

配置視圖

[Quidway-vlan100] quit //回到配置視圖

將埠加入到vlan中:

[Quidway] interface GigabitEthernet2/0/1 (10G光口)

[Quidway- GigabitEthernet2/0/1] port link-type access //定義埠傳輸模式

[Quidway- GigabitEthernet2/0/1] port default vlan 100 //將埠加入vlan100

[Quidway- GigabitEthernet2/0/1] quit

[Quidway] interface GigabitEthernet1/0/0 //進入1號插槽上的第一個千兆網口配置視圖中。0代表1號

[Quidway- GigabitEthernet1/0/0] port link-type access //定義埠傳輸模式

[Quidway- GigabitEthernet2/0/1] port default vlan 10 //將這個埠加入到vlan10中

[Quidway- GigabitEthernet2/0/1] quit

將多個埠加入到VLAN中

system-view

[Quidway]vlan 10

[Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29 //將0到29號口加入到vlan10中

[Quidway-vlan10]quit

華為下的這個命令自己現在不知道,找了下答案也沒有結果。

3:設置VTP cisco專有的vlan終極協議也成為區域網幹道協議,作用是十幾台交換機在企業網中,配置

VLAN工作量大,可以使用VTP協議,把一台交換機配置成VTP Server, 其餘交換機配置成VTP Client,這樣

他們可以自動學習到server 上的VLAN 信息

『配置環境參數』

(1)交換機SwitchA、SwitchB和SwitchC都通過GE介面互連

(2)SwitchB和SwitchC交換機是核心交換機,要求主備。

『組網需求』

要求整個網路運行STP協議

數據配置步驟

(1)【SwitchA交換機配置】

啟動生成樹協議: [SwitchA]stp enable

(1)【SwitchB交換機配置】

啟動生成樹協議:[SwitchB]stp enable

(3)配置本橋為根橋

[SwitchB]stp root primary

(4)【SwitchC交換機配置】

a 啟動生成樹協議[SwitchC]stp enable

b 配置本橋為備份根橋[SwitchC]stp root secondary

(5)【SwitchD交換機配置】

a 啟動生成樹協議[SwitchD]stp enable

【補充說明】

(1)預設情況下交換機的優先順序都是32768,如果想人為指定某一台交換機為根交換機,也可以通過修改優

先級來實現;

(2)預設情況下打開生成樹後,所有埠都會開啟生成樹協議,請把接PC的埠改為邊緣埠模式;

(3)如果要控制某條鏈路的狀態可以通過設置埠的cost值來實現。

測試驗證

(1)使用display stp查看交換機STP運行狀態

(2)查看埠STP狀態display stp interface Ethernet XX是否正確

4:交換機配置IP地址

[Quidway] interface Vlanif100 // 進入vlan100介面視圖與vlan 100命令進入的地方不同

[Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定義vlan100管理IP三層

交換網關路由

[Quidway-Vlanif100] quit

[Quidway] interface Vlanif10 // 進入vlan10介面視圖與vlan 10命令進入的地方不同

[Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定義vlan10管理IP三層

交換網關路由

[Quidway-Vlanif10] quit

配置默認網關:

[Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默認網關。

5: 交換機保存設置和重置命令

save //保存配置信息

reset saved-configuration /重置交換機的配置

reboot //重新啟動交換機

6:交換機常用的顯示命令

用戶視圖模式下:

display current-configuration //顯示現在交換機正在運行的.配置明細

display device //顯示S9303各設備狀態

display interface ? //顯示個埠狀態,用?可以查看後邊跟的選項

display version //查看交換機固件版本信息

display vlan ? // 查看vlan的配置信息

7:基於埠的mac地址綁定

系統視圖下

am user-bind mac-addr mac地址 ip-addr ip地址 interface 介面類型 介面序號

乙太網埠視圖下

interface 介面類型 介面序號

am user-bind mac-addr mac地址 ip-addr ip地址

8:配置交換機的snmp功能

[Quidway] snmp-agent community read xx //xx是組織名稱,read是以只讀模式查看

[Quidway] undo snmp-agent community xx //刪除xx組織

[Quidway] display snmp-agent community //顯示組織名

9:交換機禁ping配置

[Quidway]acl number 3000

[Quidway-acl-adv-3000]rule 1 deny icmp-type echo any //禁止所有網路ping

[Quidway-acl-adv-3000]rule 3 deny icmp source 1.1.1.1 0.0.0.15 destination 2.2.2.2 0 禁止

1.1.1.1到2.2.2.2的icmp包

[Quidway-acl-adv-3000]quit

[Quidway]interface giga1/0/20

[Quidway-GigabitEthernet1/0/20]packet-filter inbound ip-group 3000 rule 1 //將規則在介面下用

[Quidway-GigabitEthernet1/0/20]packet-filter inbound ip-group 3000 rule 3 //將規則在介面下

[Quidway-GigabitEthernet1/0/20]quit

[Quidway]interface Vlanif 100

[Quidway-Vlanif100]packet-filter inbound ip-group 3000 rule 1 //將規則在介面下用

[Quidway-Vlanif100]quit

[Quidway]interface Vlanif 10

[Quidway-Vlanif10]packet-filter inbound ip-group 3000 rule 1 //將規則在介面下用

[Quidway-Vlanif10]quit

10:恢復交換機出廠設置

reset saved-configuration /重置交換機的配置

11: 實際工作中的一個配置實例

vlan 10

quit

vlan 100

quit

interface XGigabitEthernet2/0/1 (10G光口)

port link-type access

port default vlan 100

quit

interface Vlanif100

ip address 119.187.200.90 255.255.255.252

quit

ip route-static 0.0.0.0 0.0.0.0 119.187.200.89

aaa local-user wds password cipher wds

local-user wds privilege level 15

local-user wds service-type telnet terminal ssh

quit

user-interface vty 0 4

authentication-mode aaa quit

12:埠匯聚實例

(1)交換機SwitchA和SwitchB通過乙太網口實現互連。

(2)SwitchA用於互連的埠為e0/1和e0/2,SwitchB用於互連的埠為e0/1和e0/2。

『組網需求』

增加SwitchA的SwitchB的互連鏈路的帶寬,並且能夠實現鏈路備份,使用埠匯聚數據配置步驟

【SwitchA交換機配置】

(1)進入埠E0/1

[SwitchA]interface Ethernet 0/1

(2)匯聚埠必須工作在全雙工模式

[SwitchA-Ethernet0/1]plex full

(3)匯聚的埠速率要求相同,但不能是自適應

[SwitchA-Ethernet0/1]speed 100

(4)進入埠E0/2

[SwitchA]interface Ethernet 0/2

(5)匯聚埠必須工作在全雙工模式

[SwitchA-Ethernet0/2]plex full

(6)匯聚的埠速率要求相同,但不能是自適應

[SwitchA-Ethernet0/2]speed 100

(7)根據源和目的MAC進行埠選擇匯聚

[SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

【SwitchB交換機配置】

[SwitchB]interface Ethernet 0/1

[SwitchB-Ethernet0/1]plex full

[SwitchB-Ethernet0/1]speed 100

[SwitchB]interface Ethernet 0/2

[SwitchB-Ethernet0/2]plex full

[SwitchB-Ethernet0/2]speed 100

[SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both

【注意】

(1)同一個匯聚組中成員埠的鏈路類型與主埠的鏈路類型保持一致,即如果主埠為Trunk埠,

則成員埠也為Trunk埠;如主埠的鏈路類型改為Access埠,則成員埠的鏈路類型也變為Access

埠。

(2)不同的產品對埠匯聚時的起始埠號要求各有不同,請對照《操作手冊》進行配置。

13:埠鏡像配置實例

『環境配置參數』

(1)PC1接在交換機E0/1埠,IP地址1.1.1.1/24

(2)PC2接在交換機E0/2埠,IP地址2.2.2.2/24

(3)E0/24為交換機上行埠

(4)Server接在交換機E0/8埠,該埠作為鏡像埠

『組網需求』

(1)通過交換機埠鏡像的功能使用server對兩台pc的業務報文進行監控。根據Quidway交換機不同型號,

鏡像有不同方式進行配置:

基於埠的鏡像 ——基於埠的鏡像是把被鏡像埠的進出數據報文完全拷貝一份到鏡像埠,這樣來

進行流量觀測或者故障定位。

基於流的鏡像 ——基於流鏡像的交換機針對某些流進行鏡像,每個連接都有兩個方向的數據流,對於交

換機來說這兩個數據流是要分開鏡像的。

S2008/S2016/S2026/S2403H/S3026等交換機支持的都是基於埠的鏡像,8016交換機支持基於埠的鏡像

3500/3026E/3026F/3050支持基於流的鏡像,5516/6506/6503/6506R支持對入埠流量進行鏡像數據配置

步驟 以Quidway S3026C為例,通過基於二層流的鏡像進行配置:

(1)定義一個ACL

[SwitchA]acl num 200

(2)定義一個規則從E0/1發送至其它所有埠的數據包

[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress

interface Ethernet0/2

(3)定義一個規則從其它所有埠到E0/1埠的數據包

[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress

interface Ethernet0/1

(4)將符合上述ACL的數據包鏡像到E0/8

[SwitchA]mirrored-to link-group 200 interface e0/8

14:顯示配置命令

顯示系統版本信息:display version

顯示診斷信息:display diagnostic-information

顯示系統當前配置:display current-configuration

顯示系統保存配置: display saved-configuration

顯示介面信息:display interface

顯示路由信息:display ip routing-table

顯示VLAN信息:display vlan

顯示生成樹信息:display stp

顯示MAC地址表:display mac-address

顯示ARP表信息:display arp

顯示系統CPU使用率:display cpu

顯示系統內存使用率:display memory

顯示系統日誌:display log

顯示系統時鍾:display clock

驗證配置正確後,使用保存配置命令:save

刪除某條命令,一般使用命令: undo

15:trunk幹道配置

『配置環境參數』

(1)SwitchA 埠E0/1屬於vlan10,E0/2屬於vlan20,E0/3與SwitchB端

口E0/3互連

(2)SwitchB 埠E0/1屬於vlan10,E0/2屬於vlan20,E0/3與SwitchA端

口E0/3互連

『組網需求』

(1)要求SwitchA的vlan10的PC與SwitchB的vlan10的PC互通

(2)要求SwitchA的vlan20的PC與SwitchB的vlan20的PC互通

數據配置步驟

【SwitchA相關配置】

(1)創建(進入)vlan10

[SwitchA] vlan 10

(2)將E0/1加入到vlan10

[SwitchA-vlan10]port Ethernet 0/1

(3)創建(進入)vlan20

[SwitchA]vlan 20

(4)將E0/2加入到vlan20

[SwitchA-vlan20]port Ethernet 0/2

(5)實際當中一般將上行埠設置成trunk屬性,允許vlan透傳

[SwitchA-Ethernet0/3]port link-type trunk

(6)允許所有的vlan從E0/3埠透傳通過,也可以指定具體的vlan值

[SwitchA-Ethernet0/3]port trunk permit vlan all

【SwitchB相關配置】

(1)創建(進入)vlan10

[SwitchB] vlan 10

(2)將E0/1加入到vlan10

[SwitchB-vlan10]port Ethernet 0/1

(3)創建(進入)vlan20

[SwitchB]vlan 20

(4)將E0/2加入到vlan20

[SwitchB-vlan20]port Ethernet 0/2

(5)實際當中一般將上行埠設置成trunk屬性,允許vlan透傳

[SwitchB-Ethernet0/3]port link-type trunk

(7)允許所有的vlan從E0/3埠透傳通過,也可以指定具體的vlan值

[SwitchB-Ethernet0/3]port trunk permit vlan all

【補充說明】

(1)如果一個埠是trunk埠,則該埠可以屬於多個vlan;

(2)預設情況下trunk埠的PVID為1,可以在埠模式下通過命令port trunk pvid vlan vlanid 來修改

埠的PVID;

(3)如果從trunk轉發出去的數據報文的vlan id和埠的PVID一致,則該報文的VLAN信息會被剝去,這點

在配置trunk埠時需要注意。

(4)一台交換機上如果已經設置了某個埠為hybrid埠,則不可以再把另外的埠設置為trunk埠。

(5)一般情況下最好指定埠允許通過哪些具體的VLAN,不要設置允許所有的VLAN通過。

測試驗證

(1)SwitchA vlan10內的PC可以與SwitchB vlan10內的PC互通

(2)SwitchA vlan20內的PC可以與SwitchB vlan20內的PC互通

(3)SwitchA vlan10內的PC不能與SwitchB vlan20內的PC互通

(4)SwitchA vlan20內的PC不能與SwitchB vlan10內的PC互通

;

② 華為交換機查看配置的命令是什麼

華為交換機常用命令:

1、displaycurrent-configuration顯示當前配畝孫置

2、/1/4顯示介面信息

3、displaypacket-/1/4顯示介面acl應用信核神息

4、displayaclall顯示所有acl設置3900系列交換機

5、displayaclconfigall顯示所有acl設置6500系列交換機

6、displayarp10.78.4.1顯示該ip地址的mac地址,所接交換機的埠位置

7、displaycpu顯示cpu信息

8、system-view進入系統圖(配置交換機),等於configt命令

9、aclnumber5000在system-view命令後使用,進入acl配置狀態

10、rule0deny改耐虧0806ffff240a4e0401f40在上面的命令後使用,acl配置例子

11、//在上面的命令後使用,acl配置例子

12、interfaceGigabitEthernet1/0/9//在system-view命令後使用,進入介面配置狀態

13、[86ZX-S6503-GigabitEthernet1/0/9]qos//在上面的命令後使用,進入介面qos配置

14、[86ZX-S6503-qosb-GigabitEthernet1/0/9]packet-filterinbounser-group5000//在上面的命令後使用,在介面上應用進站的acl

15、[Build4-2_S3928TP-GigabitEthernet1/1/4]packet-filteroutbounser-group5001//在介面上應用出站的acl

16、undoaclnumber5000//取消aclnumber5000的設置

17、iproute-static0.0.0.00.0.0.010.78.1.1preference60//設置路由

18、/0/14//重置介面信息

19、save//保存設置

20、quit//退出

③ 交換機基本配置命令

一、單交換機VLAN劃分

命令 命令解釋

system 進入系統視圖

system-view 進入系統視圖

quit 退到系統視圖

undo vlan 20 刪除vlan 20

sysname 交換機命名

disp vlan 顯示vlan

vlan 20 創建vlan(也可進入vlan 20)

port e1/0/1 to e1/0/5 把埠1-5放入VLAN 20 中

disp vlan 20 顯示vlan里的埠20

int e1/0/24 進入埠24

port access vlan 20 把當前埠放入vlan 20

undo port e1/0/10 表示刪除當前VLAN埠10

disp curr 顯示當前配置

二、配置交換機支持TELNET

system 進入系統視圖

sysname 交換機命名

int vlan 1 進入VLAN 1

ip address 192.168.3.100 255.255.255.0 配置IP地址

user-int vty 0 4 進入虛擬終端

authentication-mode password (aut password) 設置口令模式

set authentication password simple 222 (set aut pass sim 222) 設置口令

user privilege level 3(use priv lev 3) 配置用戶級別

disp current-configuration (disp cur) 查看當前配置

disp ip int 查看交換機VLAN IP配置

刪除配置必須退到用戶模式

reset saved-configuration(reset saved) 刪除配置

reboot 重啟交換機

三、跨交換機VLAN的通訊

在sw1上:

vlan 10 建立VLAN 10

int e1/0/5 進入埠5

port access vlan 10 把埠5加入vlan 10

vlan 20 建立VLAN 20

int e1/0/15 進入埠15

port access vlan 20 把埠15加入VLAN 20

int e1/0/24 進入埠24

port link-type trunk 把24埠設為TRUNK埠

port trunk permit vlan all 同上

在SW2上:

vlan 10 建立VLAN 10

int e1/0/20 進入埠20

port access vlan 10 把埠20放入VLAN 10

int e1/0/24 進入埠24

port link-type trunk 把24埠設為TRUNK埠

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan

10使用)24埠為所有VLAN使用

disp int e1/0/24 查看埠24是否為TRUNK

undo port trunk permit vlan all 刪除該句

四、路由的配置命令

system 進入系統模式

sysname 命名

int e1/0 進入埠

ip address 192.168.3.100 255.255.255.0 設置IP

undo shutdown 打開埠

disp ip int e1/0 查看IP介面情況

disp ip int brief 查看IP介面情況

user-int vty 0 4 進入口令模式

authentication-mode password(auth pass) 進入口令模式

set authentication password simple 222 37 設置口令

user privilege level 3 進入3級特權

save 保存配置

reset saved-configuration 刪除配置(用戶模式下運行)

undo shutdown 配置遠程登陸密碼

int e1/4

ip route 192.168.3.0(目標網段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的介面) 靜態路由

ip route 0.0.0.0 0.0.0.0 192.168.12.1 默認路由

disp ip rout 顯示路由列表

華3C AR-18

E1/0(lan1-lan4)

E2/0(wan0)

E3/0(WAN1)

路由器連接使用直通線。wan0接wan0或wan1接wan1

計算機的網關應設為路由器的介面地址。

五、三層交換機配置VLAN-VLAN通訊

sw1(三層交換機):

system 進入視圖

sysname 命名

vlan 10 建立VLAN 10

vlan 20 建立VLAN 20

int e1/0/20 進入埠20

port access vlan 10 把埠20放入VLAN 10

int e1/0/24 進入24埠

port link-type trunk 把24埠設為TRUNK埠

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan

10使用)24埠為所有VLAN使用

sw2:

vlan 10

int e1/0/5

port access vlan 10

int e1/0/24

port link-type trunk 把24埠設為TRUNK埠

port trunk permit vlan all (port trunk permit vlan 10 只能為vlan

10使用)24埠為所有VLAN使用

sw1(三層交換機):

int vlan 10 創建虛擬介面VLAN 10

ip address 192.168.10.254 255.255.255.0 設置虛擬介面VLAN 10的地址

int vlan 20 創建虛擬介面VLAN 20

ip address 192.168.20.254 255.255.255.0 設置虛擬介面IP VLAN 20的地址

注意:vlan 10里的計算機的網關設為 192.168.10.254

vlan 20里的計算機的網關設為 192.168.20.254

六、動態路由RIP

R1:

int e1/0 進入e1/0埠

ip address 192.168.3.1 255.255.255.0 設置IP

int e2/0 進入e2/0埠

ip adress 192.168.5.1 255.255.255.0 設置IP

rip 設置動態路由

network 192.168.5.0 定義IP

network 192.168.3.0 定義IP

disp ip rout 查看路由介面

R2:

int e1/0 進入e1/0埠

ip address 192.168.4.1 255.255.255.0 設置IP

int e2/0 進入e2/0埠

ip adress 192.168.5.2 255.255.255.0 設置IP

rip 設置動態路由

network 192.168.5.0 定義IP

network 192.168.4.0 定義IP

disp ip rout 查看路由介面

(注意:兩台PC機的網關設置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)

七、IP訪問列表

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.168.1.1 255.255.255.0

int e3/0

ip address 192.168.2.1 255.255.255.0

acl number 2001 (2001-2999屬於基本的訪問列表)

rule 1 deny source 192.168.1.0 0.0.0.255 (拒絕地址192.168.1.0網段的數據通過)

rule 2 permit source 192.168.3.0 0.0.0.255(允許地址192.168.3.0網段的數據通過)

以下是把訪問控制列表在介面下應用:

firewall enable

firewall default permit

int e3/0

firewall packet-filter 2001 outbound

disp acl 2001 顯示信息

undo acl number 2001 刪除2001控制列表

擴展訪問控制列表

acl number 3001

rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

destination-port eq ftp

必須在r-acl-adv-3001下才能執行

rule permit ip source an destination any (rule permit ip)

int e3/0

firewall enable 開啟防火牆

firewall packet-filter 3001 inbound

必須在埠E3/0下才能執行

八、命令的標准訪問IP列表(三層交換機):

允許A組機器訪問伺服器內資料,不允許訪問B組機器(伺服器沒有限制)

sys

vlan 10

name server

vlan 20

name teacher

vlan 30

name student

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 2001

rule 1 deny source 192.168.30.0 0.0.0.255

rule 2 permit source any

disp acl 2001 查看2001列表

int e1/0/10

port access vlan 20

packet-filter outbound ip-group 2001 rule 1

出口

九、允許A機器訪問B機器的FTP但不允許訪問WWW,C機器沒有任何限制。

vlan 10

vlan 20

vlan 30

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 3001

rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0

0.0.0.255 destination-port eq www

int e1/0/15

packet-filter inbound ip-group 3001 rule 1

進口

十、NAT地址轉換(單一靜態一對一地址轉換)

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

R2:

sys

sysname R2

int e2/0

ip address 192.1.1.2 255.255.255.0

int e1/0

ip address 10.80.1.1 255.255.255.0

回到R1:

nat static 192.168.3.1 192.1.1.1

int e2/0

nat outbound static

ip route 0.0.0.0 0.0.0.0 192.1.1.2

十一、NAT內部整網段地址轉換

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

acl number 2008

rule 0 permit source 192.168.3.0 0.0.0.255

rule 1 deny

quit

int e2/0

nat outbound 2008

quit

ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60

④ 華為H3C交換機配置命令

華為H3C交換機配置命令

華為交換機之間只能有一條通路,使得信息集中在一條通信鏈路上,不能進行動態分配,以平衡負載。下面是我整理的關於華為H3C交換機配置命令,希望大家認真閱讀!

一、配置軟體和硬體

1、配置(Console)電纜連接

配置電纜是一根8芯屏蔽電纜,一端是壓接的`RJ-45連接器,插入交換機的Console口裡;另一端則同時帶有一個DB-9(孔)和DB-25(孔)連接器

2、配置軟體及設置

使用系統自帶的“超級終端”,運行“hypertrm”程序,設置終端參數參數要求:波特率為9600,數據位為8,奇偶校驗為無,停止位為1,流量控制為無,選擇終端模擬為VT100。

二、常用命令

1、用戶模式:交換機啟動後在控制台直接按回車就進入用戶模式(遠程管理telnet 交換機ip時需要口令)。

? --幫助

quit ――退出當前模式返回上一級

ping ip-address --測試網路連通性

telnet ip-address --從交換機登陸其它設備 super --從用戶模式進入特權模式

2、特權模式:進入特權模式一般需要口令,可以防止非法登陸交換機

display current --顯示當前運行的配置

save --保存當前運行的配置

reboot --重啟交換機

display mac ――顯示mac地址表

display inteface ethernet 0/1 ――查看乙太網口狀態

system-view --從特權模式進入全局模式

3、全局模式:更改配置

a.進入乙太網口配置模式及相關配置

[switchone]interface ethernet 0/1

[switchone-Ethernet0/1]shutdown/undo shutdown 關閉/打開介面

[switchone-Ethernet0/1]port link-type access/trunk 介面類型設為untagged埠(默認)/tagged埠(用於上行口和級聯口)

access埠發出和接收的幀不帶vlan標記,即untagged埠

trunk埠發出和接收的幀一般要帶vlan標記,即tagged埠

設為tagged口後,還要做以下操作:

[switchone-Ethernet0/1]port trunk permit vlan 225 to 250

這條命令是允許有vlan標記225到250的幀上傳

b.進入vlan配置模式(為了便於操作,不用在介面模式下配置access,而在vlan模式下進行相關操作)

[switchone]vlan 225

[switchone-vlan225] port Ethernet 1/1 將ethernet 1/1加入vlan225

c.設置super口令

[switchone]super password simple 2403h 特權口令為2403h

;

⑤ 華為交換機的配置命令,很簡單,一學就會

登陸設備後,直接進入用戶模式,只能執行少量查看配置的命令

用戶模式下,輸入system-view命令進入視圖模式,可執行設備全局配置的命令

系統視圖模式下,輸入局部配置命令,進入局部對像的配置視圖。如interface GE 1/0/0,進入GE1/0/0埠配置模式

LEVEL 0(訪問級):可以執行用於網路診斷等功能的命令。包括ping、tracert、telnet等命令,執行該級別命令的結果不能被保存到配置文件中。
LEVEL 1(監控級):可以執行用於系統維護、業務故障診斷等功能的命令。包括debugging、terminal等命令,執行該級別命令的結果不能被保存到配置文件中。
LEVEL 2(系統級):可以執行用於業務配置的命令,主要包括路由等網路層次的命令,用於向用戶提供網路服務。
LEVEL 3(管理級):最高級,可以運行所有命令:關繫到系統的基本運行、系統支撐模塊功能的命令,這些命令對業務提供支撐作用。包括文件系統、FTP、TFTP、XModem下載、用戶管理命令、級別設置命令等。

創建vlan,設置vlan的ip,並將埠加入vlan中。

需要對多個埠進行相同操作時,可以創建埠組進行批量操作。

⑥ 三家交換機配置命令詳解(華為、H3C、銳捷)

一、華為交換機基礎配置命令

1、創建vlan:

//用戶視圖,也就是在Quidway模式下運行命令。

system-view //進入配置視圖

[Quidway] vlan 10 //創建vlan 10,並進入vlan10配置視圖,如果vlan10存在就直接進入vlan10配置視圖

[Quidway-vlan10] quit //回到配置視圖

[Quidway] vlan 100 //創建vlan 100,並進入vlan100配置視圖,如果vlan10存在就直接進入vlan100配置視圖

[Quidway-vlan100] quit //回到配置視圖

2、將埠加入到vlan中:

[Quidway] interface GigabitEthernet2/0/1 (10G光口)

[Quidway- GigabitEthernet2/0/1] port link-type access //定義埠傳輸模式

[Quidway- GigabitEthernet2/0/1] port default vlan 100 //將埠加入vlan100

[Quidway- GigabitEthernet2/0/1] quit //回到配置視圖

[Quidway] interface GigabitEthernet1/0/0 //進入1號插槽上的第一個千兆網口配置視圖中。0代表1號口

[Quidway- GigabitEthernet1/0/0] port link-type access //定義埠傳輸模式

[Quidway- GigabitEthernet2/0/1] port default vlan 10 //將這個埠加入到vlan10中

[Quidway- GigabitEthernet2/0/1] quit

3、將多個埠加入到VLAN中

system-view

[Quidway]vlan 10

[Quidway-vlan10]port GigabitEthernet 1/0/0 to 1/0/29 //將0到29號口加入到vlan10中

[Quidway-vlan10]quit

4、交換機配置IP地址

[Quidway] interface Vlanif100 // 進入vlan100介面視圖與vlan 100命令進入的地方不同

[Quidway-Vlanif100] ip address 119.167.200.90 255.255.255.252 // 定義vlan100管理IP三層 交換網關路由

[Quidway-Vlanif100] quit //返回視圖

[Quidway] interface Vlanif10 // 進入vlan10介面視圖與vlan 10命令進入的地方不同

[Quidway-Vlanif10] ip address 119.167.206.129 255.255.255.128 // 定義vlan10管理IP三層交換網關路由

[Quidway-Vlanif10] quit

5、配置默認網關:

[Quidway]ip route-static 0.0.0.0 0.0.0.0 119.167.200.89 //配置默認網關。

6、 交換機保存設置和重置命令

save //保存配置信息

reset saved-configuration //重置交換機的配置

reboot //重新啟動交換機

7、交換機常用的顯示命令

用戶視圖模式下:

display current-configuration //顯示現在交換機正在運行的配置明細

display device //顯示各設備狀態

display interface ? //顯示個埠狀態,用?可以查看後邊跟的選項

display version //查看交換機固件版本信息

display vlan ? // 查看vlan的配置信息

8、恢復交換機出廠設置

reset saved-configuration //重置交換機的配置

二、H3C交換機的基本配置

我們先來了解下h3c的配置命令與功能,都是常用的,基本上大部分網路配置都少不了這些命令。

1、基本配置

//用戶直行模式提示符,用戶視圖

system-view //進入配置視圖

[H3C] sysname xxx //設置主機名成為xxx這里使用修改特權用戶密碼

2、用戶配置

system-view

[H3C]super password H3C //設置用戶分級密碼

[H3C]undo superpassword //刪除用戶分級密碼

[H3C]localuser bigheap 1234561 //Web網管用戶設置,1為管理級用戶

[H3C]undo localuser bigheap //刪除Web網管用戶

[H3C]user-interface aux 0 //只支持0

[H3C-Aux]idle-timeout 250 //設置超時為2分50秒,若為0則表示不超時,默認為5分鍾

[H3C-Aux]undoidle-timeout //恢復默認值

[H3C]user-interface vty 0 //只支持0和1

[H3C-vty]idle-timeout 250 //設置超時為2分50秒,若為0則表示不超時,默認為5分鍾

[H3C-vty]undoidle-timeout //恢復默認值

[H3C-vty]set authentication password123456 //設置telnet密碼,必須設置

[H3C-vty]undo set authenticationpassword //取消密碼

[H3C]displayusers //顯示用戶

[H3C]displayuser-interface //用戶界面狀態

3、vlan配置

[H3C]vlan 2 //創建VLAN2

[H3C]undo vlanall //刪除除預設VLAN外的所有VLAN,預設VLAN不能被刪除

[H3C-vlan2]port Ethernet 0/4 to Ethernet0/7 //將4到7號埠加入到VLAN2中,此命令只能用來加access埠,不能用來增加trunk或者hybrid埠

[H3C-vlan2]port-isolate enable //打開VLAN內埠隔離特性,不能二層轉發,默認不啟用該功能

[H3C-Ethernet0/4]port-isolate uplink-portvlan 2 //設置4為VLAN2的隔離上行埠,用於轉發二層數據,只能配置一個上行埠,若為trunk,則建議允許所有VLAN通過,隔離不能與匯聚同時配置

[H3C]display vlan all //顯示所有VLAN的詳細信息

[H3C]user-group 20 //創建user-group 20,默認只存在user-group 1

[H3C-UserGroup20]port Ethernet 0/4 toEthernet 0/7 //將4到7號埠加入到VLAN20中,初始時都屬於user-group 1中

[H3C]display user-group 20 //顯示user-group 20的相關信息

四、交換機ip配置

[H3C]vlan 20 //創建vlan

[H3C]management-vlan 20 //管理vlan

[H3C]interface vlan-interface 20 //進入並管理vlan20

[H3C]undo interface vlan-interface 20 //刪除管理VLAN埠

[H3C-Vlan-interface20]ip address192.168.1.2 255.255.255.0 //配置管理VLAN介面靜態IP地址

[H3C-Vlan-interface20]undo ipaddress //刪除IP地址

[H3C-Vlan-interface20]ip gateway 192.168.1.1 //指定預設網關(默認無網關地址)

[H3C-Vlan-interface20]undo ip gateway

[H3C-Vlan-interface20]shutdown //關閉介面

[H3C-Vlan-interface20]undo shutdown //開啟

[H3C]display ip //顯示管理VLAN介面IP的相關信息

[H3C]display interface vlan-interface20 //查看管理VLAN的介面信息

debugging ip //開啟IP調試功能

undo debugging ip

5、DHCP客戶端配置

[H3C-Vlan-interface20]ip address dhcp-alloc // 管理VLAN介面通過DHCP方式獲取IP地址

[H3C-Vlan-interface20]undo ip address dhcp-alloc // 取消

[H3C]display dhcp //顯示DHCP客戶信息

debugging dhcp-alloc //開啟DHCP調試功能

undo debugging dhcp-alloc

6、埠配置

[H3C]interface Ethernet0/3 //進入埠

[H3C-Ethernet0/3]shutdown //關閉埠

[H3C-Ethernet0/3]speed 100 //速率可為10,100,1000和auto(預設)

[H3C-Ethernet0/3]plexfull //雙工,可為half,full和auto,光口和匯聚後不能配置

[H3C-Ethernet0/3]flow-control //開啟流控,默認為關閉

[H3C-Ethernet0/3]broadcast-suppression 20 //設置抑制廣播百分比為20%,可取5,10,20,100,預設為100,同時組播和未知單播也受此影響

[H3C-Ethernet0/3]loopback internal //內環測試

[H3C-Ethernet0/3]port link-type trunk //設置鏈路的類型為trunk

[H3C-Ethernet0/3]port trunk pvid vlan 20 //設置20為該trunk的預設VLAN,默認為1(trunk線路兩端的PVID必須一致)

[H3C-Ethernet0/3]port access vlan 20 //將當前access埠加入指定的VLAN

[H3C-Ethernet0/3]port trunk permit vlanall //允許所有的VLAN通過當前的trunk埠,可多次使用該命令

[H3C-Ethernet0/3]mdiauto //設置以太埠為自動監測,normal為直通線,across為交叉線

[H3C]link-aggregation Ethernet 0/1 toEthernet 0/4 //將1-4口加入匯聚組,1為主埠,兩端需要同時配置,設置了埠鏡像以及埠隔離的埠無法匯聚

[H3C]undo link-aggregation Ethernet 0/1 //刪除該匯聚組

[H3C]link-aggregation mode egress

⑦ 戴爾交換機配置命令大全

交換機除了能夠連接同種類型的網路之外,還可以在不同類型的網路(如乙太網和快速乙太網)之間起到互連作用。這篇文章主要介紹了DELL6224交換機基本配置命令一覽,需要的朋友可以參考下

具體介紹

1:配置登錄用戶,口令等

console> //用戶直行模式提示符

console>enable //進入特權模式

console# //特權模式(配置密碼後必須輸入密碼才可進入特 權模式)

console#config //進入全局配置模式 configure

console(config)# //配置模式提示符

console(config)#exit //還有一個命令是end也和exit差不多

console#quit

console>

console(config)#hostname xxx //設置主機名成為xxx這里使用console

console(config)#enable password xxx //設置使能口令為明文顯示為xxx,必須不少於8字元遠程telnet的時候起作用本地通過console口不需要密碼的

console(config)#username zy password 12345678 level 15 //定義交換機的用戶名以及對應的許可權。

console(config)#line console //進入console口配置視圖,這里可以設置通過超級終端訪問交換機的一些參數

console(config-line)#enable authentication default //配置訪問角色為默認

console(config-line)#exec-timeout <0-65535> minutes // 設置console口自動關閉時間,以分鍾為單位

console(config-line)#speed 9660 //設置訪問速率,一般9660為默認設置。

console(config-line)#password xxxx //不少於八位的密碼用來訪問console,與enable password xxx,差不多

console(config-line)#no password //刪除password密碼

console(config-line)#exit //退出console口配置視圖

console(config)#line telnet //進入telnet配置視圖

console(config-telnet)#enable authentication default //配置訪問角色為默認

console(config-telnet)#exec-timeout <0-65535> minutes // 設置telnet訪問閑置自動關閉時間,以分鍾為單位

console(config-telnet)#password xxxx //不少於八位的密碼用來訪問telnet

console(config-telnet)#no password //刪除password密碼

console(config-telnet)#exit //退出telnet口配置視圖

console(config)#line ssh //進入ssh配置視圖

console(config-ssh)#enable authentication default //配置訪問角色為默認

console(config-ssh)#exec-timeout <0-65535> minutes // 設置ssh訪問閑置自動關閉時間,以分鍾為單位

console(config-ssh)#password xxxx //不少於八位的密碼用來訪問ssh

console(config-ssh)#no password //刪除password密碼

console(config-ssh)#exit //退出ssh口配置視圖

2:cisco2960 VLan設置

console> enable //進入特權模式

console#configure //進入配置視圖

console(config)#vlan database //進入vlan設置

console(config-vlan)#vlan 2 //創建vlan 2

console(config-vlan)#no vlan 2 v //刪除vlan 2

console(config-vlan)#exit //回到特權模式下

console(config)#interface vlan 2 //進入vlan2配置視圖

console(config-if-vlan2)#name xxx //為vlan取名字

埠設置命令:

console(config)#interface ethernet 1/g1 //進入網口1, / 1/g1指的是第一個插槽上的第一個千兆網口

console(config-if-1/g1)# //介面視圖模式

console(config-if-1/g1)#speed 10/100/1000 //定義埠的帶寬,只能從這三種模式中做選擇。

console(config-if-1/g1)#plex full/half //定義雙工模式

console(config-if-1/g1)#negotiation //啟用自動協商速度和雙工參數

console(config-if-1/g1)#no negotiation //禁用自動協商速度和雙工參數

console(config-if-1/g1)#switchport mode access/trunk/general //定義埠類型,總共有三種類型

console(config-if-1/g1)#switchport access vlan 2 //將埠以access模式加入到vlan 2中

console(config-if-1/g1)#shutdown //關閉當前埠

console(config-if-1/g1)#no shutdown //打開當前埠

console(config)#interface ethernet 1/g24 //進入匯聚千兆口24,共有4個千兆combo口21-24

console(config-if-1/g24)#

console(config-if-1/g24)#plex auto/full/half //設置埠工作模式為 自適應/全雙通/半雙通

console(config-if-1/g24)#switchport mode trunk //設置當前埠模式為匯聚口

console(config-if-1/g24)#switchport mode access //設置當前埠模式為接入模式

console(config-if-1/g24)#switchport trunk allowed vlan add/remove 1,2 //將當前匯聚埠加入或移除從vlan1,2通過,vlan修剪,默認為all,全部允許

console(config-if-1/g24)#switchport access vlan 2 //將當前埠以access模式加入到vlan 2中

若21-24號口用作光口的話配置介面就對應1/xg1-1/xg4代表使用光線做10G上聯口用:

console(config)#interface ethernet 1/xg1 //進入匯聚萬兆口1,共有4個千兆combo口21-24對應四個1/xg1-1/xg4萬兆光口

console(config-if-1/xg1)#

console(config-if-1/xg1)#plex auto/full/half //設置埠工作模式為 自適應/全雙通/半雙通

console(config-if-1/xg1)#switchport mode trunk //設置當前埠模式為匯聚口

console(config-if-1/xg1)#switchport mode access //設置當前埠模式為接入模式

console(config-if-1/xg1)#switchport trunk allowed vlan add/remove 1,2 //將當前匯聚埠加入或移除從vlan1,2通過,vlan修剪,默認為all,全部允許

console(config-if-1/xg1)#switchport access vlan 2 //將當前埠以access模式加入到vlan 2中

將埠加入vlan

console(config)#interface ethernet 1/g1

console(config-if-1/g1)#switchport mode access

console(config-if-1/g1)#switchport access vlan 2

將多個埠加入到VLAN中

console(config)#interface range ethernet 1/g1-1/g12 //進入1-12這個介面組里配置

console(config-if)#switchport mode access

console(config-if)#switchport access vlan 2

console#show vlan //用於查看配置後結果

3:設置VTP cisco專有的vlan終極協議也成為區域網幹道協議,作用是十幾台交換機在企業網中,配置VLAN工作量大,可以使用VTP協議,把一台交換機配置成VTP Server, 其餘交換機配置成VTP Client,這樣他們可以自動學習到server 上的VLAN 信息

4:交換機配置IP地址

console(config)#interface vlan 1 //進入vlan 1

console(config-if-vlan1)#ip address 119.167.223.221 255.255.255.128 //設置交換機的管理ip地址

console(config)#ip default-gateway 119.167.223.254 //設置交換機的默認網關

console(config)#end //退出當前模式

5: 交換機保存設置命令

console# running-config startup-config //將當前正在使用中的配置保存到交換機開機需要載入的配置文件里去。

console# running-config backup-config //將當前的配置保存在備份配置文件里

6:交換機顯示命令

特權模式下:

console#show running-config //顯示當前正在使用的配置信息

console#show startup-config //交換機開機是自動載入的 配置文件

console#show vlan //顯示vlaner配置信息

console#show interfaces configuration ethernet 1/g1 //顯示二層埠狀態,可以用來決定此口是否為二層或三層口

console#show ip interface vlan100 //查看交換機vlan100的ip配置信息

console#show version //查看交換機固件版本信息

7:基於埠的mac地址綁定

console#config //進入配置視圖模式

console(config)#interface ethernet 1/g1 //進入具體埠視圖模式下

console(config-if-1/g1)#switchport port-secruity //配置埠安全模式

console(config-if-1/g1)#switchport port-secruity mac-address MAC(主機的mac地址) //配置該埠要綁定的主機的MAC地址

console(config-if)#no switchport port-secruity mac-address MAC(主機的mac地址) //刪除綁定主機的mac地址

8:配置交換機的snmp功能

console(config)#snmp-server community xxx ro //xxx為自定義的共同體名稱,並且團體的許可權為只讀。

console(config)#snmp-server host x.x.x.x(ip地址) xxx(團體名) //設置管理機x.x.x.x,同時允許該管理機以團體明xxx訪問。

console(config)#snmp-server host 119.167.223.221 zy //例子

console(config)#snmp-server enable traps //啟用snmp服務

9:交換機禁ping配置

console(config)#access-list 110 deny icmp any any //配置訪問控制列表(Access Control List,ACL)110指的ICMP對應ping。

console(config)#access-list 110 permit ip any any //運行所有的IP協議的應用

console(config)#int vlan 1

console(config-if-vlan1)#ip access-group 110 in

console(config)#int vlan 2

console(config-if-vlan2)#ip access-group 110 in

console(config)#int vlan 3

console(config-if-vlan3)#ip access-group 110 in

console(config)#interface ethernet 1/g1 //埠禁ping

console(config-if-1/g1)#ip access-group 110 in

10:恢復交換機出廠設置

console#clear config //恢復交換機出廠設置

console#reload //重新啟動交換機

相關閱讀:交換機工作原理過程

交換機工作於OSI參考模型的第二層,即數據鏈路層。交換機內部的CPU會在每個埠成功連接時,通過將MAC地址和埠對應,形成一張MAC表。在今後的通訊中,發往該MAC地址的數據包將僅送往其對應的埠,而不是所有的埠。因此,交換機可用於劃分數據鏈路層廣播,即沖突域;但它不能劃分網路層廣播,即廣播域。

閱讀全文

與常用交換機配置命令及作用相關的資料

熱點內容
android自身卸載監聽 瀏覽:76
日本經典風月片 瀏覽:56
韓國把黃瓜套上避孕套的電影 瀏覽:643
jpeg如何轉換成pdf 瀏覽:61
英譯pdf 瀏覽:222
解壓的聲控圖片 瀏覽:208
迪士尼大電影 百度網盤 瀏覽:88
數組setjava 瀏覽:275
中國禁止觀看的十部鬼片 瀏覽:745
桌面小組件app怎麼添加到桌面 瀏覽:420
看片資源不用下載 瀏覽:846
魔獸世界怎麼改加密地形 瀏覽:611
revit快捷命令 瀏覽:827
lzw演算法流程圖 瀏覽:174
燈塔在線手機app怎麼退出 瀏覽:181
兒子的妻子電影李采潭 瀏覽:148
都市重生收母收姐 瀏覽:66
重生民國建黨 瀏覽:769
侍神令2免費完整版 瀏覽:92
解壓骰子拆解視頻 瀏覽:93