導航:首頁 > 源碼編譯 > 易語言雙音軌源碼

易語言雙音軌源碼

發布時間:2023-02-01 01:30:01

❶ 易語言怎麼播放MID音樂,源碼怎麼寫

.版本 2

播放MP3 (-1, 取運行目錄 () + 「\1.MP3 」)

===============華麗的分割線====================
建議用播放MP3,以為現在很多音頻文件都是mp3格式的。如果你需要用MID也是一樣的。
你那個錯在,沒指定音頻文件的路徑。
我這個源碼第一個參數「-1」表示循環播放。你也可以用數字1.2.3......來表示具體的播放次數
第二個參數,這個就是關鍵了,指定 音頻文件的位置,
」取運行目錄 () + 「\1.MP3 」「
前面這個取運行目錄,就是表示你軟體的位置,在易語言的調試中就表示你易語言源碼的位置。
「+\1.MP3」就是說是那個音頻文件文件名。
合在一起是,循環播放,和易語言程序文件夾相同文件夾裡面的一個叫做「1.mp3」的文件。
=================再次分割=============
如果你需要用到MID也可以,原理是一樣的,
「播放MID」的參數
第一個參數,也是表示播放的次數,同播放MP3
第二個參數,表示兩次播放的間隔時間
第三個參數,也是文件路徑,道理和播放MP3是一樣的

❷ 易語言運用BASS播放非內存音樂取文件目錄的源碼怎麼寫...

BASS_Init
(-1,
44100,
0,
取窗口句柄
(),
0)
BASS_StreamFree
(Handle)
Handle

BASS_StreamCreateFile
(假,"xxxx.mp3",
0,
0,
0)
.如果真
(Handle

0)
調試輸出
(「出錯」)
調試輸出
(BASS_ErrorGetCode
())
.如果真結束
BASS_ChannelPlay
(Handle,
真)
-------------------------------------------上面是初始化+播放。
BASS_ChannelStop
(Handle)
BASS_Free
()
--------------------------------------------窗口關閉時必須釋放BASS,否則會卡音。
另外說一下,GetPosition不是這樣用的[我想笑!快笑死了哈哈哈哈果然是沒用過BASS的~]
BASS_ChannelGetPosition
(Handle,
0)
÷
BASS_ChannelGetLength
(Handle,
0)
×
1000)
----應該這樣用。取音樂播放的進度的。
太晚了早點休息

❸ 易語言源碼

哦 哦 ,那我給你個記事本的源碼吧 如下
.版本 2
.支持庫 iext2
.支持庫 iext
.支持庫 eAPI

.程序集 窗口程序集1
.程序集變數 文件路徑, 文本型
.程序集變數 當前是否正在打字, 邏輯型

.子程序 _超級編輯框1_內容被改變, , , 更改超級編輯框的顏色
.局部變數 顏色, 字元格式

顏色.文本顏色 = 取顏色值 (取隨機數 (0, 255), 取隨機數 (0, 255), 取隨機數 (0, 255))
超級編輯框1.置選擇區字元格式 (顏色)
狀態條1.置文本 (0, 「行 」 + 到文本 (超級編輯框1.取行數 ()) + 「 文本長度 」 + 到文本 (超級編輯框1.取文本長度 ()))

.子程序 __啟動窗口_創建完畢, , , 設置通用對話框

通用對話框1.過濾器 = 「txt|*.txt」
通用對話框1.默認文件後綴 = 「txt」
通用對話框1.標題 = 「傳說記事本保存對話框...」
_時間日期_被選擇 ()
_炫銀皮膚_被選擇 ()
備忘錄提醒 ()

.子程序 __啟動窗口_位置被改變, , , 位置被改變後超級編輯框也跟著改變(按鈕1也跟著改變)

.如果真 (_啟動窗口.位置 = 3)
超級編輯框1.寬度 = 取屏幕寬度 () - 3
超級編輯框1.高度 = 取屏幕高度 () - 80 - 按鈕1.高度 - 10
按鈕1.頂邊 = 取屏幕高度 () - 狀態條1.高度 - 100
按鈕1.寬度 = 取屏幕寬度 () - 5
按鈕1.高度 = 狀態條1.高度 + 10
.如果真結束
.如果真 (_啟動窗口.位置 = 0)
超級編輯框1.寬度 = _啟動窗口.寬度 - 10
超級編輯框1.高度 = _啟動窗口.高度 - 55 - 按鈕1.高度 - 10
按鈕1.頂邊 = 200
按鈕1.寬度 = 560

.如果真結束

.子程序 _新建_被選擇, , , New文件

.如果真 (超級編輯框1.內容 ≠ 「」)
.如果真 (信息框 (「您還沒保存!請問您要進行保存嗎?」, 4, ) = #是鈕)
通用對話框1.類型 = 1
通用對話框1.打開 ()
寫到文件 (通用對話框1.文件名, 到位元組集 (超級編輯框1.內容))
.如果真結束

.如果真結束

.子程序 _打開_被選擇, , , Open文件

通用對話框1.類型 = 0
通用對話框1.打開 ()
.如果真 (通用對話框1.文件名 ≠ 「」)
超級編輯框1.內容 = 到文本 (讀入文件 (通用對話框1.文件名))
文件路徑 = 通用對話框1.文件名

.如果真結束

.子程序 _保存_被選擇, , , Save文件

.如果真 (文件路徑 = 「」)
通用對話框1.類型 = 1
通用對話框1.打開 ()
寫到文件 (通用對話框1.文件名, 到位元組集 (超級編輯框1.內容))
.如果真結束
.如果真 (文件路徑 ≠ 「」)
寫到文件 (文件路徑, 到位元組集 (超級編輯框1.內容))
.如果真結束

.子程序 _保存到_被選擇, , , Save As文件

通用對話框1.類型 = 1
通用對話框1.打開 ()
.如果真 (通用對話框1.文件名 ≠ 「」)
寫到文件 (通用對話框1.文件名, 到位元組集 (超級編輯框1.內容))
.如果真結束

.子程序 _撤銷_被選擇, , , Undo 文本

超級編輯框1.撤消 ()

.子程序 _剪切_被選擇, , , Cut 文本

超級編輯框1.剪切 ()

.子程序 _復制_被選擇, , , Copy 文本

超級編輯框1.復制 ()

.子程序 _粘連_被選擇, , , Paste文本

超級編輯框1.粘貼 ()

.子程序 _刪除_被選擇, , , Delete文本

超級編輯框1.刪除 ()
超級編輯框1.內容 = 取文本左邊 (超級編輯框1.內容, 取文本長度 (超級編輯框1.內容) - 1)

.子程序 _尋找_被選擇, , , Find文本

載入 (Find窗口, , 真)

.子程序 _尋找下一個_被選擇, , , 還沒解決好

.子程序 _文本替換_被選擇, , , 文本替換

載入 (文本替換窗口, , 真)

.子程序 _跳到_被選擇, , , 還沒解決好

載入 (跳到窗口, , 真)

.子程序 _全選_被選擇, , , Select All文本

超級編輯框1.被選擇字元數 = 取文本長度 (超級編輯框1.內容)

.子程序 _時間日期_被選擇, , , Time-Date
.局部變數 小時, 文本型
.局部變數 分鍾, 文本型
.局部變數 日期, 文本型
.局部變數 年份, 文本型
.局部變數 月份, 文本型
.局部變數 日份, 文本型

小時 = 到文本 (取小時 (取現行時間 ()))
分鍾 = 到文本 (取分鍾 (取現行時間 ()))
年份 = 到文本 (取年份 (取現行時間 ()))
月份 = 到文本 (取月份 (取現行時間 ()))
日份 = 到文本 (取日 (取現行時間 ()))
狀態條1.置文本 (1, 小時 + 「:」 + 分鍾 + 「 」 + 年份 + 「-」 + 月份 + 「-」 + 日份)

.子程序 _傳說記事本v13_被選擇, , , About Notepad

信息框 (「軟體作者:古老的傳說」 + #換行符 + 「QQ:1041750677」 + #換行符 + 「MSN:[email protected]」 + #換行符 + 「編寫工具:易語言」 + #換行符 + 「軟體版本:1.3」 + #換行符, 0, )

.子程序 _密碼保管_被選擇, , , Password Protect

載入 (密碼窗口, , 真)

.子程序 _備忘錄_被選擇, , , 載入備忘錄窗口

載入 (備忘錄窗口, , 真)

.子程序 備忘錄提醒, , , 備忘錄提醒
.局部變數 分割文本, 文本型, , "0"
.局部變數 今天日期, 文本型
.局部變數 分割今天日期, 文本型, , "0"

分割文本 = 分割文本 (讀配置項 (取運行目錄 () + 「\備忘錄.ini」, 「備忘錄」, 「提示日期」, ), 「日」, )
今天日期 = 到文本 (取日期 (取現行時間 ()))
分割今天日期 = 分割文本 (今天日期, 「日」, )
.如果真 (取數組成員數 (分割文本) = 1 或 取數組成員數 (分割文本) > 1)
.如果真 (分割文本 [1] = 分割今天日期 [1])
狀態條1.置文本 (2, 「您今天有一份備忘錄噢^_^」)
.如果真結束

.如果真結束

.子程序 _銀白皮膚_被選擇, , , 銀白皮膚

更換新皮膚 (1)

.子程序 _淺白皮膚_被選擇, , , 淺白皮膚

更換新皮膚 (10)

.子程序 _淺灰皮膚_被選擇, , , 淺灰皮膚

更換新皮膚 (13)

.子程序 _淺藍皮膚_被選擇, , , 淺藍皮膚

更換新皮膚 (19)

.子程序 _淺黑皮膚_被選擇, , , 淺黑皮膚

更換新皮膚 (5)

.子程序 _炫銀皮膚_被選擇, , , 炫銀皮膚

更換新皮膚 (2)

.子程序 _炫白皮膚_被選擇, , , 炫白皮膚

更換新皮膚 (15)

.子程序 _炫藍皮膚_被選擇, , , 炫藍皮膚

更換新皮膚 (18)

.子程序 _深黑皮膚_被選擇, , , 深黑皮膚

更換新皮膚 (14)

.子程序 __啟動窗口_可否被關閉, 邏輯型, , 透明顯示最小化運行
.局部變數 變數1, 整數型

變數1 = 255
.計次循環首 (255, )
設置窗口透明度 (_啟動窗口.取窗口句柄 (), 變數1)
變數1 = 變數1 - 1
.如果真 (變數1 = 1)
置托盤圖標 (#程序圖標, 「古老的傳說記事本v1.2」)
_啟動窗口.可視 = 假
.如果真結束

.計次循環尾 ()

返回 (假)

.子程序 __啟動窗口_托盤事件, , , 透明顯示_啟動窗口
.參數 操作類型, 整數型
.局部變數 變數1, 整數型

.如果真 (操作類型 = 1)
_啟動窗口.可視 = 真
.計次循環首 (255, 變數1)
設置窗口透明度 (_啟動窗口.取窗口句柄 (), 變數1)
.計次循環尾 ()
.如果真結束
.如果真 (操作類型 = 3)
彈出菜單 (圖標菜單, 取滑鼠水平位置 (), 取滑鼠垂直位置 ())

.如果真結束

.子程序 __啟動窗口_將被銷毀, , , 銷毀任務欄圖標

置托盤圖標 ({ }, )

.子程序 _打開傳說記事本_被選擇, , , _啟動窗口.可視=真

__啟動窗口_托盤事件 (1)

.子程序 _銷毀_被選擇, , , 銷毀軟體

銷毀 ()

.子程序 _超級編輯框1_按下某鍵, 邏輯型, , 正在打字中...
.參數 鍵代碼, 整數型
.參數 功能鍵狀態, 整數型

當前是否正在打字 = 真
按鈕1.標題 = 「正在打字中...」
時鍾1.時鍾周期 = 800
返回 (真)

.子程序 _超級編輯框1_放開某鍵, 邏輯型, , 暫停打字中...
.參數 鍵代碼, 整數型
.參數 功能鍵狀態, 整數型

當前是否正在打字 = 假
返回 (真)

.子程序 _時鍾1_周期事件, , , 暫停打字中...

.如果真 (當前是否正在打字 = 假)
按鈕1.標題 = 「暫停打字中...」

.如果真結束

.子程序 _超級編輯框1_選擇區被改變, , , 超級編輯框1.滾動

超級編輯框1.滾動 (1)

❹ 易語言怎麼做YY音效軟體,和源碼

我可以教你做 但是輸出通道用易語言我寫不出來 但是各個音效在軟體上實現我可以教你 也可以給你源碼

❺ 易語言源碼是什麼

就是 文件名.e的文件 用這個文件 可以修改程序的功能 界面等 把它改寫成你自己的程序 如果你想學習易語言推薦去赤血學院 學習一下 哪裡成套的視頻教程 可以讓你快速入門。

❻ 易語言音軌

在取隨機數之前必須要置隨機數種子否則會返回1個值正確的代碼如下:.版本2置隨機數種子()播放音樂(取運行目錄()+「\res\dani」+到文本(取隨機數(1,3))+「.wav」,)

❼ 易語言如何把兩個源碼合並

首先要理解,源碼是什麼。
然後是所謂的源碼合並,就是將編寫的功能代碼的作用編寫在一起。
後面就是解決問題了:
針對易語言的源碼來說,你可以將二個源碼分別的編寫了EC模塊模塊。然後是在新的程序里,添加這二個模塊。就跟調用命令一樣的調用了,注意編譯為模塊里。源碼里的子程序應該是要公開的,不然你不能進行調用。

❽ 求如何修改易語言源碼過程,

修改易語言源碼過程:
在你的電腦上安裝一個易語言

得到你想修改的易語言源碼(*.e格式的文件)

用易語言打開源碼文件

改成你希望的效果

保存文件

關閉易語言.

就是這么簡單.

❾ 易語言源碼

通過易語言特定語言來調用組件來實現你想要的功能的!!!
比如你想在單擊一個按鈕後出現提示,就可以這樣寫

.子程序 _按鈕1_被單擊

信息框 (「就這樣寫 0, 「特別提醒」)
多看看教程你就會了····

❿ 求助,求簡單的 易語言源碼

你看一下 是不是這樣的。我大概的按你所要求的寫的。如果哪裡不合適的請追加提問!盡量幫你完善幫助到你!
以下是代碼:
----------------------------------------------------------------------------------------------------------------------
.版本 2

.程序集 窗口程序集1
.程序集變數 時間, 整數型
.程序集變數 計時, 整數型
.程序集變數 可否關閉, 邏輯型

.子程序 _時鍾1_周期事件

時間 = 時間 - 1
.判斷開始 (時間 = 0)
關閉系統 (#關機, 真)
.默認

.判斷結束
標簽1.標題 = 「請在 」 + 到文本 (時間) + 「 內輸入 我愛你 否則將強制關機!」

.子程序 _編輯框1_內容被改變

.如果真 (編輯框1.內容 = 「我愛你」)
.如果 (信息框 (「你確認嗎?」, 32 + 1, 「請確認」) = #確認鈕)
圖片框1.圖片 = 讀入文件 (取運行目錄 () + 「\1.jpg」)
圖片框1.可視 = 真
可否關閉 = 真
.否則
時鍾1.時鍾周期 = 1000
可否關閉 = 假
.如果結束

返回 ()
.如果真結束
時鍾1.時鍾周期 = 1000

.子程序 __啟動窗口_創建完畢

時間 = 60

.子程序 __啟動窗口_可否被關閉, 邏輯型

.如果真 (假 = 可否關閉)
.如果 (信息框 (「結束本程序將會關閉本系統!你確認要結束本程序嗎?」, 32 + 4, 「關機操作」) = #是鈕)
關閉系統 (#關機, 真)
結束 ()
.否則
返回 (假)
.如果結束
返回 ()
.如果真結束
結束 ()

閱讀全文

與易語言雙音軌源碼相關的資料

熱點內容
愛戀3d未刪減版百度雲網盤 瀏覽:47
安卓邊境怎麼玩 瀏覽:203
不用下載免費網址 瀏覽:186
gl片子 瀏覽:41
台灣電影男學生女老師 瀏覽:743
推薦個能看的網址你懂的 瀏覽:149
免費觀看歐美純愛電影 瀏覽:222
帶男朋友張浩回宿舍影片名字 瀏覽:177
抗戰二級電影 瀏覽:115
愛情電影中文網 瀏覽:975
民國片 瀏覽:534
移動轉電信代理伺服器地址 瀏覽:771
不卡頓電影網免費觀看 瀏覽:358
摩登情書在線免費閱讀全文 瀏覽:308
能看動漫黃的網站 瀏覽:105
陪女人看電影逛街是什麼app 瀏覽:825
韓國電影百度雲有哪些 瀏覽:982
財務經理可以命令出納幹活嗎 瀏覽:534
女性癮者2墮胎怎麼拍的 瀏覽:324
電影開頭一個叫水生的小孩 瀏覽:987