導航:首頁 > 源碼編譯 > 指標公式源碼黃金分割

指標公式源碼黃金分割

發布時間:2023-03-29 08:17:49

1. 入門股指期貨,有沒有大師給我一個通達信的黃金分割指標,帶壓力支撐位的公式

新建一個公式,輸入以下源碼即可
{主圖公式:支撐壓力射線加黃金分割}

N:=75;P:=5;P1:=10;{N為多少天內的高低值參數,我以自已的初始K線根數定義。P1、P2為短、長支撐壓力取點參數}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短壓:DRAWLINE(D1,H,F1,H,1),COLORCYAN;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED;
AA1:=REF(H,P1)=HHV(H,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
長壓:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
長支:DRAWLINE(DD2,L,FF2,L,1),COLORRED;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
高:=REFDATE(HHV(H,N),DATE);
低:=REFDATE(LLV(L,N),DATE);
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高,'高'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H1,'809'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,H2,'618'),COLORGRAY;
DRAWTEXT(CURRBARSCOUNT=1,H3,'中'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,H4,'382'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=1,H5,'191'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,低,'低'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高,高,100,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=13,H1,H1,100,-1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=13,H2,H2,100,-1),COLORGRAY;
STICKLINE(CURRBARSCOUNT=13,H3,H3,100,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=13,H4,H4,100,-1),COLORLIRED;
STICKLINE(CURRBARSCOUNT=13,H5,H5,100,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=13,低,低,100,-1),COLORRED;

2. 黃金分割的公式是怎麼計算啊

首先要了解黃金分割點的由來:
作一條線段AB,然後在線段AB上取一點C,使得AC/CB=CB/AB 這個點是視覺上的最美的點也是很有現實意義的一點,C點即為黃金分割點沒姿.
好了,黃金分割點畫出來了.該怎麼求黃金分割值呢
設線段AB長度為1,CB(較長的那一段)為x
由AC/CB=CB/AB得:(和沒1-x)/x=x
即:x^2+x-1=0
解的方程的解為:
x=(-1+根號5)/2 或x=(-1-根號5)/2 (線段長枯棚絕度不可能為負,此根捨去)
所以黃金分割值為(-1+根號5)/2

3. 黃金分割率公式

黃金分割率公式:Cosine∠BAC=直線AC/AF=1/(2(直線AB)/AC)。
黃金分割率就是指:把一條線段分割為兩部分,較大部分與整體部分的比值等於較小部分與較大部分的比值。其比值是一個無理數,取其前三位數字的近似值是0.618。由於按此比例設計的造型十飢老分美麗,因此稱為黃金分罩伍割爛悶升,也稱為中外比。其公式為,Cosine∠BAC=直線AC/AF=1/(2(直線AB)/AC)。

4. 股票黃金分割的公式及其使用方法

你好,股票黃金分割公式,股票黃金分割演算法。股價下跌行情中,脫離高檔,依照黃金分割率,它的跌勢也會在下跌幅度接近或達到0.382與0.618時容易出現支撐,股票黃金分割有反轉上升而結束下跌行情的可能。計算方法與上升行悄的黃金分割率公式相同。
例如:上升行情結束前,某股最高價為20元,那麼.股價反轉下跌時,股票黃金分割投資人可以計算出各種不同的支撐價位,股票黃金分割也就是20x(1一0.382)二12.36元或者是20 x(1一0.618)== 7.64元。
風險揭示:本信息不構成任何投資建議,投資者不應以該等信息取代其獨立判斷或僅根據該等信息作出決策,不構成任何買賣操作,不保證任何收益。如自行操作,請注意倉位控制和風險控制。

5. 通達信 畫三角 黃金分割線 主圖指標公式

可以按照n日的最高最低價畫高低點,可以選擇前面第幾個高點或者低點畫三角形然後在三角形後面畫黃金分割黃金分割百分比都是可調整的,並且標注百分比數和價格.例如下圖指標,

參數N是20日的高低點判斷

參數M是1就是畫線結束在前面最近的第一個低點,如果是2就是向前數第2個

參數高低等於0 就是從高點向低點畫線,參數高低等於1就是從低點向高點畫線

參數H1H2H3H4H5都是黃金分割的百分比參數可以自行修改

指標效果如下圖

6. 黃金分割公式是什麼

黃金分割公式是(√5-1)/2。黃金分割點是指把一條線段分割為兩部分,使其中一部分與棗尺全長之比等於另一部分與這部分之比。其比值是一個無理數,取其前三位數字的近似值是0.618。由於按此比例設計的造型十分美麗,因此稱為黃金分割枝指,也稱為中外比。通常用Φ表示。這是一個十分有趣的數字,以0.618來近似表示。

黃金分割率的特點

黃金分割率的最基本公式,是將1分割為0.618和0.382,它凳搭高們有如下一些特點(1)數列中任一數字都是由前兩個數字之和構成。(2)前一數字與後一數字之比例,趨近於一固定常數,即0.618。(3)後一數字與前一數字之比例,趨近於1.618。(4)1.618與0.618互為倒數,其乘積則約等於1。(5)任一數字如與後兩數字相比,其值趨近於2.618;如與前兩數字相比,其值則趨近於0.382。

7. 黃金分割線的公式

黃金分割線的最基本公式,是將1分割為0.618和0.382,它們有如下一些特點:
(1)數列中任一數字都是由前兩個數字之和構成。(2)前一數字與後一數行晌字之比例,趨近於一固定常數,即0.618。(3)後一數字與前一數字之和輪比例,趨近於1.618。(4)1.618與0.618互喚帶信為倒數,其乘積則約等於1。(5)任一數字如與後兩數字相比,其值趨近於2.618;如與前兩數字相比,其值則趨近於0.382。
理順下來,上列奇異數字組合除能反映黃金分割的兩個基本比值0.618和0.382以外,尚存在下列兩組神秘比值。即:
(1)0.191、0.382、0.5、0.618、0.809
(2)1、1.382、1.5、1.618、2、2.382、2.618

8. 計算股票下跌到黃金分割位的公式是什麼

當下跌行情結束前,某股的最低價10元,那麼,股價反轉上升時,投資人可以預先計算出各種不同的反壓價位,也就是10×(1+19.1%)=11.9元。

10×(1+38.2%)=13.8,10×(1+61.8%)=16.2元,10×(1+80.9%)=18.1元,10×(1+100%)=20元,10+(1+119.1%)=21.9元,然後,再依照實際股價變動情形做斟酌。

反之上升行情結束前,某股最高價為30元,那麼,股價反轉下跌時,投資人也可以計算出各種不同的持價位,也就是30×(1-19.1%)=24.3元,30×(1-38.2%)=18.5元,30×(1-61.8%)=11.5元,30×(1-80.9%)=5.7元。

然後,依照實際變動情形做斟酌。 黃金分割線的神秘數字由於沒有理論作為依據,所以有人批評是迷信,是巧合,但自然界的確充滿一些奇妙的巧合,一直難以說出道理。

(8)指標公式源碼黃金分割擴展閱讀:

黃金分割廳帶線的最基本公式,是將1分割為0.618和0.382,它們有如下一些特點:

(1)數列中任一數字都是由前兩個數字之和構成。

(2)前一數字與後一數字之比例,趨近於一固定常數,即0.618。

(3)後一數字與前一數字之比例,趨近於1.618。

(4)1.618與0.618互為倒數,其乘積則約等於1。

(5)任一數字如與前面第二個數字相比,其值趨近於2.618;如與後面第二個數字相比,其值則趨近於0.382。 理順扮猛蘆下來,上列奇異數字組合除能反映黃金分割的兩個基本比值0.618和0.382以外,尚存在下列兩組神秘比值。即:

(1)0.知乎191、0.382、0.5、0.618、0.809

(2)1、1.382、1.5、1.618、2、2.382、2.618

9. 求通達信黃金分割選股公式

N:=80;
M:=3;
MA5:=MA(C,5);
MA13:=MA(C,13);
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高譽備簡慶褲-低)*0.809;

XG:(l<=H19 AND C>滾缺=H19) OR (l<=H38 AND C>=H38) OR (l<=H中 AND C>=H中) OR (l<=H61 AND C>=H61) OR (l<=H80 AND C>=H80);

10. 黃金分割(主圖 指標)通達信指標公式源碼

首先畫黃金分割線一定要有確認高低點的判斷條件只有判斷了高低點的具體位置才能畫黃金分割線的主圖指標,例如下圖的黃金分割指標,用n日高低點來做判斷條件畫黃金分割線效果如圖.

通過調整n日內的高低點來改變黃金分割畫線位置

閱讀全文

與指標公式源碼黃金分割相關的資料

熱點內容
廣州視頻流加密晶元 瀏覽:648
伺服器異常有什麼預兆 瀏覽:748
安卓airpodspro怎麼調降噪模式 瀏覽:99
承憲的朋友電影 瀏覽:778
農場互助源碼手機版 瀏覽:115
萬安如何使用雲伺服器ip 瀏覽:212
編程語言python入門電子書 瀏覽:401
什麼是民政生存認證app 瀏覽:633
java怎麼退出 瀏覽:903
掛接pdf 瀏覽:166
浪潮伺服器遠程修改bmc地址 瀏覽:120
單立文電影 瀏覽:873
linuxtar命令 瀏覽:876
優酷app如何屏蔽短視頻 瀏覽:480
看著就解壓的軟體 瀏覽:785
android撥號界面源碼 瀏覽:54
在線高清 瀏覽:375
程序員陸漓發型劉海 瀏覽:484
台灣電影《三十兒立》 瀏覽:316
南京學程序員培訓班 瀏覽:267