導航:首頁 > 源碼編譯 > 通達信期權可靠的指標公式源碼

通達信期權可靠的指標公式源碼

發布時間:2023-01-25 07:32:38

1. 求教高人把通達信指標公式做成選股指標 源碼如下:

YC2:=REF(CLOSE,2);
YC:=REF(CLOSE,1);
TJ:=YC>=YC2;
YH:=MAX(YC2,YC);
YL:=MIN(YC2,YC);
TH:=MAX(YC,CLOSE);
TL:=MIN(YC,CLOSE);
GL:=TL;
GH1:=IF(TJ=0,MIN(YH,TH),YL);
GH:=IF(GH1<GL,GL,GH1);
XG:REF(GL,1) AND EVERY(GH>GL,2) AND C>O;

2. 通達信期貨指標公式大全

通達信征戰商品期貨重要指標公式
HA:(HHV(HIGH,120)),LINETHICK3,COLORRED;HHA:(HHV(HIGH,30)),LINETHICK1,COLORLIRED;LA:(LLV(LOW,120)),LINETHICK1,COLORGREEN;LLA:(LLV(LOW,30)),LINETHICK3,COLORRED;
DRAWBAND(HA,RGB(O,200,200),HHA,RGB(O,200,200));DRAWBAND(LA,RGB(0,100,100),LLA,RGB(O,100,10O));DRAWICON(C>(HHA-((HHA/C)/10)),H*1.01,2);
DRAWICON(C<(LLA+((LLA/C)/10)),L*0.99,1);C;

3. 知道通達信這個指標源碼,怎樣編出這個指標的選股公式

你寫不下, 你以為別人就能寫的下嗎?這是一個組合疊加的指標(說白了是個雜種)
裡面設置了很多買入條件,不知你要哪個?有w底,買點,滿倉等都是買入信號啊!!!
就暫且設置w底選股吧,
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
W底選股:IF(SSS-SSB=2 AND SSS>REF(SSS,1),1,0);
這是一個底部選股比較可靠的指標之一。

4. 通達信 wvad指標源碼

N:=24;

M:=6;

WVAD:SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,N)/10000;

MAWVAD:MA(WVAD,M);

wvad指標代碼如上,

顯示效果圖如下

5. 20個極品通達信指標公式源碼

大黑馬類型的通達信公式源碼;

通達信的公式源碼都有。

因為你的極品的概念有點模糊,但是公式要挑肯定要挑自己喜歡的,圖形啊,信號啊,等等,所以可以自行去了解哦~

6. 求一通達信的股票指標公式或源碼(有圖有懸賞)

該指標為通達信系統自帶指標:莊家抬轎(ZJTJ)。
網上有不少變異型,無非就是把兩個或兩個以上的指標撮合在一起改弦更張罷了。你只要稍微留心一下,自己都可以改的。
莊家抬轎(ZJTJ)指標中使用了形態函數WINNER(獲利盤比例)和COST(成本分布),雖然是未來函數,但不影響使用。
使用該指標一定要結合其它指標綜合研判,不可單獨使用。
====================
☆★☆在通達信主畫面狀態下,輸入:「ZJTJ」回車即可看到該指標。

7. 股市當中有哪些好用的指標,帶源碼的

指標不是萬能的,不是萬能鑰匙,靈丹妙葯,指標五花八門,林林總總,不計其數。每一類指標只能反映股票運行規律的一個側面。

我自以為是的適合自己的好用的主圖指標如下:

DRAWKLINE(H,O,L,C);

漲停1:=(C/REF(C,1))>=1.095 AND (C/REF(C,1))<=1.105;

STICKLINE(漲停1,O,C,4,0),COLORYELLOW;

漲停2:=(C/REF(C,1))>1.105 AND (C/REF(C,1))<=1.195;

STICKLINE(漲停2,O,C,4,0),COLORLIRED;

漲停3:=(C/REF(C,1))>1.195 ;

STICKLINE(漲停3,O,C,4,0),COLORMAGENTA;

EXPMA17:EXPMEMA(C,17)COLORMAGENTA LINETHICK2;

MA55:MA(C,55) COLORWHITE;

MA89:MA(C,89)COLORYELLOW ;

MA144:MA(C,144) COLORRED LINETHICK2;

CCL:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DDL:=DMA(CLOSE,CCL);

上:=(1+7/100)*DDL,DOTLINE,COLORGREEN;

下:=(1-7/100)*DDL,DOTLINE,COLORGREEN;

中:=(上+下)/2,DOTLINE,COLORGREEN;

上上:=EMA(上,181),DOTLINE,COLORRED;

下下:=EMA(下,181),DOTLINE,COLORRED;

中中:=EMA(中,181),DOTLINE,COLORRED;

DRAWICON(上>=上上,上上,17);

主十增倉:10*WINNER(CLOSE*0.9)*8,NODRAW COLORYELLOW;

十換手:SUM(VOL/CAPITAL*100,10),NODRAW COLORWHITE;

ER:=V/FINANCE(7)*100;

MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));

T1T:=BARSLAST(C>MAXCYC*POW(1.1,0.9));

T2T:=BARSLAST(C<maxcyc*pow(1.1,-0.9)); p=""> </maxcyc*pow(1.1,-0.9));>

T3T:=CROSS(T1T,T2T) OR CROSS(T2T,T1T) OR BARSSINCE(T1T+1)=0 OR BARSSINCE(T2T+1)=0 OR BARSCOUNT(C)=0;

T4T:=REF(MAXCYC,BARSLAST(T3T));

主力盈利:LN(C/T4T)/LN(1.1)*10,NODRAW;

{盈利天:BARSLASTCOUNT(主力盈利>0) COLORMAGENTA,NODRAW;}

獲利比例:WINNER(CLOSE)*100,NODRAW;

DRAWICON(獲利比例>0 AND 獲利比例<=2,L*0.98,9);

DRAWICON(獲利比例>2 AND 獲利比例<=5,L*0.98,23);

P1:=90;

AO:=P1+(100-P1)/2;

BO:=(100-P1)/2;

CCO:=COST(AO);

DDO:=COST(BO);

籌碼集中度:(CCO-DDO)/(CCO+DDO)*100/2,COLORRED,NODRAW;

DRAWICON(獲利比例>80 AND 籌碼集中度<10,L*0.98,25);

翻倍:=REFDATE(REF(LLV(LOW,90),3),DATE)=LOW AND (CLOSE-LOW>0-CLOSE OR OPEN-LOW>CLOSE-OPEN);

STICKLINE(翻倍,H,H*1.2,2,0),COLORLIRED;

DRAWTEXT(翻倍,H*1.2,'機會來了'),COLORYELLOW;

DRAWTEXT(翻倍,H*1.15,'堅決持有'),COLORCYAN;

DRAWTEXT(翻倍,H*1.1,'後市暴漲'),COLORMAGENTA;

N:=1.5;

M:=3;

DIFF:=EMA((EMA(CLOSE,N*12)-EMA(CLOSE,N*26))/EMA(CLOSE,N*26)*1000,M);

DEAF:=EMA(DIFF,N*9),COLOR000088;

加倉:IF(DIFF>=REF(DIFF,1) AND DEAF<ref(deaf,1),diff,drawnull),colorlired,nodraw; p=""> </ref(deaf,1),diff,drawnull),colorlired,nodraw;>

短線出局:=IF(DIFF REF(DEAF,1),DIFF,DRAWNULL),NODRAW;

STICKLINE(加倉 ,C,C*1.0015,8,0),COLORYELLOW;

在告訴你答案之前,先簡短的講講我的經歷吧!十多年前,我是世界500強企業的一名職員。通過自學,考試後現在轉行為證券公司的一名投顧。在我轉行之前也是到處找資料學習。相關的書籍啊,指標啊等等,但掌握了一些基礎知識後發現即使學會了這些東西還是遠遠不能在這個市場上生存的。通過認真思考我發現,如果做投資沒有自己的交易體系,那是很危險的一件事。在自己的交易體系建立之前,我做過外匯,做過權證,做過商品期貨,做過期權,當然也有股票。現在從業了,所以也就只是做做股票的模擬盤。所以對於指標類的東西還是有所發言權的。言歸正傳,下面來回答一下你的問題吧!

1.如果你真的想在這個投資市場上暢意的行走,你首先應該建立自己的交易體系。

2.在你建立交易體系之後,我現在正式回答你的問題。正常情況下,你只需要認真研究系統默認的幾個指標就可以了,K線,均線,量,KDJ,MACD就這幾個,其它雜亂的指標都是通過這幾個基礎指標編輯演變而成的,因為是手機截圖,所以這里截了兩個圖,如果需要操盤,建議最好是用電腦。

3.K線,K線就是紅綠柱,他代表最高價,最低價,開盤價和收盤價。在這里我就不詳細贅述了。

4.均線,均線分日,月,周,季,年均線等。那要看你是什麼周期,比如日均線m5就是五天內的平均價,也就是五日均線。M10就是十天均線等等。

5.量,量就比較復雜一點,常常需要配合其他指標使用,它代表成交量或成交額。周期也是和均線一樣。

6.MACD和KDJ,同樣需要結合周期來使用,最常見的就是金叉和死叉,但是也需要結合市場環境來看。


給大家一個去掉不適合自己參與的過濾選股器吧,懂代碼的可以自己修改,不懂得那就直接用,有幾個參數最好自己做一下修改,比如,股價,交易密度,等等。

它的功能是選出適合自己的帶有漲停板的活躍股,他不是操作的依據,只是幫你過濾掉那些不適合參與的股票,每天盤後下載數據,復盤選股,他不適合最預警,只適合復盤高效選股。

僅供參考(通達信使用者)

公式名稱:去掉無效選股

參數:N=2:2000:60(周期數)

N1=1:200:3(漲停板個數)

SS=2:2000:50(股價)

NN=2:30:15(交易密度)


ENTERLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,20));{這是一個均線自動交易代碼暫時先保存著以備後用}

EXITLONG:=CROSS(MA(CLOSE,5),MA(CLOSE,3));{這是一個均線自動交易代碼暫時先保存著以備後用}

ZTTJ1:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));

ZTTJ:=(CLOSE>=ZTPRICE(REF(CLOSE,1),IF(FINANCE(3)=3,0.2,0.1)));

ZTTM:=COUNT(ZTTJ,N)>=N1;

AR2:=EVERY(ZTTJ,2);

AR3:=COUNT(AR2,60)>=1;

RZ1:=INBLOCK('殼資源')=0; RZ2:=INBLOCK('商譽減值')=0; RZ4:=INBLOCK('風險品種')=0;

RZ6:=INBLOCK('細分龍頭')=1; RZ7:=INBLOCK('已高送轉')=0;

{通達信去掉創業板*ST} S1:=IF(CODELIKE(馄'),1,0);

{通達信去掉退市股}{去掉不需要的板塊}{通達信去掉*、S、ST}

S2:=IF(NAMELIKE('S'),0,1); S3:=IF(NAMELIKE('*'),0,1);

{通達信去掉停牌}

S4:=DYNAINFO(17)>0;

S5:= BETWEEN(FINANCE(7)/10000000,1,400) AND FINANCE(7)*C/100000000<360 AND C<ss p="" ;

{去掉融券融資 AND S6}

S6:=FINANCE(52)=0;

S7:=IF(CODELIKE(鬈'),0,1);{通達信去掉科創板}

S10:=FINANCE(30)>=-5;

S12:=DYNAINFO(39)<500;

S13:=SUM(DYNAINFO(37),20)>0.2;

S14:=FINANCE(30)/FINANCE(20)*100>-50;

ST:S2 AND S3 AND S4 AND S7 AND RZ4 AND S13 AND ZTTM AND C<ss;{and p="" s1}

AA1:=C/REF(C,1)>1.03 AND C<ss p="" s7;{強勢選股}

AB1:=FROMOPEN*NN;

AB2:=DYNAINFO(50)>AB1;

S11:=IF(AB2,AA1,DRAWNULL);

大家好,給大家分享一個監測莊家動向的指標——獵庄擒牛。指標通過對莊家資金的監測,可以捕捉到莊家何時進場拉升,何時出貨離場。洞察到莊家的這些動向之後,散戶獵庄擒牛並不只是說說而已。

「獵庄擒牛」指標要點:

一、指標提示「莊家出現」信號時,表明監測到此處有莊家大資金進場,行情即將開啟拉升,可跟進建倉。

二、指標提示「莊家出貨」信號時,表明監測到此處莊家在進行籌碼派發,應果斷止盈離場,落袋為安。

效果圖:

「獵庄擒牛」主要作用就是對莊家大資金動向的監測,從而給出預警信號。當然指標還有其它關於籌碼和趨勢的信號判斷,這里就不做過多講解,大家拿到後可以去慢慢摸索。

大道至簡,簡單有效不要復雜。股市中最有效的技術指標就是那些最貼近市場本質的數據跟蹤指標,我最常用的就是K線,均線,MACD和量能及均量線,夠用了。

在一個多變復雜的市場中,越簡單反而才是越有效,過於復雜的技術工具適應能力太差。

通達信精準指標——趨勢布林線主圖+神針起爆副圖+源碼 給大家分享一個趨勢布林線主圖,搭配神針起爆副圖,適用於短線和中長線,是基於系統布林線而研發的,比系統自帶的更加精準。 主圖當出現紅色箭頭為建倉信號,當出現綠色箭頭為減倉或者平倉信號。 副圖紅色趨勢為上升趨勢,綠色趨勢為下跌趨勢,紅色趨勢變為綠色交叉點為減倉信號。 綠色趨勢變為紅色為建倉信號,出現神針起爆紅柱可作為啟動點和建倉點。

主副圖點位一一對應,產生共振。 源碼

這套指標主要利用主副圖共振點來進行操作,精準率很高,喜歡的朋友可以關注我的首頁,留言指標二字,我會免費分享給大家。

好用的公式有很多,但是適合自己才行!今天我分享幾個我自己經常用的公式分享給大家!

擒牛大中短


這個公式主要就是抓買賣點的指標,不含未來函數,可以放心操作!

主力波段吸籌

該公式是精準判斷操作位置,依然沒有未來函數!

其次,如果大家想炒股,先學習一些基本的炒股知識,並且少量投入,切不可一梭哈。不要迷信技術指標,所謂的指標都是事後才出來的,有精力的可以去看看指標編程,無非都出自於成交量、成交額、均線等等,所以都是滯後的。簡單的K線、成交量、2條均線,輔助參考判斷即可。技術指標越復雜,越難以付諸實施。

所以,還請大家不要迷戀技術指標,我曾經花了1年多的時間研究、編寫各種技術指標,到現在,我已經放棄了,只留了交易軟體裡面最原始的指標,做輔助判斷而已,記住只是輔助判斷。還請大家不要走彎路,一入股市深似海,到處都是坑,切記!!!

這個我認為因人而異,畢竟適合自己的指標才是好指標。這里我們來分享下我常用的指標

第一,均線,均線是時候非常實用的指標,無論是短線,中線,長線都非常實用。

(1)如果是短線,5日均線就夠了。5日均線比較神奇。

①當K線從5日均線下方上穿5日均線,而且均線開始拐頭,結合量能,底部放量,那麼短線就可以把我了,而且是超短機會。基本都有不錯的收益。

②當市場均線多頭排列,只要K線在5日均線上方,沿著5日均線上行,那麼也是一個持倉的機會。

(2)中線,中線一般就是看20日均線,這個均線比較實用,也稱為萬能均線,只要K線站穩在20日均線上方,而且拐頭向上,結合籌碼,籌碼低位單峰,中線就可以把握。

(3)長線,長線就是60日均線上穿120日均線,而且趨勢上行。

第二,MACD,領略到精髓,賺錢非常簡單。

1、 MACD在0軸上方——每發生一次金叉,股價將創新高,但是二次金叉不要追。2、 MACD在0軸下方——每發生一次死叉,股價將創新低新低後可以適當的補倉。3, MACD在0軸上方——金叉死叉次數越多越好、牛股,4,, MACD在0軸下方——金叉死叉次數越多越差、熊股。5,MACD水下兩次金叉,第二次金叉就是買入機會。6.MACD的黃白兩線不能和柱狀形成背離,背離則會產生行情反轉。

好了我就分享了我常用的這兩個希望對大家有幫助。


如果想聽實話,我就告訴你。最好用的指標是:K線、成交量(手)、均線和MACD。其它指標都可以忽略。

你進入叢林,容易繞花眼睛,七選八選-選個漏眼。其實最顯眼的就是最好的。

8. 通達信fsl指標公式

公式如下:1.SWL=(收盤價的5日加權移動平均*7+收盤價的10日加權移動平均*3)/10
2.SWS=以1和100*[成交量的5日累和/(3*流通股本)]的較大值為權重收盤價的12日指數移動平均的動態移動平均
(SWL:(EXPMA(CLOSE,5)*7+EXPMA(CLOSE,10)*3)/10;
SWS:DMA(EMA(CLOSE,12),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL))));)
拓展資料:
1、通達信炒股軟體是一款定位於提供多功能服務的證券信息平台,由深圳財富趨勢科技股份有限公司設計的一款移動證券軟體。通達信允許用戶自由劃分屏幕,並規定每一塊對應哪個內容。
2、軟體功能
1)集滬深、港股、美股、期貨、期權、基金、宏觀以及外匯等市場行情於一體,適用於所有投資者。
2)創新結合滬深數據,推出DDE決策、個股板塊資金流向、主題事件、一致預期、持股變動、龍虎榜單等特色功能。
3)提供滬深、港股及美股市場行情,支持自選、排名、板塊以及各種技術指標。
4)通過商品期貨、外幣匯率與環球指數來概覽全球市場。
5)具備多種欄目資訊。
3、FSL分水嶺指標是一個強弱勢的分界線,它最大的特點就是使投資者跳開紛繁復雜的各種技術分析,一目瞭然,對操作的指導極其便捷。在技術分析的諸多指標中,FSL是最簡單實用的參考指標之一。
就FSL分水嶺指標而言,是SWL(白色線)大於SWS(黃色線)為強勢,反之,SWS大於SWL則為弱勢。
4、應用法則
1)股價在分水嶺之上為強勢,反之為弱勢。
2)當股價從上方向下,在分水嶺上方獲得支撐,同時分水嶺向上運行,說明股價受到支撐,可考慮建倉;當股價從下方向上,在分水嶺遇阻回落,同時分水嶺向下運行,說明股價受壓,此時應賣出股票,防範風險。這種方法同樣可以應用於對大盤的分析。
3)分水嶺向下且股價由下向上突破分水嶺時,說明此股票在由弱變強,可以考慮建倉。
4)分水嶺向上且股價由上向下跌破分水嶺時,說明此股票在由強變弱,要及時止損。

閱讀全文

與通達信期權可靠的指標公式源碼相關的資料

熱點內容
安卓智能手錶如何聽歌 瀏覽:542
win10文件夾取消分組折疊組 瀏覽:664
趨勢指標源碼分析 瀏覽:418
股票價格計算公式源碼 瀏覽:767
程序員解釋方向問題 瀏覽:831
安卓手機關閉屏幕怎麼錄音 瀏覽:232
為什麼老顯示伺服器連接失敗 瀏覽:419
滴答滴app上如何拼車 瀏覽:872
網路加密了怎麼用手機連接 瀏覽:53
香腸樹app等級怎麼看 瀏覽:364
解壓模擬器3d抖音小游戲 瀏覽:319
dlink如何列印伺服器 瀏覽:955
如何啟動後端伺服器 瀏覽:36
電腦安卓軟體界面怎麼默認恢復 瀏覽:266
java程序員接項目 瀏覽:600
炒股指標源碼官網 瀏覽:633
為什麼java安裝不了 瀏覽:559
魅族怎麼更新手機安卓系統 瀏覽:99
網路鄰居命令 瀏覽:870
哈啰出行app如何開鎖 瀏覽:948