導航:首頁 > 程序命令 > ciscodebug命令

ciscodebug命令

發布時間:2022-11-30 05:23:08

⑴ 思科路由器查看路由表命令

思科路由器查看路由表的命令為Router #show ip route。

在路由器全局配置模式下,輸入show ip route命令,這時屏幕會出現許多的路由表的詳細信息,例如目的地址、子網掩碼 、網關、明文顯示的密碼、PC埠的一些詳細信息等。

思科(Cisco)路由器是一個集成多業務路由器,福利綜合服務網路路由器,以及獲得回報的網路路由器。思科公司是全球領先的網路解決方案供應商,依靠自身的技術和對網路經濟模式的深刻理解,思科成為了網路應用的成功實踐者之一。

(1)ciscodebug命令擴展閱讀:

思科路由器優勢:

系統方法開始於單一永續平台,如思科(Cisco)集成多業務路由器。系統方法相結合的內部及其相互之間的智能服務,包裝,編織語音,安全,路由和應用服務結合起來,使程序更加自動化和智能化。

結果普遍安全的網路和應用,對數據,語音更高的服務質量和視頻流量,提高時間效率,更好地利用網路資源。

隨著集成多業務路由器,思科(Cisco)提供了一個全面的,未來需求的解決方案,最大限度地減少網路中斷,並確保進入最關鍵業務應用。思科(Cisco)對性能結合新的基礎設施服務的重點是使公司創造網路更聰明,更有彈性,可靠。

參考資料來源:網路-思科(Cisco)路由器

⑵ cisco常用命令

cisco常用命令大全

為幫助大家更好通過思科認證。我為大家分想的是思科認證基本命令,歡迎參考閱讀!

路由器的幾個基本命令:

Router>enable 進入特權模式

Router#disable 從特權模式返回到用戶模式

Router#configure terminal 進入到全局配置模式

Router(config)#interface ethernet 1 進入到路由器編號為1的乙太網口

exit 返回上層模式

end 直接返回到特權模式

========================================================

注意:

1、CISCO CATALYST(交換機),如果在初始化時沒有發現“用戶配置”文件,就會自動載入Default Settings(默認配置)文件,進行交換機初始化,以確保交換機正常工作。

2、CISCO Router(路由器)在初始化時,如果沒有發現“用戶配置”文件,系統會自動進入到“初始化配置模式”(系統配置對話模式,SETUP模式, STEP BY STEP CONFIG模式),不能正常工作!

========================================================

1、CONSOLE PORT(管理控制台介面):距離上限制,獨占的方式。剛開始配置的時候一般使用這個。

2、AUX port(輔助管理介面):可以掛接MODEM實現遠程管理,獨占的方式。

3、Telnet:多人遠程管理(決定於性能,VTY線路數量)不安全。後期維護,遠程管理登陸。

========================================================

注意:

交換機、路由器配置命令都是回車後立即執行,立即生效的。在運行中的機器上修改命令的時候要特別注意。

========================================================

Router(config)#hostname ?

WORD This system's network name

在配置模式下修改當前主機的本地標識,例:

------------------

Router(config)#hostname r11

r11(config)#

------------------

r11(config-if)#ip address ?

A.B.C.D IP address

為當前埠設置IP地址,使用前先進入需要配置的埠,例:

------------------

r11(config)#interface ethernet 1

r11(config-if)#ip address 172.16.1.1 255.255.255.0

------------------

r11>show version

r11#show version 觀察IOS版本,設備工作時間,相關介面列表

r11#show running-config 查看當前生效的配置,此配置文件存儲在RAM

r11#show interfaces ethernet 1 查看乙太網介面的狀態,工作狀態等等等...

========================================================

r11#reload 重新載入Router(重啟)

r11#setup 手工進入setup配置模式

r11#show history 查看歷史命令(最近剛用過的命令)

r11#terminal history size <0-256> 設置命令緩沖區大小,0 : 代表不緩存

r11# running-config startup-config 保存當前配置

注意概念:

nvram:非易失性內存,斷電信息不會丟失 <-- 用戶配置 <-- 保存著startup-config

ram:隨機存儲器,斷電信息全部丟失 <-- 當前生效配置 <-- 保存著running-config

startup-config:在每次路由器或是交換機啟動時候,會主動載入(默認情況)

========================================================

設置說明和密碼的幾個命令:

r11(config)#banner motd [char c] 同時要以[char c]另起一行結束,描述機器登陸時的說明

r11(config-if)#description 描述介面注釋,需要在埠配置模式下

配置console口密碼:

------------------

r11(config)#line console 0 進入到consolo 0

r11(config-line)#password eliuzd 設置一個密碼為“eliuzd”

r11(config-line)#login 設置login(登陸)時使用密碼

------------------

配置enable密碼:

------------------

r11(config)#enable password cisco 設置明文的enable密碼

r11(config)#enable secret eliuzd 設置暗文的enable密碼(優先於明文被使用)

r11(config)#service password-encryption 加密系統所有明文密碼(功能較弱)

------------------

配置Telnet密碼:

------------------

r11(config)#line vty 0

r11(config-line)#password cisco

r11(config-line)#login

------------------

========================================================

配置虛擬回環介面:(回環介面默認為UP狀態)

(config)# 下,虛擬一個埠

------------------

r11(config)#interface loopback 0 創建一個回環介面loopback 0

r11(config-if)#ip address 192.168.1.1 255.255.255.0 配置它的IP地址

no * 做配置的反向操作(刪除配置)

------------------

=========================================================

路由器 DCE/DTE 僅存在廣域網中r11#show controllers serial 0 用於查看DCE與DTE的屬性,serial 0路由器廣域網埠

DCE的Router需要配置時鍾頻率

r11(config-if)#clock rate ? 配置DCE介面的時鍾頻率(系統指定頻率)

一般實際情況下,這個不需要自己配置,因為DCE設備都在運營商那。

=========================================================

r11#show interfaces serial 1

查看埠狀態,第一行提示說明

Serial1 is administratively down, Line protocol is down

沒有使用no shutdown命令激活埠

Serial1 is down, Line protocol is down

1、對方沒有no shutdown激活埠

2、線路損壞,介面沒有任何連接線纜

Serial1 is up, line protocol is down

1、對方沒有配置相同的二層協議,Serial介面default encapsulation: HDLC

2、可能沒有配置時鍾頻率

3、可能沒有正確的配置三層地址(可能)

Serial1 is up,line protocol is up

介面工作正常

========================================================

查看CDP信息的幾個命令:

r11#show cdp neighbors 查看CDP的鄰居(不含IP)

r11#show cdp neighbors detail 查看CDP的鄰居(包含三層的IP地址)

r11#show cdp entry * 查看CDP的鄰居(包含三層的IP地址)老命令

r1(config)#no cdp run 在全局配置模式關閉CDP協議(影響所有的介面)

r1(config-if)#no cdp enable 在介面下關閉CDP協議(僅僅影響指定的介面)

r11#clear cdp table 清除CDP鄰居表

r11#show cdp interface serial 1 查看介面的CDP信息

注意兩個提示:

Sending CDP packets every 60 seconds(每60秒發送cdp數據包)

HoldTime 180 seconds(每個cdp數據包保持180秒)

========================================================

r11(config)#ip host 設置靜態的主機名映射

r11#show sessions 查看設置過的映射主機名

========================================================

Telnet *.*.*.* 被telnet的設備,需要設置line vty的密碼,如果需要進入特權模式需要配置enable密碼

例:

------------------

Router#telnet 192.168.1.1

------------------

Router#show users 查看登錄到本地的用戶

Router#show sessions 查看從本地telnet外出的會話

Router#clear line * 強制中斷“telnet到本地”的會話

Router#disconnect * 強制中斷“telnet外出”的會話

========================================================

以下只是在實驗時連接交換機上切換登陸路由器的命令,可以跳過。

>show hosts 顯示當前的主機名配置

>show sessions 顯示當前的外出TELNET會話

>clear line XXX 清除線路

+ 直接返回到特權模式

++<6> + x

========================================================

Access-enable允許路由器在動態訪問列表中創建臨時訪問列表入口

Access-group把訪問控制列表(ACL)應用到介面上

Access-list定義一個標準的IP ACL

Access-template在連接的路由器上手動替換臨時訪問列表入口

Appn向APPN子系統發送命令

Atmsig 執行ATM信令命令

B 手動引導操作系統

Bandwidth 設置介面的帶寬

Banner motd 指定日期信息標語

Bfe 設置突發事件手冊模式

Boot system 指定路由器啟動時載入的系統映像

Calendar 設置硬體日歷

Cd 更改路徑

Cdp enable 允許介面運行CDP協議

Clear 復位功能

Clear counters 清除介面計數器

Clear interface 重新啟動介面上的件邏輯

Clockrate 設置串口硬體連接的時鍾速率,如網路介面模塊和介面處理器能接受的速率

Cmt 開啟/關閉FDDI連接管理功能

Config-register 修改配置寄存器設置

Configure 允許進入存在的配置模式,在中心站點上維護並保存配置信息

Configure memory 從NVRAM載入配置信息

Configure terminal 從終端進行手動配置

Connect 打開一個終端連接

Copy 復制配置或映像數據

Copy flash tftp 備份系統映像文件到TFTP伺服器

Copy running-config startup-config 將RAM中的當前配置存儲到NVRAM

Copy running-config tftp 將RAM中的當前配置存儲到網路TFTP伺服器上

Copy tftp flash 從TFTP伺服器上下載新映像到Flash

Copy tftp running-config 從TFTP伺服器上下載配置文件

Debug 使用調試功能

Debug dialer 顯示介面在撥什麼號及諸如此類的信息

Debug ip rip 顯示RIP路由選擇更新數據

Debug ipx routing activity 顯示關於路由選擇協議(RIP)更新數據包的信息

Debug ipx sap 顯示關於SAP(業務通告協議)更新數據包信息

Debug isdn q921 顯示在路由器D通道ISDN介面上發生的數據鏈路層(第2層)的訪問過程

Debug ppp 顯示在實施PPP中發生的業務和交換信息

Delete 刪除文件

Deny 為一個已命名的IP ACL設置條件

Dialer idle-timeout 規定線路斷開前的空閑時間的長度

⑶ 求解釋一下cisco設備中的測試命令的含義:Debug ip rip,debug ip ospf, Debug ppp packet

Debug ip rip : 顯示了發送和接收到的RIP路由選擇更新
Debug ppp packet : 打開或關閉PPP報文調試信息開關
debug ip ospf : 系統預設關閉OSPF事件調試信息開關

⑷ 求思科路由器的全部配置命令

思科路由器的全部配置命令:
1、Exec commands:
<1-99> 恢復一個會話
bfe 手工應急模式設置
clear 復位功能
clock 管理系統時鍾
configure 進入設置模式
connect 打開一個終端
從tftp伺服器拷貝設置文件或把設置文件拷貝到tftp伺服器上
debug 調試功能
disable 退出優先命令狀態
disconnect 斷開一個網路連接
enable 進入優先命令狀態
erase 擦除快閃內存
exit 退出exce模式
help 交互幫助系統的描述
lat 打開一個本地傳輸連接
lock 鎖定終端
login 以一個用戶名登錄
logout 退出終端
mbranch 向樹形下端分支跟蹤多路由廣播
mrbranch 向樹形上端分支跟蹤反向多路由廣播
name-connection 給一個存在的網路連接命名
no 關閉調試功能
pad 打開X.29 PAD連接
ping 發送回顯信息
ppp 開始點到點的連接協議
reload 停機並執行冷啟動
resume 恢復一個活動的網路連接
rlogin 打開遠程注冊連接
rsh 執行一個遠端命令
send 發送信息到另外的終端行
setup 運行setup命令
show 顯示正在運行系統信息
slip 開始SLIP協議
start-chat 在命令行上執行對話描述
systat 顯示終端行的信息
telnet 遠程登錄
terminal 終端行參數
test 測試子系統內存和埠
tn3270 打開一個tin3270連接
trace 跟蹤路由到目的地
undebug 退出調試功能
verify 驗證檢查閃爍文件的總數
where 顯示活動的連接
which-route 執行OSI路由表查找並顯示結果
write 把正在運行的設置寫入內存、網路、或終端
x3 在PAD上設置X.3參數
xremote 進入xremote模式

2、#show ?

access-expression 顯示訪問控製表達式
access-lists 顯示訪問控製表
apollo Apollo 網路信息
appletalk Apple Talk 信息
arap 顯示Appletalk 遠端通道統計
arp 地址解析協議表
async 訪問路由介面的終端行上的信息
bridge 前向網路資料庫
buffers 緩沖池統計
clns CLNS網路信息
clock 顯示系統時鍾
cmns 連接模式網路服務信息
compress 顯示壓縮狀態
configuration 非易失性內存的內容
controllers 埠控制狀態
debugging 調試選項狀態
decnet DEC網路信息
dialer 撥號參數和統計
dnsix 顯示Dnsix/DMPP信息
entry 排隊終端入口
extended 擴展埠信息
flash 系統閃爍信息
flh-log 閃爍裝載幫助日誌緩沖區
frame-relay 幀中繼信息
history 顯示對話層歷史命令
hosts IP域名,查找方式,名字服務,主機表
interfaces 埠狀態和設置
ip IP信息
ipx Novell IPX信息
isis IS-IS路由信息
keymap 終端鍵盤映射
lat DEC LAT信息
line 終端行信息
llc2 IBM LLC2 環路信息
lnm IBM 局網管理
local-ack 本地認知虛環路
memory 內存統計
netbios-cache NetBios命名緩沖存貯器內存
node 顯示已知LAT節點
ntp 網路時間協議
processes 活動進程統計
protocols 活動網路路由協議
queue 顯示隊列內容
queueing 顯示隊列設置
registry 功能注冊信息
rhosts 遠程主機文件
rif RIF存貯器入口
route-map 路由器信息
sdlle 顯示sdlc-llc2轉換信息
services 已知LAT服務
sessions 遠程連接信息
smds SMDS信息
source-bridge 源網橋參數和統計
spanning-tree 跨越樹形拓樸
stacks 進程堆棧應用
standby 熱支持協議信息
stun STUN狀態和設置
subsystem 顯示子系統
tcp TCP連接狀態
terminal 顯示終端設置
tn3270 TN3270 設置
translate 協議轉換信息
ttycap 終端容易表
users 顯示終端行的信息
version 系統硬、軟體狀態
vines VINES信息
whoami 當前終端行信息
x25 X.25信息
xns XNS信息
xermote Xremote統計

3、#config ?

Memory 從非易失性內存設置
Network 從TFTP網路主機設置
Overwrite-network 從TFTP網路主機設置覆蓋非易失性內存
Terminal 從終端設置

4、Configure commads:

Access-list 增加一個訪問控制域
Apollo Apollo全局設置命令
appletalk Appletalk 全局設置命令
arap Appletalk遠程進出協議
arp 設置一個靜態ARP入口
async-bootp 修改系統啟動參數
autonomous-system 本地所擁有的特殊自治系統成員
banner 定義注冊顯示信息
boot 修改系統啟動時參數
bridge 透明網橋
buffers 調整系統緩沖池參數
busy-message 定義當連接主機失敗時顯示信息
chat-script 定義一個數據機對話文本
clns 全局CLNS設置子命令
clock 設置時間時鍾
config-register 定義設置寄存器
decnet 全局DEC網路設置子命令
default-value 預設字元位值
dialer-list 創建一個撥號清單入口
dnsix-nat 為審計提供DMDM服務
enable 修改優先命令口令
end 從設置模式退出
exit 從設置模式退出
frame-relay 全局幀中繼設置命令
help 交互幫助系統的描述
hostname 設置系統網路名
iterface 選擇設置的埠
ip 全局地址設置子命令
ipx Novell/IPX全局設置命令
keymap 定義一個新的鍵盤映射
lat DEC本地傳輸協議
line 設置終端行
lnm IBM局網管理
locaddr-priority-list 在LU地址上建立優先隊列
logging 修改注冊(設備)信息
login-string 定義主機指定的注冊字元串
map-class 設置靜態表類
map-list 設置靜態表清單
menu 定義用戶介面菜單
mop 設置DEC MOP伺服器
netbios NETBIOS通道控制過濾
no 否定一個命令或改為預設設置
ntp 設置NTP
priority-list 建立特權列表
prompt 設置系統提示符
queue-list 建立常規隊列列表
rcmd 遠程命令設置命令
rcp-enable 打開Rep服務
rif 源路由進程
router-map 建立路由表或進入路由表命令模式
router 打開一個路由進程
rsh-enable 打開一個RSH服務
sap-priority-list 在SAP或MAC地址上建立一個優先隊列
service 修改網路基本服務
snmp-server 修改SNMP參數
state-machine 定義一個TCP分配狀態的機器
stun STUN全局設置命令
tacacs-server 修改TACACS隊列參數
terminal-queue 終端隊列命令
tftp-server 為網路裝載請求提供TFTP服務
tn3270 tn3270設置命令
translate 解釋全局設置命令
username 建立一個用戶名及其許可權
vines VINES全局設置命令
x25 X.25 的第三級
x29 X.29 命令
xns XNS 全局設置命令
xremote 設置Xremote

5、(config)#ip

Global IP configuration subcommands:
Accounting-list 選擇保存IP記帳信息的主機
Accounting-threshold 設置記帳入口的最大數
accounting-transits 設置通過入口的最大數
alias TCP埠的IP地址取別名
as-path BGP自治系統路徑過濾
cache-invalidate-delay 延遲IP路由存貯池的無效
classless 跟隨無類前向路由規則
default-network 標志網路作為預設網關候選
default-gateway 指定預設網(如果沒有路由IP)
domain-list 完成無資格主機的域名
domain-lookup 打開IP域名服務系統主機轉換
domain-name 定義預設域名
forward-protocol 控制前向的、物理的、直接的IP廣播
host 為IP主機表增加一個入口
host-routing 打開基於主機的路由(代理ARP和再定向)
hp-host 打開HP代理探測服務
mobile-host 移動主機資料庫
multicast-routing 打開前向IP
name-server 指定所用名字伺服器的地址
ospf-name-lookup 把OSPF路由作為DNS名顯示
pim PIM 全局命令
route 建立靜態路由
routing 打開IP路由
security 指定系統安全信息
source-route 根據源路由頭的選擇處理包
subnet-zero 允許子網0子網
tcp 全局TCP參數

⑸ 路由器的debug命令

1. debug

打開或關閉系統調試開關。

[no]debug{all|{protocol-name|function-name}[debug-option ]}

【參數說明】

all表示打開或關閉全部調試開關。

【預設情況】

系統預設關閉全部調試開關。

【命令模式】

特權用戶模式

【使用指南】

R>Quidway(R)系列路由器提供種類豐富的調試功能,一般用於技術支持人員和資深維護人員進行網路故障診斷。

由於打開調試開關,會產生大量的調試信息,導致系統效率的降低,尤其在執行debugall命令打開全部調試開關後,可能會引起網路系統癱瘓,建議不要使用debug all命令,而nodebugall命令卻給用戶帶來極大方便,可以一次關閉全部調試開關,不必去一一關閉。

【舉例】

打開IPPacket調試開關。

Quidway#debugippacket

IPpacketdebuggingswitchison.
再看看http://cisco.chinaitlab.com/trouble/386402.html個吧

⑹ 思科路由器配置命令一覽表

思科路由器常用配置命令一覽表:
1、Exec commands:
<1-99> 恢復一個會話
bfe 手工應急模式設置
clear 復位功能
clock 管理系統時鍾
configure 進入設置模式
connect 打開一個終端
從tftp伺服器拷貝設置文件或把設置文件拷貝到tftp伺服器上
debug 調試功能
disable 退出優先命令狀態
disconnect 斷開一個網路連接
enable 進入優先命令狀態
erase 擦除快閃內存
exit 退出exce模式
help 交互幫助系統的描述
lat 打開一個本地傳輸連接
lock 鎖定終端
login 以一個用戶名登錄
logout 退出終端
mbranch 向樹形下端分支跟蹤多路由廣播
mrbranch 向樹形上端分支跟蹤反向多路由廣播
name-connection 給一個存在的網路連接命名
no 關閉調試功能
pad 打開X.29 PAD連接
ping 發送回顯信息
ppp 開始點到點的連接協議
reload 停機並執行冷啟動
resume 恢復一個活動的網路連接
rlogin 打開遠程注冊連接
rsh 執行一個遠端命令
send 發送信息到另外的終端行
setup 運行setup命令
show 顯示正在運行系統信息
slip 開始SLIP協議
start-chat 在命令行上執行對話描述
systat 顯示終端行的信息
telnet 遠程登錄
terminal 終端行參數
test 測試子系統內存和埠
tn3270 打開一個tin3270連接
trace 跟蹤路由到目的地
undebug 退出調試功能
verify 驗證檢查閃爍文件的總數
where 顯示活動的連接
which-route 執行OSI路由表查找並顯示結果
write 把正在運行的設置寫入內存、網路、或終端
x3 在PAD上設置X.3參數
xremote 進入xremote模式

2、#show ?

access-expression 顯示訪問控製表達式
access-lists 顯示訪問控製表
apollo Apollo 網路信息
appletalk Apple Talk 信息
arap 顯示Appletalk 遠端通道統計
arp 地址解析協議表
async 訪問路由介面的終端行上的信息
bridge 前向網路資料庫
buffers 緩沖池統計
clns CLNS網路信息
clock 顯示系統時鍾
cmns 連接模式網路服務信息
compress 顯示壓縮狀態
configuration 非易失性內存的內容
controllers 埠控制狀態
debugging 調試選項狀態
decnet DEC網路信息
dialer 撥號參數和統計
dnsix 顯示Dnsix/DMPP信息
entry 排隊終端入口
extended 擴展埠信息
flash 系統閃爍信息
flh-log 閃爍裝載幫助日誌緩沖區
frame-relay 幀中繼信息
history 顯示對話層歷史命令
hosts IP域名,查找方式,名字服務,主機表
interfaces 埠狀態和設置
ip IP信息
ipx Novell IPX信息
isis IS-IS路由信息
keymap 終端鍵盤映射
lat DEC LAT信息
line 終端行信息
llc2 IBM LLC2 環路信息
lnm IBM 局網管理
local-ack 本地認知虛環路
memory 內存統計
netbios-cache NetBios命名緩沖存貯器內存
node 顯示已知LAT節點
ntp 網路時間協議
processes 活動進程統計
protocols 活動網路路由協議
queue 顯示隊列內容
queueing 顯示隊列設置
registry 功能注冊信息
rhosts 遠程主機文件
rif RIF存貯器入口
route-map 路由器信息
sdlle 顯示sdlc-llc2轉換信息
services 已知LAT服務
sessions 遠程連接信息
smds SMDS信息
source-bridge 源網橋參數和統計
spanning-tree 跨越樹形拓樸
stacks 進程堆棧應用
standby 熱支持協議信息
stun STUN狀態和設置
subsystem 顯示子系統
tcp TCP連接狀態
terminal 顯示終端設置
tn3270 TN3270 設置
translate 協議轉換信息
ttycap 終端容易表
users 顯示終端行的信息
version 系統硬、軟體狀態
vines VINES信息
whoami 當前終端行信息
x25 X.25信息
xns XNS信息
xermote Xremote統計

3、#config ?

Memory 從非易失性內存設置
Network 從TFTP網路主機設置
Overwrite-network 從TFTP網路主機設置覆蓋非易失性內存
Terminal 從終端設置

4、Configure commads:

Access-list 增加一個訪問控制域
Apollo Apollo全局設置命令
appletalk Appletalk 全局設置命令
arap Appletalk遠程進出協議
arp 設置一個靜態ARP入口
async-bootp 修改系統啟動參數
autonomous-system 本地所擁有的特殊自治系統成員
banner 定義注冊顯示信息
boot 修改系統啟動時參數
bridge 透明網橋
buffers 調整系統緩沖池參數
busy-message 定義當連接主機失敗時顯示信息
chat-script 定義一個數據機對話文本
clns 全局CLNS設置子命令
clock 設置時間時鍾
config-register 定義設置寄存器
decnet 全局DEC網路設置子命令
default-value 預設字元位值
dialer-list 創建一個撥號清單入口
dnsix-nat 為審計提供DMDM服務
enable 修改優先命令口令
end 從設置模式退出
exit 從設置模式退出
frame-relay 全局幀中繼設置命令
help 交互幫助系統的描述
hostname 設置系統網路名
iterface 選擇設置的埠
ip 全局地址設置子命令
ipx Novell/IPX全局設置命令
keymap 定義一個新的鍵盤映射
lat DEC本地傳輸協議
line 設置終端行
lnm IBM局網管理
locaddr-priority-list 在LU地址上建立優先隊列
logging 修改注冊(設備)信息
login-string 定義主機指定的注冊字元串
map-class 設置靜態表類
map-list 設置靜態表清單
menu 定義用戶介面菜單
mop 設置DEC MOP伺服器
netbios NETBIOS通道控制過濾
no 否定一個命令或改為預設設置
ntp 設置NTP
priority-list 建立特權列表
prompt 設置系統提示符
queue-list 建立常規隊列列表
rcmd 遠程命令設置命令
rcp-enable 打開Rep服務
rif 源路由進程
router-map 建立路由表或進入路由表命令模式
router 打開一個路由進程
rsh-enable 打開一個RSH服務
sap-priority-list 在SAP或MAC地址上建立一個優先隊列
service 修改網路基本服務
snmp-server 修改SNMP參數
state-machine 定義一個TCP分配狀態的機器
stun STUN全局設置命令
tacacs-server 修改TACACS隊列參數
terminal-queue 終端隊列命令
tftp-server 為網路裝載請求提供TFTP服務
tn3270 tn3270設置命令
translate 解釋全局設置命令
username 建立一個用戶名及其許可權
vines VINES全局設置命令
x25 X.25 的第三級
x29 X.29 命令
xns XNS 全局設置命令
xremote 設置Xremote

5、(config)#ip

Global IP configuration subcommands:
Accounting-list 選擇保存IP記帳信息的主機
Accounting-threshold 設置記帳入口的最大數
accounting-transits 設置通過入口的最大數
alias TCP埠的IP地址取別名
as-path BGP自治系統路徑過濾
cache-invalidate-delay 延遲IP路由存貯池的無效
classless 跟隨無類前向路由規則
default-network 標志網路作為預設網關候選
default-gateway 指定預設網(如果沒有路由IP)
domain-list 完成無資格主機的域名
domain-lookup 打開IP域名服務系統主機轉換
domain-name 定義預設域名
forward-protocol 控制前向的、物理的、直接的IP廣播
host 為IP主機表增加一個入口
host-routing 打開基於主機的路由(代理ARP和再定向)
hp-host 打開HP代理探測服務
mobile-host 移動主機資料庫
multicast-routing 打開前向IP
name-server 指定所用名字伺服器的地址
ospf-name-lookup 把OSPF路由作為DNS名顯示
pim PIM 全局命令
route 建立靜態路由
routing 打開IP路由
security 指定系統安全信息
source-route 根據源路由頭的選擇處理包
subnet-zero 允許子網0子網
tcp 全局TCP參數

⑺ 思科路由器基礎配置命令

基礎配置命令如下
一、1.router(config)#router rip 啟動rip進程
2.router(conifg-router)#network 172.17.0.0指定rip協議的主網路
3.router(config-router)#passive-interface f0/1把f0/1配置成passive埠
4.router(config-router)#neighbor 172.17.12.67 以單波方式通告rip更新給路由器
5.router(config-if)#ip address 192.168.83.244 255.255.255.0 主ip地址
router(config-if)#ip address 10.33.55.1 255.255.255.0 secondary輔助ip地址
二、1.router(config-router)#version 2將rip配置成版本2
2.router(config-ip)#ip rip send version 1隻發rip 1數據包
router(config-ip)#ip rip receive version 2隻接收rip 2數據包
3.router(config-router)#no auto-summary 關閉匯總功能
4.router(config-if)#no ip split-horizon關閉水平分割
5.router#show ip ospf database router 192.168.30.10顯示路由器LSA通告
router#show ip ospf database network 192.168.17.18顯示網路LSA通告
router#show ip ospf database summary 172.16.121.0顯示網路匯總LSA通告
router#show ip ospf database asbr-summary顯示ASBR匯總LSA通告
router#show ip ospf database external 10.83.10.0顯示自主系統外部LSA通告
router#show ip ospf database nssa-external顯示NSSA外部LSA通告
三、1.router(config)#router ospf 10配置ospf進程id
2.router(config)#interface loopback0
router(config-if)#ip address 192.168.10.1 255.255.255.0配置loopback0介面
3.router(config-router)#area 1 stub 配置stub區域
4.router(config-router)#area 1 stub no-summary配置totally stubby區域
5.router(config-router)#area 1 nssa配置nssa區域
6.router(config-router)#area 25 range 172.16.0.0 255.240.0.0 配置地址匯總
7.router(config-router)#area 100 virtual-link 192.168.100.33 配置虛鏈路
四、1.router(config)#standby 172 ip 172.16.10.254加入備份組172 指定虛擬IP 地址
2.router(config-if)#standby 47 priority 150配置HSRP的優先順序150
3.router(config-if)#standby 47 preempt 配置HSRP的佔先權
4.router(config-if)#standby 47 ip time 2 9 2表示HELLO時間,9表示保持時間
5.router(config)#interface s0
6.router(config-if)#standby 47 track s0 100配置跟蹤埠s0並在埠down時減少100
7.router#show standby brief 查看HSRP的狀態
8.router#no debuge all關閉調試功能
五、1.router(config-if)#ip access-group 1 in 訪問列表的入
router(config-if)#ip access-group 1 out訪問列表的出
2.router(config)#access-list 1 premit 192.168.10.0 0.0.0.255 允許192.168.10.0的網段通過
router(config)#access-list 1 deny 192.168.10.0 2.0.0.255 拒絕192.168.10.2的主機通過
3.router(config)#access-list 1 premit any ;any表示0.0.0.0 255.255.255.255
router(config)#access-list 1 premit host 172.30.16.29 ;host表示0.0.0.0
4.router(config)#access-list 101 deny tcp 172.16.4.0 0.0.0.255 172.16.3.0 0.0.0.255 eq 21拒絕來自172.16.4.0去往172.16.3.0的FTP流量
5.router(config)#ip access-list extended cisco創建名為cisco的命名訪問控制列表
六、靜態地址轉換1.配置外部埠的IP地址
Router(config)#interface s0
Router(config-if)#ip address 61.159.62.129 255.255.255.248
2.配置內部埠的IP地址
Router(config)#interface e0
Router(config-if)#ip address 192.168.100.1 255.255.255.0
3.靜態地址轉換
Router(config)#ip nat inside source static 192.168.100.2 61.159.62.130
4.在內部和外部埠上啟用NAT
Router(config)#interafce s0
Router(config-if)#ip nat outside
Router(config)#interafce e0
Router(config-if)#ip nat inside
七、動態NAT配置1.配置外部埠的IP地址
Router(config)#interface s0
Router(config-if)#ip address 61.159.62.129 255.255.255.248
2.配置內部埠的IP地址
Router(config)#interface e0
Router(config-if)#ip address 192.168.100.1 255.255.255.0
3.定義內部網路允許訪問外部網路
Router(config)#access-list 1 permit 192.168.100.0 0.0.0.255
4.定義合法的IP地址池
Router(config)#ip nat pool chen 61.159.62.129 61.159.62.190 netmask 255.255.255.248
5.實現網路地址轉換
Router(config)#ip nat inside source list 1 pool chen
6.在內部和外部埠上啟用NAT
Router(config)#interafce s0
Router(config-if)#ip nat outside
Router(config)#interafce e0
Router(config-if)#ip nat inside
八、PAT的配置1.配置外部埠的IP地址
Router(config)#interface s0
Router(config-if)#ip address 61.159.62.129 255.255.255.248
2.配置內部埠的IP地址
Router(config)#interface e0
Router(config-if)#ip address 192.168.100.1 255.255.255.0
3.定義內部網路允許訪問外部網路
Router(config)#access-list 1 permit 192.168.100.0 0.0.0.255
4.定義合法的IP地址池
Router(config)#ip nat pool chen 61.159.62.129 61.159.62.190 netmask 255.255.255.248
5.實現復用IP地址轉換
Router(config)#ip nat inside source list 1 pool chen overload
6.在內部和外部埠上啟用NAT
Router(config)#interafce s0
Router(config-if)#ip nat outside
Router(config)#interafce e0
Router(config-if)#ip nat inside

閱讀全文

與ciscodebug命令相關的資料

熱點內容
冷撲大師演算法 瀏覽:373
重復數據比對演算法 瀏覽:740
golang調用python 瀏覽:171
hsc伺服器做raid0怎麼做 瀏覽:231
android50源代碼 瀏覽:127
程序員需要本科學位證書嗎 瀏覽:775
手機版wps許多文檔如何放到文件夾 瀏覽:687
安卓手機怎麼退出帳戶 瀏覽:767
夜神安卓模擬器怎麼刪 瀏覽:561
運行命令無法打開共享 瀏覽:524
安卓怎麼與單片機交互 瀏覽:736
linux下tcpdump 瀏覽:919
華為榮耀手機隱藏文件夾方法 瀏覽:535
python怎麼做簡單線性回歸模型 瀏覽:252
安卓系統電視是什麼 瀏覽:343
全款買了房開發商遲遲不解壓 瀏覽:812
linux退出oracle 瀏覽:652
不能截圖的app怎麼截長圖 瀏覽:307
pythonwindows窗口程序 瀏覽:621
怎麼把app投送到ipad 瀏覽:833