導航:首頁 > 程序命令 > cisco命令配置

cisco命令配置

發布時間:2023-06-02 23:00:08

A. Cisco基礎配置命令#注釋

R1(config)#banner motd # 提示信息,#(分界符)

設置console密碼

R1(config)#line console 0 進入console 0

R1(config-line)#login 允許登陸

R1(config-line)#password cisco 設置密碼

R1(config-line)#logging synchronous 使游標還原到原來的位置,重新顯示被覆蓋的命令里

R1(config-line)#exec-timeout 0 0 阻止會話退出(前1個0單位是「分鍾」,後1個0單位是「秒」)

設置特權密碼

#enable password cisco 設置明文密碼cisco(進特權模式密碼)

#service password-encryption 加密上面的明文密碼

#enable secret cisco1 設置密文密碼cisco1(進特權模式密碼)

當明文密碼和密文密碼同時存在時,密碼密碼的優先順序要高於明文密碼

R1(config)#line vty 0 4 設置虛擬終端 允許0~4共5個用戶同時登陸

R1(config-line)#password cisco 設置明文密碼cisco

R1(config-line)#login local 登陸採用本地密碼驗證

R1(config)# running-config startup-config 保存配置

R1#show startup-config 查看NVRAM裡面的配置

R1#reload 重新啟動

R1(config)#interface ethernet 0 進入介面模式

R1(config-if)#description Telecom 提示信息

R1(config-if)#ip add 10.10.10.1 255.255.255.0

R1#show interfaces serial 1 查看介面狀態,如果封裝協議不同會顯示一端介面up,另一端介面down

R1#show interfaces serial 0

R1#show controller serial 0 查看哪一端是DCE或DTE

R1(config)#interface serial 0 進入子介面

R1(config-if)#clock rate 64000 必須在DCE端配置,兩個路由器之間通訊必須配置時鍾同步

R1(config-if)#no shutdown 開啟埠

R1#show cdp 思科專有發現協議CDP,發現直接相鄰的設備

entry 詳細信息 show cdp entry *

interface 介面

neighbors 鄰居

traffic 介面數據包情況匯總

R1(config)#no cdp run 所有介面取消CDP

R1(config)#interface serial 0 假如我想只關掉serial 0介面的CDP協議,進入介面

R1(config-if)#no cdp enable 關閉這個介面CDP

Router>en 進特權模式

Router#conf t 進全局模式

Router(config)#line con 0 進console口

Router(config-line)#logg sy 游標跟隨不覆蓋命令

Router(config-line)#exec-t 0 0 會話永不超時

Router(config-line)#exi 退回上層

Router(config)#no ip domain-lo 取消域名解析

Router(config)#host R1 重命名路由器名稱

創建VLAN

SW#vlan database 進入vlan模式

SW(vlan)#vlan 2 name cisco 創建vlan2並命名為cisco

SW(config)#int fa 0/2 在全局模式下進入快速乙太網介面2

SW(config-if)#switchport mode access 定義埠為訪問介面模式(介面模式分為"trunk"主幹介面和訪問介面)

SW(config-if)#switchport access vlan 2 將埠2加入到vlan2中

SW(config-if)#no shutdown

Trunk配置

SW#vlan database

SW#conf t

SW(config)#int fa 0/1

SW(config-if)#switchport mode trunk 定義埠為主幹介面模式

SW(config-if)#switchport trunk encapsulation dot1q 封裝dot1q協議

SW(config-if)#no shutdown

Telnet相關命令

Router#show session 查看連接的是哪台設備

Router#show user 查看登錄的用戶

RouterB# X 先按Ctrl+Shift+6然後再按X就切換到路由A上面

RouterA#show session

RouterA#resume 1 返回到路由器B上面

RouterB# disconnect 斷開連接

RouterA#clear line 0 清除遠端設備建立的會話

show version ! 檢查配置寄存器的值

show flash ! 檢查Flash中的ISO

show startup-config ! 檢查NVRAM中的啟動配置文件

show running-config ! 檢查RAM中的文件

Router#erase startup-config 刪除NVRAM中的配置文件

Router(config)#config-register 0x2101 修改寄存器的值(0x2102 正常的值,0x2142 跳過配置文件,0x2101 進入迷你ios)

Router# running-config startup-config 保存配置文件

Router#write 保存配置文件(全程保存配置)

cisco2600、3600等新系列路由器密碼破解

1.啟動路由器,60秒內按下CTRL+break鍵

2.rommon>confreg 0x2142 配置啟動時不引導配置文件

3.rommon>reset 重啟

4.router# startup-config running-config 將NVRAM裡面的配置文件拷貝到內存中(進特權模式操作)

5.router(config)#no enable secrect 取消特權密碼

6.router(config-line)#no password 取消vty密碼

7.router# running-config startup 保存

8.router(config)#config-register 0x2102

配置VTP

SW#vlan database

SW(vlan)#vtp server VTP伺服器端,另一台交換機設置為client客戶端

SW(vlan)#vtp domain cisco 設置VTP域名為cisco ,客戶端同樣設置

SW(vlan)#vtp password cisco 設置密碼為cisco ,客戶端同樣設置

B. cisco 3750交換機上如何設置靜態ARP表的命令

在cisco交換機中為了防止ip被盜用或員工亂改ip,可以做以下措施,即ip與mac地址的綁定和ip與交換機埠的綁定。

一、通過IP查埠

先查Mac地址,再根據Mac地址查埠:

bangonglou3#show arp | include 208.41 或者show mac-address-table 來查看整個埠的ip-mac表

Internet 10.138.208.41 4 0006.1bde.3de9 ARPA Vlan10

bangonglou3#show mac-add | in 0006.1bde 10 0006.1bde.3de9 DYNAMIC Fa0/17

bangonglou3#exit

二、ip與mac地址的綁定,這種綁定可以簡單有效的防止ip被盜用,別人將ip改成了你綁定了mac地址的ip後,其網路不通:

(tcp/udp協議不同,但netbios網路共項可以訪問),具體做法:

cisco(config)#arp 10.138.208.81 0000.e268.9980 ARPA

這樣就將10.138.208.81 與mac:0000.e268.9980 ARPA綁定在一起了

三、ip與交換機埠的綁定,此種方法綁定後的埠只有此ip能用,改為別的ip後立即斷網。有效的防止了亂改ip。

cisco(config)# interface FastEthernet0/17

cisco(config-if)# ip access-group 6 in

cisco(config)#access-list 6 permit 10.138.208.81

這樣就將交換機的FastEthernet0/17埠與ip:10.138.208.81綁定了。

C. CISCO交換機的查看配置命令是什麼

1、Router#show startup-config //查看啟動配置文件

啟動配置文件startup-config位於路由器的NVRAM中,可以長期保存。它在啟動路由器時裝入RAM,成為running-config。

2、Router#show version //查看路由器的版本信息

3、Router#show ip interface brief //查看路由器的介面狀態

(3)cisco命令配置擴展閱讀:

工作在數據鏈路層。交換機擁有一條很高帶寬的背部匯流排和內部交換矩陣。交換機的所有的埠都掛接在這條背部匯流排上,控制電路收到數據包以後,處理埠會查找內存中的地址對照表以確定目的MAC(網卡的硬體地址)的NIC(網卡)掛接在哪個埠上。

通過內部交換矩陣迅速將數據包傳送到目的埠,目的MAC若不存在,廣播到所有的埠,接收埠回應後交換機會「學習」新的地址,並把它添加入內部MAC地址表中。使用交換機也可以把網路「分段」,通過對照MAC地址表,交換機只允許必要的網路流量通過交換機。

通過交換機的過濾和轉發,可以有效的減少沖突域,但它不能劃分網路層廣播,即廣播域。交換機在同一時刻可進行多個埠對之間的數據傳輸。每一埠都可視為獨立的網段,連接在其上的網路設備獨自享有全部的帶寬,無須同其他設備競爭使用。當節點A向節點D發送數據時,節點B可同時向節點C發送數據,而且這兩個傳輸都享有網路的全部帶寬,都有著自己的虛擬連接。

假使這里使用的是10Mbps的乙太網交換機,那麼該交換機這時的總流通量就等於2×10Mbps=20Mbps,而使用10Mbps的共享式HUB時,一個HUB的總流通量也不會超出10Mbps。

總之,交換機是一種基於MAC地址識別,能完成封裝轉發數據包功能的網路設備。交換機可以「學習」MAC地址,並把其存放在內部地址表中,通過在數據幀的始發者和目標接收者之間建立臨時的交換路徑,使數據幀直接由源地址到達目的地址。

D. 配置 CISCO telnet 命令

1、switch> enable進去全局模式

2、switch#configure terminal進入配置模式

3、switch(conf)#hostname Nuctech-Core-01交換機命名

4、Nuctech-Core-01 #enable password nuctech或者Nuctech-Core-01 # enable secret cisco配置密碼

5、Nuctech-Core-01 #interface vlan 1進入VLAN1

6、Nuctech-Core-01(conf)# ip address 192.168.111.201 255.255.255.0 給VLAN1配置IP地址

7、Nuctech-Core-01 (conf- if)#no shut打開埠

8、Nuctech-Core- 01 (conf if)#exit退出配置模式也可不退出

9、Nuctech-Core 01 (confline vty 0 4配置虛擬連接數量

10、Nuctech-Core-01(conf-line)#login設置允許登錄

11、Nuctech-Core-01 (conf-line)#password nuctech設置登錄密碼

12、Nuctech-Core-01 (conf-line)#exit退出

13、Nuctech-Core-01 (conf-if)#exit退出

14、Nuctech-Core-01 #write保存配置

(4)cisco命令配置擴展閱讀

CISCO交換機功能

交換機的主要功能包括物理編址、網路拓撲結構、錯誤校驗、幀序列以及流控。如今交換機還具備了一些新的功能,如對VLAN(虛擬區域網)的支持、對鏈路匯聚的支持,甚至有的還具有防火牆的功能。

學習:乙太網交換機了解每一埠相連設備的MAC地址,並將地址同相應的埠映射起來存放在交換機緩存中的MAC地址表中。

轉發/過濾:當一個數據幀的目的地址在MAC地盯宏址表中有映射時,它被轉發到連接目的節點的埠而不是所有埠(如該數據幀為廣播/組播幀則轉發至所有埠)。

消除迴路:當交換機包括一個冗餘迴路時,乙太網交換機通過生成樹協議避免迴路的產生,緩清同時允許存在後備路徑。

交換機除了能夠連接同種類型的網路之外,還可以在不同類型的網路(如乙太網和快速乙太網)之間起到互連作用。如今許多交換機都能夠提供支持快速乙太網或FDDI等的高速連接埠,用於連接網路中的其它交換機或者為帶寬佔用量大的關鍵伺服器提供附加帶寬。

最後簡略的概括一下交換機的基本功能:

1. 像集線器一樣,交換機提供了大量可供線纜連接的埠,這樣可以採用星型拓撲布線。

2. 像中繼器、集線器和網橋那樣,當它轉發幀時,交換機會重新產生一個不失真的方形電信號。

3. 像網橋那樣,交換機在每個埠上都使用相同的轉發或過濾邏輯。

4. 像網橋那樣,交換機將區域網分為多個沖突域,每個沖突域都是有獨立的寬頻,因此大大提高了區域網的帶寬。

5. 除了具有網橋、集線器和中繼器的功能以外,交換機還提供了更先進的功能,如虛擬區域網(VLAN)和更高的性能擾則前。

E. Cisco路由器配置命令

Cisco路由器配置命令大全

為方便考生復習思科路由器的配置,以下是我為大家整理的Cisco路由器配置命令,歡迎閱讀與收藏。

1. switch配置命令

(1)模式轉換命令

用戶模式----特權模式, 使用命令"enable"

特權模式----全局配置模式, 使用命令"config t"

全局配置模式----介面模式, 使用命令"interface+介面類型+介面號"

全局配置模式----線控模式, 使用命令"line+介面類型+介面號"

注:

用戶模式:查看初始化的信息.

特權模式:查看所有信息、調試、保存配置信息

全局模式:配置所有信息、針對整個路由器或交換機的所有介面

介面模式:針對某一個介面的配置

線控模式:對路由器進行控制的介面配置

(2)配置命令

show running config 顯示所有的配置

show versin 顯示版本號和寄存器值

shut down 關閉介面

no shutdown 打開介面

ip add +ip地址 配置IP地址

secondary+IP地址 為介面配置第二個IP地址

show interface+介面類型+介面號 查看介面管理性

show controllers interface 查看介面是否有DCE電纜

show history 查看歷史記錄

show terminal 查看終端記錄大小

hostname+主機名 配置路由器或交換機的標識

config memory 修改保存在NVRAM中的啟動配置

exec timeout 0 0 設置控制台會話超時為0

service password-encryptin 手工加密所有密碼

enable password +密碼 配置明文密碼

ena sec +密碼 配置密文密碼

line vty 0 4/15 進入telnet介面

password +密碼 配置telnet密碼

line aux 0 進入AUX介面

password +密碼 配置密碼

line con 0 進入CON介面

password +密碼 配置密碼

bandwidth+數字 配置帶寬

no ip address 刪除已配置的IP地址

show startup config 查看NVRAM中的配置信息

run-config atartup config 保存信息到NVRAM

write 保存信息到NVRAM

erase startup-config 清除NVRAM中的配置信息

show ip interface brief 查看介面的謫要信息

banner motd # +信息 + # 配置路由器或交換機的描素信息

description+信息 配置介面聽描素信息

vlan database 進入VLAN資料庫模式

vlan +vlan號+ 名稱 創建VLAN

switchport access vlan +vlan號 為VLAN為配介面

interface vlan +vlan號 進入VLAN介面模式

ip add +ip地址 為VLAN配置管理IP地址

vtp+service/tracsparent/client 配置SW的VTP工作模式

vtp +domain+域名 配置SW的VTP域名

vtp +password +密碼 配置SW的密碼

switchport mode trunk 啟用中繼

no vlan +vlan號 刪除VLAN

show spamming-tree vlan +vlan號 查看VLA怕生成樹議

2. 路由器配置命令

ip route+非直連網段+子網掩碼+下一跳地址 配置靜態/默認路由

show ip route 查看路由表

show protocols 顯示出所有的被動路由協議和介面上哪些協議被設置

show ip protocols 顯示了被配置在路由器上的路由選擇協議, 同時給出了在路由選擇協議中使用的定時器等信息

router rip 激活RIP協議

路由器的幾個基本命令:

Router>enable 進入特權模式

Router#disable 從特權模式返回到用戶模式

Router#configure terminal 進入到全局配置模式

Router(config)#interface ethernet 1 進入到路由器編號為1的乙太網口

exit 返回上層模式

end 直接返回到特權模式

========================================================

注意:

1、CISCO CATALYST(交換機),如果在初始化時沒有發現「用戶配置」文件,就會自動載入Default Settings(默認配置)文件,進行交換機初始化,以確保交換機正常工作。

2、CISCO Router(路由器)在初始化時,如果沒有發現「用戶配置」文件,系統會自動進入到「初始化配置模式」(系統配置對話模式,SETUP模式, STEP BY STEP CONFIG模式),不能正常工作!

========================================================

1、CONSOLE PORT(管理控制台介面):距離上限制,獨占的方式。剛開始配置的時候一般使用這個。

2、AUX port(輔助管理介面):可以掛接MODEM實現遠程管理,獨占的方式。

3、Telnet:多人遠程管理(決定於性能,VTY線路數量)不安全。後期維護,遠程管理登陸。

========================================================

注意:

交換機、路由器配置命令都是回車後立即執行,立即生效的。在運行中的機器上修改命令的時候要特別注意。

========================================================

Router(config)#hostname ?

WORD This system's network name

在配置模式下修改當前主機的本地標識,例:

------------------

Router(config)#hostname r11

r11(config)#

------------------

r11(config-if)#ip address ?

A.B.C.D IP address

為當前埠設置IP地址,使用前先進入需要配置的埠,例:

------------------

r11(config)#interface ethernet 1

r11(config-if)#ip address 172.16.1.1 255.255.255.0

------------------

r11>show version

r11#show version 觀察IOS版本,設備工作時間,相關介面列表

r11#show running-config 查看當前生效的配置,此配置文件存儲在RAM

r11#show interfaces ethernet 1 查看乙太網介面的狀態,工作狀態等等等...

========================================================

r11#reload 重新載入Router(重啟)

r11#setup 手工進入setup配置模式

r11#show history 查看歷史命令(最近剛用過的命令)

r11#terminal history size<0-256>設置命令緩沖區大小,0 : 代表不緩存

r11# running-config startup-config 保存當前配置

注意概念:

nvram:非易失性內存,斷電信息不會丟失 <-- 用戶配置 <-- 保存著startup-config

ram:隨機存儲器,斷電信息全部丟失 <-- 當前生效配置 <-- 保存著running-config

startup-config:在每次路由器或是交換機啟動時候,會主動載入(默認情況)

========================================================

設置說明和密碼的幾個命令:

r11(config)#banner motd [char c] 同時要以[char c]另起一行結束,描述機器登陸時的說明

r11(config-if)#description 描述介面注釋,需要在埠配置模式下

配置console口密碼:

------------------

r11(config)#line console 0 進入到consolo 0

r11(config-line)#password eliuzd 設置一個密碼為「eliuzd」

r11(config-line)#login 設置login(登陸)時使用密碼

------------------

配置enable密碼:

------------------

r11(config)#enable password cisco 設置明文的enable密碼

r11(config)#enable secret eliuzd 設置暗文的enable密碼(優先於明文被使用)

r11(config)#service password-encryption 加密系統所有明文密碼(功能較弱)

------------------

配置Telnet密碼:

------------------

r11(config)#line vty 0

r11(config-line)#password cisco

r11(config-line)#login

------------------

========================================================

配置虛擬回環介面:(回環介面默認為UP狀態)

(config)# 下,虛擬一個埠

------------------

r11(config)#interface loopback 0 創建一個回環介面loopback 0

r11(config-if)#ip address 192.168.1.1 255.255.255.0 配置它的IP地址

no * 做配置的反向操作(刪除配置)

------------------

=========================================================

路由器 DCE/DTE 僅存在廣域網中

r11#show controllers serial 0 用於查看DCE與DTE的屬性,serial 0路由器廣域網埠

DCE的Router需要配置時鍾頻率

r11(config-if)#clock rate ? 配置DCE介面的時鍾頻率(系統指定頻率)

一般實際情況下,這個不需要自己配置,因為DCE設備都在運營商那。

=========================================================

r11#show interfaces serial 1

查看埠狀態,第一行提示說明

Serial1 is administratively down, Line protocol is down

沒有使用no shutdown命令激活埠

Serial1 is down, Line protocol is down

1、對方沒有no shutdown激活埠

2、線路損壞,介面沒有任何連接線纜

Serial1 is up, line protocol is down

1、對方沒有配置相同的二層協議,Serial介面default encapsulation: HDLC

2、可能沒有配置時鍾頻率

3、可能沒有正確的配置三層地址(可能)

Serial1 is up,line protocol is up

介面工作正常

========================================================

查看CDP信息的幾個命令:

r11#show cdp neighbors 查看CDP的鄰居(不含IP)

r11#show cdp neighbors detail 查看CDP的鄰居(包含三層的IP地址)

r11#show cdp entry * 查看CDP的鄰居(包含三層的IP地址)老命令

r1(config)#no cdp run 在全局配置模式關閉CDP協議(影響所有的介面)

r1(config-if)#no cdp enable 在介面下關閉CDP協議(僅僅影響指定的介面)

r11#clear cdp table 清除CDP鄰居表

r11#show cdp interface serial 1 查看介面的CDP信息

注意兩個提示:

Sending CDP packets every 60 seconds(每60秒發送cdp數據包)

HoldTime 180 seconds(每個cdp數據包保持180秒)

========================================================

r11(config)#ip host 設置靜態的主機名映射

r11#show sessions 查看設置過的映射主機名

========================================================

Telnet *.*.*.* 被telnet的設備,需要設置line vty的密碼,如果需要進入特權模式需要配置enable密碼

F. 思科路由器配置命令一覽表是什麼

思科路由器常用配置命令一覽表: x0dx0a1、Exec commands: x0dx0a<1-99> 恢復一個會話 x0dx0abfe 手工應急模式設置 x0dx0aclear 復位功能 x0dx0aclock 管理系統時鍾 x0dx0aconfigure 進入設置模式 x0dx0aconnect 打開一個終端 x0dx0a 從tftp伺服器拷貝設置文件或把設置文件拷貝到tftp伺服器上 x0dx0adebug 調試功能 x0dx0adisable 退出優先命令狀態 x0dx0adisconnect 斷開一個網路連接 x0dx0aenable 進入優先命令狀態 x0dx0aerase 擦除快閃內存 x0dx0aexit 退出exce模式 x0dx0ahelp 交互幫助系統的描述 x0dx0alat 打開一個本地傳輸連接 x0dx0alock 鎖定終端 x0dx0alogin 以一個用戶名登錄 x0dx0alogout 退出終端 x0dx0ambranch 向樹形下端分支跟蹤多路由廣播 x0dx0amrbranch 向樹形上端分支跟蹤反向多路由廣播 x0dx0aname-connection 給一個存在的網路連接命名 x0dx0ano 關閉調試功能 x0dx0apad 打開X.29 PAD連接 x0dx0aping 發送回顯信息 x0dx0appp 開始點到點的連接協議 x0dx0areload 停機並執行冷啟動 x0dx0aresume 恢復一個活動的網路連接 x0dx0arlogin 打開遠程注冊連接 x0dx0arsh 執行一個遠端命令 x0dx0asend 發送信息到另外的終端行 x0dx0asetup 運行setup命令 x0dx0ashow 顯示正在運行系統信息 x0dx0aslip 開始SLIP協議 x0dx0astart-chat 在命令行上執行對話描述 x0dx0asystat 顯示終端行的信息 x0dx0atelnet 遠程登錄 x0dx0aterminal 終端行參數 x0dx0atest 測試子系統內存和埠 x0dx0atn3270 打開一個tin3270連接 x0dx0atrace 跟蹤路由到目的地 x0dx0aundebug 退出調試功能 x0dx0averify 驗證檢查閃爍文件的總數 x0dx0awhere 顯示活動的連接 x0dx0awhich-route 執行OSI路由表查找並顯示結果 x0dx0awrite 把正在運行的設置寫入內存、網路、或終端 x0dx0ax3 在PAD上設置X.3參數 x0dx0axremote 進入xremote模式 x0dx0ax0dx0a2、#show ? x0dx0ax0dx0aaccess-expression 顯示訪問控製表達式 x0dx0aaccess-lists 顯示訪問控製表 x0dx0aapollo Apollo 網路信息 x0dx0aappletalk Apple Talk 信息 x0dx0aarap 顯示Appletalk 遠端通道統計 x0dx0aarp 地址解析協議表 x0dx0aasync 訪問路由介面的終端行上的信息 x0dx0abridge 前向網路資料庫 x0dx0abuffers 緩沖池統計 x0dx0aclns CLNS網路信息 x0dx0aclock 顯示系統時鍾 x0dx0acmns 連接模式網路服務信息 x0dx0acompress 顯示壓縮狀態 x0dx0aconfiguration 非易失性內存的內容 x0dx0acontrollers 埠控制狀態 x0dx0adebugging 調試選項狀態 x0dx0adecnet DEC網路信息 x0dx0adialer 撥號參數和統計 x0dx0adnsix 顯示Dnsix/DMPP信息 x0dx0aentry 排隊終端入口 x0dx0aextended 擴展埠信息 x0dx0aflash 系統閃爍信息 x0dx0aflh-log 閃爍裝載幫助日誌緩沖區 x0dx0aframe-relay 幀中繼信息 x0dx0ahistory 顯示對話層歷史命令 x0dx0ahosts IP域名,查找方式,名字服務,主機表 x0dx0ainterfaces 埠狀態和設置 x0dx0aip IP信息 x0dx0aipx Novell IPX信息 x0dx0aisis IS-IS路由信息 x0dx0akeymap 終端鍵盤映射 x0dx0alat DEC LAT信息 x0dx0aline 終端行信息 x0dx0allc2 IBM LLC2 環路信息 x0dx0alnm IBM 局網管理 x0dx0alocal-ack 本地認知虛環路 x0dx0amemory 內存統計 x0dx0anetbios-cache NetBios命名緩沖存貯器內存 x0dx0anode 顯示已知LAT節點 x0dx0antp 網路時間協議 x0dx0aprocesses 活動進程統計 x0dx0aprotocols 活動網路路由協議 x0dx0aqueue 顯示隊列內容 x0dx0aqueueing 顯示隊列設置 x0dx0aregistry 功能注冊信息 x0dx0arhosts 遠程主機文件 x0dx0arif RIF存貯器入口 x0dx0aroute-map 路由器信息 x0dx0asdlle 顯示sdlc-llc2轉換信息 x0dx0aservices 已知LAT服務 x0dx0asessions 遠程連接信息 x0dx0asmds SMDS信息 x0dx0asource-bridge 源網橋參數和統計 x0dx0aspanning-tree 跨越樹形拓樸 x0dx0astacks 進程堆棧應用 x0dx0astandby 熱支持協議信息 x0dx0astun STUN狀態和設置 x0dx0asubsystem 顯示子系統 x0dx0atcp TCP連接狀態 x0dx0aterminal 顯示終端設置 x0dx0atn3270 TN3270 設置 x0dx0atranslate 協議轉換信息 x0dx0attycap 終端容易表 x0dx0ausers 顯示終端行的信息 x0dx0aversion 系統硬、軟體狀態 x0dx0avines VINES信息 x0dx0awhoami 當前終端行信息 x0dx0ax25 X.25信息 x0dx0axns XNS信息 x0dx0axermote Xremote統計 x0dx0ax0dx0a3、#config ? x0dx0ax0dx0aMemory 從非易失性內存設置 x0dx0aNetwork 從TFTP網路主機設置 x0dx0aOverwrite-network 從TFTP網路主機設置覆蓋非易失性內存 x0dx0aTerminal 從終端設置 x0dx0ax0dx0a4、Configure commads: x0dx0ax0dx0aAccess-list 增加一個訪問控制域 x0dx0aApollo Apollo全局設置命令 x0dx0aappletalk Appletalk 全局設置命令 x0dx0aarap Appletalk遠程進出協議 x0dx0aarp 設置一個靜態ARP入口 x0dx0aasync-bootp 修改系統啟動參數 x0dx0aautonomous-system 本地所擁有的特殊自治系統成員 x0dx0abanner 定義注冊顯示信息 x0dx0aboot 修改系統啟動時參數 x0dx0abridge 透明網橋 x0dx0abuffers 調整系統緩沖池參數 x0dx0abusy-message 定義當連接主機失敗時顯示信息 x0dx0achat-script 定義一個數據機對話文本 x0dx0aclns 全局CLNS設置子命令 x0dx0aclock 設置時間時鍾 x0dx0aconfig-register 定義設置寄存器 x0dx0adecnet 全局DEC網路設置子命令 x0dx0adefault-value 預設字元位值 x0dx0adialer-list 創建一個撥號清單入口 x0dx0adnsix-nat 為審計提供DMDM服務 x0dx0aenable 修改優先命令口令 x0dx0aend 從設置模式退出 x0dx0aexit 從設置模式退出 x0dx0aframe-relay 全局幀中繼設置命令 x0dx0ahelp 交互幫助系統的描述 x0dx0ahostname 設置系統網路名 x0dx0aiterface 選擇設置的埠 x0dx0aip 全局地址設置子命令 x0dx0aipx Novell/IPX全局設置命令 x0dx0akeymap 定義一個新的鍵盤映射 x0dx0alat DEC本地傳輸協議 x0dx0aline 設置終端行 x0dx0alnm IBM局網管理 x0dx0alocaddr-priority-list 在LU地址上建立優先隊列 x0dx0alogging 修改注冊(設備)信息 x0dx0alogin-string 定義主機指定的注冊字元串 x0dx0amap-class 設置靜態表類 x0dx0amap-list 設置靜態表清單 x0dx0amenu 定義用戶介面菜單 x0dx0amop 設置DEC MOP伺服器 x0dx0anetbios NETBIOS通道控制過濾 x0dx0ano 否定一個命令或改為預設設置 x0dx0antp 設置NTP x0dx0apriority-list 建立特權列表 x0dx0aprompt 設置系統提示符 x0dx0aqueue-list 建立常規隊列列表 x0dx0arcmd 遠程命令設置命令 x0dx0arcp-enable 打開Rep服務 x0dx0arif 源路由進程 x0dx0arouter-map 建立路由表或進入路由表命令模式 x0dx0arouter 打開一個路由進程 x0dx0arsh-enable 打開一個RSH服務 x0dx0asap-priority-list 在SAP或MAC地址上建立一個優先隊列 x0dx0aservice 修改網路基本服務 x0dx0asnmp-server 修改SNMP參數 x0dx0astate-machine 定義一個TCP分配狀態的機器 x0dx0astun STUN全局設置命令 x0dx0atacacs-server 修改TACACS隊列參數 x0dx0aterminal-queue 終端隊列命令 x0dx0atftp-server 為網路裝載請求提供TFTP服務 x0dx0atn3270 tn3270設置命令 x0dx0atranslate 解釋全局設置命令 x0dx0ausername 建立一個用戶名及其許可權 x0dx0avines VINES全局設置命令 x0dx0ax25 X.25 的第三級 x0dx0ax29 X.29 命令 x0dx0axns XNS 全局設置命令 x0dx0axremote 設置Xremote x0dx0ax0dx0a5、(config)#ip x0dx0ax0dx0aGlobal IP configuration subcommands: x0dx0aAccounting-list 選擇保存IP記帳信息的主機 x0dx0aAccounting-threshold 設置記帳入口的最大數 x0dx0aaccounting-transits 設置通過入口的最大數 x0dx0aalias TCP埠的IP地址取別名 x0dx0aas-path BGP自治系統路徑過濾 x0dx0acache-invalidate-delay 延遲IP路由存貯池的無效 x0dx0aclassless 跟隨無類前向路由規則 x0dx0adefault-network 標志網路作為預設網關候選 x0dx0adefault-gateway 指定預設網(如果沒有路由IP) x0dx0adomain-list 完成無資格主機的域名 x0dx0adomain-lookup 打開IP域名服務系統主機轉換 x0dx0adomain-name 定義預設域名 x0dx0aforward-protocol 控制前向的、物理的、直接的IP廣播 x0dx0ahost 為IP主機表增加一個入口 x0dx0ahost-routing 打開基於主機的路由(代理ARP和再定向) x0dx0ahp-host 打開HP代理探測服務 x0dx0amobile-host 移動主機資料庫 x0dx0amulticast-routing 打開前向IP x0dx0aname-server 指定所用名字伺服器的地址 x0dx0aospf-name-lookup 把OSPF路由作為DNS名顯示 x0dx0apim PIM 全局命令 x0dx0aroute 建立靜態路由 x0dx0arouting 打開IP路由 x0dx0asecurity 指定系統安全信息 x0dx0asource-route 根據源路由頭的選擇處理包 x0dx0asubnet-zero 允許子網0子網 x0dx0atcp 全局TCP參數

G. 思科路由器設置方法和常見配置命令

思科路由器設置方法和常見配置命令

思科路由器怎麼設置,是我們經常遇到的問題,下面我准備了關於思科路由器設置方法和常見配置命令,歡迎大家參考學習!

一、基本設置方式

一般來說,可以用5種方式來設置Cisco思科路由器:

1.Console口接終端或運行終端模擬軟體的微機;

2.AUX口接MODEM,通過電話線與遠方的終端或運行終端模擬軟體的微機相連;

3.通過Ethernet上的TFTP伺服器;

4.通過Ethernet上的TELNET程序;

5.通過Ethernet上的SNMP網管工作站。

但Cisco思科路由器的第一次設置必須通過第一種方式進行,一般用超級終端通過com口進行控制。此時終端的硬體設置如下:

波特率 :9600

數據位 :8

停止位 :1

奇偶校驗: 無

二、命令操作

Cisco思科路由器所用的操作系統是IOS.共有以下幾種狀態:

1、router>

在router>提示符下,Cisco思科路由器處於用戶命令狀態,這時用戶可以看Cisco思科路由器的連接狀態,訪問其它網路和主機,但不能看到和更改Cisco思科路由器的設置內容。此時輸入?並回車,可以查看到在此狀態下可以用的命令。(IOS允許你在任何時候用這種方式查看在某種狀態下可以用的命令)。在敲入enable並回車後,按照系統提示輸入密碼,(在新的Cisco思科路由器第一次進行調試的時候不需要輸入密碼,直接回車即可)進入#提示符,就可以對Cisco思科路由器進行各種操作了。

2、router#

Cisco思科路由器進入特權命令狀態router#後,不但可以執行所有的用戶命令,還可以看到和更改Cisco思科路由器的設置內容。此時就可以對Cisco思科路由器的名字、密碼等進行設置。

3、router(config)#

在router#提示符下鍵入configure terminal,出現提示符router(config)#,此時Cisco思科路由器處於全局設置狀態,這時可以設置Cisco思科路由器的全局參數。

4、router(config-if)#;

router(config-line)#;

router(config-router)#;…

Cisco思科路由器處於局部設置狀態,這時可以設置Cisco思科路由器某個局部的參數。

5、Cisco思科路由器處於RXBOOT狀態,在開機後60秒內按ctrl-break可進入此狀態,這時Cisco思科路由器不能完成正常的功能,只能進行軟體升級和手工引導。在此狀態下,可以進行口令恢復。

三、常用命令

1.幫助

在IOS操作中,無論任何狀態和位置,都可以鍵入“?”得到系統的幫助。系統會顯示此時可以使用的命令。

2.改變命令狀態

任務命令

進入特權命令狀態enable

退出特權命令狀態disable

進入設置對話狀態Setup

進入全局設置狀態config terminal

退出全局設置狀態End

進入埠設置狀態interface type slot/number

進入子埠設置狀態interface type number.subinterface [point-to-point | multipoint]

進入線路設置狀態line type slot/number

進入路由設置狀態router protocol

退出局部設置狀態Exit

3.顯示命令

任務命令

查看版本及引導信息show version

查看運行設置show running-config

查看開機設置show startup-config

顯示埠信息show interface type slot/number

顯示路由信息show ip router

4.拷貝命令

用於IOS及CONFIG的備份和升級

5.網路命令

任務命令

登錄遠程主機telnet hostname|IP address

網路偵測ping hostname|IP address

路由跟蹤Trace hostname|IP address

6.基本設置命令

任務命令

全局設置config terminal

設置訪問用戶及密碼username username password password

設置特權密碼enable secret password

設置Cisco思科路由器名hostname name

設置靜態路由ip route destination subnet-mask next-hop

啟動IP路由ip routing

啟動IPX路由Ipx routing

埠設置interface type slot/number

設置IP地址ip address address subnet-mask

設置IPX網路Ipx network network

激活埠no shutdown

物理線路設置line type number

啟動登錄進程login [local|tacacs server]

設置登錄密碼password password

本文描述了如何進行思科路由器的基本設置,基本的命令操作以及常用命令進行操作和總體的.設置,並講述了一些基本的服務設置。

四、總體設置

在router#特權命令狀態下,可以用setup對Cisco思科路由器進行總體設計,利用這個設計過程可以省略手工設置的煩瑣。但它還不能完全代替手工設置,一些特殊的設置還必須通過手工輸入的方式完成。

進入設置對話過程後,Cisco思科路由器首先會顯示一些提示信息:

--- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.

Use ctrl-c to abort configuration dialog at any prompt.

Default settings are in square brackets '[]'.

這是告訴你在設置對話過程中的任何地方都可以鍵入“?”得到系統的幫助,按ctrl-c可以退出設置過程,預設設置將顯示在‘[]’中。然後Cisco思科路由器會問是否進入設置對話:

Would you like to enter the initial configuration dialog? [yes]:

如果按y或回車,Cisco思科路由器就會進入設置對話過程。首先你可以看到各埠當前的狀況:

First, would you like to see the current interface summary? [yes]:

Any interface listed with OK? value "NO" does not have a valid configuration

InterfaceIP-AddressOK?MethodStatusProtocol

Serial0unassignedNOunsetupup

……………………………

然後,Cisco思科路由器就開始全局參數的設置:

Configuring global parameters:

1.設置Cisco思科路由器名:

Enter host name [Router]:

2.設置進入特權狀態的密文(secret),此密文在設置以後不會以明文方式顯示:

The enable secret is a one-way cryptographic secret used

instead of the enable password when it exists.

Enter enable secret: cisco

3.設置進入特權狀態的密碼(password),此密碼只在沒有密文時起作用,並且在設置以後會以明文方式顯示:

The enable password is used when there is no enable secret

and when using older software and some boot images.

Enter enable password: pass

4.設置虛擬終端訪問時的密碼:

Enter virtual terminal password: cisco

5.詢問是否要設置Cisco思科路由器支持的各種網路協議:

Configure SNMP Network Management? [yes]:

Configure DECnet? [no]:

Configure AppleTalk? [no]:

Configure IPX? [no]:

Configure IP? [yes]:

Configure IGRP routing? [yes]:

Configure RIP routing? [no]:

………

6.如果配置的是撥號訪問伺服器,系統還會設置非同步口的參數:

Configure Async lines? [yes]:]

1)設置線路的最高速度:

Async line speed [9600]:

2)是否使用硬體流控:

Configure for HW flow control? [yes]:

3)是否設置modem:

Configure for modems? [yes/no]: yes

4)是否使用默認的modem命令:

Configure for default chat script? [yes]:

5)是否設置非同步口的PPP參數:

Configure for Dial-in IP SLIP/PPP access? [no]: yes

6)是否使用動態IP地址:

Configure for Dynamic IP addresses? [yes]:

7)是否使用預設IP地址:

Configure Default IP addresses? [no]: yes

是否使用TCP頭壓縮:

Configure for TCP Header Compression? [yes]:

9)是否在非同步口上使用路由表更新:

Configure for routing updates on async links? [no]: y

10)是否設置非同步口上的其它協議。接下來,系統會對每個介面進行參數的設置。

1.Configuring interface Ethernet0:

1)是否使用此介面:

Is this interface in use? [yes]:

2)是否設置此介面的IP參數:

Configure IP on this interface? [yes]:

3)設置介面的IP地址:

IP address for this interface: 192.168.162.2

4)設置介面的IP子網掩碼:

Number of bits in subnet field [0]:

Class C network is 192.168.162.0, 0 subnet bits; mask is /24

在設置完所有介面的參數後,系統會把整個設置對話過程的結果顯示出來:

The following configuration command script was created:

hostname Router

enable secret 5 $W5Oh$p6J7tIgRMBOIKVXVG53Uh1

enable password pass

…………

請注意在enable secret後面顯示的是亂碼,而enable password後面顯示的是設置的內容。就是說,secret密碼的優先順序比較高,在兩個密碼都設了的情況下,secret密碼起作用。

顯示結束後,系統會問是否使用這個設置:

Use this configuration? [yes/no]: yes

如果回答yes,系統就會把設置的結果存入Cisco思科路由器的NVRAM中,然後結束設置對話過程,使Cisco思科路由器開始正常的工作。

五、廣域網協議設置

PPP

PPP(Point-to-Point Protocol)是SLIP(Serial Line IP protocol)的繼承者,它提供了跨過同步和非同步電路實現Cisco思科路由器到Cisco思科路由器(router-to-router)和主機到網路(host-to-network)的連接。

CHAP(Challenge Handshake Authentication Protocol)和PAP(Password Authentication Protocol) (PAP)通常被用於在PPP封裝的串列線路上提供安全性認證。使用CHAP和PAP認證,每個Cisco思科路由器通過名字來識別,可以防止未經授權的訪問。

任務命令

設置PPP封裝encapsulation ppp1

設置認證方法ppp authentication {chap | chap pap | pap chap | pap} [if-needed] [list-name | default] [callin]

指定口令username name password secret

設置DCE端線路速度clockrate speed

;

H. 思科配置命令詳細介紹

思科配置命令詳細介紹

對於剛想學計算機網路技術的朋友,首先接觸的就是思科路由器,下面是我給大家帶來的最詳細的CISCO路由器配置命令及方法:

第一章 路由器配置基礎

一、基本設置方式

二、命令狀態

三、設置對話過程

四、常用命令

五、配置IP定址

六、配置靜態路由

第二章 廣域網協議設置

一、HDLC

二、PPP

三、X.25

四、Frame Relay

五、ISDN

六、PSTN

第三章 路由協議設置

一、RIP協議

二、IGRP協議

三、OSPF協議

四、重新分配路由

五、IPX協議設置

第四章 服務質量及訪問控制

一、協議優先順序設置

二、隊列定製

三、訪問控制

第五章 虛擬區域網(VLAN)路由

一、虛擬區域網(VLAN)

二、交換機間鏈路(ISL)協議

三、虛擬區域網(VLAN)路由實例

第一章:路由器配置基礎

一、基本設置方式

一般來說,可以用5種方式來設置路由器:

1.Console口接終端或運行終端模擬軟體的微機;

2.AUX口接MODEM,通過電話線與遠方的終端或運行終端模擬軟體的微機相連;

3.通過Ethernet上的TFTP伺服器;

4.通過Ethernet上的TELNET程序;

5.通過Ethernet上的SNMP網管工作站。

但路由器的第一次設置必須通過第一種方式進行,此時終端的硬體設置如下:

波特率 :9600

數據位 :8

停止位 :1

奇偶校驗: 無

二、命令狀態

1. router>

路由器處於用戶命令狀態,這時用戶可以看路由器的連接狀態,訪問其它網路和主機,但不能看到和更改路由器的設置內容。

2. router#

在router>提示符下鍵入enable,路由器進入特權命令狀態router#,這時不但可以執行所有的用戶命令,還可以看到和更改路由器的設置內容。

3. router(config)#

在router#提示符下鍵入configure terminal,出現提示符router(config)#,此時路由器處於全局設置狀態,這時可以設置路由器的全局參數。

4. router(config-if)#; router(config-line)#; router(config-router)#;…

路由器處於局部設置狀態,這時可以設置路由器某個局部的參數。

5. >

路由器處於RXBOOT狀態,在開機後60秒內按ctrl-break可進入此狀態,這時路由器不能完成正常的功能,只能進行軟體升級和手工引導。

設置對話狀態

這是一台新路由器開機時自動進入的狀態,在特權命令狀態使用SETUP命令也可進入此狀態,這時可通過對話方式對路由器進行設置。

三、設置對話過程

顯示提示信息

全局參數的設置

介面參數的設置

顯示結果

利用設置對話過程可以避免手工輸入命令的煩瑣,但它還不能完全代替手工設置,一些特殊的設置還必須通過手工輸入的方式完成。

進入設置對話過程後,路由器首先會顯示一些提示信息:

--- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.

Use ctrl-c to abort configuration dialog at any prompt.

Default settings are in square brackets '[]'.

這是告訴你在設置對話過程中的任何地方都可以鍵入“?”得到系統的幫助,按ctrl-c可以退出設置過程,預設設置將顯示在‘[]’中。然後路由器會問是否進入設置對話:

Would you like to enter the initial configuration dialog? [yes]:

如果按y或回車,路由器就會進入設置對話過程。首先你可以看到各埠當前的狀況:

First, would you like to see the current interface summary? [yes]:

Any interface listed with OK? value "NO" does not have a valid configuration

Interface IP-Address OK? Method Status Protocol

Ethernet0 unassigned NO unset up up

Serial0 unassigned NO unset up up

……… ……… … …… … …

然後,路由器就開始全局參數的設置:

Configuring global parameters:

1.設置路由器名:

Enter host name [Router]:

2.設置進入特權狀態的密文(secret),此密文在設置以後不會以明文方式顯示:

The enable secret is a one-way cryptographic secret used

instead of the enable password when it exists.

Enter enable secret: cisco

3.設置進入特權狀態的密碼(password),此密碼只在沒有密文時起作用,並且在設置以後會以明文方式顯示:

The enable password is used when there is no enable secret

and when using older software and some boot images.

Enter enable password: pass

4.設置虛擬終端訪問時的密碼:

Enter virtual terminal password: cisco

5.詢問是否要設置路由器支持的各種網路協議:

Configure SNMP Network Management? [yes]:

Configure DECnet? [no]:

Configure AppleTalk? [no]:

Configure IPX? [no]:

Configure IP? [yes]:

Configure IGRP routing? [yes]:

Configure RIP routing? [no]:

………

6.如果配置的是撥號訪問伺服器,系統還會設置非同步口的參數:

Configure Async lines? [yes]:

1) 設置線路的最高速度:

Async line speed [9600]:

2) 是否使用硬體流控:

Configure for HW flow control? [yes]:

3) 是否設置modem:

Configure for modems? [yes/no]: yes

4) 是否使用默認的modem命令:

Configure for default chat s cript? [yes]:

5) 是否設置非同步口的PPP參數:

Configure for Dial-in IP SLIP/PPP access? [no]: yes

6) 是否使用動態IP地址:

Configure for Dynamic IP addresses? [yes]:

7) 是否使用預設IP地址:

Configure Default IP addresses? [no]: yes

8) 是否使用TCP頭壓縮:

Configure for TCP Header Compression? [yes]:

9) 是否在非同步口上使用路由表更新:

Configure for routing updates on async links? [no]: y

10) 是否設置非同步口上的其它協議。

接下來,系統會對每個介面進行參數的設置。

1.Configuring interface Ethernet0:

1) 是否使用此介面:

Is this interface in use? [yes]:

2) 是否設置此介面的IP參數:

Configure IP on this interface? [yes]:

3) 設置介面的IP地址:

IP address for this interface: 192.168.162.2

4) 設置介面的IP子網掩碼:

Number of bits in subnet field [0]:

Class C network is 192.168.162.0, 0 subnet bits; mask is /24

在設置完所有介面的參數後,系統會把整個設置對話過程的結果顯示出來:

The following configuration command s cript was created:

hostname Router

enable secret 5 $1$W5Oh$p6J7tIgRMBOIKVXVG53Uh1

enable password pass

…………

請注意在enable secret後面顯示的是亂碼,而enable password後面顯示的是設置的內容。

顯示結束後,系統會問是否使用這個設置:

Use this configuration? [yes/no]: yes

如果回答yes,系統就會把設置的結果存入路由器的NVRAM中,然後結束設置對話過程,使路由器開始正常的工作。

四、常用命令

1. 幫助

在IOS操作中,無論任何狀態和位置,都可以鍵入“?”得到系統的幫助。

2. 改變命令狀態

任務 命令

進入特權命令狀態 enable

退出特權命令狀態 disable

進入設置對話狀態 setup

進入全局設置狀態 config terminal

退出全局設置狀態 end

進入埠設置狀態 interface type slot/number

進入子埠設置狀態 interface type number.subinterface [point-to-point | multipoint]

進入線路設置狀態 line type slot/number

進入路由設置狀態 router protocol

退出局部設置狀態 exit

3. 顯示命令

任務 命令

查看版本及引導信息 show version

查看運行設置 show running-config

查看開機設置 show startup-config

顯示埠信息 show interface type slot/number

顯示路由信息 show ip router

4. 拷貝命令

用於IOS及CONFIG的備份和升級

5. 網路命令

任務 命令

登錄遠程主機 telnet hostname|IP address

網路偵測 ping hostname|IP address

路由跟蹤 trace hostname|IP address

6. 基本設置命令

任務 命令

全局設置 config terminal

設置訪問用戶及密碼 username username password password

設置特權密碼 enable secret password

設置路由器名 hostname name

設置靜態路由 ip route destination subnet-mask next-hop

啟動IP路由 ip routing

啟動IPX路由 ipx routing

埠設置 interface type slot/number

設置IP地址 ip address address subnet-mask

設置IPX網路 ipx network network

激活埠 no shutdown

物理線路設置 line type number

啟動登錄進程 login [local|tacacs server]

設置登錄密碼 password password

五、配置IP定址

1. IP地址分類

IP地址分為網路地址和主機地址二個部分,A類地址前8位為網路地址,後24位為主機地址,B類地址16位為網路地址,後16位為主機地址,C類地址前24位為網路地址,後8位為主機地址,網路地址范圍如下表所示:

種類 網路地址范圍

A 1.0.0.0 到126.0.0.0有效 0.0.0.0 和127.0.0.0保留

B 128.1.0.0到191.254.0.0有效 128.0.0.0和191.255.0.0保留

C 192.0.1.0 到223.255.254.0有效 192.0.0.0和223.255.255.0保留

D 224.0.0.0到239.255.255.255用於多點廣播

E 240.0.0.0到255.255.255.254保留 255.255.255.255用於廣播

2. 分配介面IP地址

任務 命令

介面設置 interface type slot/number

為介面設置IP地址 ip address ip-address mask

掩瑪(mask)用於識別IP地址中的網路地址位數,IP地址(ip-address)和掩碼(mask)相與即得到網路地址。

3. 使用可變長的子網掩碼

通過使用可變長的子網掩碼可以讓位於不同介面的同一網路編號的網路使用不同的掩碼,這樣可以節省IP地址,充分利用有效的IP地址空間。

如下圖所示:

Router1和Router2的E0埠均使用了C類地址192.1.0.0作為網路地址,Router1的E0的網路地址為192.1.0.128, 掩碼為255.255.255.192, Router2的E0的網路地址為192.1.0.64,掩碼為255.255.255.192,這樣就將一個C類網路地址分配給了二個網,既劃分了二個子網,起到了節約地址的作用。

4. 使用網路地址翻譯(NAT)

NAT(Network Address Translation)起到將內部私有地址翻譯成外部合法的全局地址的功能,它使得不具有合法IP地址的用戶可以通過NAT訪問到外部Internet.

當建立內部網的時候,建議使用以下地址組用於主機,這些地址是由Network Working Group(RFC 1918)保留用於私有網路地址分配的`.

?; Class A:10.1.1.1 to 10.254.254.254

?; Class B:172.16.1.1 to 172.31.254.254

?; Class C:192.168.1.1 to 192.168.254.254

命令描述如下:

任務 命令

定義一個標准訪問列表 access-list access-list-number permit source [source-wildcard]

定義一個全局地址池 ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length} [type rotary]

建立動態地址翻譯 ip nat inside source {list {access-list-number | name} pool name [overload] | static local-ip global-ip}

指定內部和外部埠 ip nat {inside | outside}

如下圖所示,

路由器的Ethernet 0埠為inside埠,即此埠連接內部網路,並且此埠所連接的網路應該被翻譯,Serial 0埠為outside埠,其擁有合法IP地址(由NIC或服務提供商所分配的合法的IP地址),來自網路10.1.1.0/24的主機將從IP地址池 c2501中選擇一個地址作為自己的合法地址,經由Serial 0口訪問Internet。命令ip nat inside source list 2 pool c2501 overload中的參數overload,將允許多個內部地址使用相同的全局地址(一個合法IP地址,它是由NIC或服務提供商所分配的地址)。命令 ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192定義了全局地址的范圍。

設置如下:

ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192

interface Ethernet 0

ip address 10.1.1.1 255.255.255.0

ip nat inside

!

interface Serial 0

ip address 202.200.10.5 255.255.255.252

ip nat outside

!

ip route 0.0.0.0 0.0.0.0 Serial 0

access-list 2 permit 10.0.0.0 0.0.0.255

! Dynamic NAT

!

ip nat inside source list 2 pool c2501 overload

line console 0

exec-timeout 0 0

!

line vty 0 4

end

六、配置靜態路由

通過配置靜態路由,用戶可以人為地指定對某一網路訪問時所要經過的路徑,在網路結構比較簡單,且一般到達某一網路所經過的路徑唯一的情況下採用靜態路由。

任務 命令

建立靜態路由 ip route prefix mask {address | interface} [distance] [tag tag] [permanent]

Prefix :所要到達的目的網路

mask :子網掩碼

address :下一個跳的IP地址,即相鄰路由器的埠地址。

interface :本地網路介面

distance :管理距離(可選)

tag tag :tag值(可選)

permanent :指定此路由即使該埠關掉也不被移掉。

以下在Router1上設置了訪問192.1.0.64/26這個網下一跳地址為192.200.10.6,即當有目的地址屬於 192.1.0.64/26的網路范圍的數據報,應將其路由到地址為192.200.10.6的相鄰路由器。在Router3上設置了訪問 192.1.0.128/26及192.200.10.4/30這二個網下一跳地址為192.1.0.65。由於在Router1上埠Serial 0地址為192.200.10.5,192.200.10.4/30這個網屬於直連的網,已經存在訪問192.200.10.4/30的路徑,所以不需要在Router1上添加靜態路由。

Router1:

ip route 192.1.0.64 255.255.255.192 192.200.10.6

Router3:

ip route 192.1.0.128 255.255.255.192 192.1.0.65

ip route 192.200.10.4 255.255.255.252 192.1.0.65

同時由於路由器Router3除了與路由器Router2相連外,不再與其他路由器相連,所以也可以為它賦予一條默認路由以代替以上的二條靜態路由,

ip route 0.0.0.0 0.0.0.0 192.1.0.65

即只要沒有在路由表裡找到去特定目的地址的路徑,則數據均被路由到地址為192.1.0.65的相鄰路由器。

;

I. 思科時鍾頻率配置命令

設置時間及時區命令如下:
1.設置時區:Router(config)#CLOCK Timezone beijing +08 //設置為北京的時區為東8區
2.設置時間:Router# clock set 10:00:00 Aug 4 2015 //設置時間為2015年8月4日10時整
3.設置網路時間:Router(config)#ntp server s1b.time.e.cn //清華大學NTP伺服器
由於路由器在交互時對時間的匹配要求嚴格,所以在配置路由器時不推薦使用手動設置時間, 我們一般藉助專門的時間同步伺服器來配置網路設備的時間。
Network Time Protocol(NTP)是用來使計兄團算機時間同步化的一種協議,它可以使計算機對其伺服器或時鍾源(如石英鍾,GPS等等)做同步化,
它可以提供高精準度的時間校正(LAN上與標准間差小於1毫秒,WAN上幾十毫秒),且可介由加密確認的方式來防止惡毒的協議攻擊。
NTP可以利用多個途徑和來源的時間伺服器來更加精確的校正時間。
現在絕大部分的操作系統都支持NTP,比凱納如在Unix和Windows中都有他們自己的NTP服務。比如在Windows中的SNTP。
由於各個系統廠商會根據自己的系統情況對NTP來進行優化和設置,
更加適合他自己的系統,對於其他系統的兼容性就會差很多。還有不同時期的系統會使用不同版本的NTP服務。最新版本位V4,由於每個版本都要他自己的一些特徵。
所以在設置NTP伺服器時會有一些兼容性問題。
因此,在多類型操作系統的環境中,盡量使用NTP官方組織提供的軟體進行設置而不使用其他廠商在盯塵沒系統中默認提供的NTP伺服器。NTP官方組織為
www.ntp.org。
Server一般用於伺服器端,該伺服器不會去同步其他伺服器時間,一般server後可以跟 127.127.1.0 該地址代表本級的時鍾,
如果Server後跟其他伺服器IP,表示會去同步其他時間伺服器的地址。

閱讀全文

與cisco命令配置相關的資料

熱點內容
網易粘土伺服器怎麼開箱子 瀏覽:486
單片機軟體開發工程師 瀏覽:170
伺服器為什麼用lamp環境 瀏覽:377
財務分析pdf下載 瀏覽:291
做游戲如何不搭建伺服器 瀏覽:612
德國是什麼伺服器 瀏覽:551
javajar部署 瀏覽:269
android菜單顯示位置 瀏覽:529
大疆自拍是哪個app 瀏覽:188
pdf夢的解析 瀏覽:608
腳步聲優化命令聽不清 瀏覽:325
程序員三大罪怎麼玩 瀏覽:729
cad列印pdf設置 瀏覽:733
國產加密演算法價格 瀏覽:602
phpobjecttojson 瀏覽:695
pdf樣式 瀏覽:749
ssid加密協議 瀏覽:354
汝州市解壓去哪個車管所 瀏覽:546
小韓api源碼 瀏覽:281
php提取手機號 瀏覽:855