導航:首頁 > 源碼編譯 > 易語言編譯後讀不出數據

易語言編譯後讀不出數據

發布時間:2022-10-01 04:09:34

㈠ 易語言讀配置項有些文本讀不出來

換行肯定不可以呀 你可以吧換行符換成[enter]
取出來的時候 子文本替換 再吧[enter]在換成換行符就可以了

㈡ 關於易語言 寫 讀 注冊表的問題,編輯框讀不到數值怎回事

.子程序 _按鈕寫_被單擊

寫注冊項 (#本地機器, 「Software\ruanjian\lm」, 」15」)
.子程序 _按鈕讀_被單擊

編輯框1.內容 = 取文本注冊項 (#本地機器, 「Software\ruanjian\lm\」, )

㈢ 新手求助,CE讀取內存數據正常易語言讀不出來

你寫的代碼呢?沒代碼怎麼幫你解決!

前提:
首先要知道CE所讀取的內存地址是否是靜態地址!或者是模塊地址!
模塊地址是游戲內某模塊內的地址+偏移 如:「game.dll+056D138」得到的一個地址!這個地址也能找到靜態地址但不能指定模塊也會出錯!
其次是你找的地址是否是64位地址,目前易語言似乎只支持32位地址!

㈣ 易語言編譯時出現讀入文件失敗怎麼辦

很簡單,你把保存的名字隨便改下,再編譯一次就可以了,破解版的經常這樣。

㈤ 易語言連接資料庫怎麼讀取不成功

資料庫連接1.連接SQLServer()命令的提示如下:
調用格式: 〈邏輯型〉 對象.連接SQLServer (文本型 伺服器名,文本型 資料庫名,文本型 用戶名,文本型 密碼) - 資料庫操作支持庫->資料庫連接
英文名稱:ConnectSQLServer
連接SQL Server資料庫,如果連接成功返回真,失敗返回假。本命令為初級對象成員命令。
參數<1>的名稱為「伺服器名」,類型為「文本型(text)」。本參數提供 SQL SERVER 伺服器名。
參數<2>的名稱為「資料庫名」,類型為「文本型(text)」。
參數<3>的名稱為「用戶名」,類型為「文本型(text)」。
參數<4>的名稱為「密碼」,類型為「文本型(text)」。

如果返回為假,那麼你要檢查伺服器ip或者名稱是否正確,用戶名和密碼是否填寫對了。你先用一個sql客戶端來登陸sql伺服器看看,如果使用你代碼裡面的伺服器ip,用戶名和密碼有錯誤則是你的參數填寫問題了。你先檢查這個吧。

㈥ 易語言程序能寫入配置但是怎麼都讀取不了配置

.版本
2
.支持庫
spec
.支持庫
xplib
.程序集
窗口程序集_啟動窗口
.子程序
_開始1_被單擊
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「登錄密碼1」,
「登錄密碼1.內容」)
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「寬頻帳號」,
「寬頻帳號.內容」)
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「寬頻密碼」,

寬頻密碼.內容」)
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「uu雲帳號」,
「uu雲帳號.內容」)
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「uu雲密碼」,
「uu雲密碼.內容」)
寫配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「第幾個」,
「第幾個.內容」)
.子程序
__啟動窗口_創建完畢
創建目錄
(取運行目錄
()

「\」

「上保護」)
.如果真
(文件是否存在
(取運行目錄
()

「\」

「上保護」

「\帳號.txt」)

假)
寫到文件
(取運行目錄
()

「\」

「上保護」

「\帳號.txt」,
{
})
.如果真結束
調試輸出
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」)
信息框
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

「配置.ini」,
「Config」,
「登錄密碼1」,
),
0,
,
)
信息框
(到文本
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「寬頻帳號」,
)),
0,
,
)
信息框
(到文本
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「寬頻密碼」,
)),
0,
,
)
信息框
(到文本
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「uu雲帳號」,
)),
0,
,
)
信息框
(到文本
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「uu雲密碼」,
)),
0,
,
)
信息框
(到文本
(讀配置項
(取運行目錄
()

「\」

「上保護」

「\」

到文本
(「配置」)

「.ini」,
「Config」,
「第幾個」,
)),
0,
,
)
XP風格
(2)
我這里可以啊?!

㈦ 易語言在調試運行的時候都是正常的,但是編譯後就不能正常的顯示了。求解答!

你給源碼也是沒用的,你這個是易語言自己給的例子,所需文件還在「易語言目錄\samples\游戲軟體\奪寶奇兵」里把這個目錄下的全部文件放在編譯好的目錄下,就可以了,若有問題可追問或網路hi

㈧ 請問一下,易語言 為什麼我讀取內存總是讀取不了呢

如果你用CE能正確讀出內存數值!
然後用易語言的 讀內存整數型命令讀不出來! 就是你寫的程序許可權不夠!
需要提權或者用驅動級的讀內存整數型!就可以讀出來

㈨ 易語言編譯讀入文件失敗怎麼辦 回答好的再給財富

如果是靜態的話 應該是你用的一些組件不支持靜態編譯 如果你不想加殼的話 個人建議用編譯 然後把編譯出來的相關組件 用molebox打包就ok了 如果你不想下載molebox 把編譯好的發我郵箱 我再發你郵箱 不為別的 只求採納! QQ郵箱 [email protected]

㈩ 易語言讀配置項時讀不出來,已經確認沒有錯誤,程序正常運行,但返回得數據就是空,我以前編輯過類似

那麼調用系統API讀取配置信息

系統"kernel32.dll"下的"WritePrivateProfileStringA"API函數可寫"*.ini"配置信息

系統"kernel32.dll"下的"GetPrivateProfileString"API函數可讀取"*.ini"配置信息

易語言的大量支持庫命令也是封裝了系統API函數!

.版本 2

.支持庫 spec


.子程序 _啟動子程序, 整數型, , 本子程序在程序啟動後最先執行

.局部變數 最後一個參數是一個配置文件的絕對路徑, 文本型

.局部變數 局部_配置信息, 文本型

.局部變數 局部_文本長度, 整數型


最後一個參數是一個配置文件的絕對路徑 = 「C:1.ini」

WritePrivateProfileStringA (「這個參數是將要寫入的小節名」, 「這個參數是將要寫入的配置名」, 「這個參數是將要寫入的數據」, 最後一個參數是一個配置文件的絕對路徑) ' 寫出失敗將返回0

局部_文本長度 = 256 ' 這里的文本長度是最大長度,256/2=128也就是一次最多可讀入128個漢字,(上面寫出的「這個參數是將要寫入的數據」*2=24個位元組)配置文件一般不會很長,如果很長不建議你使用配置文件保存

局部_配置信息 = 取空白文本 (局部_文本長度)

GetPrivateProfileString (「這個參數是將要寫入的小節名」, 「這個參數是將要寫入的配置名」, 「默認文本」, 局部_配置信息, 局部_文本長度, 最後一個參數是一個配置文件的絕對路徑)

調試輸出 (局部_配置信息)

.版本 2


.DLL命令 WritePrivateProfileStringA, 整數型, "kernel32", "WritePrivateProfileStringA"

.參數 lpApplicationName, 文本型

.參數 lpKeyName, 文本型

.參數 lpString, 文本型

.參數 lpFileName, 文本型


.DLL命令 GetPrivateProfileString, 整數型, "kernel32", "GetPrivateProfileStringA"

.參數 lpApplicationName, 文本型

.參數 lpKeyName, 文本型

.參數 lpDefault, 文本型

.參數 lpReturnedString, 文本型

.參數 nSize, 整數型

.參數 lpFileName, 文本型

閱讀全文

與易語言編譯後讀不出數據相關的資料

熱點內容
尋路演算法php 瀏覽:249
空氣壓縮機油可以當潤滑油嗎 瀏覽:842
聲音控制新命令存儲 瀏覽:117
林州無油壓縮機 瀏覽:211
銀行app在哪裡找電子票據 瀏覽:806
怎麼查公司郵箱的伺服器地址 瀏覽:443
我的世界開命令方塊開啟 瀏覽:348
java引用和對象 瀏覽:509
php提交檢測 瀏覽:534
單片機最小系統介紹說明 瀏覽:155
痔核壓縮 瀏覽:879
平安口袋銀行app積分超值兌在哪裡 瀏覽:381
影視app源碼2021 瀏覽:569
驍龍處理器屬於單片機嗎 瀏覽:573
安卓怎麼下載poppy 瀏覽:40
電子賀卡哪個app好 瀏覽:579
pplive桌面文件夾刪除不了 瀏覽:86
伺服器擠爆了什麼意思 瀏覽:261
聯通app在哪裡找客服 瀏覽:239
騰訊雲自研伺服器視頻 瀏覽:285