導航:首頁 > 編程語言 > python版本問題

python版本問題

發布時間:2023-06-05 20:22:02

⑴ 新手學python用哪個版本好

python3 和 python2 是不兼容的,而且差異比較大,python3是不向下兼容的,但是絕大多數組件和擴展都是基於python2的。目前實際應用中大部分暫不考慮 Python3,有的時候注意寫兼容 2/3 的代碼。用 Python2 為主的寫新代碼時要考慮以後遷移到 Python3 的可能性。據數據統計顯示目前10% 使用 Python 3;20% 既使用Python 2也使用Python 3,Python 2用的更多;70% 使用Python 2。
其實python是linux上最常用的軟體之一,但是linux目前的版本大部分還是使用python2的,而且,在linux上依賴python2的程序更多一些,所以 Python3 要代替 python2 成為主流還需要幾年的時間。如果為了找工作還是學Python 2,學會了Python 2,由Python 2轉到python3也不難。

⑵ python 版本問題 yum 運行 報錯

原因:
這是因為yum採用python作為命令解釋器,這可以從/usr/bin/yum文件中第一行#!/usr/bin/python發現。而python版本之間兼容性不太好,使得2.X版本與3.0版本之間存在語法不一致問題。而CentOS 5自帶的yum採用的是python2.4,當系統將python升級到2.6或3.0後,出現語法解釋錯誤。
解決辦法:
很簡單,一是升級yum,一是修改yum的解釋器為舊版本python2.4(如果你沒有採用覆蓋升級的話)
升級yum的作法就不詳述了;
修改yum的解釋器為舊版本python2.4:
vi /usr/bin/yum
將第一行"#!/usr/bin/python" 改為 "#!/usr/bin/python2.4"即可

閱讀全文

與python版本問題相關的資料

熱點內容
網易粘土伺服器怎麼開箱子 瀏覽:486
單片機軟體開發工程師 瀏覽:170
伺服器為什麼用lamp環境 瀏覽:377
財務分析pdf下載 瀏覽:291
做游戲如何不搭建伺服器 瀏覽:612
德國是什麼伺服器 瀏覽:551
javajar部署 瀏覽:269
android菜單顯示位置 瀏覽:529
大疆自拍是哪個app 瀏覽:188
pdf夢的解析 瀏覽:608
腳步聲優化命令聽不清 瀏覽:325
程序員三大罪怎麼玩 瀏覽:729
cad列印pdf設置 瀏覽:733
國產加密演算法價格 瀏覽:602
phpobjecttojson 瀏覽:695
pdf樣式 瀏覽:749
ssid加密協議 瀏覽:354
汝州市解壓去哪個車管所 瀏覽:546
小韓api源碼 瀏覽:281
php提取手機號 瀏覽:855