导航:首页 > 程序命令 > 交换机全局命令

交换机全局命令

发布时间:2022-06-05 05:50:19

❶ 谁能告诉我交换机特权模式和全局模式下的命令都有哪些急用…

switch> 用户模式
1:进入特权模式 enable
switch> enable //进入特权模式
switch# //当前在特权模式中

2:进入全局配置模式 configure terminal
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
switch(conf)# //当前全局模式

3:交换机命名 hostname aptech2950 //以aptech2950为例
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
switch(conf)#hostname aptch-2950 //红色为主机名
aptech2950(conf)# //当前全局模式

4:配置使能口令 enable password cisco 以cisco为例
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
aptech2950(conf)# enable password cisco //红色部分为密码

5:配置使能密码 enable secret ciscolab 密码以cicso01为例
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
aptech2950(conf)# enable secret ciscol01 //红色部分为加密密码

6:设置交换机IP 地址
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
aptech2950(conf)# interface vlan 1 //进入vlan1
aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0 //配置交换机端口ip和子网掩码
aptech2950(conf-if)#no shut //开启vlan1
aptech2950(conf-if)#exit
aptech2950(conf)#ip default-gateway 192.168.254 //设置网关地址

7:进入交换机某一端口,以7端口为例;
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
aptech2950(conf)# interface fastehernet 0/7 //进入第7口
aptech2950(conf-if)#

8:查看命令 show
switch> enable //进入特权模式
switch# show version //察看系统版本信息
show interface vlan 1 //查看交换机有关vlan1的配置信息
show running-configure //查看交换机当前的配置信息
show interface fastethernet 0/1 //察看交换机1接口具体配置和统计信息
show mac-address-table //查看mac地址表
show mac-address-table aging-time //查看mac地址表自动老化时间

9:交换机恢复出厂默认恢复命令
switch> enable //进入特权模式
switch# erase startup-configure //出厂默认恢复命令 s
witch# reload //从新启动

10:双工模式设置
switch> enable //进入特权模式
switch#configure terminal //进入全局模式
switch(conf)# interface fastehernet 0/7 //以7口为例
Switch(conf)# plex full/half/auto //有half:半双工,full:全双工,auto:自动

11:cdp相关命令
switch> enable
switch# show cdp 设备的cdp全局配置信息
show cdp interface fastethernet 0/17 查看17端口的cdp配置信息
show cdp traffic 查看有关cdp包的统计信息
show cdp nerghbors 列出与设备相连的cisco设备

12:csico2950的密码恢复
拔下交换机电源线。
用手按着交换机的MODE键,插上电源线
在switch:后执行flash_ini命令:switch: flash_ini
查看flash中的文件: switch: dir flash:
把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old
执行boot:
switch: boot 交换机进入是否进入配置的对话,执行no :
进入特权模式察看flash里的文件: show flash :
把“config.old”文件改名为 “config.text”: switch: rename flash: config.old flash: config.text
把“config.text”拷入系统的“running-configure”: flash: config.text system : running-configure
把配置模式重新设置密码存盘,密码恢复成功。

13:交换机telnet远程登录设置:
switch>en
switch#configure terminal
switch(conf)#hostname aptech-2950
aptech2950(conf)#enable password cisco 以cisco为特权模式密码
aptech2950(conf)#interface fastethernet 0/1 以17端口为telnet远程登录端口
aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0
aptech2950(conf-if)#no shut
aptech2950(conf-if)#exit aptech2950(conf)line vty 0 4 设置0-4 个用户可以telnet远程登陆
aptech2950(conf-line)#login
aptech2950(conf-line)#password edge 以edge为远程登录的用户密码
主机设置:
ip 192.168.1.2 主机的ip必须和交换机端口的地址在同一网络段
netmask 255.255.255.0 gate-way 192.168.1.1 网关地址是交换机端口地址
运行:
telnet 192.168.1.1 进入telnet远程登录界面
password : edge
aptech2950>en
password: cisco
aptech#

14:交换机配置的重新载入和保存
设置完成交换机的配置后:
aptech2950(conf)#reload 是否保存(y/n) y: 保存设置信息 n:不保存设置信息

路由器命令
router> 用户模式
1:进入特权模式
enable router > enable
router #

2:进入全局配置模式 configure terminal
router > enable
router #configure terminal
router (conf)#

3:交换机命名 hostname routera 以routerA为例
router > enable
router #configure terminal
router(conf)#hostname routerA
routera (conf)#

4:配置使能口令 enable password cisco 以cisco为例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# enable password cisco

5:配置使能密码 enable secret ciscolab 以cicsolab为例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# enable secret ciscolab

6:进入路由器某一端口 interface fastehernet 0/17 以17端口为例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17
routerA (conf-if)#
进入路由器的某一子端口
interface fastethernet 0/17.1 以17端口的1子端口为例
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17.1

7:设置端口ip地址信息
router > enable
router #configure terminal
router(conf)#hostname routerA
routerA(conf)# interface fastehernet 0/17 以17端口为例
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口ip和子网掩码
routerA (conf-if)#no shut 是配置处于运行中
routerA (conf-if)#exit

8:查看命令 show
router > enable
router # show version 察看系统中的所有版本信息
show interface vlan 1 查看交换机有关ip 协议的配置信息
show running-configure 查看交换机当前起作用的配置信息
show interface fastethernet 0/1 察看交换机1接口具体配置和统计信息
show mac-address-table 查看mac地址表
show mac-address-table aging-time 查看mac地址表自动老化时间
show controllers serial + 编号 查看串口类型 show ip router 查看路由器的路由表

9:cdp相关命令
router > enable
router # show cdp 查看设备的cdp全局配置信息
show cdp interface fastethernet 0/17 查看17端口的cdp配置信息
show cdp traffic 查看有关cdp包的统计信息
show cdp nerghbors 列出与设备相连的cisco设备

10:csico2600的密码恢复
重新启动路由器,
在启动过程中按下win+break键,使路由器进入rom monitor
在提示符下输入命令修改配置寄存器的值,remmon1>confreg 0x2142 ,
然后重新启动路由器 remmon2>reset
重新启动路由器后进入setup模式,
选择“no”,退回到exec模式,此时路由器原有的配置仍然保存在startup-config中,
为使路由器恢复密码后配置不变
把startup-config中配置保存到running-config中: router>enable router# startup-config running-config
然后重新设置enable密码: router#configure terminal router(conf)#enable password cisco
并把配置寄存器改回0x2102: router(conf)#config-register 0x2102
保存当前配置到startup-config: router # running-config startup-config router
重新启动路由器: #reload

11:路由器telnet远程登录设置:
router>en
router #configure terminal
router (conf)#hostname routerA
routerA (conf)#enable password cisco 以cisco为特权模式密码
routerA (conf)#interface fastethernet 0/1 以17端口为telnet远程登录端口
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0
routerA (conf-if)#no shut
routerA (conf-if)#exit
routerA (conf)line vty 0 4 设置0-4 个用户可以telnet远程登陆
routerA (conf-line)#login
routerA (conf-line)#password edge 以edge为远程登录的用户密码
主机设置:
ip 192.168.1.2 主机的ip必须和交换机端口的地址在同一网络段
netmask 255.255.255.0 gate-way 192.168.1.1 网关地址是交换机端口地址
运行:
telnet 192.168.1.1 进入telnet远程登录界面
password : edge
routera>en
password: cisco
routera#

12:配置路由器的标识 banner $……………$
在全局配置的模式下利用“banner”命令可以配置路由器的提示信息,所有连接到路由器的终端都会收到。
router>en
router #configure terminal
router (conf)#hostname routerA
routerA(conf)#banner motd $This is aptech company’ router ! Please don’t change the configuration without permission!$

13:配置接口标识 description ………
接口标识用于区分路由器的各个接口。
router>en
router #configure terminal
router (conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1 以0/1 接口为例
routerA(conf-if)# description this is a fast Ethernet port used to connecting the company’s intranet!

14:配置超时
超时适用于设置在多长时间没有对console进行配置,自动返回exec会话时间。默认为10分钟。
router>en
router #configure terminal
router (conf)#hostname routerA
routerA(conf)#line console 0
routerA(conf-if)#exec-timeout 0 0 第一个“0”代表分钟,第二个“0”代表秒

15:配置串口参数
两台路由器通过串口连接需要一个做为DTE,一个做为DCE。
DCE设备要向DTE设备提供时钟频率和带宽。
DCE配置:
router>en
router #configure terminal
router (conf)#hostname routerA
routerA(conf)#interface serial 0/0
routerA(conf_if)#clock rate 64000 提供时钟频率为64000
routerA(conf_if)#bandwidth 64 提供带宽为64
DTE配置:
路由器串口配置ip地址
router>en
router #configure terminal
router (conf)#hostname routerB
routerB(conf)#interface serial 0/0
routerB(conf_if)#ip address 192.168.1.1 255.255.255.0 16:

16:静态路由的配置
配置路由器A的主机名和接口参数
router>enable
router#configure terminal
router(conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1 路由器A的1端口为两路由器的连接端口
routerA(conf-if)#ip address 192.168.2.1 255.255.255.0
routerA(conf-if)#no shutdown
routerA(conf-if)#exit
routerA(conf)# interface fastethernet 0/0 路由器A的0端口为与主机的连接端口
routerA(conf-if)#ip address 192.168.1.2 255.255.255.0
routerA(conf-if)#no shutdown
主机A的ip地址为 192.168.1.1 255.255.255.0 192.168.1.2
配置路由器B的主机名和接口参数
router>enable
router#configure terminal
router(conf)#hostname routerB
routerB(conf)#interface fastethernet 0/0 路由器B的0端口为两路由器的连接端口
routerB(conf-if)#ip address 192.168.2.2 255.255.255.0
routerB(conf-if)#no shutdown
routerB (conf-if)#exit
routerB(conf)# interface fastethernet 0/1 路由器B的1端口为与主机的连接端口
routerB(conf-if)#ip address 192.168.3.1 255.255.255.0
主机B的ip地址为 192.168.3.2 255.255.255.0 192.168.3.1
配置路由器A的静态路由表
routerA(conf)#ip router 192.168.3.0 255.255.255.0 192.168.2.2
配置路由器B的静态路由表
routerA(conf)#ip router 192.168.1.0 255.255.255.0 192.168.2.1
在routerA和routerB上配置默认路由
routerA(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
routerA(conf)#ip classless
routerB(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.1
routerB(conf)#ip classless
在routerA和routerB上配置动态路由(RIP)
routerA(conf)#router rip
routerA(conf)#network 192.168.1.0
routerA(conf)#network 192.168.2.0
routerB(conf)# router rip
routerB(conf)#network 192.168.2.0
routerB(conf)#network 192.168.3.0

❷ 交换机配置命令

1、交换机配置命令,英文名Switchboard Command,是一种计算机语言,用来控制交换机的语言。

❸ 交换机的基本命令是什么

“Switch>”

❹ 写出交换机五种命令状态行和各种命令之间的切换方式

交换机用户视图 使用 enable命令进入特权模式,在特权模式下使用 config t 命令进入全局配置模式,在全局配置模式下使用 interface + 接口名 ,进入接口识图。
使用exit命令退出到上一级识图,直接使用end命令可以直接退出到特权模式。
华为系列交换机使用 system 进入系统识图,quit退出识图返回上一级菜单。

❺ 进入交换机各个模式命令是什么

enable 进特权模式

特权模式下输入
configure terminal 进入全局配置模式

全局配置模式输入
interface E0/1 进接口配置模式 <输入接口名如:E0/1>

输入exit返回全局配置模式

任意模式下按CTRL+C键返回特权模式

❻ 交换机全部命令和汉语翻译,高分送上!

交换机配置命令详解 1. 交换机支持的命令: 交换机基本状态: switch: ;ROM状态, 路由器是rommon hostname ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switchenable ;进入特权模式 switch#config terminal ;进入全局配置模式 switch(config)#hostname ;设置交换机的主机名 switch(config)#enable secret xxx ;设置特权加密口令 switch(config)#enable password xxa ;设置特权非密口令 switch(config)#line console 0 ;进入控制台口 switch(config-line)#line vty 0 4 ;进入虚拟终端 switch(config-line)#login ;允许登录 switch(config-line)#password xx ;设置登录口令xx switch#exit ;返回命令 交换机VLAN设置: switch#vlan database ;进入VLAN设置 switch(vlan)#vlan 2 ;建VLAN 2 switch(vlan)#no vlan 2 ;删vlan 2 switch(config)#int f0/1 ;进入端口1 switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2 switch(config-if)#switchport mode trunk ;设置为干线 switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继 switch(config)#vtp domain ;设置发vtp域名 switch(config)#vtp password ;设置发vtp密码 switch(config)#vtp mode server ;设置发vtp模式 switch(config)#vtp mode client ;设置发vtp模式 交换机设置IP地址: switch(config)#interface vlan 1 ;进入vlan 1 switch(config-if)#ip address ;设置IP地址 switch(config)#ip default-gateway ;设置默认网关 switch#dir flash: ;查看闪存 交换机显示命令: switch#write ;保存配置信息 switch#show vtp ;查看vtp配置信息 switch#show run ;查看当前配置信息 switch#show vlan ;查看vlan配置信息 switch#show interface ;查看端口信息 switch#show int f0/0 ;查看指定端口信息

❼ 普通交换机常用配置命令是什么

第一个回答的那个就挺详细的,算是普通操作吧。基本上包括第一次进机的配置,密码配置,创建vlan,对特定端口设定访问vlan,基本的就这些了,其他的比如show命令,这个有很多选项的,show
running-config之类的查看工作状态和排错的也很多也重要。

❽ 在交换机的全局配置模式下键入命令,请问能够查看交换机的什么信息

一级命令标题及释义

❾ 华为交换机从特权到全局的命令是什么 华为交换机几种模式的切换命令是什么

华为交换机切换命令如下:



(9)交换机全局命令扩展阅读:

华为交换机VRP系统配置文件是VRP命令行的集合,用户可将当前配置保存到配置文件中,以便在交换机重启后这些配置能够继续生效。另外,通过配置文件用户可以非常方便地查阅配置信息,也可以将配置文件上传到其它的交换机上,实现交换机的批量配置。

配置文件为文本文件,其规则如下:

1、以命令格式保存。

2、为了节省空间,只保存非缺省的参数。

3、以命令视图为基本框架,同一命令视图的命令组织在一起,形成一节,节与节之间通常用空行或注释行隔开(以“#”开始的为注释行)。空行或注释行可以是一行或多行。

4、文件中各节的顺序安排通常为:全局配置、接口配置、各种协议配置和用户界面配置。

5、配置文件必须以“.cfg”或“.zip”作为扩展名,而且必须存放在存储交换机的根目录下。

❿ 交换机的常用配置命令

a、更改远程TELNNET密码
Switch#configure terminal

Switch(config)#line vty 0 4

Switch(config-line)#password qycx123

Switch(config-line)#login

Switch(config-line)#exit

b、更改进入全局配置模式时的密码

Switch#configure terminal

Switch(config)#enable secret qycx123

思科交换机常用命令——创建并划分VLAN

a、创建VLAN

Switch#vlan database

Switch(vlan)#vlan 99 name office (创建vlan 99 并命名为office)

b、将端口划分至vlan

Switch(config)#interface fastEthernet 0/8

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 99 (将8号快速以太口划分至vlan 99)

思科交换机常用命令——调试命令

a、显示所有配置命令:Switch#show run

b、显示所有接口状态:Switch#show ip int brief

c、显示所有VLAN的信息:Switch#show vlan brief

cisco交换机还是比较常用的,于是我研究了一下Cisco交换机命令的大总结,在这里拿出来和大家分享一下,希望对大家有用。我所针对的都是Cisco的设备而言的,华为的可以跟据手册来查,配置都是差不多的,这里华子就不多写华为的设备了,了解的也不是很多。

Cisco交换机命令之使用Telnet远程式管理

switch(config)#interface vlan 1 进入vlan 1

switch(config-if)#ip address 设置IP地址

switch(config-if)#ip default-gateway 设置默认网关

switch(config)#line vty 0 4 进入虚拟终端

switch(config-line)#login 允许登录

switch(config-line)#password xx 设置登录口令

switch#exit 返回命令

Cisco交换机命令之控制台口令

switch(config)#line console 0 进入控制台口

switch(config-line)#login 允许登录

switch(config-line)#password xx 设置登录口令

switch#exit 返回命令

Cisco交换机命令之基本接口配置

switch(config)#interface f0/1 进入f0/1接口

switch(config-if)#plex full 配置全双工模式

switch(config-if)#speed 100 配置速率

switch(config-if)#description to ***** 接口描述

switch(config)#ip domain-name ***.com 设置或名服务器

switch(config)#mac-address-table aging-time 设置mac表超时时间

switch#write 保存配置信息

switch# running-config startup-config 保存当前配置nvram

switch#erase startup-config 清除配置文件

Cisco交换机命令之交换机VLAN设置:

switch#vlan database 进入VLAN设置

switch(vlan)#vlan 2 建VLAN 2

switch(vlan)#name 名字 建VLAN 2的名称

switch(vlan)#no vlan 2 删vlan 2

注:删除vlan时原属于此vlan的端口处于非激活状态,直到重新分配为止。

switch(config)#int f0/1 进入端口1

switch(config-if)#switchport mode access 当前端口工作莫试

switch(config-if)#switchport access vlan 2 当前端口加入vlan 2

switch(config-if)#switchport mode trunk 设置为干线

switch(config-if)#switchport trunk encapsulation dot1q 设置vlan 中继协议

switch(config-if)#no switchport mode 或 ( switchport mode access) 禁用干线

switch(config-if)#switchport trunk allowed vlan add 1,2 ; 从Trunk中添加vlans

switch(config-if)#switchport trunk allowed vlan remove 1,2 ;从Trunk中删除vlans

switch(config-if)#switchport trunk pruning vlan remove 1,2 ;从Trunk中关闭局部修剪

Cisco交换机命令之以太网通道配置

switch(config)#interface range fasternet0/1 - 2 将fasternet0/1和0/2 口捆绑

switch(config-if)#channel-group 1 mode on 配置以太通道模式

switch(config-if)#port-channel load-balance {dst-mac | src-mac}在链路间实现负载均衡

switch#show etherchannel 1 summary 查看通道信息

switch#show etherchannel load-balance 查看通道信息

Cisco交换机命令之vtp配置

switch(config)#vtp domain 设置vtp域名

switch(config)#vtp password 设置vtp密码

switch(config)#vtp mode server 设置vtp服务器模式

switch(config)#vtp mode client 设置vtp客户机模式

switch(config)#vtp mode transparent 设置vtp 透明模式

switch(config)#vtp version 设置vtp版本

switch(config)#vtp pruning 启用vtp修解

switch(config)#no vtp pruning 关闭vtp修解

注:要想从vtp中减少一台交换机只需将该交换机vtp 名更改

Cisco交换机命令之生成树stp:

switch(config)#spanning-tree vlan 启用stp生成树(基于vlan)

switch(config)#spanning-tree vlan root primary 指定根交换机(基于vlan)

switch(config)#spanning-tree vlan root secondary 指定备用根交换机(基于vlan)

switch(config)#spanning-tree vlan priority 指定交换机优先级(基于vlan)

switch(config)#no spanning-tree vlan priority 将交换机的优先级恢复默认值(基于vlan)

switch(config-if)#spanning-tree vlan cost 指定端口成本(起用trunk的端口模式下)

switch(config-if)#spanning-tree vlan port-prioty 指定交换机端口优先级(基于vlan)

switch(config-if)#spanning-tree portfast 配置速端口(连接终端设备的端口状态)如pc机

switch(config)#spanning-tree uplinkfast 配置上行速端口

switch(config)#spanning-tree vlan hello-time 配置交换机hello时间(基于vlan)

switch(config)#spanning-tree vlan forward-time 修改转发延迟计时器(基于vlan)

switch(config)#spanning-tree vlan max-time 修改最大老化时间(基于vlan)

switch#show spanning-tree summery 检测vlan生成树配置

switch#show spanning-tree vlan detail 浏览详细生成树配置信息

switch#show spanning-tree interface detail 浏览详细生成树端口配置信息

Cisco交换机命令之交换机显示命令:

switch#show vtp status 查看vtp配置信息

switch#show running-config 查看当前配置信息

switch#show vlan 查看vlan配置信息

switch#show interface 查看端口信息

switch#show int f0/0 查看指定端口信息

switch#dir flash: 查看闪存

switch#show version 查看当前版本信息

switch#show mac-address-table aging-time 查看mac超时时间

switch#show cdp cisco设备发现协议 (可以查看聆接设备)

switch#show cdp traffic 杳看接收和发送的cdp包统计信息

switch#show cdp neighbors 查看与该设备相邻的cisco设备

switch#show interface f0/1 switchport 查看有关switchport的配置

switch#show cdp neighbors 查看与该设备相邻的cisco设备

阅读全文

与交换机全局命令相关的资料

热点内容
暴力删除命令 浏览:801
qt如何编译加快速度 浏览:901
php添加数据sql语句 浏览:717
免费的小说app有什么 浏览:405
螺杆压缩机进气阀动画 浏览:651
两台服务器如何做负载均衡 浏览:227
程序员的工资是涨的吗 浏览:813
视频存储服务器可以干什么 浏览:463
创建文件夹安装失败怎么回事 浏览:832
程序员高考隔了几年 浏览:822
云服务器是哪一层 浏览:22
jit编译器的jit什么意思 浏览:330
我想清理手机中空白文件夹 浏览:976
电脑e盘文件夹删不掉怎么办 浏览:607
外圆凹圆弧编程 浏览:461
html5编程题 浏览:839
干燥机制冷压缩机一开就跳动 浏览:388
吉林压缩空气流量监测 浏览:618
根据地址获取经纬度php 浏览:12
小天才app的应用中心有什么应用 浏览:770