導航:首頁 > 源碼編譯 > 同花順主力控盤買點源碼

同花順主力控盤買點源碼

發布時間:2022-08-18 18:09:11

1. 哪位高手知道同花順軟體中的技術指標"買必升"的源碼我在同花順指標平台上看到的,知道的請說一下,先謝過!

我用的是這個,有買賣點提示的。

2. 請高手根據源碼編寫兩個同花順選股公式;1首次出現有庄控盤,2首次出現強庄控盤

VAR1:=EMA(EMA(CLOSE,9),9);
控盤:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盤<0,控盤,0,6,0),colorwhite;

A10:=CROSS(控盤,0);
無庄控盤:IF(控盤<0,控盤,0),LINETHICK0,colorwhite;
開始控盤:IF(A10,5,0),LINETHICK1,coloryellow;
STICKLINE(控盤>REF(控盤,1) AND 控盤>0,控盤,0,6,0),colorred;
有庄控盤:IF(控盤>REF(控盤,1) AND 控盤>0,控盤,0),LINETHICK0,colorred,;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盤>0,控盤,0,6,0),COLORFF00FF;
高度控盤:IF(VAR2>50 AND COST(85)<CLOSE AND 控盤>0,控盤,0),LINETHICK0,COLORFF00FF;
STICKLINE(控盤<REF(控盤,1) AND 控盤>0,控盤,0,6,0),COLOR00FF00;
主力出貨:IF(控盤<REF(控盤,1) AND 控盤>0,控盤,0),LINETHICK0,COLOR00FF00

3. 有朋友能分享一下同花順這個買入不虧的公式指標源代碼嗎謝謝啦!

不要太相信指標公式什麼的,從圖上看,你如果學會了均線和k線的應用還有成交量,基本上什麼指標公式都不需要了。

4. 同花順 漲停先鋒Ⅲ操盤線公式源碼

不是公式錯誤,而是此公式為通達信的,下面是我的公式,可以加到通達信去試試

MA5:MA(CLOSE,M1),LINETHICK1,COLORFFFFFF;
MA10:MA(CLOSE,M2),LINETHICK1,COLOR00FFFF;
MA30:MA(CLOSE,M3),LINETHICK1,COLORFF00FF;
MA60:MA(CLOSE,M4),LINETHICK1,COLOR0000FF;
MA120:MA(CLOSE,M5),LINETHICK1,COLORFFFF00;
DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),(LOW * 0.99),'Ψ'),LINETHICK3,COLORF00FF0;
DRAWTEXT(CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2)),(HIGH * 1.01),'◎'),LINETHICK3,COLORFFFFFF;
STICKLINE((EMA(CLOSE,2) >= EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLOR0000FF;
STICKLINE((EMA(CLOSE,2) >= EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE((EMA(CLOSE,2) >= EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE((EMA(CLOSE,2) < EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLORCCCC00;
STICKLINE((EMA(CLOSE,2) < EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE((EMA(CLOSE,2) < EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLORFFFF00;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)) OR CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),LOW,HIGH,0.1,0),COLOR00FFFF;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)) OR CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)) OR CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,2,0),COLOR00CCCC;

5. 請高手將源碼改成首次主力進的同花順選股公式

V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5;
主力進:(V4>=0 AND REF(V4,1)<0);
{復制可直接使用}

6. 同花順DPO指標源碼

在個股日K線圖的任何一天上,雙擊滑鼠左鍵,在日K線圖的右下角會有那一天的實時交易K線.
如果不會運用,可求助幫助功能.
如: 大智慧的指標快捷鍵
打開大智慧'幫助'--4.5指標快捷鍵一覽
〖110〗:MA 移動平均線 〖112〗:CHANNELS 通道線
〖114〗:主力成本 〖115〗:TDX 天地線
〖116〗:SAR 拋物轉向 〖117〗:XS 薛氏通道
〖118〗:PBX 瀑布線 〖120〗:ROC 變動速率
〖121〗:MTM 動力指標 〖123〗:DMI 趨向指標
〖125〗:RSI 相對強弱指標 〖126〗:主力軌跡
〖128〗:DMA 平均離差 〖130〗:DPO 區間震盪線

〖132〗:MACD 指數平滑異同平均線 〖133〗:KDJ 隨機指標
〖134〗:CCI 順勢指標 〖139〗:PSY 心理線
〖140〗:BIAS 乖離率 〖141〗:W&R 威廉指標
〖142〗:%B 布林極限 〖143〗:CR 能量指標
〖144〗:BRAR 人氣意願指標 〖148〗:TRIX 三重指數平滑平均數
〖149〗:ASI 振動升降指標 〖150〗:OBV 能量潮
〖151〗:主力進出 〖154〗:MFI 資金流量指標

〖155〗:PVI 正量指標 〖156〗:NVI 負量指標
〖157〗:VMACD 指數平滑異同平均線 〖158〗:VR 容量比率
〖161〗:WVAD 威廉變異離散量 〖163〗:EMV 簡易波動指標
〖164〗:拉升在即 〖165〗:底部構成
〖166〗:主力買賣 〖170〗:MIKE 麥克指標
〖171〗:CDP 逆勢操作 〖180〗:ADL 藤落指數
〖181〗:ADR 漲落比率 〖182〗:ABI 指標
〖183〗:STIX 指數平滑廣量指標 〖187〗:EXPMA 平滑移動平均線

〖188〗:散戶線 〖189〗:KCX 控籌線
〖190〗:成交筆數 〖191〗:每筆手數

〖AD〗:AD集散量、A/D上漲家數比 〖ABI〗:ABI 指標
〖ACD〗:ACD 收集派發 〖ADL〗:ADL 藤落指數
〖ADR〗:ADR 漲落比率 〖ALF〗:ALF 過濾指標
〖ASI〗:ASI 振動升降指標 〖ASR〗:ASR 浮籌比例
〖ATR〗:ATR 真實波幅 〖AMOUNT〗:AMOUNT 成交額
〖ADTM〗:ADTM 動態買賣氣指 〖B〗:%B 布林極限

〖BBI〗:BBI 多空指數 〖BTI〗:BTI 廣量沖力指標
〖BFTD〗:VB 波幅通道 〖BIAS〗:BIAS 乖離率
〖BOLL〗:BOLL 布林線 〖BRAR〗:BRAR 人氣意願指標
〖B3612〗:B3612三減六日乖離 〖BWIDTH〗:BWIDTH 布林極限寬
〖BBIBOLL〗:BBIBOLL 多空布林線 〖CD〗:CD 相對強度
〖CHAIKIN〗: CHAIKIN 佳慶線 〖CR〗:CR 能量指標
〖CCI〗:CCI 順勢指標 〖CDP〗:CDP 逆勢操作

〖CHO〗:CHO 濟堅指數 〖CYC〗:CYC 指南針成本均線
〖CYS〗:CYS 市場盈虧 〖CYW〗:CYW 主力控盤
〖CYQKL〗: CYQKL 指南針博弈K線長度 〖DDI〗:DDI 方向標准離差指數
〖DKX〗:DKX 多空線 〖DMA〗:DMA 平均離差
〖DMI〗:DMI 趨向指標 〖DMIQL〗DMI-QL 趨向指標(錢龍)
〖DPO〗:DPO 區間震盪線 〖DBCD〗:DBCD 異同離差乖離率
〖DBGC〗:DBGC 底部構成 〖DPTB〗:DPTB 大盤同步指標

〖EMV〗:EMV 簡易波動指標 〖ENV〗:ENV 軌道線
〖EOM〗:EOM 活動能力 〖EXPMA〗:EXPMA 平滑移動平均線
〖FASTKD〗:FASTKD 隨機快步 〖GLZB〗:ALF 過濾指標
〖HDNL〗:EOM 活動能力 〖II〗:II當日成交密度
〖JDQS〗:JDQS 階段強勢指標 〖JJZB〗:CHO 濟堅指數
〖JEZF〗:江恩正方 〖KD〗:KD 隨機指標
〖KDJ〗:KDJ 隨機指標 〖KST〗:KST 完定指標

〖LFS〗:LFS 鎖定因子 〖LWR〗:LW&R 威廉指標
〖LJX〗:量價線 〖LJQS〗:VPT 量價趨勢
〖LSZJ〗:LSZJ 拉升在即 〖M1〗:M1 移動平均線
〖MA〗:移動平均線 〖MI〗:MI 動量指標
〖MFI〗:MFI 資金流量指標 〖MJR〗:MJR
〖MTM〗:MTM 動力指標 〖MACD〗:MACD 指數平滑異同平均線
〖MASS〗:MASS 重量指數 〖MICD〗:MICD 異同離差動力指數

〖MIKE〗:MIKE 麥克指標 〖NDB〗:NDB 腦電波
〖NVI〗:NVI 負量指標 〖NORVOL〗:NORVOL 標准化成交量
〖OX〗:OX 圖 〖OBV〗:OBV 能量潮
〖OSC〗:OSC 震盪量 〖OBOS〗:OBOS 超買超賣
〖OLAL〗:OLAL 疊加線 〖PR〗:PR 穿透率
〖PBX〗:PBX 瀑布線 〖PSY〗:PSY 心理線
〖PVI〗:PVI 正量指標 〖PVT〗:PVT價/量 趨勢

〖PRICE〗:PRICE 價位線 〖PRICEOSC〗:PRICEOSC 指數震盪
〖QLCX〗:錢龍長線 〖QLDX〗:錢龍短線
〖QLZB〗:錢龍指標 〖QRSI〗:QRSI 量RSI
〖QHLSR〗:QHLSR 阻力指標 〖RC〗:RC 變化率指數
〖RS〗:RS 相對強弱比 〖RMI〗:RMI
〖ROC〗:ROC 變動速率 〖RSI〗:RSI 相對強弱指標
〖RCCD〗:RCCD 異同離差變化率指數 〖SP〗:SP 低點搜尋交易系統

〖SAR〗:SAR 拋物轉向 〖SCR〗:SCR 籌碼集中度
〖SMI〗:SMI 〖SJKB〗:FASTKD 隨機快步
〖SJPF〗:ACD 收集派發 〖SOBV〗:SOBV 能量潮
〖SRMI〗:SRMI MI 修正指標 〖STIX〗:STIX 指數平滑廣量指標
〖SLOWKD〗:SLOWKD 慢速KD 〖SDKJ〗:四度空間
〖TBR〗:TBR 新三價率 〖TDX〗:TDX 天地線
〖TDZS〗:CCI-4.0 通道指數 〖TRIX〗:TRIX 三重指數平滑平均數

〖TRIX40〗:TRIX-4.0 TRIX趨向指標 〖UOS〗:UOS 終極指標
〖VB〗:VB 波幅通道 〖VR〗:VR 容量比率
〖VMA〗:VMA 成交量指標 〖VOL〗:VOL 成交量
〖VPT〗:VPT 量價趨勢 〖VOSC〗:VOSC 成交量震盪
〖VSTD〗:VSTD 成交量標准差 〖VMACD〗:VMACD 指數平滑異同平均線
〖WR〗:W&R 威廉指標 〖WDZB〗:KST 完定指標
〖WLLD〗:威力雷達 〖WVAD〗:WVAD 威廉變異離散量

〖XS〗:XS 薛氏通道 〖XDT〗:XDT 心電圖
〖ZIG〗: ZIG ZIG ZAG 之字轉向 〖ZDZB〗:ZDZB 築底指標
〖ZHPS〗:ZHPS 智慧判勢 〖ZHSL〗:ZHSL 換手率
〖ZLGJ〗:ZLGJ 主力軌跡 〖ZLJC〗:ZLJC 主力進出
〖ZLMM〗:ZLMM 主力買賣 〖ZUPR〗:ZUPR 階段漲幅
〖ZVOL〗:ZVOL 階段總成交量 〖ZLCB〗:主力成本
〖ZAMOUNT〗:ZAMOUNT 階段總成交額 〖CCI40〗:CCI-4.0 通道指數

〖STOCKRSI〗:STOCKRSI 〖SHX〗:散戶線

7. 求文檔: 經傳主力控盤指標通達信源碼

{N 1 300 35
M 1 500 35
N1 1 1000 3}
B1:=(HHV(H,N)-C)/(HHV(H,N)-LLV(LOW,N))*100- M;
B2:=SMA(B1,N,1)+100;
B3:=(C-LLV(L,N))/(HHV(H,N)- LLV(L,N))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
控盤程度:(IF(B6>N1,B6-N1,0))*2.5,COLORYELLOW;
控盤度:100,COLORRED;
STICKLINE( 控盤程度,0,控盤程度 ,7,0 ),COLOR00FFFF;
STICKLINE( 控盤程度 AND 控盤程度>100,100,控盤程度 ,7,0 ),COLORRED;

這個是網上現在流傳的經傳主力控盤源碼。主要是模仿了指標的形態,指標的內在演算法是完全偏離不真實的。

8. 同花順主力密碼原理

同花順主力密碼是同花順其推出的一款行情分析功能,這款產品主要是分析個股主力資金的動向,通過金融機構的核心演算法,計算出每隻股票的主力控盤度、主力堅決度、主力進場動能、主力獲利度、量價背離度,來分析主力意圖。
需要注意的是,分析功能只能作為參考作用,任何軟體上的分析功能都只能做參考,要判斷行情一定要綜合分析,有一套系統的方法。
同花順的主力密碼只能作為參考,任何軟體的技術指標都只能作為參考,技術指標都要結合起來看的,而且現在的市場環境,技術指標作用不大。
產品特色指標:主力控盤度、主力堅決度、主力進場動能、主力獲利度以及量價背離度。
產品策略:根據歷史大數據回測計算主力的意圖,幫助用戶判斷該股票是否有主力在活躍,應該買入還是賣出,投資者可作為參考。

9. 請高手把通達信的這條主力資金(開始控盤、控盤、主力出貨、主力吸貨)指標公式源碼改為可以在同花順上使

VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);
VAR6:=MA(VAR5,3);
開始控盤:=STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR00AAFF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3.5,0),COLOR0044FF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),2.5,0),COLOR0088FF;
STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),3,0),COLOR00AAFF;
VAR1:=EMA(EMA(CLOSE,3),1);
控盤:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盤<0,控盤,0,3.5,0),COLORFFAA00;
STICKLINE(控盤<0,控盤,0,3.5,2,0,),COLORFF4400;
STICKLINE(控盤<0,控盤,0,2.5,0),COLORFF8800;
STICKLINE(控盤<0,控盤,0,0,0),COLORFFAA00;
主力出貨:0,COLORFFAA00;
STICKLINE(控盤>REF(控盤,3) AND 控盤>0,控盤,0,3.5,0),COLOR000088;
STICKLINE(控盤>REF(控盤,3) AND 控盤>0,控盤,0,2.5,0),COLOR0000AA;
STICKLINE(控盤>REF(控盤,3) AND 控盤>0,控盤,0,1.5,0),COLOR0000CC;
STICKLINE(控盤>REF(控盤,3) AND 控盤>0,控盤,0,1,0),COLOR0000EE;
主力吸貨:0,COLOR0000FF;
STICKLINE(控盤<REF(控盤,3) AND 控盤>0,控盤,0,3.5,0),COLOR008800;
STICKLINE(控盤<REF(控盤,3) AND 控盤>0,控盤,0,2.5,0),COLOR00AA00;
STICKLINE(控盤<REF(控盤,3) AND 控盤>0,控盤,0,1.5,0),COLOR00CC00;
STICKLINE(控盤<REF(控盤,3) AND 控盤>0,控盤,0,1,0),COLOR00EE00;
對倒出貨洗盤:0,COLOR00FF00;
黃色底部吸貨:0,coloryellow;
DRAWTEXT(CROSS(控盤,0),0-3,'買。追'),COLORFF00FF;
DRAWTEXT(CROSS(0,控盤),0-0,'賣'),colorgreen;
{去除了收費專用函數和未來函數部分}

10. 同花順的指標公式,高分求高人,幫我把這個編譯成買入點選股公式

Var1:=(HHV(HIGH,5)-LLV(LOW,5));
Var2:=(HHV(HIGH,9)-CLOSE);
Var3:=(CLOSE-LLV(LOW,9));
Var4:=Var2/Var1*100-70
;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(2*C+H+L)/4;
Var7:=SMA((Var3/Var1*100),3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
Var10:=
IF(Var9>100,Var9-100,0);
VarA:=HHV(HIGH,34);
主力:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
見底信號
:
=10;
買入准備:
=IF(主力<=10,50,10);
買入時機:
=IF(CROSS(主力,見底信號),100,10);
XG:買入時機=100;

閱讀全文

與同花順主力控盤買點源碼相關的資料

熱點內容
安卓打游戲怎麼設置電話勿擾 瀏覽:891
顯示所屬概念指標源碼 瀏覽:834
照片怎麼合成pdf 瀏覽:28
安卓手機如何錄制王者戰績 瀏覽:388
pec盤文件夾灰了 瀏覽:509
查詢指定命令是否為內建命令 瀏覽:427
gridview行高android 瀏覽:447
itextpdfjsp 瀏覽:277
雲主機加密狗哪個品牌好 瀏覽:621
酷跑用什麼文件夾 瀏覽:192
國外解壓小實驗 瀏覽:724
強硬的命令 瀏覽:608
向量pdf 瀏覽:715
釘釘開通第三方加密服務 瀏覽:520
牙科用空氣壓縮機 瀏覽:255
在linux上卸載jdk 瀏覽:764
演算法軟體實現 瀏覽:837
pdf怎麼列印小冊子 瀏覽:907
qt只編譯核心組件 瀏覽:2
java線程阻塞的方法 瀏覽:823