導航:首頁 > 源碼編譯 > 壓力支撐位源碼

壓力支撐位源碼

發布時間:2024-06-21 09:04:28

❶ 通達信如何在k線主圖上顯示壓力位和支撐位

支撐壓力位,首先你要有判斷支撐壓力位的條件,沒有條件無法畫出支撐壓力位.

畫支撐壓力位有很多方法,
例如黃金比例
高低點
通道線
等等等

❷ 求博易大師指標帶源碼,可能叫壓力支撐或壓力支撐線吧,具體什麼請看看圖

壓力:HHV(H,20),COLOR0000FF;
支撐:LLV(L,20),COLOR00FF00;
============================
看你的圖,大概是這樣編寫公式,你試試

❸ 通達信指標中如何自動畫線

自動畫線太多了,給你一個我看好的,源碼下面網址里有圖片演示.

該指標能夠做到對前期高點和最近高點的連線、前期低點和最近低點的連線、阻力位和支撐位的平行直線的連線,可以說簡單易懂,一目瞭然。這類指標要用到未來函數,通常不做為買賣信號的參考。但該指標在一定周期內根據K線的走勢所畫的線已經成立,因此股價突破前高或頸線的點位還是比較可靠的,大家不妨在實戰中來驗證。所以,除了主圖以外,還編制了選股指標。
指標中的實線為高、低點連線,虛線為阻力位和支撐位。
該指標可以復制粘貼到任何主圖里。

MA7:MA(C,7),COLORWHITE;
MA14:MA(C,14),COLORYELLOW;
MA25:MA(C,25),COLORFF00FF;
MA120:MA(C,120),COLORFFCC66;
QA:=REF(H,10)=HHV(H,2*10+1);
QB:=BACKSET(QA,10+1);
QC:=FILTER(QB,10) AND H=HHV(H,10+1);
QD:=BARSLAST(QC);
QE:=IF(QC,CURRBARSCOUNT,0);
QF:=IF(QD,REF(QE,QD),QE);
QG:=CONST(QF);
QH:=REF(QF,QD+1);
QW:=CONST(QH);
DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
QM:=INTPART(3*8/5);
QR:=REF(H,QM)=HHV(H,2*QM+1);
QT:=FILTER(QR,QM);
QY:=BACKSET(QT,QM+1);
QU:=FILTER(QY,QM);
QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
QP:=QI>REF(QI,1);
DRAWLINE(QU,H,QP,H,1),COLORRED;
QA1:=REF(L,8)=LLV(L,2*8+1);
QB1:=BACKSET(QA1,8+1);
QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
QD1:=BARSLAST(QC1);
QE1:=IF(QC1,CURRBARSCOUNT,0);
QF1:=IF(QD1,REF(L,QD1),L);
QG1:=IF(QD1,REF(QE1,QD1),QE1);
QH1:=CONST(QG1);
QW1:=REF(QF1,QD1+1);
QM1:=REF(QG1,QD1+1);
QR1:=CONST(QM1);
DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
QT1:=REF(L,QM)=LLV(L,2*QM+1);
QY1:=FILTER(QT1,QM);
QU1:=BACKSET(QY1,QM+1);
QI1:=FILTER(QU1,QM);
QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
QJ1:=QP1>REF(QP1,1);
DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信號}

❹ 股票軟體通達信里有一個LFS,籌碼鎖定因子,這個是什麼意思,源碼是什麼,有未來嗎

指標原理:
LFS指標是體現股票買入者是持籌不動,還是實施賣出這兩種操作行為的比例,持籌的比例增大表示鎖定加快,賣出的比例增大則表示解鎖加快。
形態特點:
LFS指標有33、50、67三條橫坐標線和一條LFS指標值走勢黃線,LFS指標值位於50時籌碼鎖定、解鎖處於平衡狀態,高於50鎖定加快,低於50解鎖加快,LFS指標值大部分時間在50以上運行,但有時會快速下探,然後又迅速拉起繼續高位運行,形成錐底。
證券之星問股

❺ 請教高手老師,怎麼能把股市提款機中全倉和出擊同時選出,或者選出全倉,出擊,出貨,指標源碼,多謝老師

ma20:=MA(CLOSE,20);
ma120:=MA(CLOSE,120);
ma30:=MA(CLOSE,37);
map:=MA(CLOSE,8);
aa5:=MA(CLOSE,21);
aa10:MA(CLOSE,8),color0000ff;
aa12:MA(CLOSE,12),color0000ff;
bb10:=((ATAN((aa10 - REF(aa10,1))) * 3.1416) * 10);
bb12:=((ATAN((aa12 - REF(aa12,1))) * 3.1416) * 10);
ma13:=MA(CLOSE,13);
var1q:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
中期大底:LLV(LOW,30),colorcdffbb;
短底:=EMA(var1q,5);
支撐:=HHV(短底,60);
壓力一:HHV(LOW,20),colorfaabec;
壓力:=SMA(LOW,5,1);
中線:=MA(CLOSE,3);
DRAWTEXT(FILTER(((((HIGH > 支撐) AND (CLOSE < 支撐)) AND ((CLOSE / OPEN) > (0 - 1.06))) AND (CLOSE < OPEN)),5),(HIGH + 0.02),'←逃'),color00ffff;
中軌道:=(MA(HIGH,15) * 1.05);
天:=(MA(LOW,15) * 0.985);
人:=(MA(LOW,15) * 0.96);
地:=(((HIGH + LOW) + CLOSE) / 3);
b1:=HHV(地,(4 * 15));
b6:=LLV(地,(4 * 15));
b7:=(b1 - b6);
b8:=(MA(((地 - b6) / b7),2) * 80);
var1:=(((CLOSE - LLV(LOW,100)) / (HHV(HIGH,100) - LLV(LOW,100))) * 200);
飛龍頂底線:=SMA(var1,3,1);
var2:=SMA(飛龍頂底線,3,1);
var3:=((3 * 飛龍頂底線) - (2 * var2));
var4:=LLV(LOW,5);
var5:=HHV(HIGH,5);
var6:=(EMA((((CLOSE - var4) / (var5 - var4)) * 100),4) * 2);
var7:=EMA(((0.667 * REF(var6,1)) + (0.333 * var6)),2);
var8:=((3 * var6) - (2 * var7));
var9:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));
vara:=(POW(MA(LOW,5),2) + MA(LOW,5));
varb:=(POW(MA(HIGH,5),2) + MA(HIGH,5));
varc:=(((((var9 - LLV(vara,64)) / (HHV(varb,64) - LLV(vara,64))) * 150) + 65) - 10);
vard:=((SMA(varc,3,1) * 1.5) - 100);
vare:=SMA(vard,3,1);
varf:=((3 * vard) - (2 * vare));
var10:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
var11:=EMA(var10,13);
var12:=STD(var10,13);
var13:=(((var10 - var11) * 100) / var12);
var14:=EMA(var13,5);
var15:=EMA(var14,13);
var16:=((EMA(var14,13) + 200) - 100);
var17:=EMA(var16,10);
var18:=((3 * var16) - (2 * var17));
var19:=(((飛龍頂底線 + var6) + vard) + var16);
var1a:=(((var2 + var7) + vare) + var17);
var1b:=(((var3 + var8) + varf) + var18);
var1c:=(((HIGH + LOW) + CLOSE) / 3);
var1d:=((AMOUNT / VOL) / 100);
var1e:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);
var1f:=((var1c - MA(var1c,34)) / (0.015 * AVEDEV(var1c,34)));
var20:=DMA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
var21:=((((HIGH + LOW) + CLOSE) + var1c) / 4);
var22:=EMA(var21,24);
var23:=STD(var21,24);
var24:=(((var21 - var22) / var23) * 100);
var25:=((var1c - MA(var1c,24)) / (0.015 * AVEDEV(var1c,24)));
var26:=EMA(var24,5);
var27:=((var1d - MA(var1d,21)) / (0.015 * AVEDEV(var1d,21)));
var28:=((var1e - MA(var1e,90)) / (0.015 * AVEDEV(var1e,90)));
var29:=(((((((var28 + var27) + var26) + var25) + var1f) / 5) + 165) / 4);
var2a:=(((((var19 + var1a) + (var1b * 30)) / 32) / 5) - 15);
var2b:=(((var29 + var2a) / 2) / 1.1);
var2c:=var2b;
短線:=MA(var2c,26);
mid:=(短線 + (2 * STD(var2c,26)));
upper:=(短線 - (2 * STD(var2c,26)));
lower:=IF((var2c > 短線),短線,var2c);
xy:=MA(CLOSE,5);
ma5:=MA(CLOSE,80);
短期底部:(LLV(HIGH,30) * 0.93),color0000ff;
ma80:=LLV(HIGH,30);
短期底部二:=SMA(CLOSE,2,1);
趨勢:=(MA(LOW,10) * 0.96);
趨:=(EMA(OPEN,107) * 0.897);
超跌位二:=MA(CLOSE,15);
gf:=MA(CLOSE,10);
man:=(SMA(HIGH,21,2) * 1.05);
上一:=(HHV(短底,60) * 0.92);
壓力二:=(SMA(HIGH,21,2) * 1.035);
阻擋線:=(SMA(LOW,21,2) * 0.96);
下檔線:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
rsv:=SMA(下檔線,3,1);
k:=SMA(rsv,3,1);
d:=((3 * rsv) - (2 * k));
j:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
var2p:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
var3p:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
var4p:=(((j + (2 * var2p)) + (3 * var3p)) / 6);
var5p:=MA(var4p,3);
var6p:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
rsv12:=SMA(var6p,3,1);
k12:=SMA(rsv12,3,1);
d12:=((3 * rsv12) - (2 * k12));
j12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
rsv24:=SMA(j12,3,1);
k24:=SMA(rsv24,3,1);
d24:=((3 * rsv24) - (2 * k24));
{j24:=IF(CROSS(d,d24),LOW,REF(LOW,BARSLAST(CROSS(d,d24))));}
壓力位:IF(CROSS(d24,d),HIGH,L),POINTDOT,colorffffff;
支撐位:=IF((CLOSE >= MA(CLOSE,20)),80,50);
u2l:=IF((CLOSE >= MA(CLOSE,20)),50,20);
{l2l:=IF(((d < 支撐位) AND (REF(d,1) >= 支撐位)),HHV(REF(HIGH,1),(BARSLAST(((d >= 支撐位) AND (REF(d,1) < 支撐位))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((d >= 支撐位) AND (REF(d,1) < 支撐位))) - 1)),BARSLAST(((d < 支撐位) AND REF(d,1)))));
rh1:=IF((HIGH > l2l),LOW,REF(LOW,BARSLAST((HIGH > l2l))));
rh4:=IF((HIGH > l2l),d,REF(d,BARSLAST((HIGH > l2l))));
rh42:=IF((((HIGH > rh1) AND (d < rh4)) AND (d < d24)),HIGH,REF(HIGH,BARSLAST((((HIGH > rh1) AND (d < rh4)) AND (d < d24)))));
rh5:=IF(((d > u2l) AND (REF(d,1) <= u2l)),LLV(REF(LOW,1),(BARSLAST(((d <= u2l) AND (REF(d,1) > u2l))) - 1)),REF(LLV(REF(LOW,1),(BARSLAST(((d <= u2l) AND (REF(d,1) > u2l))) - 1)),BARSLAST(((d > u2l) AND REF(d,1)))));
rl1:=IF((LOW < rh5),HIGH,REF(HIGH,BARSLAST((LOW < rh5))));
rl4:=IF((LOW < rh5),d,REF(d,BARSLAST((LOW < rh5))));
rl42:=IF((((LOW < rl1) AND (d > rl4)) AND (d > d24)),LOW,REF(LOW,BARSLAST((((LOW < rl1) AND (d > rl4)) AND (d > d24)))));}
長期底部:LLV(HIGH,30),color00ff00;
{DRAWTEXT(FILTER(((((rl42 = j24) AND (CLOSE > OPEN)) AND (CLOSE > 長期底部)) AND (LOW <= j24)),20),(LOW - 0.12),'←底成'),color0eabff;}
rl5:=(SMA(HIGH,5,2) * 1.05);
上:=(SMA(LOW,5,2) * 0.96);
下:=SMA(LOW,2,1);
中:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
x1:=EMA(中,10);
x2:=REF(x1,1);
x3:=((REF(HIGH,1) + REF(LOW,1)) / 2);
x4:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));
x5:=REF(CLOSE,1);
x6:=((SMA(MAX((CLOSE - x5),0),7,1) / SMA(ABS((CLOSE - x5)),7,1)) * 100);
x7:=CROSS(79,x6);
x8:=FILTER(x7,4);
x9:=MA(CLOSE,115);
var1m:=EMA(CLOSE,8);
飛龍頂底線一:=EMA(var1m,20);
var2m:=CROSS(var1m,飛龍頂底線一);
var3m:=(var1m < MA(CLOSE,20));
var4m:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
var5m:=SMA(var4m,5,1);
var6m:=SMA(var5m,8,1);
var7m:=(CROSS(var5m,var6m) AND (var6m < 5));
var8m:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND var7m);
var9m:=IF((CLOSE > 1000),var7m,var8m);
varfm:=CROSS(x1,x2);
ma115:=varfm;
低買:=(var2m AND var3m);
黑馬起步:=var9m;
DRAWTEXT(x8,(HIGH * 1.03),'←出貨'),color9000f5;
DRAWTEXT((黑馬起步 > 0),(HIGH * 1.04),'←逃命'),color0000ff;
逃遁:=(SMA(HIGH,21,2) * 1.05);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorff5b00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorff6c00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorff7b00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorff9c00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorffbe00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorffcc00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorffff00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000a3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000b7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000cd;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000e9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754e9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076ef3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color077bf3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726ca;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726ca;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorde9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorde9100;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,9,0),color0090ff;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,8,0),color009fff;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,4,0),color00b5ff;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),color00e4ff;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0.7,0),color00ffff;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.7,0),color00ffff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),OPEN,LOW,0.7,0),colorff76ff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,HIGH,0.7,0),colorff76ff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,9,0),colorff00ff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,6,0),colorff62ff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,4,0),colorff76ff;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,2,0),colorffa8ff;

網上搜的是這個指標么
公式較復雜裡面含有未來函數不建議使用

❻ 求公式:如何通過股票公式選股公式找出長期橫盤的股票

長期橫盤,可以描述為股價在某一段時間內的波動很小。可以用下面的公式(hhv(h,N)-llv(l,N))/llv(l,N)*100可以用這個方法可以選出長期橫盤的股票,選股功能里有這個功能,好像叫圖形選股吧,就是選出類似圖形的股票,自己找找看,有同花順,點選股,在上面一排,形態選股,自繪形態,想找什麼形態就自己畫,就篩選出來了。可以使用通達信軟體尋找長期橫盤的股票,通達信軟體裡面的條件選股。你選平台整理公式,可以設置整理的時間周期長度,和橫盤整理幅度。就可以選出來橫盤的股票。
拓展資料:
一、股票(stock)是股份公司所有權的一部分,也是發行的所有權憑證,是股份公司為籌集資金而發行給各個股東作為持股憑證並藉以取得股息和紅利的一種有價證券。股票是資本市場的長期信用工具,可以轉讓,買賣,股東憑借它可以分享公司的利潤,但也要承擔公司運作錯誤所帶來的風險。每股股票都代表股東對企業擁有一個基本單位的所有權。每家上市公司都會發行股票。
二、同一類別的每一份股票所代表的公司所有權是相等的。每個股東所擁有的公司所有權份額的大小,取決於其持有的股票數量占公司總股本的比重。股票是股份公司資本的構成部分,可以轉讓、買賣,是資本市場的主要長期信用工具,但不能要求公司返還其出資。南方財富網,是一家以股票為主題的財富網站,提供全方位綜合財經信息和金融市場資訊的平台。內容包括股票知識、股票行情、個股分析、個股點評。

閱讀全文

與壓力支撐位源碼相關的資料

熱點內容
老戰爭電影大全中國 瀏覽:538
與人肉叉燒包並肩的電影電影 瀏覽:681
大家用什麼雲盤看片 瀏覽:466
博途編譯快捷鍵是什麼 瀏覽:493
在線天堂網頁版 瀏覽:180
智能雲列印伺服器 瀏覽:554
適合晚上看片的網站 瀏覽:413
蛇變人電影 瀏覽:303
阿里程序員的菜單 瀏覽:610
python九乘法表教學 瀏覽:884
Tyler faith hot 瀏覽:639
愛奇藝怎麼付費只看一部電影 瀏覽:14
中國石化app余額查詢從哪裡查 瀏覽:108
農行app里買了理財在哪裡查詢 瀏覽:593
程序員用什麼軟體播放視頻 瀏覽:54
李采潭限制電影都有哪些 瀏覽:66
剪頭發電影 瀏覽:310
媽媽的故事韓國電影免費觀看 瀏覽:229
數學大師pdf 瀏覽:372
Cherry Ta|e 瀏覽:739