導航:首頁 > 程序命令 > ssh命令telnet

ssh命令telnet

發布時間:2023-06-03 13:39:58

A. 思科路由器(cisco)配置telnet登錄和ssh登錄應用舉例

Telnet協議是TCP/IP協議族中的一員,是Internet遠程登錄服務的標准協議和主要方式。它為用戶提供了在本地計算機上完成遠程主機工作的能力。在終端使用者的電腦上使用telnet程序,用它連接到伺服器。終端使用者可以在telnet程序中輸入命令,這些命令會在伺服器上運行,就像直接在服務宴宏核器的控制台上輸入一樣。可以在本地就能控制服務絕絕器。

SSH 為 Secure Shell 的縮寫,由 IETF 的網路小組(Network Working Group)所制定;SSH 為建立在應用層基礎上的安全協議。SSH 是目前較可靠,專為遠程登錄會話和其他網路服務提供安全性的協議。利用 SSH 協議可以有效防止遠程管理過程中的信息泄露問題。SSH最初是UNIX系統上的一個程序,後來又迅速擴展到其他操作平台。SSH在正確使用時可彌補網路中的漏洞。SSH客戶端適用於多種平台。幾乎所有UNIX平台—包括HP-UX、Linux、AIX、Solaris、Digital UNIX、Irix,以及其他平台,都可運行SSH。

思科telnet/ssh登錄配置案例:

要求:

R2可以telnet R1

R3可以ssh R2

配置AR1

R1(config)#enable password 123

R1(config)#line vty 0 4

R1(config-line)#password 123

R1(config-line)#login

R1(config-line)#transport input telnet

R1(config)#interface ethernet 0/0

R1(config-if)#ip address 192.168.12.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

配置AR2

Router(config)#interface ethernet 0/1

Router(config-if)# ip address 192.168.12.2 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface ethernet 0/0

Router(config-if)#ip address 192.168.13.2 255.255.255.0

Router(config-if)#no shutdown

Router#telnet 192.168.12.1 //晌掘telnet R1

Trying 192.168.12.1 ... Open

User Access Verification

Password:

R1>enable

Password:

R1#exit

[Connection to 192.168.12.1 closed by foreign host]

又回到R2

Router(config)#hostname R2

R2(config)#ip domain name www.163.com

R2(config)#crypto key generate rsa molus 1024

The name for the keys will be: R2.www.163.com

% The key molus size is 1024 bits

% Generating 1024 bit RSA keys, keys will be non-exportable...

[OK] (elapsed time was 0 seconds)

R2(config)#username glab1 secret glab1

R2(config)#line vty 0 4

R2(config-line)#login local

R2(config-line)#transport input ssh

R2(config)#enable password 123

R2(config)#

R2(config)#do show ip interface brief

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 192.168.13.2 YES manual up up

Ethernet0/1 192.168.12.2 YES manual up up

Ethernet0/2 unassigned YES unset administratively down down

Ethernet0/3 unassigned YES unset administratively down down

R2(config)#

配置AR 3

Router(config)#hostname R3

R3(config)#interface ethernet 0/1

R3(config-if)#ip address 192.168.13.2 255.255.255.0

R3(config-if)#no shutdown

ssh R2開始

R3#ssh -l glab1 192.168.13.2

Password:

Password:

R2>

B. Telnet 命令到底是干什麼用的怎麼用

Telnet 命令為用戶提供了在本地計算機上完成遠程主機工作的能力,它可以使用戶坐在已上網的電腦鍵盤前通過網路進入的另一台電腦已上網的電腦,使它們互相連通。

在終端使用者的電腦上使用telnet程序,用它連接到伺服器。終端使用者可以在telnet程序中輸入命令,這些命令會在伺服器上運行,就像直接在伺服器的控制台上輸入一樣。

使用Telnet的最簡單的方法是在命令行鍵入(以UNⅨ系統的C shell為例):

%telnet remote-computer-name(or IP)

(2)ssh命令telnet擴展閱讀

telnet的交互過程:

當我們使用Telnet登錄進入遠程計算機系統時,事實上啟動了兩個程序:一個是Telnet客戶程序,運行在本地主機上;另一個是Telnet伺服器程序,它運行在要登錄的遠程計算機上。

本地主機上的Telnet客戶端程序主要完成以下功能:

1、建立與遠程伺服器的TCP聯接。

2、從鍵盤上接收本地輸入的字元。

3、將輸入的字元串變成標准格式並傳送給遠程伺服器。

4、從遠程伺服器接收輸出的信息。

5、將該信息顯示在本地主機屏幕上。

遠程主機的「服務」程序通常被昵稱為「精靈」,它平時不聲不響地守候在遠程主機上,一接到本地主機的請求,就會立馬活躍起來,並完成以下功能:

1、通知本地主機,遠程主機已經准備好了。

2、等候本地主機輸入命令。

3、對本地主機的命令作出反應(如顯示目錄內容,或執行某個程序等)。

4、把執行命令的結果送回本地計算機顯示。

5、重新等候本地主機的命令。

閱讀全文

與ssh命令telnet相關的資料

熱點內容
java怎麼退出 瀏覽:900
掛接pdf 瀏覽:163
浪潮伺服器遠程修改bmc地址 瀏覽:119
單立文電影 瀏覽:871
linuxtar命令 瀏覽:874
優酷app如何屏蔽短視頻 瀏覽:480
看著就解壓的軟體 瀏覽:785
android撥號界面源碼 瀏覽:54
在線高清 瀏覽:375
程序員陸漓發型劉海 瀏覽:484
台灣電影《三十兒立》 瀏覽:315
南京學程序員培訓班 瀏覽:267
怎麼把華為手機app密碼刪掉 瀏覽:623
android事件冒泡 瀏覽:685
大片在線高清電影 瀏覽:791
程序員限制年齡怎麼辦 瀏覽:428
ug80數控編程視頻教程下載 瀏覽:771
四川信息化少兒編程定製 瀏覽:9
跟血戀一樣打真搶的電影 瀏覽:931
雲伺服器為什麼快 瀏覽:877